[LOGGED] Pathfinding still broken

Post bug reports and ask for game support here.

Moderator: MOD_Command

jarraya
Posts: 322
Joined: Mon Sep 10, 2007 4:04 pm

[LOGGED] Pathfinding still broken

Post by jarraya »

Even after the latest patch I find that pathfinding is very broken. Issuing a straight line order of more than a few kms almost always results in the AI doing some crazy dotted line path to the final location. If you trace along the intended path the water depth is always deep enough for the ship.

Adding to this above, have attached a save file where one of the ships is stuck on something and just won't go anywhere, then the AI tries to pathfind?

Can this please be fixed as it is forcing a high level of micromanagement.

Build 1147.34
Attachments
Bedford.zip
(388.37 KiB) Downloaded 2 times
SteveMcClaire
Posts: 4091
Joined: Mon Nov 19, 2007 9:31 pm

RE: [LOGGED] Pathfinding still broken

Post by SteveMcClaire »

Logged for investigation.
User avatar
goldfinger35
Posts: 143
Joined: Thu Jan 01, 2009 4:59 pm

RE: [LOGGED] Pathfinding still broken

Post by goldfinger35 »

True, example:



Image
Attachments
Untitled.jpg
Untitled.jpg (58.24 KiB) Viewed 9 times
SteveMcClaire
Posts: 4091
Joined: Mon Nov 19, 2007 9:31 pm

RE: [LOGGED] Pathfinding still broken

Post by SteveMcClaire »

Hi jarraya, thanks for the report.

I am unable to reproduce the problem on my machine -- when I run the saved game the ships both follow their plotted course as expected. I assume the issue was with the USS Beford since it's doing 0.6kts initially in the saved game?

For those encountering these issues:

Does this problem happen consistently, every time you try to plot a course? Intermittently? Is it something that doesn't happen for a time but then becomes consistent at some point during the scenario?

It sounds like there may be an issue with terrain elevation caching / retrieval, making the game think your ships need to navigate around land when they do not. Is there any other relatively high-resource-use software running at the time the problem crops up? Windows update or anti-virus scanning, or something like that? What sort of CPU does your machine have?

Thanks for any additional information you can provide.

morphin
Posts: 576
Joined: Fri Apr 26, 2002 6:51 pm
Location: Switzerland

RE: [LOGGED] Pathfinding still broken

Post by morphin »

Hi
I have this on almost every scenario that i play, but not on every plot. Workaround is to plot a course that is only a few nm. I have quite often error in the exeptoinlog.txt, but i don't think it correlates timely with the change of the course. I have similar observations with land course plotting. It would be interesting if others has also errors in the execptionlog.txt (this file is found in the cmo/logs directory)

The behaviour is only for land and sea units, for AC i havent seen this

Here an example log from my actual scenario "Operation Eagle guardian"
Attachments
ExceptionLog.txt
(38.98 KiB) Downloaded 6 times
morphin
Posts: 576
Joined: Fri Apr 26, 2002 6:51 pm
Location: Switzerland

RE: [LOGGED] Pathfinding still broken

Post by morphin »


Please see this thread also:
https://www.matrixgames.com/forums/tm.asp?m=4933666
Thank's
User avatar
goldfinger35
Posts: 143
Joined: Thu Jan 01, 2009 4:59 pm

RE: [LOGGED] Pathfinding still broken

Post by goldfinger35 »

ORIGINAL: SteveMcClaire

Does this problem happen consistently, every time you try to plot a course? Intermittently? Is it something that doesn't happen for a time but then becomes consistent at some point during the scenario?


No, it does not happen consistently. It happens intermittently. It is something that doesn't happen for a time but then becomes consistent at some point during the scenario.


ORIGINAL: morphin
I have this on almost every scenario that i play, but not on every plot. Workaround is to plot a course that is only a few nm. The behaviour is only for land and sea units, for AC i havent seen this

Exactly. It happens with land units, subs and ships, not planes.


Also, please check my thread about this problem: https://www.matrixgames.com/forums/tm.asp?m=5085852

thewood1
Posts: 6822
Joined: Sun Nov 27, 2005 6:24 pm

RE: [LOGGED] Pathfinding still broken

Post by thewood1 »

This seems like it must happen with combinations of machines, scenarios, and other system-related parameters. I have a high-end laptop and a Surface. I don't have this issue showing up much on either. Every now and then, in close to shore paths or around piers, I see it, but it usually resolves itself. I'm going to see if I can break it under controlled conditions.
You are like puss filled boil on nice of ass of bikini model. You are nasty to everybody but then try to sweeten things up with a nice post somewhere else. That's nice but you're still a boil on a beautiful thing! - BDukes
SteveMcClaire
Posts: 4091
Joined: Mon Nov 19, 2007 9:31 pm

RE: [LOGGED] Pathfinding still broken

Post by SteveMcClaire »

Thanks morphin. The out of memory exceptions in that log are happening when the game is trying to save the scenario (probably during an autosave.) So it is not directly related to the path finding issue.

If the scenario is big enough that it's running you out of memory, that /could/ be causing issue with the path finder being unable to fetch terrain data, and thus pathing using incorrect elevation/depth values. If that were the case we'd be seeing out of memory exceptions in the actual elevation-fetching code, however. Since we don't, it's impossible to say for certain whether those exceptions are related or not.

Just as a test, could you disable autosaves (in the game options) and try to see if that has any effect on how often you see the pathing issues?
SteveMcClaire
Posts: 4091
Joined: Mon Nov 19, 2007 9:31 pm

RE: [LOGGED] Pathfinding still broken

Post by SteveMcClaire »

Hi goldfinger35 -- thanks for the information.

I took a look at the first example in the thread you linked and the pathfinder is kicking in because there are islands in the way. Turn off the Sentinel-2 map and turn on BMG / coastlines and you'll see them. Apparently the Sentinel-2 image doesn't have much coverage away from the coastline in this area. I didn't go further into your thread as I could not tell at a glance where the other examples where on the earth.

The pathfinder will be invoked whenever the sim finds a major obstacle in the direct path to the next waypoint. Attached is an example image that illustrates this -- in the first case the pathfinder will run, but in the second two it will not. Hope that helps.


Image
Attachments
pathblock.jpg
pathblock.jpg (53.35 KiB) Viewed 9 times
SteveMcClaire
Posts: 4091
Joined: Mon Nov 19, 2007 9:31 pm

RE: [FIXED] Pathfinding still broken

Post by SteveMcClaire »

I've implemented a fix for an unexpected diversion / pathing issue. I suspect this is what was causing the issue you were seeing, but it is possible that it was not. Please let me know if the problem presists in the next update.
User avatar
goldfinger35
Posts: 143
Joined: Thu Jan 01, 2009 4:59 pm

RE: [FIXED] Pathfinding still broken

Post by goldfinger35 »

Thank you, Steve. Turning off the Sentinel-2 map and turning on BMG showed the island which was in the way. Zooming out with Sentinel also works (island borders are than shown in yellow).
User avatar
goldfinger35
Posts: 143
Joined: Thu Jan 01, 2009 4:59 pm

RE: [FIXED] Pathfinding still broken

Post by goldfinger35 »

Steve, if you have time, please check this exampke from Goodnight Irene scenario:
CTF-150 is stuck with message "waiting for pathfinder-generated course"

Attachments
testpathfinding.zip
(1.53 MiB) Not downloaded yet
User avatar
goldfinger35
Posts: 143
Joined: Thu Jan 01, 2009 4:59 pm

RE: [FIXED] Pathfinding still broken

Post by goldfinger35 »

And here is a pic:


Image
Attachments
Untitled.jpg
Untitled.jpg (96.53 KiB) Viewed 9 times
jarraya
Posts: 322
Joined: Mon Sep 10, 2007 4:04 pm

RE: [LOGGED] Pathfinding still broken

Post by jarraya »

Apologies for the late reply. The situation is as others have described:
- happens intermittently but on most scenarios.
- I don't think it has to do with processor or pc - I have a very fast pc Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz 3.60 GHz with 16GB RAM and no virus scanner or other major process running when I play CMO.
- This pathfinding issue appears on all scenarios, not just the one I reported (Red Tide).

Thanks for looking at it.
Dimitris
Posts: 13379
Joined: Sun Jul 31, 2005 10:29 am
Contact:

RE: [LOGGED] Pathfinding still broken

Post by Dimitris »

Can you give it a try with B1147.35 ?
Dimitris
Posts: 13379
Joined: Sun Jul 31, 2005 10:29 am
Contact:

RE: [LOGGED] Pathfinding still broken

Post by Dimitris »

ping
User avatar
goldfinger35
Posts: 143
Joined: Thu Jan 01, 2009 4:59 pm

RE: [LOGGED] Pathfinding still broken

Post by goldfinger35 »

I am still playing complicated Gunners scenario with multiple exclusion zones and many units and sofar it looks ok with minor problems.
Quick test in Live: Pole positions shows mostly correct pathfinding, but SSN 21 USS Seawolf has some problems (see attachment)
Attachments
testpathfinding2.zip
(408.21 KiB) Not downloaded yet
DWReese
Posts: 1879
Joined: Fri Mar 21, 2014 11:40 am
Location: Miami, Florida

RE: [LOGGED] Pathfinding still broken

Post by DWReese »

Steve,

I have used a test-created scenario for a while which allows me to test several different attacks at the same time. All of them worked perfectly in release 34 and before. Beginning with 35, a path issue developed. #36 also behaves like #35.

Specifically, I have an attack (Striker 123) that the path needs to actually plot and zig zag around some nav zones. The program will initially give you the message that it can't plot a path and that it was working on it. Release #34 eventually (within a minute) figures it out and it worked fine. Beginning with release #35, it could no longer figure it out, and the strike never takes off. #36 is the same as #35.

If you manually launch the aircraft using #35 or #36, the strike flies forward until it reaches the nav zone and then it bounces off of it and repeatedly tries it again and again, without ever figuring it out.

Release #34 was much better than #35 or #36.

I have included the scenario. Watch the Striker 123 mission to see what I am talking about. Use #34 and then #36 and you will see the difference.

Attachments
1Everythi..Strikesc.zip
(283.74 KiB) Downloaded 3 times
DWReese
Posts: 1879
Joined: Fri Mar 21, 2014 11:40 am
Location: Miami, Florida

RE: [LOGGED] Pathfinding still broken

Post by DWReese »

As a follow up, version 37 is much more restrictive in trying to find a path from a base to a target for aircraft than Version 34.

Version 34 was really good. It might have taken about 30 seconds, but Version 34 was able to figure out an alternative when the path wasn't simply a straight line.

In the example that I previously provided, Version 34 was even able to make multiple (as in 2 or more) path changes to get to its target. That was quite impressive.

Version 37, on the other hand, is quite limited. Unless you are dealing with an almost straight line, Version 37 can't figure it out.

(Note: Versions 35 and 36 came out so fast that I didn't really get a chance to test them.)

In my opinion, I would rather have the Version 34 portion of the code back, rather than the existing version 37, when it comes to being able to formulate a path to a target for an aircraft.
Post Reply

Return to “Tech Support”