If the game crashes on launch PLEASE READ THIS

Please post any bugs or technical issues found here for official support.

Moderators: Joel Billings, RedLancer

Post Reply
User avatar
Erik Rutins
Posts: 38307
Joined: Tue Mar 28, 2000 4:00 pm
Location: Vermont, USA
Contact:

If the game crashes on launch PLEASE READ THIS

Post by Erik Rutins »

Please be sure that you allowed DirectX 9 and .NET 4.7.2 to install during the installation.

Please also try installing to the default location.

Try turning off Cortana and any speech recognition software.

If you are running at 4k / DPI Scaling, please install the latest (1.01.02 or later) update and read this thread:


https://www.matrixgames.com/forums/tm.asp?m=4991284

For older updates:

It looks like in some systems where the default Windows DPI is set higher, there is a conflict with the default Application DPI setting. The net result can be a crash on launch. If this is happening to you, here's an alternate fix to try with the default 1.00 executable:

1. Go to your installation folder.
2. Select the WarintheEast2 application.
3. Right click on it and choose Properties, then click on the Compatibility tab
4. If you have Administrator privileges, click the Change settings for all users button to make changes to the scaling for all users of the computer. If not, skip to the next step;
5. Click Change high DPI settings.
6. Ensure your settings on that tab match the screenshot below, then click OK.

Program DPI: Use this setting to fix scaling problems for this program instead of the one in Settings. If you have switched the Fix scaling for apps in System Settings then ticking this box allows you to override that setting for this particular application and gives you options on the dropdown below it. PLEASE CHECK THIS BOX FOR WITE2.

Override high DPI scaling behaviour. When you tick this box you are overriding the way Windows would normally handle high DPI scaling for your application.
Application: The application will be unaware of high DPI and will not be scaled; - DO NOT USE THIS WITH WITE2
System: The application will again be unaware of high DPI and the system will scale it; - DO NOT USE THIS WITH WITE2
System (Enhanced): This is only available in Windows 10 (1703)+. This applies GDI Scaling to the application; - PLEASE USE THIS WITH WITE2


Let us know if that resolves the issue for you.

Image


If this does not resolve the issue, please try the following:

Please try to disable all background programs in case these are interfering with the normal running of the game.

You can do this by running msconfig and disabling all non-windows start-up programs and services.
Then once you have disabled all non-Microsoft services, please run the game and see if the issue persists.

If it does not, please then reopen msconfig and reenable those services, one by one, until you find the program causing the problem.

A tutorial on how to do this can be found below:
https://eu.battle.net/support/en/article/23848


Please note that we have confirmed that the Nahimic Audio Software from MSI is conflicting with War in the East 2. Try disabling that first if you have it installed.


Additional suggestions:

Make sure you disable any overlay software,
like MSI Afterburner,
NVIDIA GeForce Experience Overlay,
AMD Overlay,
Discord Overlay etc,
Game recording software,
Xbox overlay, this list goes on and on...

Any of these may interfere with the game, any game you are having issues with, etc.

Install the game as administrator and running the game as administrator should setup the correct file permissions to run with most AV & firewall programs, some 3rd party poor ones may need to add a exception manually.
Attachments
DPIScaling.png
DPIScaling.png (36.69 KiB) Viewed 114 times
Erik Rutins
CEO, Matrix Games LLC


Image

For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.
User avatar
MakeeLearn
Posts: 4274
Joined: Sun Sep 11, 2016 1:01 pm

RE: If the game crashes on launch PLEASE READ THIS

Post by MakeeLearn »

Yes it work! I reset computer to 150% Display and the scenario loaded.
THANKS!






similar
Posts: 17
Joined: Tue Sep 01, 2009 8:07 am
Location: London, UK

RE: If the game crashes on launch PLEASE READ THIS

Post by similar »

Yes, that fixed my issue I reported here https://www.matrixgames.com/forums/tm.asp?m=4987567. I reverted to my original display settings, then applied the fix above, and it works fine. Thanks again.
speedyglides
Posts: 58
Joined: Thu Oct 01, 2015 3:12 am

RE: If the game crashes on launch PLEASE READ THIS

Post by speedyglides »

It works!
User avatar
barrykimmerly
Posts: 17
Joined: Sun Jun 06, 2010 8:18 pm

RE: If the game crashes on launch PLEASE READ THIS

Post by barrykimmerly »

Thanks Erik. I had this exact problem and it went away with the settings you just posted :-)
Barry
User avatar
Dennistoun
Posts: 233
Joined: Wed Oct 17, 2007 6:48 pm
Location: Perth, Scotland.

RE: If the game crashes on launch PLEASE READ THIS

Post by Dennistoun »

Thank you! That certainly worked for me.
Exemel
Posts: 1
Joined: Thu Mar 25, 2021 5:01 pm

RE: If the game crashes on launch PLEASE READ THIS

Post by Exemel »

Thank you! That did the trick for me.
Majick
Posts: 180
Joined: Thu Jan 07, 2010 3:25 pm

RE: If the game crashes on launch PLEASE READ THIS

Post by Majick »

Works for me too thanks very much Erik.
User avatar
wwtiger89
Posts: 10
Joined: Fri Aug 10, 2018 8:48 am

RE: If the game crashes on launch PLEASE READ THIS

Post by wwtiger89 »

The compatibility settings adjustment worked for me. Running on Surface Book 2.
User avatar
dethbass
Posts: 15
Joined: Sat Apr 21, 2007 12:40 am

RE: If the game crashes on launch PLEASE READ THIS

Post by dethbass »

I had an issue where the intro screen would briefly flash white, then crash. Closing Cortana fixed the issue
Post Reply

Return to “Tech Support”