[Logged] Text Editor Issue (Again)

Post bug reports and ask for game support here.

Moderator: MOD_Command

Post Reply
User avatar
BeirutDude
Posts: 2733
Joined: Sat Apr 27, 2013 9:44 am
Location: Jacksonville, FL, USA

[Logged] Text Editor Issue (Again)

Post by BeirutDude »

Have Build 11 Beta and the Text Editor for the Scenario Description is locking up the game in Edit Mode (again). It was a hidden window issue the last time and indeed when I close the game (Cntrl+Alt+Del necessary to close) I can see a ghost widow briefly appear and then quickly disappear.
"Some people spend an entire lifetime wondering if they made a difference. The Marines don't have that problem."
PRESIDENT RONALD REAGAN, 1985

I was Navy, but Assigned TAD to the 24th MAU Hq in Beirut. By far the finest period of my service!
User avatar
BeirutDude
Posts: 2733
Joined: Sat Apr 27, 2013 9:44 am
Location: Jacksonville, FL, USA

RE: Text Editor Issue (Again)

Post by BeirutDude »

Just checked and is happening with the Side Briefing Editor as well. Was working fine with Build 10 Beta as I just leaded Build 11 Beta the other day. So it is something with the most recent build.

Edit, actually the side editor behaved differently. The game didn't lock up but the Editor opened behind the Screen and when I minimized the game window it was there. I also noted that in the Events Editor the "Action" menu/GUI was doing that to me for a bit but that was an intermittent issue.

Hope this helps.
"Some people spend an entire lifetime wondering if they made a difference. The Marines don't have that problem."
PRESIDENT RONALD REAGAN, 1985

I was Navy, but Assigned TAD to the 24th MAU Hq in Beirut. By far the finest period of my service!
KnightHawk75
Posts: 1552
Joined: Thu Nov 15, 2018 7:24 pm

RE: Text Editor Issue (Again)

Post by KnightHawk75 »

Yup BD, I run into this A LOT, and have since CMO launched, though it did happen on CMANO for me it was very very rare.

I also agree that it seems worse in .10+ though (nearly every time vs ~33-50% of time prior). The trick work-around for me as I've said before is going to task manager, application list and doing a right-click 'minimize' action from there (I have found no other way to trigger workaround when the main form is locked, though yes if you catch it super early and can minimize before it locks sometimes works), and then the dialog will instantly generate (or finish generating) and all is good...till the next time you do anything that invokes a dialog with the text editor...then it's usually rinse and repeat.

Side\side-briefing editing, any lua script screens etc, same as you anything that invokes the text\html editor control(s), it also tends to happen with the manual allocation dialog window as well, but for that one it seems to only happen after hours of use, and the applied 'workaround', seems to last for awhile.

Sometimes restating the game stops it from happening for awhile, sometimes that that makes no difference, it's very random, or it used to be more random, but since updating to .10 (I'm skipping .11) it seems to be happening much more, nearly all the time. IDK if anythings been tweaked lately with the generation or modality or threading related to the windows\dialogs that is making it even more prevalent than before on some systems.

It acts as if the game (main form) is in a wait state loop waiting to hear back that the call to generate the dialog has been completed, but something stops the dialog itself from getting generated\init'ed (or messaging back that it did), hence the locked wait state of the main form waiting for the dialog call to return.

Whatever a 'minimize' does on the application (injected from taskmanger) does seems to free up or interject some timing pause or message loop interaction that (95% of the time, I've had an instance or two where the workaround fails) clears the block such that the dialog then immediately finishes spawning and then the main form execution continues on it's merry way (unfreezes). I've tried to debug this various different ways with little definitive success as I can not tell what exactly is the cause\getting in the way, or why it seems only some of us run into this and not others, and some of us it seems way more often than others.

win7x64 |editor mode| windowed mode (though it does happen in full screen too, I just rarely use full screen).
When dbging this all av protection software disabled, no msi afterburner\overlay stuff running, Matrix distro (steam not involved). It's a tough one for devs to look into if they can't repo it on their systems though which I'm guessing they can't since it's been reported before.
Rory Noonan
Posts: 2419
Joined: Thu Dec 18, 2014 1:53 am
Location: Brooklyn, NY

RE: Text Editor Issue (Again)

Post by Rory Noonan »

Logged for investigation.

0014165
Image
Geoffropi
Posts: 98
Joined: Tue Oct 27, 2020 6:01 am

RE: Text Editor Issue (Again)

Post by Geoffropi »

Hey guys,

I could not reproduce it on my side, this might be related to the OS version used. Older Windows versions are rather capricious the further techs are evolving.

BeirutDude : are you running windows 10 or an older version?

Geoffroy.


Post Reply

Return to “Tech Support”