The Operational Art of WAr v4.1.0.40 not loading

Post bug reports and ask for game support here.
Post Reply
datumsoft
Posts: 15
Joined: Tue Sep 17, 2019 6:52 am

The Operational Art of WAr v4.1.0.40 not loading

Post by datumsoft »

When I start the game I get the main screen and the music plays. But none of the buttons like Load Game New Game Quit Game are working.
User avatar
sPzAbt653
Posts: 9629
Joined: Thu May 03, 2007 7:11 am
Location: east coast, usa

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by sPzAbt653 »

Maybe - in some resolutions the coordination between buttons and where to click is a little off. Try clicking around the screen to see if anything happens ever? That's the only simpleton thing I can think of, otherwise someone else with better brains will show up to help.
datumsoft
Posts: 15
Joined: Tue Sep 17, 2019 6:52 am

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by datumsoft »

I noticed I have to wait about a 40 seconds then the New Game button responds. It shows a file directory listing. I close it then click new game again then finally the scenario lists appear. I did not have this behaviour in previous versions
User avatar
zakblood
Posts: 22673
Joined: Thu Oct 04, 2012 11:19 am

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by zakblood »

with no logs or reports provided, it's only guess work on what could be wrong, if you can upload a link to a online store where you have placed them, so staff support can reach and read it will be helpful

https://www.matrixgames.com/forums/tm.asp?m=4382074
Windows 11 Pro 64-bit (10.0, Build 22000) (22000.co_release.210604-1628)
Meyer1
Posts: 925
Joined: Tue Feb 09, 2010 6:01 pm

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by Meyer1 »

Take a look at this thread: https://www.matrixgames.com/forums/tm.asp?m=4740990

I would check the Sound folder at "C:\Users\--\Documents\My Games\The Operational Art of War IV", chances arer that is empty, if that is the case you could try copy the content of the Sound folder of the Toaw directory at Program Files (x86) to the My games Sound folder, that's what fixed my game.
datumsoft
Posts: 15
Joined: Tue Sep 17, 2019 6:52 am

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by datumsoft »

I noticed if I go into Sound folder under My Games, file explorer hangs but eventually displays the contents. But if I go into SOunds folder under Matrix Games, I see a list of folders and a bunch of ogg files. But again it hangs. Maybe it has something to do with the folder structure.
So by having sound in the game it forces it to use the sound folder, and this in turn is responsible for the hanging.
datumsoft
Posts: 15
Joined: Tue Sep 17, 2019 6:52 am

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by datumsoft »

I changed the nosound parameter to Y, but it did not help. Game still hangs.I have left it for over a minute and buttons still don't work.
I had no such problems with previous version of this game so this is really disappointing.
datumsoft
Posts: 15
Joined: Tue Sep 17, 2019 6:52 am

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by datumsoft »

I went back and uninstalled version .40 and installed version .20 and the buttons don't work for that either. I did a restart in between these tasks.
The previous time I ran .20 was on a different PC where I did not have this problem.
Installing patch .21 did not help either. Basically the game is unusable.
datumsoft
Posts: 15
Joined: Tue Sep 17, 2019 6:52 am

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by datumsoft »

I went back and reloaded .20 from MyPage on Matrix site and now the game will load but I have to wait about a minute first.
Any ideas why? I could check Windows event viewer but any easier suggestions would be appreciated.
User avatar
Shadrach
Posts: 727
Joined: Tue Oct 16, 2001 8:00 am
Location: Oslo, Norway
Contact:

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by Shadrach »

Have you reported this to Matrix Support?
https://www.matrixgames.com/member/helpdesk

At this point it's probably the best, as the help others can provide without sitting at your machine is limited.
The game definitely has issues with Sound playback, but if you've disabled sound it should be ok.

The hangs experienced by some others was caused by patching the game from an old install. But it sounds like you go first Base .20 and then patch to .40 which should be fine.

- Make sure the game's Documents folder is cleared before installing (make a backup of anything you want to keep there).
c:\Users\<username>\Documents\My Games\The Operational Art of War IV\

- You could try like others have suggested, to copy the Sounds folder from the Programs folder to the Documents folder before starting the game. But really shouldn't be necessary.

- Are you seeing high CPU usage while the game hangs?

- When you say you can't click the buttons do you mean the *entire* game hangs (grey window, spinning cursor) or can you for instance interact with the dropdown menus?

- It's really weird it hangs looking at the folder in Windows Explorer. Usually Explorer will try to parse the OGG files to find artist and title, but this shouldn't hang your machine for a long time. It should only take a couple of seconds.

- You've said nothing about what OS version you have and what computer specs (from System Information)?

- Are you running some very aggressive Anti-virus or other security software in the background?

I doubt you'll find anything useful in Event Viewer but it's worth a try I guess. What I do at times like this is use the tool Process Monitor to examine what the process does when it hangs. But this gets technical and requires you to search through thousands of log entries, and you need to know what you're looking for as well.
https://docs.microsoft.com/en-us/sysint ... ds/procmon
But if you're willing to give it a go I can help walk you through it.
OUW (Order of the Upgrade Wars)
Image
There are folks out there with way too much time on their hands.
- Norm Koger
User avatar
Curtis Lemay
Posts: 13053
Joined: Fri Sep 17, 2004 3:12 pm
Location: Houston, TX

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by Curtis Lemay »

ORIGINAL: datumsoft

I went back and uninstalled version .40 and installed version .20 and the buttons don't work for that either. I did a restart in between these tasks.
The previous time I ran .20 was on a different PC where I did not have this problem.
Installing patch .21 did not help either. Basically the game is unusable.
Are you watching your hard-drive light while this is happening? Perhaps it is busy with something else - especially if you've just booted. Could you try waiting for longer than just a minute before giving up?
My TOAW web site:

Bob Cross's TOAW Site
datumsoft
Posts: 15
Joined: Tue Sep 17, 2019 6:52 am

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by datumsoft »

Seems to be working now. Wait about 15 seconds after launch before cursor can click button
User avatar
Shadrach
Posts: 727
Joined: Tue Oct 16, 2001 8:00 am
Location: Oslo, Norway
Contact:

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by Shadrach »

ORIGINAL: datumsoft
Seems to be working now. Wait about 15 seconds after launch before cursor can click button

That wouldn't be any definition of "working" I know about, but hey if it "works" for you [;)]
OUW (Order of the Upgrade Wars)
Image
There are folks out there with way too much time on their hands.
- Norm Koger
User avatar
Toby42
Posts: 1626
Joined: Sat Aug 09, 2003 11:34 pm
Location: Central Florida

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by Toby42 »

I'm getting the same thing. The start screen doesn't load and I get the "not responding" message. All I can do is shut down! Game is useless!!
Tony
User avatar
Curtis Lemay
Posts: 13053
Joined: Fri Sep 17, 2004 3:12 pm
Location: Houston, TX

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by Curtis Lemay »

ORIGINAL: Toby42

I'm getting the same thing. The start screen doesn't load and I get the "not responding" message. All I can do is shut down! Game is useless!!
Be patient. Let it run for a while. There's some initialization done on first time running on a machine.
My TOAW web site:

Bob Cross's TOAW Site
User avatar
Shadrach
Posts: 727
Joined: Tue Oct 16, 2001 8:00 am
Location: Oslo, Norway
Contact:

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by Shadrach »

ORIGINAL: Toby42
I'm getting the same thing. The start screen doesn't load and I get the "not responding" message. All I can do is shut down! Game is useless!!

Did you try one of the solutions already posted in this thread?
How did you install TOAW4, did you update from an older version directly to .40? These hangs have been reported by users going from versions prior to .20 directly to .40.

Did you try copying the Sounds folder from Program Files to Documents?
Did you try disabling sound in the ini file?
OUW (Order of the Upgrade Wars)
Image
There are folks out there with way too much time on their hands.
- Norm Koger
User avatar
Toby42
Posts: 1626
Joined: Sat Aug 09, 2003 11:34 pm
Location: Central Florida

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by Toby42 »

I got it figured out. Somehow I missed version .20?
Tony
MBogdasarian
Posts: 49
Joined: Wed Jul 05, 2006 11:44 pm

RE: The Operational Art of WAr v4.1.0.40 not loading

Post by MBogdasarian »

A friend and I have been playing on line. He surrendered while the scenario still had turns to run. I clicked on "end scenario" and put in his password but nothing appears to have changed. What am I missing?
Post Reply

Return to “Tech Support”