Can't Run in Full Screen Mode

Post bug reports and ask for help with other issues here.

Moderators: wdolson, MOD_War-in-the-Pacific-Admirals-Edition

Post Reply
Posts: 110
Joined: Sat Nov 02, 2013 3:48 pm

Can't Run in Full Screen Mode

Post by BKL »

I have a laptop and the resolution is 1920 x 1080. I can run the game in window mode using the "-wd -altFont -px1920 -py1080" line but as soon as I change it to "-f -altFont -px1920 -py1080" I get an error that says "can't set screen mode."

I don't mind running in window mode, but it's just that my task bar gets in the way of menu items in the game. I prefer not to have to keep hiding my taskbar.

EDIT: What's really weird is that for some reason now, in window mode, I cannot maximize my window. Earlier today, with same settings, I could click on the little box in the corner to maximize my window. Now I just have a smaller window centered in the screen.

Any suggestions? I'd prefer to just run the game in full screen mode.

User avatar
Posts: 4583
Joined: Tue Nov 08, 2011 2:09 pm
Location: Poland

RE: Can't Run in Full Screen Mode

Post by Yaab »

Install the official patch from 16 March 2015 from here

Try running fullscreen at a lower resolution.

Here is mine Full HD laptop with 15.6 inch screen and the switches for Win10.

-altFont -skipVideo -archive -deepColor -dd_sw -px1600 -py900
User avatar
Posts: 18328
Joined: Wed Aug 04, 2010 5:36 pm
Location: Winnipeg, MB

RE: Can't Run in Full Screen Mode

Post by BBfanboy »

You need to find out what resolution is native to your video card/chip and the screen on your laptop. If you can look at your desktop properties there should be a tab in there for resolution, and the settings offered there are the ones that the laptop can handle without major problems.
The game normally runs (at the map display) in full screen mode at any resolution, but it seems laptops and Win 10 do not like that.

You can force a resolution by changing px/py to fpx/fpy (with the numbers you wish to try).

You can run full screen by not setting -wd windowed mode, but others have reported that, on laptops, they get bleed through of the desktop with full screen mode so many run in windowed mode with the window frame expanded to the screen edges. Others have fiddled with transparency settings in Win 10 and perhaps some other settings to eliminate the bleed-through. The specific hardware you have may limit what is possible, but I recommend you read the many Win10 and switch threads in the Tech section and try some of the fixes suggested for laptops.
No matter how bad a situation is, you can always make it worse. - Chris Hadfield : An Astronaut's Guide To Life On Earth
Post Reply

Return to “Tech Support”