Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

My Engine Problem in editor?? "Engine Unknown"

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Scenario Design and Modding >> My Engine Problem in editor?? "Engine Unknown" Page: [1]
Login
Message << Older Topic   Newer Topic >>
My Engine Problem in editor?? "Engine Unknown" - 8/14/2021 9:37:58 AM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
I’ve got a complicated problem with engines.

I created a few more engines to make it technically more difficult for the late more Japanese aircraft. Would like to retain them in the game if possible.

Started a test mod for them putting then in 1941 .

Added a few aircraft using these lightweight engines and they all appear OK on the map.

But

Some of these engines even with a starting pool appear on the production list with the words "engine unknown". a couple I did like the HE Jet are fine a production works ok? Device slots 1939- 42 all the same issue - are these slots not allowed?

I have no idea why this is because it is just a name. When I created the engine all I did was copy and paste one of the Japanese engines and just renamed it. That’s all I did. Then allocated it to a new aircraft. You can add the aircraft units onto the map no problem but the engine seems to be a problem displaying in some of the production screens and information screens.

I tried moving one of the engines from device number 1941 to 1942 and the 1942 slot shows up but still not the1941 – what is going on? have about three problems all the same.

Any help would be appreciated because I am completely at a loss as to what to do.




Attachment (1)

< Message edited by Cavalry Corp -- 8/14/2021 10:01:26 AM >
Post #: 1
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 9:38:59 AM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
screen = aircraft on map fine ??




Attachment (1)

< Message edited by Cavalry Corp -- 8/14/2021 9:42:25 AM >

(in reply to Cavalry Corp)
Post #: 2
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 9:39:33 AM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
screen HE new engine = fine




Attachment (1)

< Message edited by Cavalry Corp -- 8/14/2021 9:41:59 AM >

(in reply to Cavalry Corp)
Post #: 3
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 9:54:51 AM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Another screen - G10N as example and all planes with the same engine have a -




Attachment (1)

(in reply to Cavalry Corp)
Post #: 4
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 12:55:08 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
This is the result of copy and paste of an engine that does work to the new slot and just changing the name = you can see the pool is ok at 116 But it still says Engine unknown. After moving the Engine I changed all the Planes that use it to make sure...

No joy








Attachment (1)

(in reply to Cavalry Corp)
Post #: 5
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 2:54:31 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
And the answer to life the universe and everything is .... not 42
In AE ... In this game there is only a certain number of Engines that may be present for Japan - but no where does it say that !

Issue fixed - took hours to come to this...

< Message edited by Cavalry Corp -- 8/14/2021 2:55:07 PM >

(in reply to Cavalry Corp)
Post #: 6
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 3:09:57 PM   
btd64


Posts: 9464
Joined: 1/23/2010
From: Mass. USA. now in Lancaster, OHIO
Status: offline
Just a thought. Do you have a factory to produce the new engine type?....GP

_____________________________

Intel i7 4.3GHz 10th Gen,16GB Ram,Nvidia GeForce MX330

AKA General Patton

WPO,WITP,WITPAE-Mod Designer/Tester
DWU-Beta Tester
TOAW4-Alpha/Beta Tester

"Do everything you ask of those you command"....Gen. George S. Patton

(in reply to Cavalry Corp)
Post #: 7
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 3:11:34 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Well Yes on one I think - any concern its RD ( engines allowed R+d)

(in reply to btd64)
Post #: 8
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 3:14:37 PM   
btd64


Posts: 9464
Joined: 1/23/2010
From: Mass. USA. now in Lancaster, OHIO
Status: offline
Just thinking that if the engine is not recognized maybe it has something to do with production 🤔....GP

_____________________________

Intel i7 4.3GHz 10th Gen,16GB Ram,Nvidia GeForce MX330

AKA General Patton

WPO,WITP,WITPAE-Mod Designer/Tester
DWU-Beta Tester
TOAW4-Alpha/Beta Tester

"Do everything you ask of those you command"....Gen. George S. Patton

(in reply to Cavalry Corp)
Post #: 9
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 5:12:29 PM   
JuanG


Posts: 906
Joined: 12/28/2008
Status: offline
Don't think you can add more engines, you have to use one of the existing slots.

_____________________________


(in reply to btd64)
Post #: 10
RE: My Engine Problem in editor?? "Engine Unknown... - 8/14/2021 10:27:06 PM   
LargeSlowTarget


Posts: 4347
Joined: 9/23/2000
From: Hessen, Germany - now living in France
Status: offline
I have had the same issue in my mod, as had others before - see http://www.matrixgames.com/forums/fb.asp?m=4540605

You cannot add engines, you can only edit existing ones.

In my mod I have grouped the "Hitachi (early)" and "Kawasaki (early)" into one "obsolete engine", thus freeing one engine slot. Another slot can be freed by unifying the two versions of the Ha-60 engine - these are Army and Navy "versions" of the same engine. The Argus engine is being used only by the Ka-1 Autogyro, the slot can be freed by assigning the "obsolete engine" to this airframe.

_____________________________


(in reply to JuanG)
Post #: 11
RE: My Engine Problem in editor?? "Engine Unknown... - 8/15/2021 11:19:58 AM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
OK thanks LST and others for this - how odd it is.
I have fixed it now but it will mean a new version of my mod will be posted later today or tomorrow.

(in reply to LargeSlowTarget)
Post #: 12
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Scenario Design and Modding >> My Engine Problem in editor?? "Engine Unknown" Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.164