Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[Resolved] Cannot Launch Game

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Resolved] Cannot Launch Game Page: [1]
Login
Message << Older Topic   Newer Topic >>
[Resolved] Cannot Launch Game - 4/30/2021 9:24:24 PM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline
Recently reinstalled Command after a fresh install of Windows 10. Now when I try to launch it, I get two errors. First:

"Error found during gamma5 application startup. Error details: Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies, is not a valid Win32 application. (Exception from HRESULT:0x800700C1)"

Clicking Ok then leads to another error popup:

"Error found during application startup. Error Details: Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies, is not a valid Win32 application. (Exception from HRESULT:0x800700C1)"

I'm not really sure where to begin with this. I do have Visual Studio 2019 Community edition installed along with all the DirectX programming items, as well as all the different variations of the .net frameworks. I doubt that has anything to do with this though.

Help please!

< Message edited by WSBot -- 5/3/2021 4:18:55 PM >


_____________________________

Post #: 1
RE: Cannot Launch Game - 4/30/2021 10:32:23 PM   
thewood1

 

Posts: 6109
Joined: 11/27/2005
Status: offline
Did you apply all the prerequisites like .net and DirectX?

_____________________________

You are like puss filled boil on nice of ass of bikini model. You are nasty to everybody but then try to sweeten things up with a nice post somewhere else. That's nice but you're still a boil on a beautiful thing! - BDukes

(in reply to Midcon113)
Post #: 2
RE: Cannot Launch Game - 4/30/2021 11:18:04 PM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline
quote:

ORIGINAL: thewood1

Did you apply all the prerequisites like .net and DirectX?


Yes, a couple of different ways - first, installing using Steam (three times), and secondly by downloading directly from the Matrix site and going through a manual install. The only thing I can see there is that when it goes to install the .Net 4.x frameworks, a message indicates (correctly) that those frameworks are already installed. Regardless, no matter how I install it, I get messages indicating that the installs were successful.

(in reply to thewood1)
Post #: 3
RE: Cannot Launch Game - 5/1/2021 1:22:19 AM   
PaulTheWolf

 

Posts: 40
Joined: 12/10/2017
Status: offline
Hi MidCon. First off I'm sorry you're experiencing this issue. Secondly could you provide a screenshot of the issue as you encounter it and your Command.exe file? Additionally is this with the current Open Beta installed as well, or just the base Steam Install?

Paul.


(in reply to Midcon113)
Post #: 4
RE: Cannot Launch Game - 5/1/2021 1:37:03 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline
quote:

ORIGINAL: PaulTheWolf

Hi MidCon. First off I'm sorry you're experiencing this issue. Secondly could you provide a screenshot of the issue as you encounter it and your Command.exe file? Additionally is this with the current Open Beta installed as well, or just the base Steam Install?

Paul.




Yep - here you go:

First Error

Second Error

This is the base Steam install - the launcher shows Version: 1.02.114714 - hope that's what you wanted for the Command.exe file?

Edited to fix second image.

< Message edited by Midcon113 -- 5/1/2021 1:40:04 AM >

(in reply to PaulTheWolf)
Post #: 5
RE: Cannot Launch Game - 5/1/2021 1:58:03 AM   
PaulTheWolf

 

Posts: 40
Joined: 12/10/2017
Status: offline
Hi Midcon. Thanks for the Screenshots. Any chance you could attach your .exe file as well? Also can you try downloading and extracting the Open Beta from the general Command Forum and see if that resolves the issue? I'm going to pass your screenshots along to the team.

Paul.

(in reply to Midcon113)
Post #: 6
RE: Cannot Launch Game - 5/1/2021 2:03:14 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline

quote:

ORIGINAL: PaulTheWolf

Hi Midcon. Thanks for the Screenshots. Any chance you could attach your .exe file as well? Also can you try downloading and extracting the Open Beta from the general Command Forum and see if that resolves the issue? I'm going to pass your screenshots along to the team.

Paul.


Ah, okay, attached Command.exe zipped up in it's own file.

I'll check out the beta and report back.

Thanks!!

Attachment (1)

(in reply to PaulTheWolf)
Post #: 7
RE: Cannot Launch Game - 5/1/2021 2:10:32 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline

quote:

ORIGINAL: PaulTheWolf

Hi Midcon. Thanks for the Screenshots. Any chance you could attach your .exe file as well? Also can you try downloading and extracting the Open Beta from the general Command Forum and see if that resolves the issue? I'm going to pass your screenshots along to the team.

Paul.


Reporting back...same issue with the beta dated 4/29/21 with an 05:48 timestamp.

(in reply to PaulTheWolf)
Post #: 8
RE: Cannot Launch Game - 5/1/2021 2:27:31 AM   
PaulTheWolf

 

Posts: 40
Joined: 12/10/2017
Status: offline
Hi midcon. Thanks for the update. I've passed this along to the team, and they've informed me that there is a common issue with fresh installs that precludes the prerequisites from installing fully during the base install process. The errors you're experiencing appear to relate to that.

This thread details the best approach for resolving that:

https://www.matrixgames.com/forums/tm.asp?m=3913550

Please run those individual exes indicated in this topic. Once that's complete you should also use Steam to verify your Game Cache's integrity via Steam.

This does appear to be tied to the Prerequisites somehow, and from what we've been able to see so far, installing them individually should resolve this issue.

Paul.

(in reply to Midcon113)
Post #: 9
RE: Cannot Launch Game - 5/1/2021 2:31:26 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline

quote:

ORIGINAL: PaulTheWolf

Hi midcon. Thanks for the update. I've passed this along to the team, and they've informed me that there is a common issue with fresh installs that precludes the prerequisites from installing fully during the base install process. The errors you're experiencing appear to relate to that.

This thread details the best approach for resolving that:

https://www.matrixgames.com/forums/tm.asp?m=3913550

Please run those individual exes indicated in this topic. Once that's complete you should also use Steam to verify your Game Cache's integrity via Steam.

This does appear to be tied to the Prerequisites somehow, and from what we've been able to see so far, installing them individually should resolve this issue.

Paul.


I've tried this as well, but I will give it another go. FYI the post being quoted refers to a "PreRequisites" folder that doesn't exist - at least in the Steam installation.

Going to do a fresh Steam Install, then try these out, and will report back. Thank you for your continued help with this!

(in reply to PaulTheWolf)
Post #: 10
RE: Cannot Launch Game - 5/1/2021 2:47:02 AM   
KnightHawk75

 

Posts: 1211
Joined: 11/15/2018
Status: offline
quote:

I do have Visual Studio 2019 Community edition installed along with all the DirectX programming items, as well as all the different variations of the .net frameworks. I doubt that has anything to do with this though.


It might in terms of what version of the frameworks\dependencies\etc are installed and the overall environment perhaps. x001c is usually ERROR_BAD_EXE_FORMAT, and commonly a bitness issue like trying to load a x64 dll into x32 process (or the reverse). I wonder if some unusual pathing order or environmental issue is going on making cmo attempt to load a x64 version of a dependency (or dependency of a dependency doing such) that it's expecting to be an x32 version. Just a thought should the usual attempts (dependencies,corrupted dependency or system file somewhere,AV,Viddrv,permissions,etc) fail to point toward the problem. Also eyeball [cmofolder]\logs\exception.log for any additional info that might be logged, probably the same info as your screenshots but might have more.


< Message edited by KnightHawk75 -- 5/1/2021 2:56:02 AM >

(in reply to Midcon113)
Post #: 11
RE: Cannot Launch Game - 5/1/2021 2:52:42 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline

quote:

ORIGINAL: Midcon113


quote:

ORIGINAL: PaulTheWolf

Hi midcon. Thanks for the update. I've passed this along to the team, and they've informed me that there is a common issue with fresh installs that precludes the prerequisites from installing fully during the base install process. The errors you're experiencing appear to relate to that.

This thread details the best approach for resolving that:

https://www.matrixgames.com/forums/tm.asp?m=3913550

Please run those individual exes indicated in this topic. Once that's complete you should also use Steam to verify your Game Cache's integrity via Steam.

This does appear to be tied to the Prerequisites somehow, and from what we've been able to see so far, installing them individually should resolve this issue.

Paul.


I've tried this as well, but I will give it another go. FYI the post being quoted refers to a "PreRequisites" folder that doesn't exist - at least in the Steam installation.

Going to do a fresh Steam Install, then try these out, and will report back. Thank you for your continued help with this!



As I suspected, I'm still getting the same errors. I had to resort to installing 3.5 via the Windows Feature app, and then in a last-ditch attempt tried using Visual Studio 2019 Community Edition to install all the 4.x .Net Frameworks, but I still have the same problem.

(in reply to Midcon113)
Post #: 12
RE: Cannot Launch Game - 5/1/2021 2:55:54 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline

quote:

ORIGINAL: KnightHawk75

quote:

I do have Visual Studio 2019 Community edition installed along with all the DirectX programming items, as well as all the different variations of the .net frameworks. I doubt that has anything to do with this though.


It might in terms of what version of the frameworks\dependencies\etc are installed and the overall environment perhaps. x001c is usually ERROR_BAD_EXE_FORMAT, and commonly a bitness issue like trying to load a x64 dll into x32 process (or the reverse). I wonder if some unusual pathing order or environmental issue is going on making cmo attempt to load a x64 version of a dependency (or dependency of a dependency doing such) that it's expecting to be an x32 version. Just a thought should the usual attempts (dependencies,corrupted dependency or system file somewhere,AV,Viddrv,permissions,etc) fail to point toward the problem.



Sounds logical - the error text does point to a 32-bit vs. 64-bit issue. I'm running an AMD Ryzen 7 3700X processor with 32 gigs of RAM so clearly everything is 64 bit on my machine. AMD Radeon RX 5700 XT video card. And this all ran fine prior to me having to reinstall Windows 10 for completely separate reasons.

(in reply to KnightHawk75)
Post #: 13
RE: Cannot Launch Game - 5/1/2021 3:07:45 AM   
KnightHawk75

 

Posts: 1211
Joined: 11/15/2018
Status: offline
fwiw does [cmo install path]\logs\exceptionlog.txt give you anything more than the screenshots?, probably not, but worth eyeballing if you haven't yet.


(in reply to Midcon113)
Post #: 14
RE: Cannot Launch Game - 5/1/2021 3:16:36 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline
quote:

ORIGINAL: KnightHawk75

fwiw does [cmo install path]\logs\exceptionlog.txt give you anything more than the screenshots?, probably not, but worth eyeballing if you haven't yet.




Well, in case it helps, here's the last log entry:


Successfully loaded Sim Configuration.

DPI registry setting, HKEY_CURRENT_USER\Control Panel\Desktop\LogPixels:0.

DPI registry setting, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontDPI\LogPixels:96.

DPI scale: 1.

Showing splash screen.

Initialization started.

4/30/2021 21:50:06 -- B1147.14 -- An error occurred creating the form. See Exception.InnerException for details. The error is: Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
Exception: An error occurred creating the form. See Exception.InnerException for details. The error is: Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
Stack Trace: at †...[T](T )
at †...()
at Command.Client.()
Inner Exception: Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
Inner StackTrace: at Command.MainForm..ctor()
Call Stack & Error details:
Error at 200576, An error occurred creating the form. See Exception.InnerException for details. The error is: Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)

4/30/2021 21:50:10 -- B1147.14 -- Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
Exception: Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
Stack Trace: at ‡..(Object , UnhandledExceptionEventArgs )
at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.raise_UnhandledException(Object sender, UnhandledExceptionEventArgs e)
at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnUnhandledException(UnhandledExceptionEventArgs e)
at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnUnhandledExceptionEventAdaptor(Object sender, ThreadExceptionEventArgs e)
at System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t)
at System.Windows.Forms.Control.WndProcException(Exception e)
at System.Windows.Forms.Control.ControlNativeWindow.OnThreadException(Exception e)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at †..(Object , StartupEventArgs )
Call Stack & Error details:
Error at 200575, Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)

< Message edited by Midcon113 -- 5/1/2021 3:17:31 AM >

(in reply to KnightHawk75)
Post #: 15
RE: Cannot Launch Game - 5/1/2021 3:38:12 AM   
KnightHawk75

 

Posts: 1211
Joined: 11/15/2018
Status: offline
Ok well it's the same info just in longer form with the stack trace.
Assuming the req's are all there already, have you run SFC /scannow to check for system file corruption?

(in reply to Midcon113)
Post #: 16
RE: Cannot Launch Game - 5/1/2021 9:04:05 PM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline

quote:

ORIGINAL: KnightHawk75

Ok well it's the same info just in longer form with the stack trace.
Assuming the req's are all there already, have you run SFC /scannow to check for system file corruption?


Hi KnightHawk - great suggestion, and I did run that and ran into some errors which were corrected. However, the problem is still there. Open to any other thoughts - thank you!

(in reply to KnightHawk75)
Post #: 17
RE: Cannot Launch Game - 5/1/2021 11:31:33 PM   
KnightHawk75

 

Posts: 1211
Joined: 11/15/2018
Status: offline
quote:

ORIGINAL: Midcon113
Hi KnightHawk - great suggestion, and I did run that and ran into some errors which were corrected. However, the problem is still there. Open to any other thoughts - thank you!

Assuming it's not .net runtime, vc-runtimes, driver related, or file corruption, or av getting in the way, or permissions issues...
yeah I have two more I can throw out there, I doubt either is the problem and it's gonna sound really simple but it's worth 30 seconds to check. The first has resolved the 001c and c0000143's for a few different apps of all flavors over the years. These people had either a "c:\program" file or folder or "c:\program.exe" file, if you have that for some odd reason remove\rename it. _NOT_ to be confused with "Program Files", just the word "program" only at the root of C:\. Having such can break certain apps under the right circumstances, I'll spare you then details unless it turns you have it and removing\renaming it resolves the issue.

The second, sort of related, but really tricky thing to spot, does the folder (or any other folder involved where you installed the application start with a space or end with an space such like "D:\Games\ Steam\steamapps\common\Cities_Skylines  "? (I have matrix version so idk exactly what the path is for steam for example.)

Failing that, maybe bust out ProcMon, filter for loadimage and watch what and from what folders files are attempted to be loaded from, paying attention to fails (but maybe successes too), checking if said files exist, and where runtimes are getting pulled from and what version, as it's far more likely you're suffering from something related to the usual stuff, even though I know you've said you've basically installed and re-installed said runtimes multiple times. Maybe official matrix support ticket at that point, though I'm sure others might have some ideas.

(in reply to Midcon113)
Post #: 18
RE: Cannot Launch Game - 5/2/2021 12:50:06 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline

quote:

ORIGINAL: KnightHawk75

quote:

ORIGINAL: Midcon113
Hi KnightHawk - great suggestion, and I did run that and ran into some errors which were corrected. However, the problem is still there. Open to any other thoughts - thank you!

Assuming it's not .net runtime, vc-runtimes, driver related, or file corruption, or av getting in the way, or permissions issues...
yeah I have two more I can throw out there, I doubt either is the problem and it's gonna sound really simple but it's worth 30 seconds to check. The first has resolved the 001c and c0000143's for a few different apps of all flavors over the years. These people had either a "c:\program" file or folder or "c:\program.exe" file, if you have that for some odd reason remove\rename it. _NOT_ to be confused with "Program Files", just the word "program" only at the root of C:\. Having such can break certain apps under the right circumstances, I'll spare you then details unless it turns you have it and removing\renaming it resolves the issue.

The second, sort of related, but really tricky thing to spot, does the folder (or any other folder involved where you installed the application start with a space or end with an space such like "D:\Games\ Steam\steamapps\common\Cities_Skylines  "? (I have matrix version so idk exactly what the path is for steam for example.)

Failing that, maybe bust out ProcMon, filter for loadimage and watch what and from what folders files are attempted to be loaded from, paying attention to fails (but maybe successes too), checking if said files exist, and where runtimes are getting pulled from and what version, as it's far more likely you're suffering from something related to the usual stuff, even though I know you've said you've basically installed and re-installed said runtimes multiple times. Maybe official matrix support ticket at that point, though I'm sure others might have some ideas.


Hi KnightHawk,

Couple of things: I got procmon installed (I haven't used SysInternals in ages ... forgot it even existed! :)) When you say filter for loadimage, filter "what" for loadimage? I don't know my way around procmon yet.

I tried one other thing, which was to load up all the DLC I own (all of them) in addition to Command from Steam, and while I'm getting the same error, I also got an "Unhandled Exception" error when trying to load via Northern Inferno. Here's that text, not sure it'll help:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.BadImageFormatException: Could not load file or assembly 'Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
File name: 'Microsoft.DirectX.Direct3DX.dll'
at Command.MainForm.(Object , EventArgs )
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at Command.MainForm.WndProc(Message& )
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)




************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4341.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
Command
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///E:/SteamLibrary/steamapps/common/Command%20Modern%20Air%20%20Naval%20Operations/Command.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 10.0.0.0
Win32 Version: 14.8.4084.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4300.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4341.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4341.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4190.0 built by: NET48REL1LAST_B
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Web
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4330.0 built by: NET48REL1LAST_B
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Web/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Web.dll
----------------------------------------
Steamworks.NET
Assembly Version: 7.0.0.0
Win32 Version: 7.0.0
CodeBase: file:///E:/SteamLibrary/steamapps/common/Command%20Modern%20Air%20%20Naval%20Operations/Steamworks.NET.DLL
----------------------------------------
PresentationFramework
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4341.0
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/PresentationFramework/v4.0_4.0.0.0__31bf3856ad364e35/PresentationFramework.dll
----------------------------------------
WindowsBase
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4341.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/WindowsBase/v4.0_4.0.0.0__31bf3856ad364e35/WindowsBase.dll
----------------------------------------
PresentationCore
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4341.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/PresentationCore/v4.0_4.0.0.0__31bf3856ad364e35/PresentationCore.dll
----------------------------------------
System.Xaml
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4341.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xaml/v4.0_4.0.0.0__b77a5c561934e089/System.Xaml.dll
----------------------------------------
{b0dd12fe-b4f2-4619-adf4-648c2702c394}
Assembly Version: 0.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///E:/SteamLibrary/steamapps/common/Command%20Modern%20Air%20%20Naval%20Operations/GameMenu_CNI/../Command.exe
----------------------------------------
PresentationFramework.Aero2
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/PresentationFramework.Aero2/v4.0_4.0.0.0__31bf3856ad364e35/PresentationFramework.Aero2.dll
----------------------------------------
System.Runtime.Caching
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Caching/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Runtime.Caching.dll
----------------------------------------
WindowsFormsIntegration
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/WindowsFormsIntegration/v4.0_4.0.0.0__31bf3856ad364e35/WindowsFormsIntegration.dll
----------------------------------------
Odyssey
Assembly Version: 1.4.22.32171
Win32 Version: 1.4.22.35
CodeBase: file:///E:/SteamLibrary/steamapps/common/Command%20Modern%20Air%20%20Naval%20Operations/Odyssey.DLL
----------------------------------------
System.Windows.Interactivity
Assembly Version: 4.0.0.0
Win32 Version: 2.0.20525.0
CodeBase: file:///E:/SteamLibrary/steamapps/common/Command%20Modern%20Air%20%20Naval%20Operations/System.Windows.Interactivity.DLL
----------------------------------------
PresentationFramework-SystemXml
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/PresentationFramework-SystemXml/v4.0_4.0.0.0__b77a5c561934e089/PresentationFramework-SystemXml.dll
----------------------------------------
Microsoft.DirectX
Assembly Version: 1.0.2902.0
Win32 Version: 5.04.00.2904
CodeBase: file:///C:/Windows/assembly/GAC/Microsoft.DirectX/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

(in reply to KnightHawk75)
Post #: 19
RE: Cannot Launch Game - 5/2/2021 3:33:20 AM   
KnightHawk75

 

Posts: 1211
Joined: 11/15/2018
Status: offline
You can filter on:
process name "is" Command.exe include
operation "is not" load image exclude
Then start Command.exe
Should narrow results (for me to the main screen) to like ~250 entries, and look (minus paths although some should probably be roughly the same on win 10) like this, but you more easily can see where things load from like if it's gac, vs native image assembly store, etc.


You tried the dx EndUserRuntimes right, I noticed you mentioning the prereq's folder was not there for steam figured it's worth repeating if not, I know that post mentions the march 2009 folder, but my matrix install has the June_2010's that you can grab here:
https://www.microsoft.com/en-us/download/details.aspx?id=8109

< Message edited by KnightHawk75 -- 5/2/2021 4:17:37 AM >

(in reply to Midcon113)
Post #: 20
RE: Cannot Launch Game - 5/2/2021 9:52:09 PM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline
Okay, this is now resolved, but I have concerns about the resolution.

After following all the great advice from this forum, plus a lot of searching the web, I determined that ultimately this wasn't going to get fixed if I didn't do something drastic, so I did a Windows reset on my PC. I then got Windows updated to the latest version via Windows update. So far, very easy. But here's where it gets interesting.

1) Reinstalled Steam - straightforward.
2) Reinstalled Command - not any of the DLCs, just the core program.
3) Attempted to run the program and had the exact same issue. (Got pissed at this point LOL)
4) Sat for a few minutes trying to think of anything I had missed and then it dawned on me that I hadn't yet installed the Radeon drivers for my graphics card, so I downloaded and installed Radeon Drivers. Now normally I would have searched and downloaded the Adrenalin program which is for the graphics card only, but this time I actually got chipset drivers in addition to the graphics card drivers. That was new step #1.
5) Radeon wants a couple of restarts which we do.
6) Now I'm looking at my desktop and there it sits - the Command shortcut. On a whim, I double click it.
7) Steam now installs some of the Prerequisites that have been talked about here.
8) Game launches just fine.

So, here's my concern - why isn't Steam not installing the right prereqs when I launch the game from the Steam app? I normally do that - I turn off desktop icons and never use them. Is this a problem on Steam's end? Is it something in Command's installation routine that's off? I can't figure out why using a desktop shortcut fixed this.

To make sure things continue to work, I installed Chains of War and then launched from within steam, and it appears to continue to work just fine.

So, I guess we're done with the troubleshooting here as far as I am concerned - thanks all for the suggestions! Hopefully the team can figure out what actually happened here and do something to prevent it in the future.

Mark

(in reply to KnightHawk75)
Post #: 21
RE: Cannot Launch Game - 5/3/2021 1:42:50 AM   
KnightHawk75

 

Posts: 1211
Joined: 11/15/2018
Status: offline
quote:

Just a thought should the usual attempts (dependencies,corrupted dependency or system file somewhere,AV,Viddrv,permissions,etc) fail to point toward the problem.

quote:

Assuming it's not .net runtime, vc-runtimes, driver related, or file corruption, or av getting in the way, or permissions issues...

quote:

4) Sat for a few minutes trying to think of anything I had missed and then it dawned on me that I hadn't yet installed the Radeon drivers for my graphics card, so I downloaded and installed Radeon Drivers. Now normally I would have searched and downloaded the Adrenalin program which is for the graphics card only, but this time I actually got chipset drivers in addition to the graphics card drivers.


So the two times vid drivers were mentioned, didn't make you think to install the Radeon drivers?
That's usually step 2 or 3 after one reinstalls the os, but hey I'm glad it's resolved and you can play now.

Thanks for the update.

(in reply to Midcon113)
Post #: 22
RE: Cannot Launch Game - 5/3/2021 2:07:00 AM   
Midcon113


Posts: 86
Joined: 12/18/2014
From: Wheaton, IL
Status: offline
quote:

So the two times vid drivers were mentioned, didn't make you think to install the Radeon drivers?


LOL Fair enough - but in my defense, the video card drivers were installed before (and up to date) and I didn't realize AMD had Radeon drivers for the chipset for the motherboard. I've learned that lesson now.

Thanks!

(in reply to KnightHawk75)
Post #: 23
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Resolved] Cannot Launch Game Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.332