Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Multi Player "Time Lag"

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Close Combat – The Bloody First >> Close Combat: The Bloody First - Tech Support Forum >> Multi Player "Time Lag" Page: [1]
Login
Message << Older Topic   Newer Topic >>
Multi Player "Time Lag" - 12/21/2020 10:46:45 AM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
Dear matrix,

I posted this on the Steam forum too, but it recommends posting here:

I bought the game (twice!) to play with my brother... but we just started playing tonight and the game seems to lose sync? I finished my 15 minute engagement and my brother still had nearly 5 minutes on his clock????

Whats all that about? Is there any way to deal with this?

We both have Windows 10 installs, and play via Steam installs, via the MP Lobby in game.

We have been looking forward to this for ages, but this destroys the H2H fun completely.....
Post #: 1
RE: Multi Player "Time Lag" - 12/21/2020 6:28:15 PM   
SteveMcClaire

 

Posts: 4430
Joined: 11/19/2007
Status: offline
Hi VonVolks,

If your brother plays the game single player does it run slower than 'real time' on his machine? This can happen with older video cards depending on the game options you have set. If this is the case, I'd recommend he turn off some of the more taxing graphical settings in the game options -- set 'Show Ground Clutter' off, 'Shadows' to off, and Antialiasing to 'None' to see if that helps if this is the case.

Please let me know if this is the issue or not, as we haven't been able to reproduce this problem and we're collecting information to try and help pinpoint the cause.

(in reply to VonVolks)
Post #: 2
RE: Multi Player "Time Lag" - 12/21/2020 7:27:36 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
Thanks Steve,

Also we seem to be having real issues with the lobby trying to get "multi battle" continuity....

If we finish a round, and go to briefing (I was hosting) it would often make me go tot he multiplayer log in and back to the MP Lobby, whilst my brother would still be in the game, as if he was still connected to our game but I wasn't anymore....

If he left to go back to MP Lobby, I would be there, but I couldn't host or join, as it would send me an error message saying "not available" or something....

Its being very difficult, which is not promosing for our planned "Grand CampaigN" style H2H....

(in reply to SteveMcClaire)
Post #: 3
RE: Multi Player "Time Lag" - 12/21/2020 7:31:46 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
By the way Steve I heard you basically got the game going....so you know my brother and I are super long time massive CC fans, from CC1, so well done for keeping it it running, but we really want to be able to actually play it as well! 8)

(in reply to VonVolks)
Post #: 4
RE: Multi Player "Time Lag" - 12/22/2020 5:42:49 PM   
SteveMcClaire

 

Posts: 4430
Joined: 11/19/2007
Status: offline
If one player is still in the battle and the other proceeds to the debrief screen there will be sync issues. So if this problem occurs your best bet for continuing the game without sync problems is to wait for them to click the 'Debrief' button at the end of the battle.

I can't take credit for starting Close Combat -- my involvement didn't begin until after Atomic Games had closed up shop. But I'm glad you've enjoyed the series and hopefully we can resolve this issue.

(in reply to VonVolks)
Post #: 5
RE: Multi Player "Time Lag" - 12/22/2020 5:44:10 PM   
SteveMcClaire

 

Posts: 4430
Joined: 11/19/2007
Status: offline
One other thing -- please ask your brother what setting he is using for 'Game Speed' in his game options. This /should/ be ignored in multiplayer (it is always 100% speed) but I would like to confirm the settings as a data point. Thanks!

(in reply to VonVolks)
Post #: 6
RE: Multi Player "Time Lag" - 12/22/2020 6:39:23 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
Yes his is set to 100%. I had already checked about that.

I actually set mine to 90% after we started having sync problems, in case it might help "lessen the gap" if you see what i mean? Should I set mine back to 100% as well?

In terms of "post battle" order of actions. Should I (as host) wait for my brother to hit "Debrief" first before I exit the battle, and then at every stage following let him make the first click?

Update: with careful "Host letting client click first" procedure, the Multi Player progress issues seems to be OK on last nights test....

However there was still some "Time Lag" issues..... MY brother has now set the Shadows to "OFF" and Ground Clutter to "OFF" so we shall see how that goes. I am still set to 90% time speed.

< Message edited by VonVolks -- 12/23/2020 11:08:11 AM >

(in reply to SteveMcClaire)
Post #: 7
RE: Multi Player "Time Lag" - 1/1/2021 8:05:18 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
Update....

GC started and going well, on Operation 4 or something like that...

However even though the lag seems less often and smaller we are still getting my brother as client lagging a bit from say 15 - 35 seconds usually (but at worst one minute).

He has anti aliasing off. Shadows None, no ground clutter.

We have just turned off "high quality LOS" tool as well, to see if that helps?

Any other ideas?

(in reply to VonVolks)
Post #: 8
RE: Multi Player "Time Lag" - 1/2/2021 5:19:47 PM   
PipFromSlitherine

 

Posts: 1450
Joined: 6/23/2010
Status: offline
If you both hit SHIFT+Q what is the framerate value shown in the top left? We want to determine if it is an issue of general performance, or if it is a MP networking stack issue.

Cheers

Pip


_____________________________

follow me on Twitter here

(in reply to VonVolks)
Post #: 9
RE: Multi Player "Time Lag" - 1/2/2021 7:22:29 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
HI Pip,

I will try that next time we play. We just played a game and the time lag was terrible...... up to 2 minutes sometimes....

We both just run windows 10 computer performance checks and the results were pretty good for both... My brothers worst score was graphics and he got a 5.7 rating .. so not super terrible....

we will try the Shift Q now....

(in reply to PipFromSlitherine)
Post #: 10
RE: Multi Player "Time Lag" - 1/2/2021 7:51:14 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
We just tried single battle on Tine Valley.....

My FPS was generally around 48 but dipped down to 18 (once for a second) so it was 18- 60

My brother was generally around average 24 (zoomed out to max) and zoomed in was average of 45 (high of 52)

We also did small map battle.... but both suffered no time lag at all.....

So next time we play in the actual GC, if we suffer lag we will do the shift+Q test.....

(in reply to VonVolks)
Post #: 11
RE: Multi Player "Time Lag" - 1/4/2021 8:12:21 AM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
Update... we play via steam, and were getting weird audio feedback through Steam Chat which we used for voice comms.... For example even though we were both using headphones my brother could hear my audio sometimes and we were getting voice echo etc

So as an experiment last night we tried no steam comms and just used Whatsapp.. no lag seemingly? So possibly Steam chat + CC was doing something weird network wise? No idea but we will keep going without using Steam chat to see if we get lag..... and report in...

(in reply to VonVolks)
Post #: 12
RE: Multi Player "Time Lag" - 1/4/2021 9:55:03 PM   
SteveMcClaire

 

Posts: 4430
Joined: 11/19/2007
Status: offline
Glad you've been able to get some improvement -- based on what you've reported so far it seems more likely to be a CPU/GPU related rather than network through-put. It could be that the Steam comms were eating more of the available CPU on your brother's machine, which was already taxed by the game itself.

Neither player's game speed should matter -- multiplayer should always play at 100% game speed regardless of the local setting. I just wanted to know for reference purposes.

(in reply to VonVolks)
Post #: 13
RE: Multi Player "Time Lag" - 1/23/2021 7:33:23 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
we are still suffering badly from Time Lag....

It is usually happening almost instantly on the start of the game. My brother is showing around 25 -35 FPS, I am usually at 60.

It even happens at the start of battles where there is NO action taking place, ie shooting / artillery bombardments , nothing....

Its really frustrating and is a MAJOR problem for H2H play which is th eonly reason we got the game?

Any more ideas?

(in reply to SteveMcClaire)
Post #: 14
RE: Multi Player "Time Lag" - 1/25/2021 11:05:33 PM   
PipFromSlitherine

 

Posts: 1450
Joined: 6/23/2010
Status: offline
Can you give us more information on your networking setups - wifi/hard, bandwidth, other bandwidth users, etc. That may help us try and find any common elements.

Cheers

Pip


_____________________________

follow me on Twitter here

(in reply to VonVolks)
Post #: 15
RE: Multi Player "Time Lag" - 2/5/2021 7:19:13 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
Hi Pip,

I have tried using wifi and hard connected to ADSL. I think my brother is always via wifi. The connections are not super fast, but a 2 player game like this shouldn't be super demanding.

We played again tonight and again suffered 2 minute lag in a sicily fight. It is killing enjoyment as its basically not head to head if one player is 2 minutes behind!

Its not consistently happening, and sometimes it happens straight from the off, and sometimes develops over the 30 minute game....


(in reply to PipFromSlitherine)
Post #: 16
RE: Multi Player "Time Lag" - 2/7/2021 8:22:36 PM   
lordmike-cc

 

Posts: 1
Joined: 3/27/2018
Status: offline
Hi Pip,

This has been happening to a friend and I in our 2-player games as well. We start in the lobby and for a few minutes everything is fine, but usually by the time we're 5 minutes into the games the clock has slowed so that 1 second of clock time takes 2-3 real seconds. For us it seems to be synced up between us, and we both run slow. We both have slightly older hardware, i7-4790 w/ GTX590 and i5-2600k w/Radeon 6800. We both have fast internet connections (400mbit down, 25mbit up). Neither of us has seen this in single player games, only when we play each other. We started our Grand Campaign not long after the game came out, and I think we were over 1/2 way through before this cropped up, maybe after a patch. We have recently finished that GC game and started a new one, which also has the problem, so it doesn't seem to be related to the fact it was an old save game. We are happy to provide whatever information you'd like to help identify what's going on.

Thanks,

Mike

(in reply to VonVolks)
Post #: 17
RE: Multi Player "Time Lag" - 2/8/2021 2:37:56 PM   
SteveMcClaire

 

Posts: 4430
Joined: 11/19/2007
Status: offline
VonVolks -- can you and your opponent switch who is hosting (i.e. have the player with the slower-running game host) and see if that effects what you see in terms of game timing? Thanks.


(in reply to VonVolks)
Post #: 18
RE: Multi Player "Time Lag" - 2/10/2021 12:01:47 PM   
VonVolks

 

Posts: 31
Joined: 2/12/2009
Status: offline
OK we will try that.....

(in reply to SteveMcClaire)
Post #: 19
RE: Multi Player "Time Lag" - 2/10/2021 4:27:07 PM   
SteveMcClaire

 

Posts: 4430
Joined: 11/19/2007
Status: offline
Thank you. I appreciate your assistance trying to pinpoint the problem.

(in reply to VonVolks)
Post #: 20
RE: Multi Player "Time Lag" - 4/8/2021 12:15:25 AM   
STIENER

 

Posts: 857
Joined: 1/7/2001
From: Vancouver, Canada
Status: offline
theres still timer issues eh...even after 2 or 3 more updates. sad. we shouldnt have to turn OFF game functions to make it work...altho turning off the game functions doesnt help any ways. if your PC is up to the game standards the timer should function properly. as vonvolks has said and i have said in past posts while trying to get the timer issue fixed...this is a real issue...a game breaker. knights and i quit playing last year after beating our heads against the wall with the timer issue...as did other players im sure...too bad...game had possibility's but lack of getting to the bottom of the issue is even worse. i wasted alot of money on a game thats isnt playable H2H. not even playable against the AI with the tank main gun excessive loading times and tank and a/t gun accuracy.



< Message edited by STIENER -- 4/8/2021 12:17:47 AM >

(in reply to SteveMcClaire)
Post #: 21
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Close Combat – The Bloody First >> Close Combat: The Bloody First - Tech Support Forum >> Multi Player "Time Lag" Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.461