Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Ok thanks to all your help almost there - But....

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Ok thanks to all your help almost there - But.... Page: [1]
Login
Message << Older Topic   Newer Topic >>
Ok thanks to all your help almost there - But.... - 10/27/2020 6:27:15 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Thank you for all your help so far!! I managed to find a good work around for the problems with 2 separate shortcuts!!!! One for replay ( V small screen) and one for orders ( big wide screen).

However in the full wide screen I still have a big problem. With the mouse at the edge the screen it will scroll Northward and Westward fine - no lag etc :) and mouse on the screen edge.

But not South or East how weird is that? No mouse image can be seen, have you got any suggestions. Here is the command line for my orders shortcut that allows full use of the screen but not scrolling S +E.

"C:\Matrix Games\War in the Pacific Admiral's Edition ORIGINAL\Beta2\War in the Pacific Admiral Edition.exe" -px3440 -py1440 -nofire -deepColor -cpu2 -altFont

the only thing is to get this scrolling S and E.

Thanks M

Post #: 1
RE: Ok thanks to all your help almost there - But.... - 10/28/2020 2:20:04 AM   
geofflambert


Posts: 14838
Joined: 12/23/2010
From: St. Louis
Status: offline
I'm not any good at this and I've never used the resolution you are, but just out of curiosity, can you see the bottom of the display (not of the map but the part with info about hex contents). Here's a pic of what I'm seeing on mine. You can see part of the bottom is obscured and the cursor has to be below that before scrolling occurs.
edit: I'm using windowed mode




Attachment (1)

< Message edited by geofflambert -- 10/28/2020 2:23:32 AM >


_____________________________

Currently fighting for the Emperor against AW1Steve. As of 8/21 it is 8/45.

(in reply to Cavalry Corp)
Post #: 2
RE: Ok thanks to all your help almost there - But.... - 10/28/2020 3:22:18 AM   
Nomad


Posts: 5469
Joined: 9/5/2001
From: West Yellowstone, Montana
Status: online
Your spaceship is interfering with the display.

_____________________________


(in reply to geofflambert)
Post #: 3
RE: Ok thanks to all your help almost there - But.... - 10/28/2020 11:59:12 PM   
Xargun

 

Posts: 3634
Joined: 2/14/2004
From: Near Columbus, Ohio
Status: offline
Do you have multiple monitors?

Xargun

(in reply to Cavalry Corp)
Post #: 4
RE: Ok thanks to all your help almost there - But.... - 10/29/2020 7:58:48 AM   
Chris21wen

 

Posts: 6170
Joined: 1/17/2002
From: Cottesmore, Rutland
Status: online

quote:

ORIGINAL: Xargun

Do you have multiple monitors?

Xargun



This will answer the E movement but it does work but the point on the activation on the screen is very narrow and usually kust on the left edge of the second monitor.

Guess here from you pic. It looks as if you can't see the bottom of the game screen so this might be the cause of the S movement. Put it in a window so you can and then try. If it works then that's the problem.

(in reply to Xargun)
Post #: 5
RE: Ok thanks to all your help almost there - But.... - 10/29/2020 8:51:40 AM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Thanks for the suggestions if I put it in -w mode I can now scroll!! BUT I cannot see the base info at the bottom of the screen and also the off map bases are not showing. Any ideas?

I have only one monitor.

(in reply to Chris21wen)
Post #: 6
RE: Ok thanks to all your help almost there - But.... - 10/29/2020 4:46:11 PM   
BBfanboy


Posts: 17617
Joined: 8/4/2010
From: Winnipeg, MB
Status: online

quote:

ORIGINAL: Cavalry Corp

Thanks for the suggestions if I put it in -w mode I can now scroll!! BUT I cannot see the base info at the bottom of the screen and also the off map bases are not showing. Any ideas?

I have only one monitor.

You need to look at the other switches available. The -dd_sw switch might help. Other people reported this problem when Win 10 came out but solved it. The thread on "Slow Performance" covers a lot of problems if you scan through it.

_____________________________

No matter how bad a situation is, you can always make it worse. - Chris Hadfield : An Astronaut's Guide To Life On Earth

(in reply to Cavalry Corp)
Post #: 7
RE: Ok thanks to all your help almost there - But.... - 10/29/2020 4:51:11 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
I think I have tried this switch already. And rather strangely it seems to lock up my whole screen. Not just a game. I will try again though. Thanks for the help.

(in reply to BBfanboy)
Post #: 8
RE: Ok thanks to all your help almost there - But.... - 10/31/2020 8:21:49 AM   
moore4807


Posts: 1089
Joined: 6/2/2000
From: Punta Gorda FL
Status: offline
I am getting my game restored so I do not offer any guarantees with my advice, but your description of your problem is ringing a bell with my ancient memory cells. you should be looking for the post that talks about bleedover on the edge of the screen and different types of video cards.

What I remember was Nvidia cards would take the same desktop resolution and it would do exactly the same thing of overrunning sides of the screen, that is why your mouse only works against one side of the -pw & -py axis, while the other "side" actually is extending beyond your monitors capability to scroll or move to the opposite end.

My hazy memory thinks the answer given was you had to play with the resolution to get the screen the right resolution -pw -py size for the -w (windowed) mode to properly display. The axis had to be smaller than your screen size in both directions, but the Nvidia cards were giving people fits because GeForce cards resolution didn't fit all sizes, just like you are pointing out.

I still can't find the post - and there are newer posts that discuss the wide screen aspects - but I can't shake that feeling that I had the problem once myself - I had a 42" TV attached and had a devil of a time getting a good resolution between the game, the video card and the 1080p TV. Good Luck!


Found Korvar's post in "Command Line Switch Reference" in Tech Support after posting mine - last sentence could be important for your problems.

Korvar
Matrix Hero

Posts: 813
Joined: 9/3/2014
Status: offline Good idea!

A couple more that come to mind:

-pxf#### -pyf####
A more 'forceful' implementation of the -px and -py switches. Allows 'non-standard' resolutions. If the -px -py switches aren't working for you, try these.

-noFire
Disables the fires, explosions, etc. in the combat replays. Helps with certain video cards that don't handle these well.


Also, a few brief reminders:

-dd_sw and -deepColor are the ones to try first if you have slow interface issues (often in relatively newer versions of Windows: 7, 8, 10).

-archive is very important if you plan to use any of the optional add-on utilties to WitPAE (Tracker, Combat Reporter, Intel Monkey, etc.).

As 4k+ resolution monitors become more common, there has been at least one report of an upper resolution limit of 3000 x 1500 (unconfirmed so far) where slowness returns above that. It could easily be specific to the 1st report though.

< Message edited by moore4807 -- 10/31/2020 8:44:14 AM >


_____________________________


(in reply to Cavalry Corp)
Post #: 9
RE: Ok thanks to all your help almost there - But.... - 10/31/2020 10:14:05 AM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Many thanks I inserted some comments...


quote:

ORIGINAL: moore4807

I am getting my game restored so I do not offer any guarantees with my advice, but your description of your problem is ringing a bell with my ancient memory cells. you should be looking for the post that talks about bleedover on the edge of the screen and different types of video cards.

What I remember was Nvidia cards would take the same desktop resolution and it would do exactly the same thing of overrunning sides of the screen, that is why your mouse only works against one side of the -pw & -py axis, while the other "side" actually is extending beyond your monitors capability to scroll or move to the opposite end.

My hazy memory thinks the answer given was you had to play with the resolution to get the screen the right resolution -pw -py size for the -w (windowed) mode to properly display. The axis had to be smaller than your screen size in both directions, but the Nvidia cards were giving people fits because GeForce cards resolution didn't fit all sizes, just like you are pointing out.

I still can't find the post - and there are newer posts that discuss the wide screen aspects - but I can't shake that feeling that I had the problem once myself - I had a 42" TV attached and had a devil of a time getting a good resolution between the game, the video card and the 1080p TV. Good Luck!


Found Korvar's post in "Command Line Switch Reference" in Tech Support after posting mine - last sentence could be important for your problems.

Korvar
Matrix Hero

Posts: 813
Joined: 9/3/2014
Status: offline Good idea!

A couple more that come to mind:

-pxf#### -pyf####
A more 'forceful' implementation of the -px and -py switches. Allows 'non-standard' resolutions. If the -px -py switches aren't working for you, try these. mi tried these no diference but I guess I can again

-noFir e
Disables the fires, explosions, etc. in the combat replays. Helps with certain video cards that don't handle these well.I will try that but replay is not the main issue.


Also, a few brief reminders:

-dd_sw and -deepColor are the ones to try first if you have slow interface issues (often in relatively newer versions of Windows: 7, 8, 10). hve tried these no success and they make my screen worse - except deepCpolor

-archive is very important if you plan to use any of the optional add-on utilties to WitPAE (Tracker, Combat Reporter, Intel Monkey, etc.). No need as I do not use.

As 4k+ resolution monitors become more common, there has been at least one report of an upper resolution limit of 3000 x 1500 (unconfirmed so far) where slowness returns above that. It could easily be specific to the 1st report though. Can I use a resolution not suggested as a standard one by the PC?


(in reply to moore4807)
Post #: 10
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 1:35:47 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Any other ideas on this as it looks increasingly unlikely I will be able to continue with the game. I do have it on another PC but to have two pc to play one game is a bit over the top and its due to be sold.

(in reply to Cavalry Corp)
Post #: 11
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 1:37:58 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
As moore said here it maybe to do with bleedover but I have no idea how to even attempt a fix for that. Maybe I need to find a PC addict to come in and try??? After lockdown...



"I am getting my game restored so I do not offer any guarantees with my advice, but your description of your problem is ringing a bell with my ancient memory cells. you should be looking for the post that talks about bleedover on the edge of the screen and different types of video cards."

(in reply to Cavalry Corp)
Post #: 12
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 1:48:21 PM   
RangerJoe


Posts: 13111
Joined: 11/16/2015
From: My Mother, although my Father had some small part.
Status: online
Have you tried to install the game using the SeeBee utility? If not, try it in a separate folder, see how it runs, then check the switches. You still might want to add a switch or two but it might help to try.

_____________________________

Seek peace but keep your gun handy.

I'm not a complete idiot, some parts are missing!

“Illegitemus non carborundum est (“Don’t let the bastards grind you down”).”
― Julia Child


(in reply to Cavalry Corp)
Post #: 13
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 2:17:55 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Thanks for the help... I could try but do not know how to install it?? Sounds stupid I know. I thought it was just a tidy workaround for all the switches we try and put in.

I just downloaded it but the.exe is not allowed to extract on my computer. I need to get my technical onto this on Monday. I assume it will then allow me to at least install it.

Is this a kind of replacement shortcut?

Is there a step by step idiots guide to installing it. Otherwise I will just installed it on the desktop and try to manage it from there.

(in reply to RangerJoe)
Post #: 14
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 3:08:36 PM   
BBfanboy


Posts: 17617
Joined: 8/4/2010
From: Winnipeg, MB
Status: online

quote:

ORIGINAL: Cavalry Corp

Thanks for the help... I could try but do not know how to install it?? Sounds stupid I know. I thought it was just a tidy workaround for all the switches we try and put in.

I just downloaded it but the.exe is not allowed to extract on my computer. I need to get my technical onto this on Monday. I assume it will then allow me to at least install it.

Is this a kind of replacement shortcut?

Is there a step by step idiots guide to installing it. Otherwise I will just installed it on the desktop and try to manage it from there.


You need to log onto your computer as someone who has Administrator rights - a check box you should have made in your profile. I think that is under Security in the computer's Windows settings.
Once you are signed on as administrator, it should ask you if it is OK to open the .exe, and when you choose Yes it should run and install.



_____________________________

No matter how bad a situation is, you can always make it worse. - Chris Hadfield : An Astronaut's Guide To Life On Earth

(in reply to Cavalry Corp)
Post #: 15
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 5:21:32 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Thanks for your help once again. Ok have worked it out ...

In the mean time my technician has tried to help me out and we found one or 2 new things to try. and it has yielded some positive results. One thing that has helped is to not use any of the standard settings for resolutions. we have made Adjustment outside the settings offered by the computer. This is probably never good enough for me to continue with the game on this new computer. Especially as I am enjoying playing my own Mod - lucky me.

I still have one issue to resolve I will put a post up about it tomorrow. it seems as if the combat screen is kind of duplicated. It has 2 sort off windows one laid the other. This means you cannot press the done button to get through the to get through the combat a bit quicker.

Here is the current command line

"C:\Matrix Games\War in the Pacific Admiral's Edition ORIGINAL\Beta2\War in the Pacific Admiral Edition.exe" -w -f -pxf3440 -pyf1340 -nofire -SingleCpuOrders -cpu3

(in reply to BBfanboy)
Post #: 16
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 5:30:27 PM   
geofflambert


Posts: 14838
Joined: 12/23/2010
From: St. Louis
Status: offline
"done button" ? Do you mean the Esc key?

_____________________________

Currently fighting for the Emperor against AW1Steve. As of 8/21 it is 8/45.

(in reply to Cavalry Corp)
Post #: 17
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 6:04:14 PM   
Nomad


Posts: 5469
Joined: 9/5/2001
From: West Yellowstone, Montana
Status: online
"C:\Matrix Games\War in the Pacific Admiral's Edition ORIGINAL\Beta2\War in the Pacific Admiral Edition.exe" -w -f -pxf3440 -pyf1340 -nofire -SingleCpuOrders -cpu3

Well for one thing the -f means you want full screen and the -w means you want a windowed screen. I do think you will have to make up your mind.

_____________________________


(in reply to geofflambert)
Post #: 18
RE: Ok thanks to all your help almost there - But.... - 11/6/2020 6:34:42 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Done button on combat replay screen top right - not esc

So I maybe I will try an delete -f??

Does not sound as though its the problem I have though - but I will try.

(in reply to Nomad)
Post #: 19
RE: Ok thanks to all your help almost there - But.... - 11/7/2020 10:07:01 AM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
Okay so here is the screen of the problem.

Find this particular version you can see that the screen has split but that is not the main problem the combat screen is kind of duplicated. Do you think I should try and reduce the screen resolution East and West. the north and South axis seems fine it's just inside the screen. I don't want to try this if people think it will not help the situation.

Any comments are welcome thank you.







Attachment (1)

(in reply to Cavalry Corp)
Post #: 20
RE: Ok thanks to all your help almost there - But.... - 11/7/2020 2:07:44 PM   
BBfanboy


Posts: 17617
Joined: 8/4/2010
From: Winnipeg, MB
Status: online
Depending on the computer and video chip or card, the specs may not be able to handle the volume of graphic data you are throwing at it. The night mask on half your screen suggests to me that it is drawing half the map, then loading more data and drawing the other half of the map with the night mask added at the end. I don't have any ideas about the doubled combat screen unless it is also a memory/redraw issue.

What are the specs on the computer - CPU, RAM and video card/VRAM?

One of the things that can happen in this game is that the sheer volume of data in the database gradually fills up RAM (as you select items and the computer calls up the details, it seems to store the info in RAM). And if you use the Esc key too much, it can cause something called a memory leak that messes up the RAM storage. When that happens to me (after playing several turns without a restart) I get things like the icons for LCUs not showing up when I select a base, but if I then select the dot on the map representing the LCUs, they then show up on the base screen. The solution is just to save the game and restart.
Your extreme monitor size and map coverage may play into that issue by overloading the RAM or VRAM.

PS - also turn off any other programs you have running like anti-virus when you are playing the game.

_____________________________

No matter how bad a situation is, you can always make it worse. - Chris Hadfield : An Astronaut's Guide To Life On Earth

(in reply to Cavalry Corp)
Post #: 21
RE: Ok thanks to all your help almost there - But.... - 11/9/2020 4:29:10 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
BB - thank you for writing this. I have been messing around with the width settings( bespoke now not suggested by the pc) and things seem to be better, I think it is true that distorted shape of the screen is the major issue, That is it is very wide compared to its height . However I thought I had tried them before and they did not work. There must be something I have changed without knowing it and I think there is a possibility it's going to work OK. I will report back when I receive the next turn to see if it runs well. I note the point about turning off the other programs. Specification of this computer is very high (because I am the company and I splurged help on something pretty good). if need be I will come back to you but they should not be a problem. Thanks.

(in reply to BBfanboy)
Post #: 22
RE: Ok thanks to all your help almost there - But.... - 11/16/2020 4:45:06 PM   
Cavalry Corp

 

Posts: 2991
Joined: 9/2/2003
From: Sampford Spiney Devon UK
Status: offline
I just wanted to say thank you to everybody who contributed to my threads.

I have managed after a lot of fuss to get the game to a playable level - not perfect but I can live with it. I Was worried I my need to have given up. Thanks all.

(in reply to Cavalry Corp)
Post #: 23
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Ok thanks to all your help almost there - But.... Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.379