Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[Logged] Text Editor Issue (Again)

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Logged] Text Editor Issue (Again) Page: [1]
Login
Message << Older Topic   Newer Topic >>
[Logged] Text Editor Issue (Again) - 10/1/2020 10:53:08 PM   
BeirutDude


Posts: 1983
Joined: 4/27/2013
From: Jacksonville, FL, USA
Status: offline
Have Build 11 Beta and the Text Editor for the Scenario Description is locking up the game in Edit Mode (again). It was a hidden window issue the last time and indeed when I close the game (Cntrl+Alt+Del necessary to close) I can see a ghost widow briefly appear and then quickly disappear.

< Message edited by Rory Noonan -- 10/5/2020 2:16:26 AM >


_____________________________

"Some people spend an entire lifetime wondering if they made a difference. The Marines don't have that problem."
PRESIDENT RONALD REAGAN, 1985

I was Navy, but Assigned TAD to the 24th MAU Hq in Beirut. By far the finest period of my service!
Post #: 1
RE: Text Editor Issue (Again) - 10/1/2020 11:07:03 PM   
BeirutDude


Posts: 1983
Joined: 4/27/2013
From: Jacksonville, FL, USA
Status: offline
Just checked and is happening with the Side Briefing Editor as well. Was working fine with Build 10 Beta as I just leaded Build 11 Beta the other day. So it is something with the most recent build.

Edit, actually the side editor behaved differently. The game didn't lock up but the Editor opened behind the Screen and when I minimized the game window it was there. I also noted that in the Events Editor the "Action" menu/GUI was doing that to me for a bit but that was an intermittent issue.

Hope this helps.

< Message edited by BeirutDude -- 10/1/2020 11:11:29 PM >


_____________________________

"Some people spend an entire lifetime wondering if they made a difference. The Marines don't have that problem."
PRESIDENT RONALD REAGAN, 1985

I was Navy, but Assigned TAD to the 24th MAU Hq in Beirut. By far the finest period of my service!

(in reply to BeirutDude)
Post #: 2
RE: Text Editor Issue (Again) - 10/2/2020 1:13:20 AM   
KnightHawk75

 

Posts: 774
Joined: 11/15/2018
Status: offline
Yup BD, I run into this A LOT, and have since CMO launched, though it did happen on CMANO for me it was very very rare.

I also agree that it seems worse in .10+ though (nearly every time vs ~33-50% of time prior). The trick work-around for me as I've said before is going to task manager, application list and doing a right-click 'minimize' action from there (I have found no other way to trigger workaround when the main form is locked, though yes if you catch it super early and can minimize before it locks sometimes works), and then the dialog will instantly generate (or finish generating) and all is good...till the next time you do anything that invokes a dialog with the text editor...then it's usually rinse and repeat.

Side\side-briefing editing, any lua script screens etc, same as you anything that invokes the text\html editor control(s), it also tends to happen with the manual allocation dialog window as well, but for that one it seems to only happen after hours of use, and the applied 'workaround', seems to last for awhile.

Sometimes restating the game stops it from happening for awhile, sometimes that that makes no difference, it's very random, or it used to be more random, but since updating to .10 (I'm skipping .11) it seems to be happening much more, nearly all the time. IDK if anythings been tweaked lately with the generation or modality or threading related to the windows\dialogs that is making it even more prevalent than before on some systems.

It acts as if the game (main form) is in a wait state loop waiting to hear back that the call to generate the dialog has been completed, but something stops the dialog itself from getting generated\init'ed (or messaging back that it did), hence the locked wait state of the main form waiting for the dialog call to return.

Whatever a 'minimize' does on the application (injected from taskmanger) does seems to free up or interject some timing pause or message loop interaction that (95% of the time, I've had an instance or two where the workaround fails) clears the block such that the dialog then immediately finishes spawning and then the main form execution continues on it's merry way (unfreezes). I've tried to debug this various different ways with little definitive success as I can not tell what exactly is the cause\getting in the way, or why it seems only some of us run into this and not others, and some of us it seems way more often than others.

win7x64 |editor mode| windowed mode (though it does happen in full screen too, I just rarely use full screen).
When dbging this all av protection software disabled, no msi afterburner\overlay stuff running, Matrix distro (steam not involved). It's a tough one for devs to look into if they can't repo it on their systems though which I'm guessing they can't since it's been reported before.

< Message edited by KnightHawk75 -- 10/2/2020 1:15:38 AM >

(in reply to BeirutDude)
Post #: 3
RE: Text Editor Issue (Again) - 10/5/2020 2:16:36 AM   
Rory Noonan

 

Posts: 2719
Joined: 12/18/2014
From: Brooklyn, NY
Status: offline
Logged for investigation.

0014165

_____________________________


(in reply to KnightHawk75)
Post #: 4
RE: Text Editor Issue (Again) - 11/30/2020 8:57:42 AM   
Geoffropi

 

Posts: 13
Joined: 10/27/2020
Status: offline
Hey guys,

I could not reproduce it on my side, this might be related to the OS version used. Older Windows versions are rather capricious the further techs are evolving.

BeirutDude : are you running windows 10 or an older version?

Geoffroy.



(in reply to Rory Noonan)
Post #: 5
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Logged] Text Editor Issue (Again) Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.117