Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[Logged] time trigger not working

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Logged] time trigger not working Page: [1]
Login
Message << Older Topic   Newer Topic >>
[Logged] time trigger not working - 9/22/2020 4:21:44 PM   
orca

 

Posts: 500
Joined: 11/6/2013
Status: offline
I have set up an event that is triggered by a time trigger. But the time trigger is not working.

In my scenario the trigger is called "time trigger J-15'. I am using it in an event called "reassign J-15 to AAW after strike naval".

As a background, before the "time trigger J-15" is run, I am using a LUA function ScenEdit_SetTrigger to update this time trigger (in an action called "SetTrigger-time trigger J-15") which is run in the event "ready strike J-15 Kennedy when in range". The "time trigger J-15" updates the time for this trigger as intended however when the scenario reaches this time the trigger does not fire.

To replicate the issue, please see attached scenario and play in the editor in god's eye view.

After starting scenario look at the "time trigger J-15" and it should be set to 2025-10-10. Play as axis and after scenario start move the Kennedy CSG to a position approximately 500 nm from the Axis CSG group (and in the detection arc of the OTH radar at Pearl Harbor and then start the game. This will initiate the event "ready strike J-15 Kennedy when in range" which readies aircraft for a strike but also updates the "time trigger J-15" to approximately 6 hours after this event runs. Check the updated "time trigger J-15" to see this new time.

Then run the scenario until the new trigger time is reached. The time will pass and the trigger will not fire.

I've ran through this multiple times and I'm not good at LUA thus it's possible it's something I'm doing wrong. But the time trigger seems to be set correctly at the new time but that trigger does not fire.

Thanks

Attachment (1)

< Message edited by Rory Noonan -- 9/23/2020 4:35:51 AM >
Post #: 1
RE: time trigger not working - 9/22/2020 8:02:59 PM   
KnightHawk75

 

Posts: 1403
Joined: 11/15/2018
Status: offline
You can't update timetriggers post them firing for the first time as a flag gets set that it's been triggered (even though you can update the time). I came across this while testing scenes a lot.

You'll need to create a fresh one with a new time that will have a clean fired-flag.

http://www.matrixgames.com/forums/fb.asp?m=4822744

http://www.matrixgames.com/forums/fb.asp?m=4822622 (script I provided where you give it the old one and the new time and it'll recreate a fresh one for you - I use this a ton during testing and before finalizing a finished scene to make sure all the specific-time-triggers are rebuilt cleanly.)

In short works as designed, author just needs to work around it.


< Message edited by KnightHawk75 -- 9/22/2020 8:06:33 PM >

(in reply to orca)
Post #: 2
RE: time trigger not working - 9/23/2020 4:37:58 AM   
Rory Noonan

 

Posts: 2816
Joined: 12/18/2014
From: Brooklyn, NY
Status: offline
Logged for investigation.

0014150

_____________________________


(in reply to KnightHawk75)
Post #: 3
RE: time trigger not working - 10/10/2020 3:07:40 AM   
michaelm75au


Posts: 13472
Joined: 5/5/2001
From: Melbourne, Australia
Status: offline
The 'Fired' trigger will be cleared when you use Lua to set the Time or RandomTime triggers.
Its sole purpose was to stop checking once the time had been reached/triggered.

_____________________________

Michael

(in reply to Rory Noonan)
Post #: 4
RE: time trigger not working - 10/10/2020 3:24:11 AM   
KnightHawk75

 

Posts: 1403
Joined: 11/15/2018
Status: offline

quote:

ORIGINAL: michaelm75au
The 'Fired' trigger will be cleared when you use Lua to set the Time or RandomTime triggers.


So is that a coming change\fix for future versions? Cause that has not been the case and I don't recall seeing that make the release notes in recent public builds. If so, fantastic!

(in reply to michaelm75au)
Post #: 5
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Logged] time trigger not working Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.363