Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[Fixed] Sprint and drift distance display bug (issue identified)

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Fixed] Sprint and drift distance display bug (issue identified) Page: [1]
Login
Message << Older Topic   Newer Topic >>
[Fixed] Sprint and drift distance display bug (issue id... - 9/8/2020 9:59:09 PM   
cmanouser1

 

Posts: 163
Joined: 2/28/2020
Status: offline
In a recent update Steve or apache added a great QOL, showing the remaining Sprint and Drift distance. See next screenshot.



However if "avoid cavitation" is checked AND "desired Avg Speed" is above cavitation speed, the sprinting distance isn't displayed anymore. Drifting distance isn't affected.




< Message edited by Steve McClaire -- 10/9/2020 11:51:19 PM >
Post #: 1
RE: [Logged] Sprint and drift distance display bug (iss... - 9/9/2020 12:25:47 AM   
Rory Noonan

 

Posts: 2787
Joined: 12/18/2014
From: Brooklyn, NY
Status: offline
Logged for investigation.

0014121

_____________________________


(in reply to cmanouser1)
Post #: 2
RE: [Logged] Sprint and drift distance display bug (iss... - 9/9/2020 12:18:39 PM   
boogabooga

 

Posts: 283
Joined: 7/18/2018
Status: offline
My take on this is because you are requesting a "desired Avg Speed" higher than your 13 kt cavitation maximum, you just end up going as fast as possible- a steady 13 kt permanent "sprint". If you want to alternate between 13 kt and creep, set "desired Avg Speed" to something less than 13, because you can never go faster than your sprint speed.

The output display there makes sense, I think.

(in reply to Rory Noonan)
Post #: 3
RE: [Logged] Sprint and drift distance display bug (iss... - 9/9/2020 2:21:23 PM   
cmanouser1

 

Posts: 163
Joined: 2/28/2020
Status: offline

quote:

ORIGINAL: boogabooga

My take on this is because you are requesting a "desired Avg Speed" higher than your 13 kt cavitation maximum, you just end up going as fast as possible- a steady 13 kt permanent "sprint". If you want to alternate between 13 kt and creep, set "desired Avg Speed" to something less than 13, because you can never go faster than your sprint speed.

The output display there makes sense, I think.

Nope; the ship does drift even with this setting

(in reply to boogabooga)
Post #: 4
RE: [Logged] Sprint and drift distance display bug (iss... - 9/9/2020 2:41:38 PM   
Swant

 

Posts: 72
Joined: 7/19/2020
Status: offline
I think boogabooga is right, yes the ship drift but only in the beginning. When It start sprinting, it will do so permanent.

(in reply to cmanouser1)
Post #: 5
RE: [Logged] Sprint and drift distance display bug (iss... - 9/9/2020 3:14:36 PM   
cmanouser1

 

Posts: 163
Joined: 2/28/2020
Status: offline
quote:

ORIGINAL: Swant

I think boogabooga is right, yes the ship drift but only in the beginning. When It start sprinting, it will do so permanent.


I've tested it just now and you're correct: ship will drift then sprint permanently at the max speed that avoids cavitation.
That doesn't mean there's no issue though: when "avoid cavitation" is checked and "sprint and drift" isn't, you can't set a speed above cavitation speed.
However, it is allowed when sprinting and drifting, which causes the issue.


edit: I think there's also a fuel consumption bug, bug report here: https://www.matrixgames.com/forums/tm.asp?m=4882943&mpage=1&key=�

< Message edited by cmanouser1 -- 9/9/2020 3:42:25 PM >

(in reply to Swant)
Post #: 6
RE: [Logged] Sprint and drift distance display bug (iss... - 10/9/2020 11:50:53 PM   
SteveMcClaire

 

Posts: 4419
Joined: 11/19/2007
Status: offline
Fixed for the next update.

F2 dialog will constrain sprint-drift average speed to cavitation speed if you have 'avoid cavitation' selected.

If set an average speed that will force the vessel to sprint (or drift) the entire course the distance display will now reflect this.

(in reply to cmanouser1)
Post #: 7
RE: [Logged] Sprint and drift distance display bug (iss... - 10/10/2020 1:40:33 PM   
guanotwozero

 

Posts: 645
Joined: 12/27/2013
Status: offline

quote:

ORIGINAL: Steve McClaire

Fixed for the next update.

F2 dialog will constrain sprint-drift average speed to cavitation speed if you have 'avoid cavitation' selected.

If set an average speed that will force the vessel to sprint (or drift) the entire course the distance display will now reflect this.


A quick question - will that apply to depth changes along a multi-wp route? Cavitation speed increases with depth and it would be nice if we didn't have to individually tailor avg speed at each section of the route.

(in reply to SteveMcClaire)
Post #: 8
RE: [Logged] Sprint and drift distance display bug (iss... - 10/10/2020 3:00:46 PM   
thewood1

 

Posts: 5925
Joined: 11/27/2005
Status: online
My remembrance is that if you set up a path for a sub, and select avoid cavitation as the default or along waypoints, the speed will always try to stay just below cavitation levels, up to the speed assigned as default or at each way point. But its been at least a couple years since I looked at it.

(in reply to guanotwozero)
Post #: 9
RE: [Logged] Sprint and drift distance display bug (iss... - 10/10/2020 3:23:02 PM   
thewood1

 

Posts: 5925
Joined: 11/27/2005
Status: online
Just did a very rough test. The sub will always maintain the "no cavitation" setting regardless of depth or max speed desired. As rise in depth and cavitation risk increases, the sub will decrease its speed to remain below the estimated cavitation threshold. But as hinted at above, when the risk of cavitation decreases on submerging further, the sub never appears to readjust to a speed higher. There might be a good reason for this, but that's what I see.

Edited for clarity.

< Message edited by thewood1 -- 10/10/2020 4:35:41 PM >

(in reply to thewood1)
Post #: 10
RE: [Logged] Sprint and drift distance display bug (iss... - 10/10/2020 3:26:38 PM   
guanotwozero

 

Posts: 645
Joined: 12/27/2013
Status: offline
My one concern is that if a sprint-drift average is only calculated initially, then coming to a shallower depth may exceed cavitation speed. If cavitation limit works as a depth-based cap, all is fine.

It does bring up the issue that we might want higher averages at greater depths, i.e. the average is based on the presets rather than a single fixed number. But that might be too much icing on the cake as we could always set that manually.

(in reply to thewood1)
Post #: 11
RE: [Logged] Sprint and drift distance display bug (iss... - 10/10/2020 4:22:33 PM   
thewood1

 

Posts: 5925
Joined: 11/27/2005
Status: online
I would suggest testing it just like I did. You'll get a definitive answer and can submit it into change requests or as a separate thread in the tech forum.

(in reply to guanotwozero)
Post #: 12
RE: [Logged] Sprint and drift distance display bug (iss... - 10/10/2020 4:48:04 PM   
guanotwozero

 

Posts: 645
Joined: 12/27/2013
Status: offline
Indeed so, though if a potential issue can be caught before rollout, so much the better.

(in reply to thewood1)
Post #: 13
RE: [Logged] Sprint and drift distance display bug (iss... - 10/10/2020 5:35:38 PM   
thewood1

 

Posts: 5925
Joined: 11/27/2005
Status: online
?

(in reply to guanotwozero)
Post #: 14
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Fixed] Sprint and drift distance display bug (issue identified) Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.266