Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Lua Console can not use lua key word require?

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Mods and Scenarios >> Lua Legion >> Lua Console can not use lua key word require? Page: [1]
Login
Message << Older Topic   Newer Topic >>
Lua Console can not use lua key word require? - 8/21/2020 7:38:09 AM   
Rinstein

 

Posts: 4
Joined: 8/21/2020
Status: offline
I found that Lua Console can not use lua basic key word require?
report this ERROR:
ERROR: [string "Console"]:1: attempt to call global 'require' (a nil value)
Post #: 1
RE: Lua Console can not use lua key word require? - 8/21/2020 8:17:54 AM   
Rory Noonan

 

Posts: 2778
Joined: 12/18/2014
From: Brooklyn, NY
Status: offline
ScenEdit_RunScript() does the same thing

_____________________________


(in reply to Rinstein)
Post #: 2
RE: Lua Console can not use lua key word require? - 8/21/2020 9:13:29 AM   
Rinstein

 

Posts: 4
Joined: 8/21/2020
Status: offline
yeah,that's true

(in reply to Rory Noonan)
Post #: 3
RE: Lua Console can not use lua key word require? - 8/21/2020 10:37:51 AM   
KnightHawk75

 

Posts: 1038
Joined: 11/15/2018
Status: offline
all keywords that relate to io or interaction with the system are removed for safety concerns in non-pro versions.

(in reply to Rinstein)
Post #: 4
RE: Lua Console can not use lua key word require? - 8/26/2020 2:07:06 PM   
jkgarner

 

Posts: 162
Joined: 4/30/2020
Status: online
It does not really do the same thing.

ScenEdit_RunScript will ONLY execute a Lua script (which can not have require or the other key words either)

require will run s script, or load a dll, or other module, based on what it finds on the system.

You need to keep this in mind when building your scripts.






(in reply to KnightHawk75)
Post #: 5
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Mods and Scenarios >> Lua Legion >> Lua Console can not use lua key word require? Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.145