Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[Fixed] Submarine AI reluctance to use creep

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Fixed] Submarine AI reluctance to use creep Page: [1]
Login
Message << Older Topic   Newer Topic >>
[Fixed] Submarine AI reluctance to use creep - 8/7/2020 11:24:39 AM   
boogabooga

 

Posts: 346
Joined: 7/18/2018
Status: offline
I'm using CMO version 1147.7

I'm just starting to use submarines in Command, so I might be mistaken, but I believe that there is a problem getting the AI to use 'creep' throttle when I would expect it to.

In CMANO, submarine sprint and drift seems to operate between creep and flank (or cavitation). That is what I would expect.
However, in CMO, it seems to operate between cruise and flank. In the provided scenario, Salt Lake City is set to sprint and drift at an average of 27 kt, and you can see that it operates between 20 kt and 32 kt. Is that WAD?


In the provided scenario, Los Angeles is set to sprint and drift at an average speed of 15 kt. Notice however, that it actually just cruises at 20 kt. I believe that is a bug, as if it can't go any slower.

Last, notice Sturgeon. It's assigned to a ASW patrol mission that is set to use a station throttle of Creep. However, it is actually operating at 15 kt cruise. If I set the mission's submarine station throttle to cruise or creep, it operates at 15 kt like this, but if I set it to Full or Flank, then it speeds to 22 kt or 30 kt, respectively, as one would expect.

Overall, it gives me the impression that there is a bug preventing the AI from using the proper creep setting somehow.

Attachment (1)

< Message edited by Steve McClaire -- 8/13/2020 8:18:49 PM >
Post #: 1
RE: Submarine AI reluctance to use creep - 8/7/2020 9:44:45 PM   
thewood1

 

Posts: 6211
Joined: 11/27/2005
Status: online
I loaded it up and did two things. First, I made sure I was setting the missions's station speed for subs, and not aircraft. I played around with different speeds and they all seemed to work.

Second, on the two non-mission subs, I took avoid cavitation off. They both responded to throttle requests. What I didn't do, and should have, was to see what happens without touching anything. So can't be sure if any my fiddling had an effect.

The short is it seems to work on my system. Can't guarantee my changes did it. After dinner, I'll go back and confirm that was a fix or just random. Sorry.

(in reply to boogabooga)
Post #: 2
RE: Submarine AI reluctance to use creep - 8/7/2020 10:11:55 PM   
boogabooga

 

Posts: 346
Joined: 7/18/2018
Status: offline
Thanks for the reply thewood1, but I think you missed the point of the errors that I was reporting.

When setting the mission's station speed for subs, the cruise setting and creep setting are BOTH resulting in 15 kt. Creep should be 5 kt or thereabout. I agree full, cruise, and flank settings are working, but not creep. Is this what others see?

On the non-mission subs, I'm showing a suspected bug as they are set up related to sprint and drift; it does not help to set throttle manually.

(in reply to thewood1)
Post #: 3
RE: Submarine AI reluctance to use creep - 8/7/2020 10:36:51 PM   
thewood1

 

Posts: 6211
Joined: 11/27/2005
Status: online
Had no issues with creep. I didn't miss the point. Only telling you what I found. Will test it in a bit without changing anything.

(in reply to boogabooga)
Post #: 4
RE: Submarine AI reluctance to use creep - 8/7/2020 11:49:11 PM   
thewood1

 

Posts: 6211
Joined: 11/27/2005
Status: online
Looks like this was reported once before, but in an off-topic thread. I'm pretty sure the devs are tracking it down.

http://www.matrixgames.com/forums/fb.asp?m=4817434

Regardless if its the same issue. In 1147.7, I see the same issue with not wanting to stay at creep in missions or in some of the throttle settings.



< Message edited by thewood1 -- 8/7/2020 11:51:03 PM >

(in reply to thewood1)
Post #: 5
RE: Submarine AI reluctance to use creep - 8/9/2020 6:23:50 PM   
Uzabit

 

Posts: 77
Joined: 7/13/2018
Status: offline
Happens on my system aswell with 1147.7 - submarines ignore "creep" as specific mission speed settings and go to cruise instead.

(in reply to thewood1)
Post #: 6
RE: Submarine AI reluctance to use creep - 8/10/2020 12:32:48 AM   
Rory Noonan

 

Posts: 2816
Joined: 12/18/2014
From: Brooklyn, NY
Status: offline
Logged for investigation.

0014074

_____________________________


(in reply to Uzabit)
Post #: 7
RE: [Logged] Submarine AI reluctance to use creep - 8/13/2020 8:18:29 PM   
SteveMcClaire

 

Posts: 4439
Joined: 11/19/2007
Status: offline
Thanks for the report. This issue will be fixed in the next update.

(in reply to boogabooga)
Post #: 8
RE: [Logged] Submarine AI reluctance to use creep - 8/13/2020 9:31:46 PM   
stww2

 

Posts: 161
Joined: 5/23/2017
Status: offline
Glad to hear it! Thank you!

(in reply to SteveMcClaire)
Post #: 9
RE: [Logged] Submarine AI reluctance to use creep - 8/23/2020 6:59:58 PM   
boogabooga

 

Posts: 346
Joined: 7/18/2018
Status: offline
Thank you.


(in reply to stww2)
Post #: 10
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [Fixed] Submarine AI reluctance to use creep Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.208