Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Shields not working?

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Shadow Empire >> Shields not working? Page: [1]
Login
Message << Older Topic   Newer Topic >>
Shields not working? - 7/12/2020 9:08:46 AM   
vlad1492

 

Posts: 12
Joined: 7/30/2013
Status: offline
1) Built a mobile shield emitter. In combat it just runs away, doesn't seem to be absorbing any hits intended for friendlies.

Friendlies are still dying while it is still nearly at full strength.

2) The shield tech is also supposed to allow for stationary shield emitters too, but there is no option in the model design to create them.

Are shields not yet implemented?
Post #: 1
RE: Shields not working? - 7/12/2020 10:21:16 AM   
vlad1492

 

Posts: 12
Joined: 7/30/2013
Status: offline
>2) Oops, I forgot I had to 'Discover' the model even after researching it. I blame game-addiction sleep deprivation.

(in reply to vlad1492)
Post #: 2
RE: Shields not working? - 7/12/2020 10:48:06 AM   
Jdane


Posts: 456
Joined: 6/5/2020
Status: offline
I've yet to try to make and use my own mobile shields, I've only used some Galactic Republic ones found as loot, and they appeared to do their jobs, until they inevitably get destroyed because I kept sending them in big battles.

What does the detailed combat report log say when your shield starts retreating?

There are special rules in the manual I didn't know about before you asked, such as:
quote:

Depleting Hit Points for Shields
A Shield starts at X HP and every turn it takes a hit.
Once it is depleted by a hit it depends if the hit is made a broken through
Subunit in which case the Shield will be killed or a non-broken through
Subunit in which case the Shield will retreat to hopefully fight another day.
(Page 301.)

It might be you were unlucky and the enemy selected the shield for a target en masse, depleting its HP and thus forcing it to retreat, but that's just a blind guess.
Additionally, mobile shields have a chance to fail to provide protection to other sub-units. You can also see that in the detailed logs for each round which will tell when the shield tried to provide protection and succeeded or failed at it.

I'll be sure to pay more attention to the detailed combat logs for shields next time I have some.

< Message edited by Jdane -- 7/12/2020 10:50:06 AM >

(in reply to vlad1492)
Post #: 3
RE: Shields not working? - 7/12/2020 5:08:40 PM   
vlad1492

 

Posts: 12
Joined: 7/30/2013
Status: offline
Thanks for the info.

>depleting its HP and thus forcing it to retreat

Not in the few fights I watched. The shield was still very nearly full when it retreated.
I'm afraid I don't have the logs handy, started a new game. May have to go reload to explore further.
I built the biggest mobile shield I could, and let me tell you buddy that pig is a hassle to drag around.


> chance to fail to provide protection to other sub-units.

This I did not know. That would explain part of the behavior. Watching my troops repeatedly get KIA next to a shield that is still at 95% capacity seems wrong.


(in reply to Jdane)
Post #: 4
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Shadow Empire >> Shields not working? Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.117