Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[RESOLVED] Game failing to load menu along with land-cover maps not found

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [RESOLVED] Game failing to load menu along with land-cover maps not found Page: [1]
Login
Message << Older Topic   Newer Topic >>
[RESOLVED] Game failing to load menu along with land-co... - 4/20/2020 6:59:18 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
Bought the game on steam. Found that bug where the game just sits on the loading screen and doesn't give me the options to load scenarios or quick game. Hit Alt+F4 to close the game and it took me to the mission editor, mission editor was basically all black and I wasn't able to see the map or anything. I tried toload a tutorial mission and couldn't do anything because the mission was allblack. Asked around on the CMO discord and didn't really get much help there. So, I refunded the game on steam thinking it was a steam problem and bought the game straight from Matrix Games. Same problem. I searched all over for a fix, and only found unsolved fixes on the forums and on steam. Downloaded a fix from a reply, made by a moderator, on one of those forum posts and got "ERROR: Land-cover map files not found! Aborting..."

Hopefully I get to play this game and I won't have to put the 2 months of saving money to buy the game to rest.

Note, my account is so new that I can't post links, but I have a picture of the error I received along with a video of what the game is doing on startup.

My discord is BreaKKer#9678 if you need to get the video of the game not loading or the picture of the error

Game build: 1134.3

< Message edited by Dimitris -- 7/6/2020 8:19:55 AM >
Post #: 1
RE: [Logged] Game failing to load menu along with land-... - 4/22/2020 7:31:39 AM   
apache85

 

Posts: 2325
Joined: 12/18/2014
From: Melbourne, Australia
Status: offline
Logged for investigation.

0013842

_____________________________


(in reply to breakker)
Post #: 2
RE: [Logged] Game failing to load menu along with land-... - 4/22/2020 4:19:19 PM   
Dimitris


Posts: 12431
Joined: 7/31/2005
Status: offline
Hi,

From your description it sounds like you accidentally unzipped the update in the wrong location.

Can you please try this:
1) Uninstall CMO.
2) Re-install and update to the latest version (we released a new official update today).

Please give it a go and let us know. Thanks!

_____________________________


(in reply to apache85)
Post #: 3
RE: [Logged] Game failing to load menu along with land-... - 4/22/2020 8:44:09 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
I've uninstalled the game. Do I download the game to the Program Files Command Modern Operations Folder? Or do I direct the download of it into the CMO MultiSetup Folder that was unpacked into the Program Files Command:Modern Operations Folder?

(in reply to Dimitris)
Post #: 4
RE: [Logged] Game failing to load menu along with land-... - 4/23/2020 12:32:12 AM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
I've uninstalled the game twice now, and updated it to the update that was just released recently. After this, it still shows the same "Loading... Please wait" screen and never advances to the main menu. To accompany that, the mission editor view by hitting Alt+F4 still shows a black map. All the options at the toolbar are visible, but the main map view is black.

(in reply to breakker)
Post #: 5
RE: [Logged] Game failing to load menu along with land-... - 4/23/2020 3:20:53 AM   
michaelm75au


Posts: 12989
Joined: 5/5/2001
From: Melbourne, Australia
Status: offline
Under the install folder, there should be one 'Logs'. Is there a file 'ExceptionLog.txt' in it? If so, does it show any errors or may be even paste the last 50 lines??

_____________________________

Michael

(in reply to breakker)
Post #: 6
RE: [Logged] Game failing to load menu along with land-... - 4/23/2020 4:06:11 AM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
It does look like there is a few error in there. I attached the file.

Attachment (1)

(in reply to michaelm75au)
Post #: 7
RE: [Logged] Game failing to load menu along with land-... - 5/21/2020 7:36:03 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
Any news?

(in reply to michaelm75au)
Post #: 8
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 9:17:01 AM   
Dimitris


Posts: 12431
Joined: 7/31/2005
Status: offline
From the exception log, there seem to be at least two components missing:

* Direct-X 9.0c . If this is a Matrix install, you should be able to find the installer for this in [CMO]\Pre-Requisites. If it's a Steam installation, it should be found in: C:\Program Files (x86)\Steam\steamapps\common\Steamworks Shared\_CommonRedist
* Microsoft Data Access Components (MDAC). You can download these from here: https://www.microsoft.com/en-us/download/details.aspx?id=5793

Please install these and give it a try. Thanks!

_____________________________


(in reply to breakker)
Post #: 9
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 9:20:58 AM   
Dimitris


Posts: 12431
Joined: 7/31/2005
Status: offline
Can you also please ensure that your OS is fully updated? MDAC should already be present if you apply updates regularly.

_____________________________


(in reply to Dimitris)
Post #: 10
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 6:25:54 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
OS is up to date. MDAC has been downloaded. PreRequisites\directx_Jun2010_redist\DXSETUP.exe has been ran multiple times. I tried updating the game with the most recent update posted, but still getting the same "Land-cover map files not found! Aborting..." message when running the UpdatePack_B1146.2\Command.exe.

(in reply to Dimitris)
Post #: 11
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 6:28:15 PM   
Dimitris


Posts: 12431
Joined: 7/31/2005
Status: offline
quote:

ORIGINAL: breakker
but still getting the same "Land-cover map files not found! Aborting..." message when running the UpdatePack_B1146.2\Command.exe.


That's what you are doing wrong. You should unzip the contents of the UpdatePack_XXX file _on the CMO installation folder_ (if you do it right, you will get lots of overwrite prompts).

If you are unsure how to do it, perhaps it's best that you wait for the official update.

_____________________________


(in reply to breakker)
Post #: 12
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 6:36:18 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
Sorry for the ignorance. Do I just run Command.exe after unzipping the contents into the CMO installation folder?

(in reply to Dimitris)
Post #: 13
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 6:36:46 PM   
Dimitris


Posts: 12431
Joined: 7/31/2005
Status: offline
Yes.

_____________________________


(in reply to breakker)
Post #: 14
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 6:41:12 PM   
KnightHawk75

 

Posts: 555
Joined: 11/15/2018
Status: offline

quote:

ORIGINAL: breakker

Sorry for the ignorance. Do I just run Command.exe after unzipping the contents into the CMO installation folder?

You can do that to start that game, or use the launcher via the start menu\etc, either method should be fine once installed successfully.

(in reply to breakker)
Post #: 15
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 6:47:09 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
By unzipping the contents into the CMO folder, version number should change to 1dot01dot11462, right? I still have the problem along with the version number being 1dot01dot11431.

(in reply to KnightHawk75)
Post #: 16
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 6:48:35 PM   
Dimitris


Posts: 12431
Joined: 7/31/2005
Status: offline
Please uninstall everything, re-install, update to the latest official version, and wait for the next official update.

< Message edited by Dimitris -- 5/22/2020 6:49:38 PM >


_____________________________


(in reply to breakker)
Post #: 17
RE: [Logged] Game failing to load menu along with land-... - 5/22/2020 6:50:13 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
Ok. Thank you for the help.

(in reply to Dimitris)
Post #: 18
RE: [Logged] Game failing to load menu along with land-... - 6/30/2020 7:47:57 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
I've waited quite a bit for an official update. I checked a couple days ago to see if there was one and saw 1147.4. I downloaded the UpdateComp.exe file and dropped it into my CMO directory. I went ahead and uninstalled CMO, reinstalled it, and updated it to 1147.4. Same problems as before. I have repeated the previous suggestions that were made by Dimitris. I ran the update.exe file, but was met by Update Error "Error: Update information for Command Modern Operations could not be download. Please contact Matrix Games for help." I searched for a fix on the update.exe file and found the forum post by Gerry Edwards from 2014. I still have the strive to play this game some day and hope this mess can get solved. Thanks again for the moderators that are still trying to figure this weird bug out.

(in reply to breakker)
Post #: 19
RE: [Logged] Game failing to load menu along with land-... - 7/1/2020 7:55:51 AM   
KnightHawk75

 

Posts: 555
Joined: 11/15/2018
Status: offline
breakker I'm assuming by now you have done:
1.Run the full original Installer v1.00.11153 (~5.8 gb)
2.Run the latest updater CMO-UpdateComp-v1.01.11474.exe (~450mb)
3.Run any prerequisites like mdac,dx9,vc14 runtimes etc. (already stated you have these)
As you've said already and...

4. *Done all of the above with antivirus\etc temporarily disabled (some have habit of silently not letting files get installed)
5. Attempted to run <installedtofolder>\Command.exe with administrator permissions.

Now is the error still "Land-cover map files not found! Aborting...", or is it something different now?
If yes (same land cover error), then I have a question.
Inside the folder you installed the game to is there there a <installedtofolder>\GIS\LandCover folder and are there any files in it?

If not and it's some new error\situation, can you delete or rename <installedtofolder>\Logs\exceptionlog.txt, then restart the game as administrator and post the exceptionlog.txt that is generated from that attempt if it fails.


(in reply to breakker)
Post #: 20
RE: [Logged] Game failing to load menu along with land-... - 7/1/2020 5:23:41 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
Full installer downloaded
latest updater downloaded
prerequisites have been downloaded and rechecked
Antivirus has been check. Windows Defender doesn't seem to be stopping anything.
I've ran Command.exe with admin perms

I don't recall the exact file I ran to create the LandCover error as it has been 1-4 months since my original forum post, but it seems to have stopped.
There are files in Landcovers folder. Interestingly enough, all the files are black. Which might explain why the main view of the game has no world view and that it is black.
I posted my exception log a little bit up on the post. I will recheck everything later tonight. Will probably uninstall and reinstall.

Edit: I uninstalled and reinstalled to see the landcovermaps folder and found that the installer was downloading the black files. going to redownload the installer.


< Message edited by breakker -- 7/2/2020 2:55:06 AM >

(in reply to KnightHawk75)
Post #: 21
RE: [Logged] Game failing to load menu along with land-... - 7/2/2020 3:35:22 AM   
KnightHawk75

 

Posts: 555
Joined: 11/15/2018
Status: offline
quote:

I posted my exception log a little bit up on the post.

I know, I read it and the log. That's why I wanted an updated one that is based on current situation.

The land-cover tiffs if you attempt to open them with normal tiff viewer would look black, that in itself isn't a problem.

(in reply to breakker)
Post #: 22
RE: [Logged] Game failing to load menu along with land-... - 7/2/2020 4:12:37 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
This is the new exceptionlog created from my most recent reinstall.

Attachment (1)

(in reply to KnightHawk75)
Post #: 23
RE: [Logged] Game failing to load menu along with land-... - 7/2/2020 5:05:37 PM   
KnightHawk75

 

Posts: 555
Joined: 11/15/2018
Status: offline
Thanks, a marked improvement actually after the reinstalls (zero log errors now), even though it doesn't feel like it I sure.
You running any overlay software like raptr,or v-card related things like msi-afterburner etc, just thinking of some of the things the devs have mentioned interfere sometimes.

(in reply to breakker)
Post #: 24
RE: [Logged] Game failing to load menu along with land-... - 7/2/2020 5:09:14 PM   
Dimitris


Posts: 12431
Joined: 7/31/2005
Status: offline
Just to clarify: This latest install is on Steam, or through the Matrix installer?

Also, the standard checklist:
* Is the OS fully updated? Graphics drivers updated? Direct-X 9 installed?
* Is Command running as admin? (ie. prompting you "are you sure you want to run this program" when you launch it)
* (If Steam) Are Steam overlays disabled for Command?
* (If Steam) Is Direct-Write disabled on the Steam client?
* Are all other applications (and especially hardware-helper apps like MSI Afterburner, RivaTuner etc.) shut down?
* Are you using Norton antivirus? (This POS is very frequently silently blocking file updates)
* Are you running in 100% DPI or high-DPI desktop?

_____________________________


(in reply to KnightHawk75)
Post #: 25
RE: [Logged] Game failing to load menu along with land-... - 7/2/2020 8:37:18 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
This is standalone Matrix Installer. I had the same problem with the LandCoverMaps thing with the steam install as well, but that was when I first bought the game.

OS is up to date
Command is running as an administrator
All hardware helping apps are closed
Norton Antivirus is not present on my computer
100% DPI is set.

(in reply to Dimitris)
Post #: 26
RE: [Logged] Game failing to load menu along with land-... - 7/3/2020 10:24:59 AM   
Dimitris


Posts: 12431
Joined: 7/31/2005
Status: offline
Can you try to install it on Steam? (Since you purchased on Matrix, you also have a Steam key for free).

_____________________________


(in reply to breakker)
Post #: 27
RE: [Logged] Game failing to load menu along with land-... - 7/3/2020 6:43:17 PM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
I installed it on steam. Same problems. Tried to verify game files and it said everything is finen
Strange how it does that for both steam and standalone. It must be with my computer some how
Once I reach the 7 days after my 10th post, I can link a video of what is happening on my end

Edit: Here is the exception log from the steam download

GPU 1 - GeForce GTX 1050 - Driver version 451 dot 48
CPU - Intel(R) Core(TM) i5 7300HQ 2.50GHz
Memory - 16G RAM

Found out MDAC is not installed properly and it won't setup properly. I was reading through the Exception log and saw the error that MDAC wasn't working how it should. Troubleshooting that now.

Attachment (1)

< Message edited by breakker -- 7/3/2020 10:27:31 PM >

(in reply to Dimitris)
Post #: 28
RE: [Logged] Game failing to load menu along with land-... - 7/6/2020 4:15:14 AM   
breakker

 

Posts: 15
Joined: 4/20/2020
Status: offline
Case closed. I reinstalled windows. Game works just fine and how it should be. Thanks for help, guys! Problem seemed to be that MDAC was not properly integrated into my OS as it should.

< Message edited by breakker -- 7/6/2020 4:20:52 AM >

(in reply to breakker)
Post #: 29
RE: [Logged] Game failing to load menu along with land-... - 7/6/2020 2:24:02 PM   
KnightHawk75

 

Posts: 555
Joined: 11/15/2018
Status: offline
Happy to hear you finally got it resolved.

(in reply to breakker)
Post #: 30
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [RESOLVED] Game failing to load menu along with land-cover maps not found Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.199