Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Two bugs

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> WarPlan >> WarPlan Open Beta Versions >> Two bugs Page: [1]
Login
Message << Older Topic   Newer Topic >>
Two bugs - 12/18/2019 1:02:47 AM   
sawtooth9993

 

Posts: 15
Joined: 10/30/2019
Status: offline
1. Disembarked a British unit in France to go back to Britain. All was well until I moved a French fleet onto the disembarked British unit (to help escort it). Upon doing this, the disembarked British unit disappeared and all I could see or interact with was the French fleet. This was all before a French surrender.

However, upon doing this with another British unit and French fleet, everything worked out great and the fleets merged successfully.

I think the key difference is that the broken fleet was set to do not repair. This is the fleet that, when merged with my disembarked British unit, made the Brits disappear.

2. I have a British fleet docked in Norway, which is currently at war with Germany. Upon selecting the British fleet, I cannot move it. I have oil stockpiled and 3 supply in each ship. Splitting the fleet does not help. They are in fleet mode. When selected, the map does not "darken" to indicate the range which the fleet can travel. Nothing changes and I get no movement markers to even attempt a move.

To my knowledge, I have installed the open beta correctly.

Thanks!
Post #: 1
RE: Two bugs - 12/19/2019 12:08:52 PM   
AlvaroSousa


Posts: 6924
Joined: 7/29/2013
Status: online
I'll take a look at this

_____________________________

Games worked on

Designer of the Strategic Command 2 products
- Brute Force (mod)
- Assault on Communism
- Assault on Democracy

Designer of the Strategic Command 3 products
- Map Image Importer

(in reply to sawtooth9993)
Post #: 2
RE: Two bugs - 12/19/2019 2:20:56 PM   
AlvaroSousa


Posts: 6924
Joined: 7/29/2013
Status: online
Ok I read this but I am not following could you please verify your statement.

BUG (A)
#1 you disembarked a unit (a land unit from a fleet to land)
#2 you moved a french fleet to escort a disembarked UK land unit now on the land and not in a fleet
#3 now the UK land unit on land vanished but the fleet stayed.

Note that the UK land unit is on land and you moved a fleet to it's location by the end of the interaction. Is this right?

BUG (B)
You might be in a frozen port if this was an early game when WarPlan 1st came out. So please specify the hex location you mean.

_____________________________

Games worked on

Designer of the Strategic Command 2 products
- Brute Force (mod)
- Assault on Communism
- Assault on Democracy

Designer of the Strategic Command 3 products
- Map Image Importer

(in reply to AlvaroSousa)
Post #: 3
RE: Two bugs - 12/20/2019 2:15:17 AM   
sawtooth9993

 

Posts: 15
Joined: 10/30/2019
Status: offline
Sorry, I misspoke.
Bug A
1. EMBARKED a UK land unit (land unit from land to fleet) on a French port
2. Moved a french fleet to escort the EMBARKED UK unit
3. When the fleets merged, the embarked UK unit disappeared, leaving only the French fleet

I did the same thing with another unit. Same scenario, just a different French fleet, different French port, different UK land unit. This one worked fine, no issues. There was the difference in that this fleet was set to repair/upgrade, while the broken fleet was set to do NOT repair/upgrade.

Bug B
This happened using the open beta combined with update v1.00.04, so this was probably not the case. The hex was 148,75. A game reload fixed the issue, but it's a bug nonetheless (unless I borked the open beta install).

(in reply to AlvaroSousa)
Post #: 4
RE: Two bugs - 12/20/2019 2:24:00 AM   
AlvaroSousa


Posts: 6924
Joined: 7/29/2013
Status: online
Ok. Now I get it. That is weird. I will try to replicate it. The repair has nothing to do with the load/unload. This is something else.

_____________________________

Games worked on

Designer of the Strategic Command 2 products
- Brute Force (mod)
- Assault on Communism
- Assault on Democracy

Designer of the Strategic Command 3 products
- Map Image Importer

(in reply to sawtooth9993)
Post #: 5
RE: Two bugs - 12/20/2019 3:18:21 PM   
AlvaroSousa


Posts: 6924
Joined: 7/29/2013
Status: online
I can't replicate this error.

Please do the following if it happens again send me the output.txt log

Error game logs are here
C:\Users\"your user name"\AppData\LocalLow\Kraken Studios\WarPlan\output_log.txt

_____________________________

Games worked on

Designer of the Strategic Command 2 products
- Brute Force (mod)
- Assault on Communism
- Assault on Democracy

Designer of the Strategic Command 3 products
- Map Image Importer

(in reply to AlvaroSousa)
Post #: 6
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> WarPlan >> WarPlan Open Beta Versions >> Two bugs Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.117