Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Map loading issues

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> Map loading issues Page: [1]
Login
Message << Older Topic   Newer Topic >>
Map loading issues - 11/18/2019 12:55:06 PM   
Ekaton


Posts: 98
Joined: 9/30/2013
From: The War Room
Status: offline
The new terrain maps are really great, if a bit obsolete (a year or two I think), and are probably my favourite improvement in CMO. They are, however, terrible at loading. They would often not load at all, only doing so after zooming in and out for a while. Even at best, they take 15-30 seconds to load, making them quite a nuisance.

Does anyone experience that as well?

EDIT:

Event at its best, when it doesn't glitch completely, it still looks something like that:





< Message edited by Ekaton -- 11/18/2019 1:03:47 PM >


_____________________________

I need ten females for each male...
Post #: 1
RE: Map loading issues - 11/18/2019 1:03:33 PM   
CmdSoda

 

Posts: 40
Joined: 11/17/2019
Status: offline
I can confirm this behavior. I'm pretty sure the developers are aware of this issue.

< Message edited by CmdSoda -- 11/18/2019 1:04:01 PM >

(in reply to Ekaton)
Post #: 2
RE: Map loading issues - 11/18/2019 1:25:07 PM   
Ekaton


Posts: 98
Joined: 9/30/2013
From: The War Room
Status: offline
This is how it typically glitches for me when loading larger portions of the map:



_____________________________

I need ten females for each male...

(in reply to CmdSoda)
Post #: 3
RE: Map loading issues - 11/18/2019 1:46:17 PM   
LargeDiameterBomb

 

Posts: 46
Joined: 3/3/2019
Status: offline
I haven't had the same exact issue as you but loading of most maps, in particular the terrain type map (I can't remember the exact names of the maps already), is extremely slow or often does not download at all for my part even though I have a 100 Mbit fiber internet connection.
The basic map that was available in CMANO and which makes water blue always seems to download very fast though.

At least one other user that I have seen has reported slow downloading or maps not downloading at all in another thread.

I will see if the issue persists and if it does create a thread in the bug report forum. Slow downloading of maps is one thing but the download not happening at all is something else.

There is caching of maps so a map you have already downloaded should load very fast. At first I thought there might be a problem with the cache too but I was informed by an administrator that there are 13 levels of every map available so even if you have downloaded a map at a very high camera altitude doesn't mean that the map that is loaded when you are at a very low camera attitude will be in your cache. Just for your knowledge if you haven't heard it already. (Though I am unsure if there wasn't one time when I had already downloaded a map while just spending half an hour checking out the different maps and the terrain in northern europe at the same camera altitude and a map - The terrain type one - didn't load anyways).


(in reply to Ekaton)
Post #: 4
RE: Map loading issues - 11/18/2019 1:54:08 PM   
Ekaton


Posts: 98
Joined: 9/30/2013
From: The War Room
Status: offline
I also have 100 mbit connection and never had any problems with it. The game acts as if it had no idea which map to choose and switches between them before eventually loading the right one, or not - then I have to zoom in and out to make it try to load the right one again and eventually it will succeed.

_____________________________

I need ten females for each male...

(in reply to LargeDiameterBomb)
Post #: 5
RE: Map loading issues - 11/18/2019 2:19:23 PM   
morphin

 

Posts: 339
Joined: 4/26/2002
From: Switzerland
Status: offline
I have the same. I hope they offer offline map soon. At this time it is not usable for me

->you can disable and use only classic map until it is fixed

Andy

(in reply to Ekaton)
Post #: 6
RE: Map loading issues - 11/18/2019 4:59:39 PM   
Grazyn

 

Posts: 145
Joined: 10/24/2016
Status: offline
Could you post your system specs? I have the same issues with a 100mbps connection and a very old laptop so I think hardware may be the problem. Sentinel and Stamen layers load eventually (with long delays), but the "land cover" layer doesn't load at all except for very high camera altitude (like 80-100 km)

(in reply to morphin)
Post #: 7
RE: Map loading issues - 11/18/2019 5:47:43 PM   
Bandura1

 

Posts: 15
Joined: 12/11/2016
Status: offline
I have the same problem.

(in reply to Grazyn)
Post #: 8
RE: Map loading issues - 11/18/2019 6:25:57 PM   
morphin

 

Posts: 339
Joined: 4/26/2002
From: Switzerland
Status: offline
I suppose it is not the hardware. I have the latest Gaming Laptop. My internet connection is about 33MBbit/s

(in reply to Bandura1)
Post #: 9
RE: Map loading issues - 11/19/2019 7:09:23 PM   
KnightHawk75

 

Posts: 197
Joined: 11/15/2018
Status: offline
quote:

Does anyone experience that as well?


Yup, same exact experience here with the glitchy fragments, sometimes moving around or in\out a level will clean it up a bit, sometimes not.

(in reply to morphin)
Post #: 10
RE: Map loading issues - 11/19/2019 7:20:21 PM   
kylania

 

Posts: 155
Joined: 1/2/2015
Status: offline
Same here!

i7-8700K 3.70GHz
32GB RAM
GeForce 1080ti

(in reply to KnightHawk75)
Post #: 11
RE: Map loading issues - 11/19/2019 8:05:03 PM   
guanotwozero

 

Posts: 378
Joined: 12/27/2013
Status: offline
Could it be a latency issue?

That's the delay between the player's machine and map server. If it were synchronous (one tile at a time) with high latency, then bandwidth wouldn't be the issue.

It would be like trying to fill a bowl of peas by slowly rolling the peas through a long pipe, one at a time. The width of the pipe (bandwidth) would be irrelevant if each pea takes a long time.

Just a speculation.

(in reply to kylania)
Post #: 12
RE: Map loading issues - 11/19/2019 9:24:03 PM   
Gizzmoe


Posts: 155
Joined: 8/24/2005
From: Germany
Status: offline
quote:

ORIGINAL: guanotwozero
Could it be a latency issue?


That's very unlikely. It is like KnightHawk75 wrote two posts above yours, "sometimes moving around or in\out a level will clean it up a bit, sometimes not." So the correct data is basically there, it's just not being rendered correctly.

Just a speculation as well ;)

(in reply to guanotwozero)
Post #: 13
RE: Map loading issues - 11/22/2019 7:16:40 PM   
tiag

 

Posts: 15
Joined: 6/21/2018
Status: offline
Is there any solution for that? I could not find any reply by any dev or any support....
The maps are definitely not working. I have a high-end machine, high end GPU with 400mbit/s BW.
These glitches are a game stop rigth for me in CMO!

(in reply to Gizzmoe)
Post #: 14
RE: Map loading issues - 11/23/2019 6:25:02 AM   
morphin

 

Posts: 339
Joined: 4/26/2002
From: Switzerland
Status: offline
i really hope they are working for a solution

(in reply to tiag)
Post #: 15
RE: Map loading issues - 11/23/2019 12:34:30 PM   
xan2622


Posts: 17
Joined: 6/12/2011
Status: offline
I can also confirm this problem: maps/layers load very slowly.

I bought the game on Steam a few days ago and my fears (after reading some comments on forums) about maps loading slowly were true.

Maps load slowly while zooming in or out (with the Sentinel-2 satellite map).
- When I zoom in: it takes (at least) 3-8 seconds for the map to display the detailed version of the area.
- When I zoom out: areas that where previously hidden (out of the screen) are black for ~3-8 seconds, then the game eventually displays the map in these areas.

As advised on a Steam Discussion topic, I disabled the Sentinel-2 layer to only keep the BMNGv2 one. The game then displays the map faster but not always while zooming in.

I have installed the game on a SSD drive, I have a Nvidia GTX 1070 8Gb graphics card, 16 Gb DDR3 RAM + a 3.2 Ghz quad core CPU. I am quite surprised that these computer specs aren't enough to have a smooth experience in CMO..

I have been told that the Sentinel-2 layer is not installed on the SSD (locally), and that it is fetched from a remote server in real time..
I have a fiber internet (330 Mbps down.) and even with this download speed and my nvidia gtx 1070 8 Gb graphics card, the game is not able to load maps fast.

I also noticed that if you try to resize the CMO window, or if you try to maximize/restore the CMO window, and also if you hide/expand the side panel, it is quite slow as well.
IMO, there is a real performance problem with this game (and it's quite disappointing for a game sold for 67,99€)

I hope that developers will consider adding an option to download the Sentinel-2 map locally (on the hard drive), as an option.
Thanks to the Bitorrent protocol, players could be able to download this big texture pack, it would be also painless for your bandwidth. Once the first players have finished downloading the Satellite-2 map, the bitorrent file sharing could run in the background, allowing other CMO players to get the map from other players..





(in reply to morphin)
Post #: 16
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> Map loading issues Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.135