Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: game won't start (2)

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Armored Brigade >> Armored Brigade: Tech Support Forum >> RE: game won't start (2) Page: <<   < prev  1 [2]
Login
Message << Older Topic   Newer Topic >>
RE: game won't start (2) - 3/24/2020 8:41:22 PM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline
If it used to work, then perhaps it's caused by an automatic Windows update. They have caused the AB 'stuttering' issue in the past. I'm reading now that recent Windows 10 updates have had issues.


_____________________________

Know thyself!

(in reply to mmacguinness)
Post #: 31
RE: game won't start (2) - 3/25/2020 8:09:05 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
Checked my update history.

No updates in the period 20-23 March since the the last time i successfully ran AB

(in reply to Veitikka)
Post #: 32
RE: game won't start (2) - 3/25/2020 8:40:25 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
Digging aroung in my computer I found a Windows AppCrash report file at c:\ProgramData\Microsoft\Windows\WER\ReportArchive.

It is not in an approved format, so I can't upload it here, so here is ascreenshot




Attachment (1)

(in reply to mmacguinness)
Post #: 33
RE: game won't start (2) - 3/25/2020 8:55:41 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
Just uninstalled and reinstalled the game.

It still won't run

(in reply to mmacguinness)
Post #: 34
RE: game won't start (2) - 3/25/2020 9:00:47 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
And then installed the v1.056 patch.

It still doesn't run

(in reply to mmacguinness)
Post #: 35
RE: game won't start (2) - 3/25/2020 10:21:58 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
This is the AppCrash report file mentionedd above.

I changed the file ending from .wer to .txt to get the system to upload it.

Attachment (1)

(in reply to mmacguinness)
Post #: 36
RE: game won't start (2) - 3/25/2020 10:45:30 AM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline
LoadedModule[73]=C:\WINDOWS\System32\DriverStore\FileRepository\iigd_dch.inf_amd64_c002fecfdc9bbd33\igc32.dll

If that's where it crashes it strongly suggests that this has something to do with the graphics drivers. Google says that it's part of Intel HD Graphics Drivers. Perhaps the game tries to use the integrated graphics after all?


< Message edited by Veitikka -- 3/25/2020 10:49:24 AM >


_____________________________

Know thyself!

(in reply to mmacguinness)
Post #: 37
RE: game won't start (2) - 3/25/2020 12:23:48 PM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
You asking me?

How would I know? I build oil & gas plants and stuff. I have no idea how your software interacts with hardware.

Anyway, yesterday I updated the drivers for both the Intel and Nvidia graphics cards, then this morning, uninstalled and re-installed AB and the 1.056 patch.

So now, I have a clean install on a computer with updated graphics drivers. And it doesn't work.

Over to you. Would you like a copy of the sysinfo?

(in reply to Veitikka)
Post #: 38
RE: game won't start (2) - 3/26/2020 12:30:39 AM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline
I mean that perhaps your system selects the integrated graphics instead of the NVIDIA card. Practically all these cases where the game crashes without an error message are related to Intel graphics and/or drivers.

One user reported that he had to downgrade the drivers to make the game work.

What makes this case special is that you said the game used to work, but then it stopped working without anything being changed on the system.

If you have all the latest drivers I can only recommend to revert back to default values in the NVIDIA control panel and make sure that the preferred graphics processor for the program (Armored Brigade) is the NVIDIA processor. If the application crashes when loading igc32.dll then it probably still tries to use the integrated graphics.


_____________________________

Know thyself!

(in reply to mmacguinness)
Post #: 39
RE: game won't start (2) - 3/26/2020 7:48:23 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
OK. Got it working. But NOT via the Nvidia control panel.

By adjusting Windows Settings-Display Settings-Advanced Graphics.

On Desktop:
1. Right click and select Display
2. At the bottom of the page, click on Graphics Settings
3. Im Graphics Settings, use Browse to find and select ArmoredBrigade.exe
4. Click on the Options button
5. Select High Performance

Screenshots as follows:





Attachment (1)

(in reply to Veitikka)
Post #: 40
RE: game won't start (2) - 3/26/2020 7:49:24 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
Graphics Settings

Attachment (1)

(in reply to mmacguinness)
Post #: 41
RE: game won't start (2) - 3/26/2020 7:50:10 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
Graphics Settings




Attachment (1)

(in reply to mmacguinness)
Post #: 42
RE: game won't start (2) - 3/26/2020 7:51:02 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
Graphics Settings - AB selected




Attachment (1)

(in reply to mmacguinness)
Post #: 43
RE: game won't start (2) - 3/26/2020 7:52:14 AM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
Select High performance




Attachment (1)

(in reply to mmacguinness)
Post #: 44
RE: game won't start (2) - 3/27/2020 3:37:17 PM   
tmoilanen

 

Posts: 39
Joined: 10/19/2011
Status: offline
Thanks for this! I've been unable to get the game to work and this solved it.

(in reply to mmacguinness)
Post #: 45
RE: game won't start (2) - 3/27/2020 4:22:12 PM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
Glad to help.

(in reply to tmoilanen)
Post #: 46
RE: game won't start (2) - 4/12/2020 9:34:21 PM   
Mudchook

 

Posts: 2
Joined: 10/23/2015
Status: offline
Thanks mmacguinness! Brand new purchase/download and I had the same issues as described.

Your fix allowed me to play.

Cheers mate!

(in reply to mmacguinness)
Post #: 47
RE: game won't start (2) - 5/28/2020 8:57:40 AM   
MirabelleBenou

 

Posts: 310
Joined: 4/3/2010
Status: offline
Waooo !!

It works also for me, even with only Intel Graphics card. With default parameter, game won't start, and when applying High Performance, it works just fine !

Veitikka > I think you should stick this one :)

_____________________________


(in reply to Mudchook)
Post #: 48
Page:   <<   < prev  1 [2]
All Forums >> [New Releases from Matrix Games] >> Armored Brigade >> Armored Brigade: Tech Support Forum >> RE: game won't start (2) Page: <<   < prev  1 [2]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.137