Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

game won't start (2)

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Armored Brigade >> Armored Brigade: Tech Support Forum >> game won't start (2) Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
game won't start (2) - 6/3/2019 12:50:52 AM   
jt2074

 

Posts: 3
Joined: 4/21/2019
Status: offline
I have the same symptoms as Bill. The game won't run even if I press the play button.
Likewise, when I press the setting button, it doesn't respond. I deleted the game and reinstalled it,
but the problem is still there. My computer's CPU is m3-7y30, Graphic Card is intel HID615.
I hope you can solve the problem as soon as possible.
Post #: 1
RE: game won't start (2) - 6/3/2019 12:23:00 PM   
CapnDarwin


Posts: 7753
Joined: 2/12/2005
From: Newark, OH
Status: offline
Are you up to date on the openGL drivers for that Intel 615 chip? Also how much RAM does your system have?

_____________________________

Work on Southern Storm continues as we squish bugs and work on features.

Cap'n Darwin aka Jim Snyder
On Target Simulations LLC

(in reply to jt2074)
Post #: 2
RE: game won't start (2) - 6/4/2019 11:23:21 AM   
CapnDarwin


Posts: 7753
Joined: 2/12/2005
From: Newark, OH
Status: offline
From jt2074 via email - My graphic driver version is latest version 26.20.100.6890.
My com has 8G ram and window 10 1903 version.
But before update to 1903, there was a problem.
Please help me I want to play the game.

_____________________________

Work on Southern Storm continues as we squish bugs and work on features.

Cap'n Darwin aka Jim Snyder
On Target Simulations LLC

(in reply to CapnDarwin)
Post #: 3
RE: game won't start (2) - 6/4/2019 11:31:05 AM   
CapnDarwin


Posts: 7753
Joined: 2/12/2005
From: Newark, OH
Status: offline
jt2074, seems like you may have enough ram. My best guess right now is the Intel 615 is not compatible with the Devs home grown graphics engine. Hopefully another 615 user who is successful in running the game will pop in and say so. That will point the problem in another direction.

In the mean time, what is your screen resolution? Does the computer run any other recent games? What version of OpenGL does your latest graphics card driver support? Sorry there isn't a quick fix at the moment.

_____________________________

Work on Southern Storm continues as we squish bugs and work on features.

Cap'n Darwin aka Jim Snyder
On Target Simulations LLC

(in reply to CapnDarwin)
Post #: 4
RE: game won't start (2) - 6/4/2019 12:28:01 PM   
nikolas93TS


Posts: 556
Joined: 2/24/2017
Status: offline
This happens both for windowed mode and full screen?

(in reply to CapnDarwin)
Post #: 5
RE: game won't start (2) - 6/4/2019 1:38:28 PM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline

quote:

ORIGINAL: nikolas93TS

This happens both for windowed mode and full screen?


I believe he never gets beyond the Matrix launcher, so there's no screen mode selection.

What I can recommend is updating the video card drivers and checking if there's the 'error.log' file in the game root folder.

If nothing works then I suspect that your video card is incompatible with the game, and the only way is to try the game on a different system.


_____________________________

Know thyself!

(in reply to nikolas93TS)
Post #: 6
RE: game won't start (2) - 6/4/2019 10:01:28 PM   
BeirutDude


Posts: 1882
Joined: 4/27/2013
From: Jacksonville, FL, USA
Status: offline
One suggestion, try not installing it in the default, "Program Folder (x86)" Folder. I'm finding that that folder uses some resources and loading it to a C:\Matrix Games (or other folder) might help a bit. I reinstalled by AB under my Matrix Games folder and am having a lot less problems with a marginal machine. With Campaigns Middle East the 2.01 update was crashing my system but I moved it and it plays fine now.

_____________________________

"Some people spend an entire lifetime wondering if they made a difference. The Marines don't have that problem."
PRESIDENT RONALD REAGAN, 1985

I was Navy, but Assigned TAD to the 24th MAU Hq in Beirut. By far the finest period of my service!

(in reply to jt2074)
Post #: 7
RE: game won't start (2) - 8/22/2019 4:49:08 PM   
GaretBale

 

Posts: 10
Joined: 8/22/2019
Status: offline
What's your OS version?

(in reply to BeirutDude)
Post #: 8
RE: game won't start (2) - 8/24/2019 2:18:49 AM   
KC45


Posts: 219
Joined: 11/23/2017
From: JPN
Status: offline
(laptop) Win10+i7(HD630)+16GBRAM+GTX1060, the game installed on SSD and same things happen in here.

_____________________________

Steam CMANO Japanese Community(unofficial).

(in reply to GaretBale)
Post #: 9
RE: game won't start (2) - 8/24/2019 2:42:24 PM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline
Probably not related to most of these cases, but I noticed that if there's an empty folder in the data\database directory, usually after creating and removing a custom database, the application crashes without an error message. This will be fixed in the next patch.

Do you give the application the admin rights when it asks for them?


_____________________________

Know thyself!

(in reply to KC45)
Post #: 10
RE: game won't start (2) - 8/24/2019 4:19:53 PM   
KC45


Posts: 219
Joined: 11/23/2017
From: JPN
Status: offline
Well, I forced launch AB with GTX1060, it launched. so that was HD630 problem.

_____________________________

Steam CMANO Japanese Community(unofficial).

(in reply to Veitikka)
Post #: 11
RE: game won't start (2) - 9/3/2019 1:43:00 AM   
Majestic12

 

Posts: 3
Joined: 4/6/2018
Status: offline
I'm having a similar issue. The game won't go past the pop up screen whether I go to change settings or press play game.

(in reply to KC45)
Post #: 12
RE: game won't start (2) - 10/26/2019 4:16:36 PM   
bgutzman

 

Posts: 5
Joined: 2/22/2011
Status: offline
I Have a new Asus Strix Hero III with RTX 2070 Processor, the game wont start even though I tried both integrated graphics and my graphic card? Can I get this to work or get my money back?

_____________________________

Freedom is legislated away one bill at a time.

(in reply to Majestic12)
Post #: 13
RE: game won't start (2) - 10/26/2019 4:20:58 PM   
bgutzman

 

Posts: 5
Joined: 2/22/2011
Status: offline
I did get it to Run on my Asus, was id10t issue with clicking apply and forcing it to use graphics card.

_____________________________

Freedom is legislated away one bill at a time.

(in reply to bgutzman)
Post #: 14
RE: game won't start (2) - 11/2/2019 9:17:47 PM   
rgeiger


Posts: 13
Joined: 1/20/2019
Status: offline
I have the same problem after having to switch my laptop for a newer model (company issue, so no choice here).

Armored Brigade ran flawlessly on my old MS Surface Laptop (integrated Intel Iris 640 GPU), but will not start on the new Surface Laptop 3 (integrated Intel Iris G7 GPU (10th gen. Ice Lake chipset)). Unfortunately, there is no error.log. The laptop also does not have any other GPU, so I seem to be locked out for good . Unless there is some kind of workaround, I am desperately looking for...

Now that it is out on Steam and available to less grognard-y players (and my system in theory meets the specifications), maybe it would be good to add a warning or a list of incompatible GPUs to avoid bad press?

(in reply to bgutzman)
Post #: 15
RE: game won't start (2) - 11/2/2019 9:25:31 PM   
nikolas93TS


Posts: 556
Joined: 2/24/2017
Status: offline
Have you tried this?

https://www.matrixgames.com/forums/tm.asp?m=4702459

It is usually the driver issue that can be quickly fixed.

(in reply to rgeiger)
Post #: 16
RE: game won't start (2) - 11/2/2019 9:38:37 PM   
rgeiger


Posts: 13
Joined: 1/20/2019
Status: offline
Thank you for your reply!
I am however not sure if I understand it correctly. As my laptop does not have any Nvidia graphics card installed (just the integrated Intel GPU), installing new Nvidia drivers does not seem to be an intuitive solution - unless I can define a virtual GPU afterwards?

N.B. The game of course also works on my desktop PC where there are dedicated Nvidia GPUs (SLI-ed GTX 980ti), but I mostly play on my laptop when away on business trips.

Edit: Typo.

< Message edited by rgeiger -- 11/2/2019 9:39:59 PM >

(in reply to nikolas93TS)
Post #: 17
RE: game won't start (2) - 11/2/2019 9:49:24 PM   
nikolas93TS


Posts: 556
Joined: 2/24/2017
Status: offline
Sorry, I misread. But in any case first step should be always to try updating the drivers.

(in reply to rgeiger)
Post #: 18
RE: game won't start (2) - 11/2/2019 10:07:13 PM   
rgeiger


Posts: 13
Joined: 1/20/2019
Status: offline
I tested the pinned solution regardless, but this solution will unfortunately only work if there is indeed a Nvidia GPU installed (my hope for a virtual GPU melted away like an M109 facing an enemy MBT).
My Intel drivers and DirectX are of course updated to the latest versions, so also no hope there. For the moment I seem to be definitely locked out of the game I love to play.

(in reply to rgeiger)
Post #: 19
RE: game won't start (2) - 2/25/2020 1:28:36 PM   
rgeiger


Posts: 13
Joined: 1/20/2019
Status: offline
Just a follow-up.
Even though I cannot find anything in the change log, the recent 1.056 update seems to have fixed the issue with my integrated graphics card. There have not been any updates for the Intel graphics drivers that I am aware of, my driver is from last December.
AB runs again for me as of today, so it may be worthwile to try again if you had the same problem.


< Message edited by rgeiger -- 2/25/2020 1:33:13 PM >

(in reply to rgeiger)
Post #: 20
RE: game won't start (2) - 2/25/2020 3:06:40 PM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline

quote:

ORIGINAL: rgeiger

Just a follow-up.
Even though I cannot find anything in the change log, the recent 1.056 update seems to have fixed the issue with my integrated graphics card. There have not been any updates for the Intel graphics drivers that I am aware of, my driver is from last December.
AB runs again for me as of today, so it may be worthwile to try again if you had the same problem.



Is this the Matrix, Steam, or GOG version?


_____________________________

Know thyself!

(in reply to rgeiger)
Post #: 21
RE: game won't start (2) - 2/25/2020 3:49:00 PM   
rgeiger


Posts: 13
Joined: 1/20/2019
Status: offline
I initially bought the game from the Matrix store on release day.
When you made the Steam keys available I installed it on Steam and that is where I was testing it today after 1.056 dropped. I've tried after every update and today it suddenly worked.
I guess that means I am using the Steam version now.

EDIT: Tech info
I am now using driver version 26.20.100.7641 dated 21. Dec. 2019 for my integrated graphics card. According to Windows, this version was installed on Jan. 31st 2020. It may be that I haven't tried AB since the end of January, I have no possibility to check that. Maybe it was this driver update which solved the problem.

EDIT 2: will also update my post at the Steam forums with the tech info.

< Message edited by rgeiger -- 2/25/2020 3:56:47 PM >

(in reply to Veitikka)
Post #: 22
RE: game won't start (2) - 3/24/2020 1:06:09 PM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
New computer, i7, 16Gb RAM, Nvidia MX250.
AB installed (Matrix download) in Dec 2019. no problems.

Last successfull launch, about 4 or 5 days ago. No subsequent changes to system hardware or software.

Since 2 days ago, game will not launch from menu. Nor will settings launch.

Downloaded from Matrix and re-installed latest game update.
Re-installed video drivers. Nvidia MX250 set as default.

Nothing. Still doesn't work. But it did a few days ago! ?????????????????????????????????????

(in reply to rgeiger)
Post #: 23
RE: game won't start (2) - 3/24/2020 6:40:55 PM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline

quote:

ORIGINAL: mmacguinness

New computer, i7, 16Gb RAM, Nvidia MX250.
AB installed (Matrix download) in Dec 2019. no problems.

Last successfull launch, about 4 or 5 days ago. No subsequent changes to system hardware or software.

Since 2 days ago, game will not launch from menu. Nor will settings launch.

Downloaded from Matrix and re-installed latest game update.
Re-installed video drivers. Nvidia MX250 set as default.

Nothing. Still doesn't work. But it did a few days ago! ?????????????????????????????????????


Try to disable your anti-virus software.


_____________________________

Know thyself!

(in reply to mmacguinness)
Post #: 24
RE: game won't start (2) - 3/24/2020 7:13:13 PM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
OK. Just tried that, disabled my AV. No change.

Not surprised, my AV software hasn't interfered in the three months I've had this computer, nor did it create a problem on any of the other three computers I've played the game on.

One day it worked, next day it didn't. Zero hardware or software changes, no configuration changes, no new software, nothing.


(in reply to Veitikka)
Post #: 25
RE: game won't start (2) - 3/24/2020 7:20:16 PM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline

quote:

ORIGINAL: mmacguinness

OK. Just tried that, disabled my AV. No change.

Not surprised, my AV software hasn't interfered in the three months I've had this computer, nor did it create a problem on any of the other three computers I've played the game on.

One day it worked, next day it didn't. Zero hardware or software changes, no configuration changes, no new software, nothing.




Is there an error.log file in the game folder? Try to delete all the .cfg files in the data\cfg folder.


_____________________________

Know thyself!

(in reply to mmacguinness)
Post #: 26
RE: game won't start (2) - 3/24/2020 7:41:02 PM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
there is no error log.

the only files in the cfg folder are

preferences.cfg

and

tutorial.cfg

(in reply to Veitikka)
Post #: 27
RE: game won't start (2) - 3/24/2020 7:42:51 PM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
deleted the two files.

still doesn't work

(in reply to mmacguinness)
Post #: 28
RE: game won't start (2) - 3/24/2020 8:04:37 PM   
Veitikka


Posts: 1260
Joined: 6/25/2007
From: Finland
Status: offline
You have selected High-performance NVIDIA Processor or such in the NVIDIA Global settings?


_____________________________

Know thyself!

(in reply to mmacguinness)
Post #: 29
RE: game won't start (2) - 3/24/2020 8:08:12 PM   
mmacguinness

 

Posts: 60
Joined: 2/3/2007
Status: offline
yes

(in reply to Veitikka)
Post #: 30
Page:   [1] 2   next >   >>
All Forums >> [New Releases from Matrix Games] >> Armored Brigade >> Armored Brigade: Tech Support Forum >> game won't start (2) Page: [1] 2   next >   >>
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.167