Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

1.16.02 Update

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Strategic Command Series >> Strategic Command WWII War in Europe >> 1.16.02 Update Page: [1]
Login
Message << Older Topic   Newer Topic >>
1.16.02 Update - 5/30/2019 7:31:45 AM   
Daniele

 

Posts: 1609
Joined: 2/7/2015
Status: offline
Hi everybody,

You can download the update from here


1.16.02 Changelog

GAME ENGINE CHANGES/FIXES
- fixed a CTD error when selecting naval units within a campaign that has no set weather zones.
- fixed a CTD when entering a PURCHASE screen for a Major that has no available unit types to build for itself or for an applicable Minor.
- fixed a FoW reveal error during the last turn replay for some players when they switched computers between turns.
- Subs that dive from an attack will no longer pass through an enemy Land + Sea hex.

1939 Campaign
- The UK’s Carrier Illustrious can now be deployed at any UK port in May 1940 (witpaemail).


v1.16.01

GAME ENGINE CHANGES/FIXES
- fixed an attrition loss error that did not properly occur for land units isolated on a single land hex in some cases.
- fixed an issue where the English User Manual could not be launched from within the game.
- Research/Diplomatic investments will now highlight which country you are purchasing for when the investment confirmation question screen displays.

EDITOR CHANGES/FIXES
- fixed an issue with the Text layer where the text layer edit box was not being shown in the Editor.

< Message edited by Surtur -- 8/16/2019 1:26:20 PM >
Post #: 1
RE: 1.16.02 Update - 6/18/2019 5:28:08 PM   
Hubert Cater

 

Posts: 3243
Joined: 7/22/2013
Status: offline
For those that are updating from v1.15 to v1.16.02, and are also using the Community Pack, the Community Pack will need to be updated as well.

It can be grabbed from here:

http://www.matrixgames.com/products/714/details/Strategic.Command.WWII.Community.Pack



_____________________________


(in reply to Daniele)
Post #: 2
RE: 1.16.02 Update - 6/19/2019 1:46:13 AM   
Hubert Cater

 

Posts: 3243
Joined: 7/22/2013
Status: offline
Modders will find that their previously modded campaigns, i.e. prior to the v1.16.0x update will be incompatible with this update. This is a one time issue as the v1.16 update created new data structures that requires previous mods to be converted for compatibility.

There is a conversion tool that was packaged with the v1.16 update and it should be used to update all your previous mods to v1.16.

Please navigate to your installation folder for your game, typically this folder here:

MATRIX
C:\Program Files (x86)\Matrix Games\Strategic Command WWII - War in Europe

STEAM
C:\Program Files (x86)\Steam\steamapps\common\Strategic Command WWII War in Europe

Open the Extras folder found there and then the Campaign Conversion folder.

There is a README file in there, I suggest reading this file, and then using the Conversion Tool on your customized campaigns.

They should work after that for v1.16

Hubert

_____________________________


(in reply to Hubert Cater)
Post #: 3
RE: 1.16.02 Update - 8/13/2019 8:35:38 PM   
witpaemail

 

Posts: 125
Joined: 3/2/2015
Status: offline
ok, so why doesnt this work? I click the link and I get sent to a page that has a HUGE error 404 on it. So I blunder around the website a while and find a page that lets me download the 16.02 patch for free. So I download that, click on it after its done downloading and it just sits there.

Once upon a time when you clicked on "update program" with matrix games they ACTUALLY updated, not anymore it seems. So what gives? How do I actually patch this thing? I did unzip the file, but it doesnt seem to have done anything.

And for further info, I am running an old laptop with win 7 and the 1.08 version of the game.

< Message edited by witpaemail -- 8/13/2019 8:42:00 PM >

(in reply to Daniele)
Post #: 4
RE: 1.16.02 Update - 8/15/2019 2:56:56 PM   
BillRunacre

 

Posts: 3140
Joined: 7/22/2013
Status: online

quote:

ORIGINAL: witpaemail

ok, so why doesnt this work? I click the link and I get sent to a page that has a HUGE error 404 on it. So I blunder around the website a while and find a page that lets me download the 16.02 patch for free. So I download that, click on it after its done downloading and it just sits there.

Once upon a time when you clicked on "update program" with matrix games they ACTUALLY updated, not anymore it seems. So what gives? How do I actually patch this thing? I did unzip the file, but it doesnt seem to have done anything.

And for further info, I am running an old laptop with win 7 and the 1.08 version of the game.


Hi

Sorry to hear about the problem, and it might pay to contact support as they'll be the best people to hopefully get this fixed for you.

Bill

_____________________________

Follow us on Twitter: https://twitter.com/FurySoftware

We're also on Facebook! https://www.facebook.com/FurySoftware/

(in reply to witpaemail)
Post #: 5
RE: 1.16.02 Update - 8/16/2019 1:27:16 PM   
Surtur

 

Posts: 384
Joined: 8/6/2013
From: The Netherlands
Status: offline
Hi,

Many thanks for reporting this. It should be fixed now, please try again.

Cheers,

Bart

_____________________________

- Slitherine Group Producer -
Twitter
Steam

(in reply to BillRunacre)
Post #: 6
RE: 1.16.02 Update - 8/18/2019 7:53:32 AM   
witpaemail

 

Posts: 125
Joined: 3/2/2015
Status: offline
Works like a dream, thank you :)

(in reply to Surtur)
Post #: 7
RE: 1.16.02 Update - 8/18/2019 1:32:31 PM   
Taxman66


Posts: 1431
Joined: 3/19/2008
From: Columbia, MD. USA
Status: offline
Please note there is a serious flaw with this update.

The Days per Turn for Spring/Fall/Winter were accidentally set to longer thus shortening the number of turns per year by 3 (per side).

_____________________________

"Part of the $10 million I spent on gambling, part on booze and part on women. The rest I spent foolishly." - George Raft

(in reply to witpaemail)
Post #: 8
RE: 1.16.02 Update - 8/19/2019 1:10:29 PM   
witpaemail

 

Posts: 125
Joined: 3/2/2015
Status: offline
Back in my programming days we used to refer to things like that as "unannounced system features" :)

(in reply to Taxman66)
Post #: 9
RE: 1.16.02 Update - 8/19/2019 2:38:35 PM   
Hubert Cater

 

Posts: 3243
Joined: 7/22/2013
Status: offline
Thanks and this has already been fixed for the next update.

_____________________________


(in reply to witpaemail)
Post #: 10
RE: 1.16.02 Update - 8/19/2019 10:59:05 PM   
ReinerAllen

 

Posts: 115
Joined: 3/2/2014
Status: offline
I tried to play "Fall Weiss -20" with a friend of mine, but he has from Steam and I have mine from Matrix. He says it's not part of his update. Any thoughts.

< Message edited by ReinerAllen -- 8/19/2019 11:00:08 PM >

(in reply to Hubert Cater)
Post #: 11
RE: 1.16.02 Update - 8/20/2019 11:05:26 AM   
ArmouredLion


Posts: 648
Joined: 9/18/2015
Status: offline
You could get your steam key from matrix and play it from there... that's what I do, brother.

(in reply to ReinerAllen)
Post #: 12
RE: 1.16.02 Update - 8/20/2019 12:25:51 PM   
Hubert Cater

 

Posts: 3243
Joined: 7/22/2013
Status: offline
Fall Weiss 20 is a part of the Community Pack which is also available for the Steam version. All he would have to do is go to his Steam Library, select the game, and then tick off the DLC box for the Community Pack.

Hope this helps,
Hubert

_____________________________


(in reply to ReinerAllen)
Post #: 13
RE: 1.16.02 Update - 8/20/2019 10:29:57 PM   
El Condoro

 

Posts: 179
Joined: 4/2/2008
Status: offline
quote:

ORIGINAL: Hubert Cater

All he would have to do is go to his Steam Library, select the game, and then tick off the DLC box for the Community Pack.



I am unable to see any DLC box when I click on the game in my Steam Library. Can you say exactly where it is, please?

[Edit] NM. Although I can't see a DLC box it doesn't matter - the Community Content scenarios are all available.


< Message edited by El Condoro -- 8/21/2019 1:00:32 AM >

(in reply to Hubert Cater)
Post #: 14
RE: 1.16.02 Update - 10/11/2019 3:06:17 AM   
sPzAbt653


Posts: 8834
Joined: 5/3/2007
From: east coast, usa
Status: offline
quote:

previously modded campaigns, i.e. prior to the v1.16.0x update will be incompatible with this update. This is a one time issue as the v1.16 update created new data structures that requires previous mods to be converted for compatibility.

I'm trying to convert the 653N Mod to v1.16.03. I expect trouble as I had previously done some of the Script Conversions manually in Beta, and guess that now the Conversion won't know how to handle that.
So I rubbed my hands together, opened the Campaign Conversion Tool, opened 653N with it, and get the error seen below. I have no idea what this means nor where to look to fix it




Attachment (1)

(in reply to Hubert Cater)
Post #: 15
RE: 1.16.02 Update - 10/12/2019 8:04:30 AM   
Hubert Cater

 

Posts: 3243
Joined: 7/22/2013
Status: offline
If you still have v1.15 installed or accessible, and are able to open the original 653N mod, I believe the issue here is any fortification that is located on the map. Removing these and then saving and trying to convert again using the Conversion Tool should get you past this error.

You would then just need to add the fortifications back to the map after conversion if desired.

Hope this helps,
Hubert

_____________________________


(in reply to sPzAbt653)
Post #: 16
RE: 1.16.02 Update - 10/12/2019 11:36:56 AM   
sPzAbt653


Posts: 8834
Joined: 5/3/2007
From: east coast, usa
Status: offline
Thanks, but now I am sufficiently screwed up that nothing works and I'm chasing errors. I'm really pissed off at myself because for months I have told myself not to get involved in this and to just let it go, but I couldn't leave it and now I am paying for that decision. I know others have worked it out, but it is just beyond me. Maybe in the future I will revisit this and try to figure it out again.




Attachment (1)

(in reply to Hubert Cater)
Post #: 17
RE: 1.16.02 Update - 10/14/2019 1:26:48 PM   
Hubert Cater

 

Posts: 3243
Joined: 7/22/2013
Status: offline
If you have the original 653N mod (unconverted etc.) from before the v1.16 release please send it to me at support@furysoftware.com and I'll be happy to convert it for you.

Send via WeTransfer if you can, thanks!

https://wetransfer.com

_____________________________


(in reply to sPzAbt653)
Post #: 18
RE: 1.16.02 Update - 10/15/2019 2:53:17 AM   
sPzAbt653


Posts: 8834
Joined: 5/3/2007
From: east coast, usa
Status: offline
I feel bad I can't figure this out, usually I can get this stuff straight.

Before I started, I 'copied' 653N and then used the 'uncopied' version to attempt the conversion. After I couldn't get it to work, I deleted the uncopied 653N and all things v1.16 and reinstalled v1.15 and then renamed the 653N Copy as plain 653N. But it won't load in the 1.15 Editor or game. I have sent that file to you via We Transfer. Thanks for taking a look.

(in reply to Hubert Cater)
Post #: 19
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Strategic Command Series >> Strategic Command WWII War in Europe >> 1.16.02 Update Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.129