Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

not showing replays

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Strategic Command Series >> Strategic Command WWII: World at War >> Tech Support >> not showing replays Page: [1]
Login
Message << Older Topic   Newer Topic >>
not showing replays - 1/3/2019 2:27:02 AM   
dave123

 

Posts: 96
Score: 0
Joined: 7/14/2016
Status: offline
2 of my 3 pbem games are not showing the opponents turn, just the summary. It this a toggle or a bug?
It skips the screen where it asks you if you want to see the replay.

Really, who would ever say no to this anyway?



< Message edited by dave123 -- 1/3/2019 3:16:06 AM >
Post #: 1
RE: not showing replays - 1/4/2019 8:23:32 PM   
Pocus


Posts: 998
Score: 0
Joined: 9/22/2004
Status: offline
I'm in the same situation. What is strange is that I get the replay proposed on my desktop, but on my laptop it is never proposed.

_____________________________

AGEOD Team - Lead Developer
Makers of Empires, ACW2, EAW, WIA, WON

(in reply to dave123)
Post #: 2
RE: not showing replays - 1/7/2019 3:29:59 PM   
Hubert Cater

 

Posts: 3341
Score: 2
Joined: 7/22/2013
Status: online
Due to the nature of how we had to interface with the PBEM++ server, not all game data is sent to the server (the files would be too large otherwise as our game has a lot of data) and a lot of static data is maintained on your computer as you play your PBEM++ games. As a result, there are instances where if you play a turn on one computer and then play a turn on another computer, a proper replay cannot be shown and will be skipped. But if you then continue on the other computer, proper replays will be shown after that once the game data is fully rebuilt.

This could be the issue here, unless of course you are not switching computers between turns.

Please let me know,
Hubert

_____________________________


(in reply to Pocus)
Post #: 3
RE: not showing replays - 1/8/2019 1:54:08 PM   
dave123

 

Posts: 96
Score: 0
Joined: 7/14/2016
Status: offline
Thanx for your reply Mr. Cater - I knew you always check these threads.

It is the same computer. Also, please note that I have one game that is working fine, so it's not all the time - but it is most of the time.

I saved one of the games, if you tell me where it is I can send it to you.

Great game, but until this is fixed, I can't play multiplayer,which is the whole game for me.

I have the steam version installed on an external hard drive if that matters.

thanx!

(in reply to Hubert Cater)
Post #: 4
RE: not showing replays - 1/9/2019 3:54:44 PM   
dave123

 

Posts: 96
Score: 0
Joined: 7/14/2016
Status: offline
Hello Mr. Cater - Please don't forget this thread. I can't play the game until this is fixed.

P.S. I'm a Strategic command vet - way back to SC 1 at battlefront ;)


p.s. I have it on C drive now - didn't help.

And now a total of 7 MP games and only 2 showed the moves.

(in reply to dave123)
Post #: 5
RE: not showing replays - 1/9/2019 6:58:52 PM   
boudi

 

Posts: 233
Score: 0
Joined: 1/7/2007
From: France
Status: offline
quote:

if you play a turn on one computer and then play a turn on another computer, a proper replay cannot be shown


OK... I understand why i have some problems with my replays now, i'm playing with 3 different computers...

(in reply to Hubert Cater)
Post #: 6
RE: not showing replays - 1/10/2019 4:16:07 AM   
Pocus


Posts: 998
Score: 0
Joined: 9/22/2004
Status: offline
Same here, I'm switching regularly between desktop and laptop.

Is that possible to extend the delay thus? Or in any case that's not possible to rebuild the replay as there are missing local infos.

Is that possible in a nerdy option hidden in SC3.ini to ask that the saved game is saved in full, even if it takes much more to upload to the server? I would not mind having to wait 20 extra seconds for a full upload, if I know it guarantees me seeing a replay each time I switch to another computer.



< Message edited by Pocus -- 1/10/2019 4:18:23 AM >


_____________________________

AGEOD Team - Lead Developer
Makers of Empires, ACW2, EAW, WIA, WON

(in reply to boudi)
Post #: 7
RE: not showing replays - 1/10/2019 2:00:50 PM   
dave123

 

Posts: 96
Score: 0
Joined: 7/14/2016
Status: offline
Glad you guys got it figured out - but me, it's the same computer.

I have my privacy/security settings at super paranoia. Things like auto wiping of all my internet activity, cortana turned off, etc, since
I was a victim of identity theft. Could it be that one of these settings is somehow to blame?

But then again, I've had a few games where I see the replays...


I've saved one of them that I can send to you, Mr. Cater.

< Message edited by dave123 -- 1/10/2019 2:01:50 PM >

(in reply to Pocus)
Post #: 8
RE: not showing replays - 1/11/2019 2:29:35 PM   
Hubert Cater

 

Posts: 3341
Score: 2
Joined: 7/22/2013
Status: online

quote:

ORIGINAL: Pocus

Same here, I'm switching regularly between desktop and laptop.

Is that possible to extend the delay thus? Or in any case that's not possible to rebuild the replay as there are missing local infos.

Is that possible in a nerdy option hidden in SC3.ini to ask that the saved game is saved in full, even if it takes much more to upload to the server? I would not mind having to wait 20 extra seconds for a full upload, if I know it guarantees me seeing a replay each time I switch to another computer.




It is a server file size issue and limitation that I need to work with. Regular saved game files can be up to 40MB and I need to keep the PBEM++ server files down to about 1MB or thereabouts.

But that being said I think I have a new solution that will resolve the issue of switching between computers and keep the file size down to where it needs to be for the next build.


_____________________________


(in reply to Pocus)
Post #: 9
RE: not showing replays - 1/11/2019 2:31:02 PM   
Hubert Cater

 

Posts: 3341
Score: 2
Joined: 7/22/2013
Status: online

quote:

ORIGINAL: dave123

Glad you guys got it figured out - but me, it's the same computer.

I have my privacy/security settings at super paranoia. Things like auto wiping of all my internet activity, cortana turned off, etc, since
I was a victim of identity theft. Could it be that one of these settings is somehow to blame?

But then again, I've had a few games where I see the replays...


I've saved one of them that I can send to you, Mr. Cater.


It could be and if there is a setting to tell your privacy/security settings to leave the following folder alone, this will probably do the trick for you:

C:\Users\<username>\AppData\Local\My Games\Strategic Command WWII - World at War\PBEM++\


_____________________________


(in reply to dave123)
Post #: 10
RE: not showing replays - 1/11/2019 3:18:07 PM   
dave123

 

Posts: 96
Score: 0
Joined: 7/14/2016
Status: offline
Thank you Mr. Cater.

My appdata folder was marked as hidden. I changed it to read only (and all subfolders) and will test. Don't know of any other way
I can change a setting that might help. Oh, I also reinstalled the game.

Still, the fact that some games show the replay and others don't is quite baffling.

(in reply to Hubert Cater)
Post #: 11
RE: not showing replays - 1/12/2019 5:08:36 AM   
dave123

 

Posts: 96
Score: 0
Joined: 7/14/2016
Status: offline
Making the folder read only instead of hidden and reinstall did not seem to help.

what a bummer, it would seem i'm the only one with this game breaking issue that uses just one computer.

(in reply to dave123)
Post #: 12
RE: not showing replays - 1/12/2019 3:21:09 PM   
dave123

 

Posts: 96
Score: 0
Joined: 7/14/2016
Status: offline
I've found that if i see the first replay, the rest of the game will work.

Any chance that something about the initial turn is the problem?

(in reply to dave123)
Post #: 13
RE: not showing replays - 1/12/2019 6:20:27 PM   
Hubert Cater

 

Posts: 3341
Score: 2
Joined: 7/22/2013
Status: online
The folder is a hidden folder by Windows, as the AppData is hidden by default, so that should not be an issue and you really wouldn't want it to be read only either as it needs to write to that folder. It could be something related to the first replay and I'm making some changes on my end that will ideally resolve it for those playing turns from one computer to another, and ideally this will resolve your issue as well.

_____________________________


(in reply to dave123)
Post #: 14
RE: not showing replays - 1/13/2019 8:27:16 AM   
Pocus


Posts: 998
Score: 0
Joined: 9/22/2004
Status: offline
An update also. If I have my login pre-entered in sc3.ini, then I won't get the replay, **even** on my main computer (which has the replay usually). If I input by hand (each time, a bit cumbersome) my login, then my main computer proposes me a replay.

Is that too linked to file size and delay etc. ?

_____________________________

AGEOD Team - Lead Developer
Makers of Empires, ACW2, EAW, WIA, WON

(in reply to Hubert Cater)
Post #: 15
RE: not showing replays - 1/14/2019 7:59:58 PM   
Hubert Cater

 

Posts: 3341
Score: 2
Joined: 7/22/2013
Status: online
There is another issue I've found that I believe will resolve this oddity as well.

_____________________________


(in reply to Pocus)
Post #: 16
RE: not showing replays - 1/17/2019 3:38:32 PM   
dave123

 

Posts: 96
Score: 0
Joined: 7/14/2016
Status: offline
Thanx.

eagerly awaiting a fix so i can play again.

i think i'm also getting some weird happenings when it does work. example, i ran into a german 4 strength paratrooper on the first turn of an MP game. it was an ambush and he
popped up where i would have expected an army to be in poland.

(in reply to Hubert Cater)
Post #: 17
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Strategic Command Series >> Strategic Command WWII: World at War >> Tech Support >> not showing replays Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.207