Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[RE-FIXED B1009.27.5] Submarine depth issue

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [RE-FIXED B1009.27.5] Submarine depth issue Page: [1]
Login
Message << Older Topic   Newer Topic >>
[RE-FIXED B1009.27.5] Submarine depth issue - 9/14/2018 5:03:48 PM   
Amnectrus

 

Posts: 80
Joined: 10/22/2015
Status: offline
I ran into a possible problem when trying to test dipping sonar behavior (some of this cross-posted from here):

Submarines don't seem to hold their depth when they're on a different side than you. Test scenario is attached, it's just two sides, Red and Blue, with a single Blue sub. Set the depth of the Blue sub to something other than Just Over The Layer, and it'll go to that depth. Then switch to Red side and watch in God mode as the sub goes to just over the layer. Then switch back to Blue side and the sub goes back to whatever depth it's set to.

This seems to happen with both a manual depth setting and with the Depth Presets. The sub has no mission set, just a waypoint and a manual speed of 10 kts, and the doctrines and WRA are all at their defaults. However if you make an ASW mission and assign the sub to the mission, the same issue occurs where the sub only respects the assigned depth if you're on the same side; as soon as you switch sides it goes to "ASW behavior" where it alternates above and below the layer.

I'm also seeing the depth fluctuation problem others have reported (recently mentioned here), where the depth seems to constantly vary by +/- 1 ft.

Using Steam version on Windows 7, v1.14 Build 998.10. Please let me know if you need any other info.

Attachment (1)

< Message edited by Dimitris -- 3/22/2019 9:54:53 AM >
Post #: 1
RE: Submarine depth issue - 9/14/2018 5:16:57 PM   
Dimitris

 

Posts: 13127
Joined: 7/31/2005
Status: offline
Thank you for the report.

I think we have fixed the depth oscillation issue for good, and the fix will be included on the next public update, to be released soon.

_____________________________


(in reply to Amnectrus)
Post #: 2
RE: Submarine depth issue - 9/16/2018 12:13:23 AM   
magi

 

Posts: 1529
Joined: 2/1/2014
Status: offline

quote:

ORIGINAL: Dimitris

Thank you for the report.

I think we have fixed the depth oscillation issue for good, and the fix will be included on the next public update, to be released soon.


oh thats good news.... ive been having a problem with this issue.. but it seem intermittent....

(in reply to Dimitris)
Post #: 3
RE: Submarine depth issue - 9/16/2018 10:10:36 PM   
LMychajluk

 

Posts: 124
Joined: 10/8/2017
Status: offline
While on the subject, can you have it so that the depth, when set manually, is always entered as a negative number. I tried to set my sub's depth at 300 the other day (sorry, no save), and it went straight to the surface and tried to take off.

On a side note, add the SeaView and the Flying Sub to the hypothetical database. ;)

(in reply to magi)
Post #: 4
RE: Submarine depth issue - 9/16/2018 11:54:35 PM   
DWReese

 

Posts: 1728
Joined: 3/21/2014
Status: offline
What Amnectrus said is exactly accurate. By switching back and forth it seems that as soon as the computer AI is in charge of the sub it will automatically send it to a depth just over the layer. I spent several hours yesterday testing this. I was going to report it, but then I just saw that Amnectrus beat me to it.

Doug

(in reply to Dimitris)
Post #: 5
RE: Submarine depth issue - 9/19/2018 8:22:45 AM   
Dimitris

 

Posts: 13127
Joined: 7/31/2005
Status: offline
quote:

ORIGINAL: Amnectrus
I ran into a possible problem when trying to test dipping sonar behavior (some of this cross-posted from here):

Submarines don't seem to hold their depth when they're on a different side than you. Test scenario is attached, it's just two sides, Red and Blue, with a single Blue sub. Set the depth of the Blue sub to something other than Just Over The Layer, and it'll go to that depth. Then switch to Red side and watch in God mode as the sub goes to just over the layer. Then switch back to Blue side and the sub goes back to whatever depth it's set to.

This seems to happen with both a manual depth setting and with the Depth Presets. The sub has no mission set, just a waypoint and a manual speed of 10 kts, and the doctrines and WRA are all at their defaults. However if you make an ASW mission and assign the sub to the mission, the same issue occurs where the sub only respects the assigned depth if you're on the same side; as soon as you switch sides it goes to "ASW behavior" where it alternates above and below the layer.


Confirmed. This is a side-effect of the fix applied to this issue: http://www.matrixgames.com/forums/tm.asp?m=4504419

We are looking to see if we can fix the original issue in a different way, to avoid this repercussion.

_____________________________


(in reply to Amnectrus)
Post #: 6
RE: Submarine depth issue - 9/19/2018 11:56:08 AM   
Dimitris

 

Posts: 13127
Joined: 7/31/2005
Status: offline
Fixed, by reversing the change made to resolve this issue: http://www.matrixgames.com/forums/tm.asp?m=4504419

_____________________________


(in reply to Dimitris)
Post #: 7
RE: Submarine depth issue - 9/19/2018 7:44:01 PM   
magi

 

Posts: 1529
Joined: 2/1/2014
Status: offline

quote:

ORIGINAL: Dimitris

Fixed, by reversing the change made to resolve this issue: http://www.matrixgames.com/forums/tm.asp?m=4504419


oh... thats cool... thanks...

(in reply to Dimitris)
Post #: 8
RE: Submarine depth issue - 3/21/2019 4:38:20 PM   
TyphoonFr

 

Posts: 136
Joined: 11/23/2017
From: FRA
Status: offline
quote:

here):

Submarines don't seem to hold their depth when they're on a different side than you. Test scenario is attached, it's just two sides, Red and Blue, with a single Blue sub. Set the depth of the Blue sub to something other than Just Over The Layer, and it'll go to that depth. Then switch to Red side and watch in God mode as the sub goes to just over the layer. Then switch back to Blue side and the sub goes back to whatever depth it's set to.

This seems to happen with both a manual depth setting and with the Depth Presets. The sub has no mission set, just a waypoint and a manual speed of 10 kts, and the doctrines and WRA are all at their defaults. However if you make an ASW mission and assign the sub to the mission, the same issue occurs where the sub only respects the assigned depth if you're on the same side; as soon as you switch sides it goes to "ASW behavior" where it alternates above and below the layer.


This problem has reappeared with version 1.15.1 (build1009.27.3)

In the Tuturial 2.1 Submarine, the Han does not maintain its manually assigned depth of -984ft and rises to -348ft.
This makes it impossible to detect if you follow the instructions of the tutorial.

Attachment (1)

_____________________________

Christophe

To all English teachers of the forum, sorry if English is not my mother language.

(in reply to magi)
Post #: 9
RE: Submarine depth issue - 3/22/2019 9:54:37 AM   
Dimitris

 

Posts: 13127
Joined: 7/31/2005
Status: offline
Thanks! Re-fixed for the next release.

_____________________________


(in reply to TyphoonFr)
Post #: 10
RE: Submarine depth issue - 3/30/2019 9:25:46 AM   
Zathred

 

Posts: 66
Joined: 7/5/2018
Status: offline
Have you a planned release date for this fix? I'm concentrating on the Silent Service scenarios and my own sub/ASW creations. The non-player submarine depth bug is a fundamental defect that pretty much invalidates any game play at present. An update would be appreciated

(in reply to Dimitris)
Post #: 11
RE: Submarine depth issue - 3/30/2019 9:49:24 AM   
Dimitris

 

Posts: 13127
Joined: 7/31/2005
Status: offline
Coming very soon.

_____________________________


(in reply to Zathred)
Post #: 12
RE: Submarine depth issue - 3/30/2019 10:25:27 AM   
Dimitris

 

Posts: 13127
Joined: 7/31/2005
Status: offline
Get it here if you're in a hurry: http://www.matrixgames.com/forums/tm.asp?m=4612898


_____________________________


(in reply to Dimitris)
Post #: 13
RE: Submarine depth issue - 3/30/2019 1:41:51 PM   
Zathred

 

Posts: 66
Joined: 7/5/2018
Status: offline
I have got it, I've patched my Steam installation, it's fixed

Thank you

(in reply to Dimitris)
Post #: 14
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [RE-FIXED B1009.27.5] Submarine depth issue Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.336