Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Bug List. Let me know if I missed any.

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [World War II] >> Steel Panthers World At War & Mega Campaigns >> Bug List. Let me know if I missed any. Page: [1]
Login
Message << Older Topic   Newer Topic >>
Bug List. Let me know if I missed any. - 6/12/2001 12:53:00 AM   
FrankyVas

 

Posts: 69
Joined: 6/28/2000
From: Northridge, CA,, USA
Status: offline
Here’s a list of the bugs (taken from the bug consolidation thread): :(General: Game often make this annoying screeching sound I found when pbem and you happen to have your troops use their assault boats. They continue to be loaded status but you can see the troops on the ground. I did have a Forward Observer disappear on me. Nowhere on the map but was able to use him to call in artillery. Does that make me a cheater? When you pick the "bulls eye" - e.g. "set direct fire target" - because you see some units but no units are within your firing range the game displays a line to the nearest victory hex. Sometimes, even if units are in your range it shows the line to the nearest victory as the first choice and no unit are in the hex. The MG teams will fire both the MG and the secondary weapon even with 1 crew. The 88mm flak bug seems to be related to the 'heavy flak' class. I did a small test with US and Soviet heavy flak guns and they all had shots available immediately after unloading them from transport. Bazooka teams that use HE ammo as HEAT (and have that max penetration) Units classified as light infantry can't initiate melee combat. Both my friend and I have 4 network adapters installed under microsoft networking. Because of this, both versions of steel cannot find the internet connected adapter. This makes it impossible for us to play Spwaw over the internet. Is there a workaround to force steel to use a user-defined network adapter? Have to start game, set prefs, then exit game, then, restart to get any air sections. at least I think thats how, not even really sure. They keep resetting to 0 after evrygame. The game change randomly the # of turns you set. Problems(impossibility) to choose a custom map to play pbem; it works with random ones instead "SAVE GAME FAILED TO LOAD" OR THE "REC FILE NON UPDATED" BUG This is the most devastating one, cause it gives you no other choice than to clear the slot and start again(what about if this happens at the last turn? I don’t want imagine that!) STRANGE TARGETING units suddenly keep targeting the up left corner of the map or enemy victory hexes.... Prevent the receiving party of an air strike seeing the opposing player's troops. Vehicles immobilized in the editor often get fixed at the start of the scenario. There's a bug with setting artillery and spec ops target hexes. To see what I mean, select the first scenario "The Agony of Doom", go to unit U0 and press "B", set the first mortars target. When you set the second unit's target somewhere else, the first target is moved there too. With C&C on, clicking on each recon unit for the first time does not display the movement range correctly. Fix vehicle crews being added automatically to kill score (if you kill them, they are counted twice). When the unit's side does not surrender, the crew is added twice (if you kill them, they are counted three times). Unit availability is re-randomized every time you enter reinforcement purchase screen and is not carried over from the initial purchase phase. Shouldn't there be an asterisk setting in the preferences? Bomb strike with Fast Arty off only displays the first bombed hex, then the screen jumps to your troops while the other bombs fall. With Fast Arty on it doesn't show anything, only plays 1/4 second of the bombing sound effect. When it is my turn and I fire one unit against the enemy, the system says "special ops fire". It's impossible to be op/overwatch fire because it's my turn. Stacking limits on bridges don’t seem to be enforced. I had 5 PzIVe's on one wooden bridge hex. Manual says there should be a limit. I suffered a "override security warning ? (Y/N)" on a secure PBEM game each turn I was starting Scroll delay seems to be ignored during deploy. This makes deploying impossible without zoom-out -function on faster machines. Tank corpses sometimes disappear during online game. Not serious, but makes the game feel less reliable. Enemy infantry advanced and armor did not, even though thirteen turns passed before I was declared winner. :(Campaigns: The computer had purchased something like 20+ infantry Platoon HQs in the long campaign. I've noticed problems with all the opponents in the early war in the German long war campaign. The Poles had masses of infantry guns, ATGs, and a few 75s all within 5 hexes of their board edge. The French put a couple of companies of infantry there. Playing the Normandy Gold campaign, in the second or third battle an off board naval artillery battery was useless as it was armed with 4 machine guns. Don't know if this is a problem with the British oob or just a glitch in the setup of the campaign battle. When playing Italy vs. Greece in late 1940/early 1941, the battle location is desert. In ver. 4.5 it was correctly mountains. The campaign screen where you change/update your units is way too unforgiving and has a few flaws apart from that. If you change one unit, there's no going back, so I you by mistake happen to change your sherman into a truck you'll be sorry. Also I think that you should be able to bring new units into your 'core force' instead of just upgrading/changing. Othwerwise, players that use their last 50 points to buy a platoon of cheap units like trucks when building up their 'core force' will have an advantage by doing this since they can upgrade those trucks to tanks, making a new tank platoon. If you're pleased with your force and find no need to upgrade any units, then you should be able to bring new units onto the battlefield. When you build up your force for a campaign, I've noticed that sometimes only one unit will appear in the units listing after you purchased a platoon, for example, even if you have enough points. Also when the units sometimes turn red in the listing after you buy them (I suppose this is because of shortage of units), they will not go back to white if you return the units that you bought. I'm not really familiar with the changes to the units purchase system yet so please forgive me if I'm wrong. :(OOB: Ski troops show a twelve man roster yet they are depicted as "Ski Inf x 1". In the US Marine OOB there is a machine gun unit that is depicted by a truck icon on the game hexboard. In the upgrade screen for the Germans there is a Coastal Gun avaiable for upgrade. I'd love to upgrade my sniper but the Coastal Gun doesn't move to well. A lot of the Italian OOB's pictures are screwy. Most of their aircraft pictures show tanks or infantry. Some of the planes show up in the 75mm guns. The units listings in the encyclopedia and unit change/upgrade lists are way to unorganized apart from the 'force composition screen'. Also there something bizarre about infantry units numbered 135-140 in Finnish OOB. They have ROF 6. Pretty much every other infantry unit have ROF 9. Also, in the Norwegian OOB, the destroyer's picture shows some weird tank with a big gun.

_____________________________

Post #: 1
- 6/12/2001 4:31:00 AM   
Paul Vebber


Posts: 11430
Joined: 3/29/2000
From: Portsmouth RI
Status: offline
Thanks Franky!

_____________________________


(in reply to FrankyVas)
Post #: 2
- 6/12/2001 8:20:00 AM   
Alby


Posts: 4855
Joined: 4/29/2000
From: Greenwood, Indiana
Status: offline
IN online Play, evening after sending someone your OOBs, you still get OOB error messages, There were 3 of us Myself, Steelbart and Another named matt. I can play Bart, matt can play Bart, but when Matt and I tryed we Get "error OOB__ Different". On another Topic: Is there no way to have a sound for "fAST ARTY "on? And make it a bit slower? I normally play with it off, but some of these guys buy 70% arty and sitting thru all that Barrage takes forever. With fast arty on, you can Barely see whats happened, if at all. Would "live delay" affect this? Thanks :) [ June 11, 2001: Message edited by: Alby ]

_____________________________



(in reply to FrankyVas)
Post #: 3
- 6/13/2001 5:26:00 AM   
FrankyVas

 

Posts: 69
Joined: 6/28/2000
From: Northridge, CA,, USA
Status: offline
Back to the top

_____________________________


(in reply to FrankyVas)
Post #: 4
- 6/13/2001 7:20:00 AM   
Alby


Posts: 4855
Joined: 4/29/2000
From: Greenwood, Indiana
Status: offline
And up again ;)

_____________________________



(in reply to FrankyVas)
Post #: 5
- 6/13/2001 8:07:00 AM   
troopie

 

Posts: 997
Joined: 4/8/2000
From: Directly above the centre of the Earth.
Status: offline
1: Rubber boats do not lose movement points when they move. 2: I loaded an 8 man Marine section on a rubber boat. When they off loaded, after crossing a lake at night and never encountering any enemy, two men offloaded. Unit info screen indicated no damage. troopie

_____________________________

Pamwe Chete

(in reply to FrankyVas)
Post #: 6
- 6/13/2001 10:26:00 AM   
deggo

 

Posts: 38
Joined: 5/9/2000
From: Lewiston, Idaho
Status: offline
I had all of my German reinforcements arrive in a PBEM game with their range set to zero. In anther PBEM game every unit I owned, that hadn't moved, dissapeared after I requested reinforcements. I couldn't see them but was able to use them normally to finish the turn. I just had to cycle through every unit to check and finish the move. They were back to normal on my next turn. Scott

_____________________________

Scott

(in reply to FrankyVas)
Post #: 7
- 6/13/2001 2:25:00 PM   
Resisti


Posts: 1351
Joined: 1/22/2001
From: Livorno, Italy
Status: offline
quote:

Originally posted by deggo: I had all of my German reinforcements arrive in a PBEM game with their range set to zero. In anther PBEM game every unit I owned, that hadn't moved, dissapeared after I requested reinforcements. I couldn't see them but was able to use them normally to finish the turn. I just had to cycle through every unit to check and finish the move. They were back to normal on my next turn. Scott
I had both similar problems,too. As for the units disappearing,Matrix stated that it's something limited to pregame deployment phase(which was my case,infact): what I mean is this happened before first turn started,I deployed then entered the reinf.menu,looked at the map,bought reinf., then when back to the map,puf!,everything was disappeared. Solution suggested by Matrix:dont do that,it shouldnt be the case for people asking for reinf.before the game start!

_____________________________

Federico "Resisti" Doveri

(in reply to FrankyVas)
Post #: 8
- 6/13/2001 3:18:00 PM   
WanhaPatu

 

Posts: 33
Joined: 9/22/2000
From: Finland
Status: offline
I don't know if there is something wrong with my computers / network but it is impossible for me to play 5.01 on LAN. Way too many bugs. We even had different maps last time we tried to play it!-( But, here are some bugs I've discovered when playing WW2 campaign: - When unit (tank) is buttoned, pressing 'F' doesn't do anything. I have to select target everytime I want to shoot at it. - Graphics doesn't get updated when Alt-O or Alt-M (movement range, shots etc doesn't change the way they should). - When I try to overrun, game very often says "There are no enemy infantry in this hex to overrun" even though I am 100% sure there is! - When I use shift in deploy to put two units into same hex, the game doesn't select next unit as it normally does (when shift is not used). - Sometimes abandoned mortars & ATG's seem to have crew even though they do not. It seems the game shows the icon with the crew even though it should show the one without it.

_____________________________


(in reply to FrankyVas)
Post #: 9
- 6/13/2001 8:30:00 PM   
Larry Holt

 

Posts: 1969
Joined: 3/31/2000
From: Atlanta, GA 30068
Status: offline
Sometimes extra crew show up. I had a case where a halftrack was damaged and the crew bailed on their own. Later, the halftrack was operational,as if the crew had reoccupied it but the crew was still as a seperate unit. I know that there was no mixup in units as the vechicle was w1 and the crew w51 or something like that. Upon refitting between battles, the extra crew disappeared. I remember someone else mentioning this a long time ago (probably under 5.0 instead of 5.01 that I have)

_____________________________

Never take counsel of your fears.

(in reply to FrankyVas)
Post #: 10
- 6/13/2001 10:50:00 PM   
Warrior


Posts: 1808
Joined: 11/2/2000
From: West Palm Beach, FL USA
Status: offline
Recently noticed some German tanks do not have penetration values. (Designed scenario for self-play against AI, not a campaign)

_____________________________

Retreat is NOT an option.



(in reply to FrankyVas)
Post #: 11
- 6/13/2001 11:53:00 PM   
Peregrine Falcon

 

Posts: 165
Joined: 9/8/2000
From: Finland
Status: offline
REALLY low 'range'-setting in the beginning of the battle, for all or most units (during deploy) Why this doesn't seem to affect other SPWAW-gamers? I haven't seen any other mention this particular bug..... :( Anyone? [ June 13, 2001: Message edited by: Peregrine Falcon ]

_____________________________

--Peregrine Falcon--

(in reply to FrankyVas)
Post #: 12
- 6/14/2001 4:03:00 AM   
Resisti


Posts: 1351
Joined: 1/22/2001
From: Livorno, Italy
Status: offline
quote:

Originally posted by Peregrine Falcon: REALLY low 'range'-setting in the beginning of the battle, for all or most units (during deploy) Why this doesn't seem to affect other SPWAW-gamers? I haven't seen any other mention this particular bug..... :( Anyone?
Me,too. If I remember well,this was happening in 4.5,too,mainly in some designed campaigns. So maybe people it's not mentioning it cause they're becoming accustomed to this problem;nevertheless it's really annoying having to check and reset most of the fire range in each game..

_____________________________

Federico "Resisti" Doveri

(in reply to FrankyVas)
Post #: 13
- 6/14/2001 6:47:00 AM   
Antonius

 

Posts: 209
Joined: 6/6/2000
From: Saint Arnoult en Yvelines FRANCE
Status: offline
quote:

Originally posted by Peregrine Falcon: REALLY low 'range'-setting in the beginning of the battle, for all or most units (during deploy) Why this doesn't seem to affect other SPWAW-gamers? I haven't seen any other mention this particular bug..... :( Anyone? [ June 13, 2001: Message edited by: Peregrine Falcon ]
I have always considered this to be a normal feature and even a good one: I usually check all initial ranges but change only a few. And it's a good thing the AI does not always open fire at max range since it would revealing its positions too early with poor shots.

_____________________________

Wargamo, ergo sum

(in reply to FrankyVas)
Post #: 14
- 6/14/2001 7:03:00 AM   
Antonius

 

Posts: 209
Joined: 6/6/2000
From: Saint Arnoult en Yvelines FRANCE
Status: offline
I have a new one: While playing the "long,long, road to victory" campaign (brolo scen) I suddenly felt most of my units had disappeared from the map. Then I realized that I saw much more AI units than before and that in fact I was watching the AI's turn as if I was playing the AI's side, seing all its units while I saw mine only if the AI had spotted them. This bug seems permanent once it has happened as this went on in subsequent turns. And the bug is saved along with the game as exiting and re-loading did not help. I had a back-up file which enabled me to resume the battle at an earlier and bug-free stage. Will let you know if it happens again.

_____________________________

Wargamo, ergo sum

(in reply to FrankyVas)
Post #: 15
- 6/14/2001 7:05:00 AM   
panda124c

 

Posts: 1692
Joined: 5/23/2000
From: Houston, TX, USA
Status: offline
quote:

Originally posted by Antonius: I have always considered this to be a normal feature and even a good one: I usually check all initial ranges but change only a few. And it's a good thing the AI does not always open fire at max range since it would revealing its positions too early with poor shots.
If you are playing a campain the ranges retain their settings from the previous game. If you buy new or replace existing I have only seen the new units have their ranges set to some value example a tank has it's range set to 40 but I've seen JpzI's set to 7. I don't pay to much attention to the range setting since I go through all units on turn one and set their ranges like I want them.

_____________________________


(in reply to FrankyVas)
Post #: 16
- 6/14/2001 7:10:00 AM   
panda124c

 

Posts: 1692
Joined: 5/23/2000
From: Houston, TX, USA
Status: offline
One other thing that I have seen is the ammo limits are strange. We have unlinited Ammo, limited ammo, and I believe reduced ammo. I play with reduced ammo on the first time I buy a unit it has reduced ammo. But the next game (campain) the ammo is maxed out. I noticed this with the 28mm FJ, the first game after I pruchased it it had 4 rounds of ammo (to few may be a problem with rarity) the next game and every game after that it had 40 rounds.

_____________________________


(in reply to FrankyVas)
Post #: 17
- 6/14/2001 3:23:00 PM   
Antonius

 

Posts: 209
Joined: 6/6/2000
From: Saint Arnoult en Yvelines FRANCE
Status: offline
quote:

Originally posted by Antonius: I have a new one: While playing the "long,long, road to victory" campaign (brolo scen) I suddenly felt most of my units had disappeared from the map. Then I realized that I saw much more AI units than before and that in fact I was watching the AI's turn as if I was playing the AI's side, seing all its units while I saw mine only if the AI had spotted them. This bug seems permanent once it has happened as this went on in subsequent turns. And the bug is saved along with the game as exiting and re-loading did not help. I had a back-up file which enabled me to resume the battle at an earlier and bug-free stage. Will let you know if it happens again.
Well this happened to me again but this time I think I know "why": because I had just been playing a PBEM game, didn't go back to the main menu to select solitary gaming and loaded my saved campaign directly from the PBEM "load save " screen. I have been able to make it voluntarily happen again (by resuming play from the PBEM menu) in another "designer" campaign but not in a WWII random campaign. [ June 14, 2001: Message edited by: Antonius ]

_____________________________

Wargamo, ergo sum

(in reply to FrankyVas)
Post #: 18
- 6/15/2001 2:02:00 AM   
Peregrine Falcon

 

Posts: 165
Joined: 9/8/2000
From: Finland
Status: offline
quote:

Originally posted by Resisti: Me,too. If I remember well,this was happening in 4.5,too,mainly in some designed campaigns. So maybe people it's not mentioning it cause they're becoming accustomed to this problem;nevertheless it's really annoying having to check and reset most of the fire range in each game..
This occured in 4.5 as well...? I have never seen this happen in previous versions of SPWAW, only in 5.0 & 5.01. And I'm pretty sure about it. There is nothing worse than 3-5 large rifle companies, all have their range set to 1 :(

_____________________________

--Peregrine Falcon--

(in reply to FrankyVas)
Post #: 19
- 6/15/2001 4:19:00 AM   
BlitzSS

 

Posts: 253
Joined: 10/24/2000
From: wasChicagoLand, now DC
Status: offline
During PBEM I noticed on many occasions when an AFV took a hit the bailing out crew would become a HT icon until the shooting stoped??

_____________________________

"Nuts"

(in reply to FrankyVas)
Post #: 20
- 6/18/2001 10:41:00 PM   
FrankyVas

 

Posts: 69
Joined: 6/28/2000
From: Northridge, CA,, USA
Status: offline
bump

_____________________________


(in reply to FrankyVas)
Post #: 21
- 6/19/2001 7:54:00 AM   
Alby


Posts: 4855
Joined: 4/29/2000
From: Greenwood, Indiana
Status: offline
Online game in buy screen Sometimes Your units will not show up when you purchase them, unless you click on another formation(I>E> med tank plt, arty battery, ect ect), then once you go back to main menu (I.E. misc, armor, arty ect ect.) They vanish again. When this occurs you will also lose your HQ unit, It will not be in your unit list, and you will not have it when you go to deploy map.

_____________________________



(in reply to FrankyVas)
Post #: 22
- 6/19/2001 6:03:00 PM   
Kharan

 

Posts: 505
Joined: 5/9/2000
Status: offline
You missed one important thing that I think should be high in the priority list (since it apparently happens with a 100% certainty): Reinforcement and retreat flags are left out in generated battles with a custom map. ( http://www.matrixgames.com/cgi-bin/ultimatebb.cgi?ubb=get_topic&f=2&t=004057 )

_____________________________


(in reply to FrankyVas)
Post #: 23
- 6/20/2001 5:35:00 AM   
Antonius

 

Posts: 209
Joined: 6/6/2000
From: Saint Arnoult en Yvelines FRANCE
Status: offline
quote:

Originally posted by Alby: Online game in buy screen Sometimes Your units will not show up when you purchase them, unless you click on another formation(I>E> med tank plt, arty battery, ect ect), then once you go back to main menu (I.E. misc, armor, arty ect ect.) They vanish again. When this occurs you will also lose your HQ unit, It will not be in your unit list, and you will not have it when you go to deploy map.
I have seen this happen in a 2 vs 1 game

_____________________________

Wargamo, ergo sum

(in reply to FrankyVas)
Post #: 24
- 6/20/2001 5:36:00 AM   
Antonius

 

Posts: 209
Joined: 6/6/2000
From: Saint Arnoult en Yvelines FRANCE
Status: offline
quote:

Originally posted by Kharan: You missed one important thing that I think should be high in the priority list (since it apparently happens with a 100% certainty): Reinforcement and retreat flags are left out in generated battles with a custom map. ( http://www.matrixgames.com/cgi-bin/ultimatebb.cgi?ubb=get_topic=2=004057 )
not 100 % certainty since some of my games with customs maps did work. But certainly all too often :-(

_____________________________

Wargamo, ergo sum

(in reply to FrankyVas)
Post #: 25
- 6/20/2001 5:37:00 AM   
Antonius

 

Posts: 209
Joined: 6/6/2000
From: Saint Arnoult en Yvelines FRANCE
Status: offline
quote:

Originally posted by Kharan: You missed one important thing that I think should be high in the priority list (since it apparently happens with a 100% certainty): Reinforcement and retreat flags are left out in generated battles with a custom map. ( http://www.matrixgames.com/cgi-bin/ultimatebb.cgi?ubb=get_topic=2=004057 )
not 100 % certainty since some of my games with customs maps did work. But certainly all too often :-(

_____________________________

Wargamo, ergo sum

(in reply to FrankyVas)
Post #: 26
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [World War II] >> Steel Panthers World At War & Mega Campaigns >> Bug List. Let me know if I missed any. Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.277