Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Win10 desktop bleeds thru?

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Win10 desktop bleeds thru? Page: [1]
Login
Message << Older Topic   Newer Topic >>
Win10 desktop bleeds thru? - 4/30/2018 12:27:24 PM   
m10bob


Posts: 8622
Joined: 11/3/2002
From: Dismal Seepage Indiana
Status: offline
Ever since I was forced to acquire win10 I have been able to get the game playing perfect, (thanks to the great "switch" comments provided by our friends here in the forums.

My issue is that with Win10, ever so often the "desktop" bleeds thru the game map ever so often.

I admit I am also running other programs in the background, but this has never been an issue with Win7,and all other OS's before that.

I'm using pretty much the same HP as ever, same general strengths as ever, loads of RAM, memory, etc.

Eventually, the game map does return, but the "bleed thru" is just as annoying as it sounds and kills the mood in a big way..


Help and ideas are greatly appreciated...

Here are the commands I use...and they completely cured any "speed" issues the game had with Win10...



"C:\RHS\War in the Pacific Admiral's Edition\War in the Pacific Admiral Edition.exe" -altFont -archive -deepColor -SingleCpuOrders -dd_sw

< Message edited by m10bob -- 4/30/2018 12:45:25 PM >


_____________________________



Post #: 1
RE: Win10 desktop bleeds thru? - 4/30/2018 1:15:27 PM   
Admiral DadMan


Posts: 3526
Joined: 2/22/2002
From: A Lion uses all its might to catch a Rabbit
Status: offline
I have found that taking out the -dd_sw switch stops the bleed through

_____________________________

Scenario 127: "Scraps of Paper"
(\../)
(O.o)
(> <)

CVB Langley:

(in reply to m10bob)
Post #: 2
RE: Win10 desktop bleeds thru? - 4/30/2018 1:20:36 PM   
btd64


Posts: 5950
Joined: 1/23/2010
From: Mass. USA. now in OHIO
Status: offline
I second that motion....GP

_____________________________

Intel i7 3.4GHz,8GB Ram,1920x1080 rez

AKA General Patton

WPO,WITP,WITPAE-Mod Designer/Tester
DW Series-Beta Tester
TOAW4-Alpha/Beta Tester

I don't like paying for the same real estate twice..Gen. George S. Patton

(in reply to Admiral DadMan)
Post #: 3
RE: Win10 desktop bleeds thru? - 4/30/2018 2:14:23 PM   
m10bob


Posts: 8622
Joined: 11/3/2002
From: Dismal Seepage Indiana
Status: offline

quote:

ORIGINAL: Admiral DadMan

I have found that taking out the -dd_sw switch stops the bleed through



Admiral!!!...I will try this...It is sure not the first time you have jumped to help me!!

maybe one day...and that day may never come....I will be able to help you in some way....(Apologies to "Don" Corleone, lol)

_____________________________




(in reply to Admiral DadMan)
Post #: 4
RE: Win10 desktop bleeds thru? - 4/30/2018 7:33:28 PM   
m10bob


Posts: 8622
Joined: 11/3/2002
From: Dismal Seepage Indiana
Status: offline

quote:

ORIGINAL: Admiral DadMan

I have found that taking out the -dd_sw switch stops the bleed through



This absolutely worked!!!

Thank you..

I have acquired a new issue in that it has slowed the game order giving process, (even with game scroll set to zero.)

I have maintained the same command line as in my first post, except for having removed the -dd_sw command..

Is it possible to get any of the normal speed back by using a portion of those commands?

Obviously this is NOT a "deal breaker", lol

_____________________________




(in reply to Admiral DadMan)
Post #: 5
RE: Win10 desktop bleeds thru? - 5/1/2018 12:50:43 AM   
BBfanboy


Posts: 13132
Joined: 8/4/2010
From: Winnipeg, MB
Status: offline

quote:

ORIGINAL: m10bob


quote:

ORIGINAL: Admiral DadMan

I have found that taking out the -dd_sw switch stops the bleed through



This absolutely worked!!!

Thank you..

I have acquired a new issue in that it has slowed the game order giving process, (even with game scroll set to zero.)

I have maintained the same command line as in my first post, except for having removed the -dd_sw command..

Is it possible to get any of the normal speed back by using a portion of those commands?

Obviously this is NOT a "deal breaker", lol

I had the same problem on Win 7 (only affecting the night phase) until I added "-cpu2" to the switch string. This separates the game thread from the CPU1 which is running the Windows OS.

_____________________________

No matter how bad a situation is, you can always make it worse. - Chris Hadfield : An Astronaut's Guide To Life On Earth

(in reply to m10bob)
Post #: 6
RE: Win10 desktop bleeds thru? - 5/1/2018 12:51:40 AM   
USSAmerica


Posts: 17431
Joined: 10/28/2002
From: Chapel Hill, NC, USA
Status: online
From what I've gathered, the -dd_sw switch seems to fix the scrolling delay, but triggers the screen bleed through problem. The solution (work around) to that problem is to change from full screen to windowed mode. You can specify your screen size of the window to be almost the same as your full screen to eliminate the bleed through, keep almost the same screen area, and not run into the scrolling delay in game.

< Message edited by USSAmerica -- 7/24/2018 7:58:25 PM >


_____________________________

Mike

"Good times will set you free" - Jimmy Buffett

"They need more rum punch" - Me


Artwork by The Amazing Dixie

(in reply to m10bob)
Post #: 7
RE: Win10 desktop bleeds thru? - 5/2/2018 1:56:48 PM   
m10bob


Posts: 8622
Joined: 11/3/2002
From: Dismal Seepage Indiana
Status: offline
quote:

ORIGINAL: USSAmerica

From what I've gathered, the -dd_sw switch seems to fix the scrolling delay, but triggers the screen bleed through problem. The solution work around) to that problem is to change from full screen to windowed mode. You can specify your screen size of the window to be almost the same as your full screen to eliminate the bleed through, keep almost the same screen area, and not run into the scrolling delay in game.



Our friend Oliver Heindorf suggested this switch and by golly it runs PERFECT on my machine!!!

Just copy'pasted it to the end of the shortcut properties .exe line...( -cpu3 -dd_sw -deepColor -px1920 -py1080 )

< Message edited by m10bob -- 5/2/2018 2:02:47 PM >


_____________________________




(in reply to USSAmerica)
Post #: 8
RE: Win10 desktop bleeds thru? - 5/8/2018 3:25:10 PM   
m10bob


Posts: 8622
Joined: 11/3/2002
From: Dismal Seepage Indiana
Status: offline
UPDATE...Okay...Have now tried a few things you folks were kind enough to share...and while they seemed to work...they don't...I have got the speed back...but doggone it, the bleed thru is still happening...Much research on the subject and according to the geeks on youtube, Microsoft has admitted Win10 has messed up a LOT of games...and they claim it IS the fault of Win10.
Further, they claim some of it was caused by their decision to incorporate XBox settigs into the mix, (as if all gamers played only those games!)
Win10 comes with Xbox settings "ON" as the default so I took the advice to turn them all off...which did not really make a difference, but they claim it was like having two apps open at once to do the same thing.

Back to trying other things, but with the knowledge I (so far) know how to get rid of ALL bleed thru....OR how to have normal speed...So far, I just cannot have both...yet, lol

This is a work in progress for me and I will report any new findings, lol

_____________________________




(in reply to m10bob)
Post #: 9
RE: Win10 desktop bleeds thru? - 5/8/2018 3:35:57 PM   
zakblood


Posts: 22028
Joined: 10/4/2012
Status: online
my advice from almost a year ago was to disable it tbh, which is as simple as a few ticks in the boxes





i've offered generic windows 10 backwards compatibility help now since windows 10 came out, as a windows alpha / beta 10 tester, these are proven and also fully windows 10 approved, eg if you update windows 10, they stay on 99% of the time

http://www.matrixgames.com/forums/tm.asp?m=4454024

quote:

incorporate XBox settigs into the mix


once turned off, it's fine and doesn't load the modules either, so aren't no longer conflicting with anything either, same as all my advice, it's there to make older games better, while not spoiling new more modern games, which most of the time don't use what i've turned back on or altered back or turned off by default.

i don't have the game this forum relates to either, but if i did, i'd test it and do a guide same as i've done for almost all the game catalogue from the 3 forums / site boards etc

here's one of my test games, http://www.matrixgames.com/forums/tm.asp?m=4471477

Attachment (1)

< Message edited by zakblood -- 5/8/2018 3:45:09 PM >

(in reply to m10bob)
Post #: 10
RE: Win10 desktop bleeds thru? - 5/8/2018 4:37:25 PM   
m10bob


Posts: 8622
Joined: 11/3/2002
From: Dismal Seepage Indiana
Status: offline
Zakblood...You were months ahead of everybody else..
In my case however, Xbox settings do NOT seem to have any affect on WITP-AE atall, and I have them all turned "off"..

Following all the advice and instructions on this forum, it seems until Microsoft itself releases the next creators' version of Win10 addressing the gaming issue specifically, (they say August of 2018), the best option looks to be to run THIS game in the windows mode, if you are on Win10...

I have it working excellent now but my "best" resolution is only 1280 x 1024, which leaves a black border on all sides of the entry screens..
Once the map comes up, it is near full screen but the print is smaller than I would like.
How can I magnify this?...I know there is a way, lol

_____________________________




(in reply to zakblood)
Post #: 11
RE: Win10 desktop bleeds thru? - 5/8/2018 4:50:18 PM   
zakblood


Posts: 22028
Joined: 10/4/2012
Status: online
if the game supports higher, it can be done, if it can't and won't support higher, you can use the partially blind settings and increase it with magnifier

https://support.microsoft.com/en-gb/help/11542/windows-use-magnifier


or alter the DPI settings, but once altered in alters it for everything, so not idea either,

User DPI Setting: 120 DPI (125 percent)
System DPI Setting: 144 DPI (150 percent)
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Native Mode: 1920 x 1080(p) (60.000Hz)

these are mine custom ones for 1920 x 1080 which uses a slightly higher DPi to make more older games work better for me, but each users settings are there own and what works for one game doesn't always scale and work so well in another.

so depending on card used etc, you can use some tweaks to alter per game as follows,

https://windowsreport.com/indows-10-fullscreen-games/


which is solution 4, which works the best for me,...

< Message edited by zakblood -- 5/8/2018 4:51:00 PM >

(in reply to m10bob)
Post #: 12
RE: Win10 desktop bleeds thru? - 5/9/2018 3:28:43 PM   
m10bob


Posts: 8622
Joined: 11/3/2002
From: Dismal Seepage Indiana
Status: offline
I can purchase a stronger pair of "reading glasses" for five bucks,(lol), and this might be my next step..

Hopefully new folks will see this thread and understand that if an old-timer like me will go to these steps to keep playing the same game it was many years ago...it MUST be a truly fantastic game....and WE know it is!.

Proud plank-owner and still going strong...

_____________________________




(in reply to zakblood)
Post #: 13
RE: Win10 desktop bleeds thru? - 5/20/2018 2:55:20 AM   
blackcloud6


Posts: 435
Joined: 8/13/2002
Status: offline
Hi:

I just reloaded this game after a few years not playing it. And I did so on a newer machine than what I used to have. I followed the instructions to get a better resolution by making a short cut with this line in the target:

"C:\Matrix Games\War in the Pacific Admiral's Edition\War in the Pacific Admiral Edition.exe" -f -pxf1920 -pyf1080 -archive -deepColor -multiaudio -dd_sw -altFont

I too had desktop bleed through whenever mousing over a base or TF etc, or bringing up any info window. So reading this thread I added the -wd switch and then maximized the window and I get no bleed through whatsoever.

Thanks to all who have given suggestions.

(in reply to m10bob)
Post #: 14
RE: Win10 desktop bleeds thru? - 5/20/2018 1:54:19 PM   
Admiral DadMan


Posts: 3526
Joined: 2/22/2002
From: A Lion uses all its might to catch a Rabbit
Status: offline
quote:

ORIGINAL: blackcloud6

Hi:

I just reloaded this game after a few years not playing it. And I did so on a newer machine than what I used to have. I followed the instructions to get a better resolution by making a short cut with this line in the target:

"C:\Matrix Games\War in the Pacific Admiral's Edition\War in the Pacific Admiral Edition.exe" -f -pxf1920 -pyf1080 -archive -deepColor -multiaudio -dd_sw -altFont

I too had desktop bleed through whenever mousing over a base or TF etc, or bringing up any info window. So reading this thread I added the -wd switch and then maximized the window and I get no bleed through whatsoever.

Thanks to all who have given suggestions.

If you still have the "-f" in your command line, I would remove it. Many people think that it activates FullScreen. It does not.

Also, it was likely the "-dd_sw" command was giving you bleed through in FullScreen, but it can be helpful in Windowed Mode.

< Message edited by Admiral DadMan -- 5/20/2018 1:55:43 PM >


_____________________________

Scenario 127: "Scraps of Paper"
(\../)
(O.o)
(> <)

CVB Langley:

(in reply to blackcloud6)
Post #: 15
RE: Win10 desktop bleeds thru? - 5/20/2018 3:28:28 PM   
m10bob


Posts: 8622
Joined: 11/3/2002
From: Dismal Seepage Indiana
Status: offline
Not being an IT-kinda guy I have no idea why it makes the difference but as commented on several threads...going windows to play the game works ref the bleed thru, and the speed issues.
While the map print is a tad smaller, it does take up the full screen, (just with the usual windows borders top and bottom.)

_____________________________




(in reply to Admiral DadMan)
Post #: 16
RE: Win10 desktop bleeds thru? - 7/24/2018 7:08:33 PM   
tocaff


Posts: 4778
Joined: 10/12/2006
From: USA now in Brasil
Status: offline
As of today, 7/24/18, I got a rather large Win 10 update. The game no longer suffers from memory bleed or slow response to mouse clicks! Eureka!

_____________________________

Todd

I never thought that doing an AAR would be so time consuming and difficult.
www.matrixgames.com/forums/tm.asp?m=2080768

(in reply to m10bob)
Post #: 17
RE: Win10 desktop bleeds thru? - 7/25/2018 9:26:37 PM   
gmsitton

 

Posts: 43
Joined: 10/25/2012
Status: offline
My two cents.

I came back to the game recently and had the Win 10 speed issue. I read through a ton of threads about the problem and fixed it with the switches.

The -SingleCpuOrders orders switch, per the forum, is most effective on AMD CPUs. The -cpu switch is more effective on Intel CPUs, per the forum. I saw someone suggest using -cpu1. I think that's a bad move, use -cpu2 or -cpu3 instead.

There is a new feature for Win 10 for playing fullscreen games. It's called Focus Assist. You can use Cortana or a command box search to find it.

(in reply to tocaff)
Post #: 18
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Win10 desktop bleeds thru? Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.160