Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[From Beyond the Grave] Command won't start

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [From Beyond the Grave] Command won't start Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
[From Beyond the Grave] Command won't start - 2/26/2018 10:33:37 PM   
Crab

 

Posts: 6
Joined: 2/26/2018
Status: offline
Hey all, first time poster here.
I've had Command for about a year now, on Steam, and it's brilliant.
However I am currently unable to launch the programme, as of yesterday. The launcher window comes up and clicking on the icon to start Command results in the loading splash screenappearing, and then freezing and crashing after a message saying 'not responding'.
I have followed the advice in the threads above and have verified the installation via steam, have reinstalled DirectX, have run steam in Administrator mode, have uninstalled then reinstalled Command and have checked to see if the prerequisites are present.
They aren't in the 'PreRequisites' folder but they are inside other subfolders in the '_CommonRedist' folder. I have run the executables and still no change, the splash screen still ends up not responding and crashes.

When verifying the installation on steam after reinstalling, it says '1 file failed to validate and will be reacquired' but nothing happens and Command will still not run.

Is there anything else I should try?
Any suggestions, or is there anyone who this has happened to before and if so how was it fixed?

Thanks, and hello; pleased to meet you all.

Crab

< Message edited by apache85 -- 2/7/2020 6:45:22 AM >
Post #: 1
RE: Command won't start - 3/1/2018 5:02:40 PM   
RouquinMalin

 

Posts: 13
Joined: 11/14/2016
From: France
Status: offline
Good evening,
I'm french and me too command doesn't want to start but the issue/problem is different:
I bought CMANO via STEAM as well as all the DLC etc ... it always worked and today I bought The silent service.
I started the game and it worked (but I did not start a scenario) then I left to surf the internet.
I wanted to relaunch The Silent Service but when on the small home screen I click on "play game" a window asks me if I want to allow the program "command" to make changes to my pc, I click yes and then i have the message below ...
"it appears you are running command in steam mode, but the steam client does not appear to be running. please ensure the steam client is running before starting command. the game will now exist"
Who has a solution because I meet the same pb with other CMANO DLC, it's impossible to play? I do not understand because I am not disconnected from STEAM. What is steam mode and steam client?
thanks in advance

(in reply to Crab)
Post #: 2
RE: Command won't start - 3/1/2018 7:04:35 PM   
spartan21071

 

Posts: 14
Joined: 3/1/2018
Status: offline
RouquinMalin,

I am having the same issues after steam auto-updated today.

< Message edited by spartan21071 -- 3/1/2018 7:05:00 PM >

(in reply to RouquinMalin)
Post #: 3
RE: Command won't start - 3/1/2018 9:51:07 PM   
VPaulus

 

Posts: 3498
Joined: 6/23/2011
From: Portugal
Status: offline
If your Steam library folder is in "C:\Program Files (x86)\Steam\...", try uninstalling the game and reinstall it in a different Steam library folder, like for example "C:\New Steam\....".

For adding a new Steam library folder, please follow the steps below:
1. Open Steam Client
2. Click on "Steam" on the top left and click "Settings" on the drop down menu
3. Click on the "Downloads"
4. Click on "STEAM LIBRARY FOLDERS" button
5. Click on "ADD LIBRARY FOLDER"
6. Click on the Drive letter you wish to add a New Steam Library Folder
7. Click on "NEW FOLDER"
8. Choose a folder named (for example "New Steam") and Click on "OK" button
9. Click on "SELECT"
10. Click on "CLOSE"

Please check also this YouTube video:
https://www.youtube.com/watch?v=BqiVicULiNA

< Message edited by VPaulus -- 3/1/2018 9:52:52 PM >

(in reply to spartan21071)
Post #: 4
RE: Command won't start - 3/2/2018 12:53:12 AM   
Eggstor

 

Posts: 307
Joined: 1/24/2016
Status: offline
If your problem is the "Steam client does not appear to be running" one, Baloogan in the Steam-specific thread on this suggested running Steam as an administrator. That has worked for at least one person.

(in reply to VPaulus)
Post #: 5
RE: Command won't start - 3/2/2018 1:36:29 AM   
RoryAndersonWS


Posts: 1783
Joined: 6/16/2009
Status: offline

quote:

ORIGINAL: Eggstor

If your problem is the "Steam client does not appear to be running" one, Baloogan in the Steam-specific thread on this suggested running Steam as an administrator. That has worked for at least one person.



_____________________________


Command Developer, Warfare Sims.

(in reply to Eggstor)
Post #: 6
RE: Command won't start - 3/2/2018 11:07:44 AM   
RouquinMalin

 

Posts: 13
Joined: 11/14/2016
From: France
Status: offline
Hi,
I tried (run steam.exe as administrator) but it does not work: always the same problem...
uninstall everything (even my other games on steam like armaIII) then reinstall?
I am disappointed...

(in reply to RoryAndersonWS)
Post #: 7
RE: Command won't start - 3/2/2018 11:29:38 AM   
Dimitris


Posts: 12389
Joined: 7/31/2005
Status: online
Hi,

We are preparing a fix, it should be released soon. Please bear with us. Thanks!

_____________________________


(in reply to RouquinMalin)
Post #: 8
RE: Command won't start - 3/2/2018 12:26:03 PM   
Dimitris


Posts: 12389
Joined: 7/31/2005
Status: online
Have a look: http://steamcommunity.com/app/321410/discussions/0/1694914736000036995/

_____________________________


(in reply to Dimitris)
Post #: 9
RE: Command won't start - 3/2/2018 3:29:41 PM   
RouquinMalin

 

Posts: 13
Joined: 11/14/2016
From: France
Status: offline
quote:

We are preparing a fix, it should be released soon. Please bear with us. Thanks!


May the Force be with you !


< Message edited by RouquinMalin -- 3/2/2018 3:31:10 PM >

(in reply to Dimitris)
Post #: 10
RE: Command won't start - 3/3/2018 11:12:30 AM   
Dimitris


Posts: 12389
Joined: 7/31/2005
Status: online
Everyone who is still having this problem:

1) Download this file: https://drive.google.com/file/d/1tfeD_x5LBmd9hxi22REqMC0w1PLeae1b/view?usp=sharing

2) Drop it on the folder where CMANO is installed (same folder where Command.exe is located).

3) Run Command.

Please let us know if this works for you. Thanks!

_____________________________


(in reply to RouquinMalin)
Post #: 11
RE: Command won't start - 3/3/2018 12:50:32 PM   
RouquinMalin

 

Posts: 13
Joined: 11/14/2016
From: France
Status: offline
I have good news to announce: it works! a small file and I found my favorite game! Thanks !!!

(in reply to Dimitris)
Post #: 12
RE: Command won't start - 3/4/2018 1:23:47 PM   
Crab

 

Posts: 6
Joined: 2/26/2018
Status: offline
I have tried the above suggestions but none of these solutions have worked, as this is not the issue I am having nor is it why I started this thread.

Does anyone have a suggestion or a fix for my issue?

Command is failing to start, hangs at the loading screen and then crashes.
Running in Steam as an administrator does not work, running the game as administrator does not work, trying the public beta or compatibility mode does not work and dropping the file above on the install folder does not work.

Can anyone help with this?

(in reply to RouquinMalin)
Post #: 13
RE: Command won't start - 3/4/2018 1:37:13 PM   
Dimitris


Posts: 12389
Joined: 7/31/2005
Status: online

quote:

ORIGINAL: Crab

I have tried the above suggestions but none of these solutions have worked, as this is not the issue I am having nor is it why I started this thread.

Does anyone have a suggestion or a fix for my issue?

Command is failing to start, hangs at the loading screen and then crashes.
Running in Steam as an administrator does not work, running the game as administrator does not work, trying the public beta or compatibility mode does not work and dropping the file above on the install folder does not work.

Can anyone help with this?


Hi,

Can you check if there is any crash event generated on the Event Viewer?

_____________________________


(in reply to Crab)
Post #: 14
RE: Command won't start - 3/4/2018 4:34:05 PM   
Ergthorn

 

Posts: 4
Joined: 1/10/2016
Status: offline
I had the same issue but that little file solved this problem, Thank You

Buying CoW on steam was my worst decision, Shifting sands and Silent service I'll buy from your store like previous titles. It's sad I cannot download CoW from site Steam is good only as optional platform.

(in reply to Dimitris)
Post #: 15
RE: Command won't start - 3/4/2018 6:31:31 PM   
Crab

 

Posts: 6
Joined: 2/26/2018
Status: offline
There is, it describes this as 'Event 1002, Application Hang'.

The following text appears in the box below:

"The program Command.exe version 1.0.0.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 1e04
Start Time: 01d3b3eb76e34e9f
Termination Time: 4
Application Path: E:\SteamLibrary\steamapps\common\Command Modern Air Naval Operations\Command.exe
Report Id: d8b05dc0-e41b-469b-888e-fbfc2ff84416
Faulting package full name:
Faulting package-relative application ID: "

Thanks for your response, hope this helps.

(in reply to Dimitris)
Post #: 16
RE: Command won't start - 3/4/2018 6:35:16 PM   
Dimitris


Posts: 12389
Joined: 7/31/2005
Status: online
quote:

ORIGINAL: Crab

There is, it describes this as 'Event 1002, Application Hang'.

The following text appears in the box below:

"The program Command.exe version 1.0.0.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 1e04
Start Time: 01d3b3eb76e34e9f
Termination Time: 4
Application Path: E:\SteamLibrary\steamapps\common\Command Modern Air Naval Operations\Command.exe
Report Id: d8b05dc0-e41b-469b-888e-fbfc2ff84416
Faulting package full name:
Faulting package-relative application ID: "

Thanks for your response, hope this helps.


Right, can you try something else please: Uninstall Command from your E: drive and (assuming Steam is installed on your C: drive) re-install it on the C: drive, under Steam's own folder tree.

_____________________________


(in reply to Crab)
Post #: 17
RE: Command won't start - 3/5/2018 4:47:12 PM   
Crab

 

Posts: 6
Joined: 2/26/2018
Status: offline
Steam is installed on the E: Drive, and Command is installed inside the Steam folder tree.
I can try this anyway, but Command has already been uninstalled and reinstalled twice since this problem arose and this hasn't fixed the issue.

(in reply to Dimitris)
Post #: 18
RE: Command won't start - 3/6/2018 8:51:47 PM   
Crab

 

Posts: 6
Joined: 2/26/2018
Status: offline
Just to confirm, I have uninstalled Command and reinstalled to the C: drive. Unfortunately Command still fails to launch.
I'm at a loss for what to do next.

(in reply to Dimitris)
Post #: 19
RE: Command won't start - 3/7/2018 10:02:32 AM   
VPaulus

 

Posts: 3498
Joined: 6/23/2011
From: Portugal
Status: offline

quote:

ORIGINAL: Crab

Just to confirm, I have uninstalled Command and reinstalled to the C: drive. Unfortunately Command still fails to launch.
I'm at a loss for what to do next.

Have you tried to run, both the game and the Steam client, as administrators?

(in reply to Crab)
Post #: 20
RE: Command won't start - 3/17/2018 12:05:20 AM   
Crab

 

Posts: 6
Joined: 2/26/2018
Status: offline
I have been away for the last week and unable to test or respond, so please excuse the late reply.

I tried running steam in administrator mode and used the fix above, which got Command working again.

Still unsure as to the cause of the issue but so far it appears to be working.
Thanks for the help to all who suggested anything.

Now I can pick up the Silent Service...

(in reply to VPaulus)
Post #: 21
RE: Command won't start - 3/18/2018 4:49:10 PM   
polo199

 

Posts: 19
Joined: 12/1/2016
Status: offline
Looks like I'm getting a crash similar to those mentioned in this thread. As far as I can remember, the game has been working fine on my PC for the last versions. This crash appeared after the latest main release.

I've tried the file posted in this thread and also tried to run the exe as admin but nothing works. Game crashes just after having loaded the main screen.

If the event viewer gives any relevant indication, this seems to be linked to the .net framework (version ?). I've collected some relevant logs from my PC (error popup message and event viewer logs). All in the attached archive.

Attachment (1)

< Message edited by polo199 -- 3/18/2018 4:50:08 PM >

(in reply to Crab)
Post #: 22
RE: Command won't start - 3/18/2018 4:59:46 PM   
zakblood


Posts: 22403
Joined: 10/4/2012
Status: online
polo199, you need to load the version on .net which comes with the game, having a later one or an early one doesn't matter, as the game needs the correct one, as shown, some systems need more than a few, as each game will use a different one





plus as shown, on a 64bit version, you need both the 32bit and 64bit version for it to work correctly on most games, and in the correct install order, eg 32bit installer first with the 64bit installer second.

edited, also maybe an idea to post a report as well so others know what o/s your using, as the error log on it's own doesn't always show everything needed,

How to get a DirectX Diagnostic file:

1. click on "START"
2. click "run"
3. type in "dxdiag" and click "OK"
4. check through the tabs and perform all tests
5. click "Save all Information..." and save the text file to a location of your choice

We prefer that DxDiag files be posted as message attachments rather than pasted into the body of the post.

once the report has been made, just attach it to your post with first adding the file to a zip, which is then permitted to attach to the forum



Attachment (1)

< Message edited by zakblood -- 3/18/2018 5:04:20 PM >

(in reply to polo199)
Post #: 23
RE: Command won't start - 3/18/2018 5:11:53 PM   
polo199

 

Posts: 19
Joined: 12/1/2016
Status: offline
Hey Zakblood,

Thanks for answering. I did not mess up with my .net versions and I was under the assumption that CMANO on Steam would download and use the right one automatically. Besides I've noticed Steam "preparing" the game following the latest update. I remember seeing some message about .net. I thought there had been some update to that as well. I did not do anything on my side.

Anyway, here's the dxdiag (hope that can help). I did not run the x64 version of it by the way.

Attachment (1)

< Message edited by polo199 -- 3/18/2018 5:12:08 PM >

(in reply to zakblood)
Post #: 24
RE: Command won't start - 3/18/2018 5:23:35 PM   
Puciek

 

Posts: 63
Joined: 1/10/2017
Status: offline
Hey polo try giving the game a fresh install, so uninstall through steam then delete it's in-steam folder and then install it again, see if that helps.

(in reply to polo199)
Post #: 25
RE: Command won't start - 3/18/2018 5:31:23 PM   
polo199

 

Posts: 19
Joined: 12/1/2016
Status: offline
Hey Puciek!

I did not mention it but I reinstalled the game from scratch already (after having uninstalled it via Steam and manually deleted the remaining files and folders).

(in reply to Puciek)
Post #: 26
RE: Command won't start - 3/18/2018 5:50:43 PM   
zakblood


Posts: 22403
Joined: 10/4/2012
Status: online

quote:

ORIGINAL: polo199

Hey Zakblood,

Thanks for answering. I did not mess up with my .net versions and I was under the assumption that CMANO on Steam would download and use the right one automatically. Besides I've noticed Steam "preparing" the game following the latest update. I remember seeing some message about .net. I thought there had been some update to that as well. I did not do anything on my side.

Anyway, here's the dxdiag (hope that can help). I did not run the x64 version of it by the way.


yes steam version should install everything that's needed as long as on a administers level account

(in reply to polo199)
Post #: 27
RE: Command won't start - 3/18/2018 5:53:20 PM   
zakblood


Posts: 22403
Joined: 10/4/2012
Status: online
drivers all old,

Card name: NVIDIA GeForce GTX 1070 Driver Date/Size: 12/1/2016

VIA High Definition Audio 10/22/2012

update them may help

(in reply to zakblood)
Post #: 28
RE: Command won't start - 3/18/2018 6:23:48 PM   
Puciek

 

Posts: 63
Joined: 1/10/2017
Status: offline
If that didn't do it for you (reinstall) can you find the event that fires up and post it here so we can see exactly what's squirrly? And yep, update your stuff :D

(in reply to zakblood)
Post #: 29
RE: Command won't start - 3/18/2018 7:06:41 PM   
polo199

 

Posts: 19
Joined: 12/1/2016
Status: offline
Thanks forn the support guys. Event info is in the first file I've attached to this thread (couple of comments above).

Gonna update the drivers and report back.

---EDIT---
Here are some screenshots of the 2 events I'm getting in the event viewer. Sorry this is in French. Definitely seems to be linked to .net.

Attachment (1)

< Message edited by polo199 -- 3/18/2018 7:17:21 PM >

(in reply to Puciek)
Post #: 30
Page:   [1] 2   next >   >>
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> [From Beyond the Grave] Command won't start Page: [1] 2   next >   >>
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.156