Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Idle Mouse Cursor Creates Huge Black Box

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> The Operational Art of War IV >> Tech Support >> Idle Mouse Cursor Creates Huge Black Box Page: [1]
Login
Message << Older Topic   Newer Topic >>
Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 1:16:37 AM   
geozero


Posts: 1886
Joined: 5/22/2002
From: Southern California, U.S.A.
Status: offline
If I leave the mouse cursor idle for a few seconds on the map it creates a black box that is approx 5x12 hexes in size. If I move the mouse to another map location it draws yet again another black box. They seem to only go away when I move the mouse cursor over to the right side panel.

This is annoying as hell, never happened on ANY prior TOAW games, and in fact I can fire up TOAW 3 and this does not occur.

More annoying is trying to draw a new map in the editor because it makes all these black boxes and without the right panel no way to effectively remove them and pretty soon you can't see the map you're supposed to be drawing or doing anything.

If it helps track the issue, it appears that there is a new pop up window feature when you leave the mouse idle that tells you what is in that map location, that pop up box stays open for a bit, and THEN the larger black box appears. It's as if something is trying to re-draw a box or something.






Attachment (1)

< Message edited by geozero -- 11/18/2017 2:02:45 AM >


_____________________________

JUST SAY NO... To Hideous Graphics.
Post #: 1
RE: Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 3:42:20 AM   
Meyer1

 

Posts: 894
Joined: 2/9/2010
Status: offline
Sounds like is related to the "tooltip". I guess you could set it to never show up, but shouldn`t be doing this to your game. It´s only on the editor?

When installed IV the game make me to install Dx, and I already had III installed and working just fine. Maybe try to reinstall Dx?

< Message edited by Meyer1 -- 11/18/2017 3:43:47 AM >

(in reply to geozero)
Post #: 2
RE: Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 4:20:57 AM   
sPzAbt653


Posts: 9426
Joined: 5/3/2007
From: east coast, usa
Status: offline
I have also reported this as a glitch. Hopefully it makes it into a patch soon. Or maybe someone will tell us that there is a setting for it somewhere.

(in reply to geozero)
Post #: 3
RE: Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 10:12:11 AM   
Lobster


Posts: 4908
Joined: 8/8/2013
From: Third rock from the Sun.
Status: offline
For the time just do as Meyer says. Start a scenario, not in the editor. Click on Play in the menu bar at top. Then click on Player Options. Set tool tip to 100000 for the Tool Tip Show and 1 for Tool Tip Hide.

Personally I'd like a way to turn the tool tip off completely. I don't need it when editing.

I would also like to see the Player options and Game Options available in the editor and have asked for that since forever but no joy.

_____________________________

http://www.operationbarbarossa.net/

"There are more things in Heaven and Earth, Horatio, than are dreamt of in your philosophy."

Wearing blinders and earplugs everything you do is correct.

(in reply to sPzAbt653)
Post #: 4
RE: Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 1:39:46 PM   
geozero


Posts: 1886
Joined: 5/22/2002
From: Southern California, U.S.A.
Status: offline

quote:

ORIGINAL: sPzAbt653

I have also reported this as a glitch. Hopefully it makes it into a patch soon. Or maybe someone will tell us that there is a setting for it somewhere.


Ok, then it's just not me. I did search forum and did not see a thread. Hopefully it gets attention and gets fixed.

_____________________________

JUST SAY NO... To Hideous Graphics.

(in reply to sPzAbt653)
Post #: 5
RE: Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 1:42:40 PM   
geozero


Posts: 1886
Joined: 5/22/2002
From: Southern California, U.S.A.
Status: offline

quote:

ORIGINAL: Meyer1

Sounds like is related to the "tooltip". I guess you could set it to never show up, but shouldn`t be doing this to your game. It´s only on the editor?

When installed IV the game make me to install Dx, and I already had III installed and working just fine. Maybe try to reinstall Dx?



When I get more time to play around with it I will try the disable suggestion.

This issue came up on about 3-4 different scenarios. Oddly, after I posted the issue I could not recreate it in scenario, yet still occurred in editor.

I might try uninstall DX although that should not cause it IMO since I have DX for a great many other games without issues, including TOAW3.




_____________________________

JUST SAY NO... To Hideous Graphics.

(in reply to Meyer1)
Post #: 6
RE: Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 1:44:39 PM   
geozero


Posts: 1886
Joined: 5/22/2002
From: Southern California, U.S.A.
Status: offline

quote:

ORIGINAL: Lobster

For the time just do as Meyer says. Start a scenario, not in the editor. Click on Play in the menu bar at top. Then click on Player Options. Set tool tip to 100000 for the Tool Tip Show and 1 for Tool Tip Hide.

Personally I'd like a way to turn the tool tip off completely. I don't need it when editing.

I would also like to see the Player options and Game Options available in the editor and have asked for that since forever but no joy.



Tooltip is not necessary in editor for me either. Why they never provided options is bizarre.

_____________________________

JUST SAY NO... To Hideous Graphics.

(in reply to Lobster)
Post #: 7
RE: Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 6:19:12 PM   
ralphtricky


Posts: 6685
Joined: 7/27/2003
From: Colorado Springs
Status: offline
There's an option for tooltip delay, set it to a very large number. Can you also post your dxdiag and someone will take a look at it.

It's probably a video driver issue. The tooltips are the only thing that uses something called GDI Plus.

Ralph

_____________________________

Ralph Trickey
TOAW IV Programmer
Blog: http://operationalwarfare.com
---
My comments are my own, and do not represent the views of any other person or entity. Nothing that I say should be construed in any way as a promise of anything.

(in reply to geozero)
Post #: 8
RE: Idle Mouse Cursor Creates Huge Black Box - 11/18/2017 8:10:39 PM   
geozero


Posts: 1886
Joined: 5/22/2002
From: Southern California, U.S.A.
Status: offline

quote:

ORIGINAL: ralphtrick

There's an option for tooltip delay, set it to a very large number. Can you also post your dxdiag and someone will take a look at it.

It's probably a video driver issue. The tooltips are the only thing that uses something called GDI Plus.

Ralph


Ralph, thanks for the tips and will try to post the dxdiag later.

As for drivers or graphics cards issues - I seriously doubt it. I have a Radeon R9 390 with 8GB of RAM that powers a dual monitor. I do a lot of 3D spatial designs, architecture stuff, and other things. In addition to playing a lot of complex graphics games. TOAW 4 is a 2D game with PNG graphics and engine that is basically 20 years old. I think my video card/drivers should handle it just fine.

I'm guessing it's some sort of programming bug or memory leak issue which is at the coded level. Something is bugging out.

Tell me more about GDI PLus? Is that in your install? Did that DLL file get corrupted or having an issue? I'm on Win7 Pro system BTW. I have never seen this DLL have an issue.

I'm probably going to disable this tooltips thing, but honestly if it was something that was added to TOAW4 and is not working and I have to disable it really degrades the whole rationale for buying an "upgrade".




_____________________________

JUST SAY NO... To Hideous Graphics.

(in reply to ralphtricky)
Post #: 9
RE: Idle Mouse Cursor Creates Huge Black Box - 11/21/2017 9:37:12 PM   
Splatsch

 

Posts: 103
Joined: 12/27/2016
From: France
Status: offline
I just launched the game for the first time, and I seem to have not exactly the same issue but a similar one : I'm playing a scenario, when I over an hex, I have the tooltip. If I right-click to see the movement options (single-unit move/group move), the tooltip turns into a black box.

You can see the issue with my capture.

Here are my specs, if this can help :
Win7 64bits
Intel Core i5 2300 @ 2.80GHz
6,00 Go Dual-Channel DDR3
NVIDIA GeForce GT 440 with 1535MB




Thanks for any help :)

Edit : And the issue is the same if I only right-click on the unit to see the Deploy/Orders/Divide Unit... etc options.

Attachment (1)

< Message edited by Splatsch -- 11/21/2017 10:14:02 PM >

(in reply to geozero)
Post #: 10
RE: Idle Mouse Cursor Creates Huge Black Box - 11/21/2017 10:36:31 PM   
Splatsch

 

Posts: 103
Joined: 12/27/2016
From: France
Status: offline
And another addendum :
I noticed too that menus are sometimes letting "black ghost" of them when you click on one menu (like "File", "Play", ...) and move your mouse over another one (or one sub-option of the menu)(that happens with unit menus too) . This issue happens very often but not always though, and I don't understand the exact pattern for now.

On this screenshot, I clicked on "File", and moved the mouse over Play, View, Options Sound and stopped my mouse over Help and took the screenshot. Hope you'll understand more what I badly tried to explain.



Sorry for the second post, but I can only post one picture per message :P
If I can help, don't hesitate to ask !

(By the way, sorry for my bad english !)

Attachment (1)

< Message edited by Splatsch -- 11/21/2017 10:42:14 PM >

(in reply to Splatsch)
Post #: 11
RE: Idle Mouse Cursor Creates Huge Black Box - 11/25/2017 2:01:02 AM   
ralphtricky


Posts: 6685
Joined: 7/27/2003
From: Colorado Springs
Status: offline

quote:

ORIGINAL: Splatsch

And another addendum :
I noticed too that menus are sometimes letting "black ghost" of them when you click on one menu (like "File", "Play", ...) and move your mouse over another one (or one sub-option of the menu)(that happens with unit menus too) . This issue happens very often but not always though, and I don't understand the exact pattern for now.

On this screenshot, I clicked on "File", and moved the mouse over Play, View, Options Sound and stopped my mouse over Help and took the screenshot. Hope you'll understand more what I badly tried to explain.

Sorry for the second post, but I can only post one picture per message :P
If I can help, don't hesitate to ask !

(By the way, sorry for my bad english !)

Your English is way better than the other languages I speak.

I'm going to try some things for the black boxes, those are the tooltip, you can turn it off or put it in one corner of the screen using the options to see if that helps. The menu is just plain weird, that's pure Windows code there, I'm not doing anything so it should just work.

What video card are you using? Can you please run DXDiag and post your results?


_____________________________

Ralph Trickey
TOAW IV Programmer
Blog: http://operationalwarfare.com
---
My comments are my own, and do not represent the views of any other person or entity. Nothing that I say should be construed in any way as a promise of anything.

(in reply to Splatsch)
Post #: 12
RE: Idle Mouse Cursor Creates Huge Black Box - 11/25/2017 3:21:52 PM   
Splatsch

 

Posts: 103
Joined: 12/27/2016
From: France
Status: offline
quote:

ORIGINAL: ralphtricky


quote:

ORIGINAL: Splatsch

And another addendum :
I noticed too that menus are sometimes letting "black ghost" of them when you click on one menu (like "File", "Play", ...) and move your mouse over another one (or one sub-option of the menu)(that happens with unit menus too) . This issue happens very often but not always though, and I don't understand the exact pattern for now.

On this screenshot, I clicked on "File", and moved the mouse over Play, View, Options Sound and stopped my mouse over Help and took the screenshot. Hope you'll understand more what I badly tried to explain.

Sorry for the second post, but I can only post one picture per message :P
If I can help, don't hesitate to ask !

(By the way, sorry for my bad english !)

Your English is way better than the other languages I speak.

I'm going to try some things for the black boxes, those are the tooltip, you can turn it off or put it in one corner of the screen using the options to see if that helps. The menu is just plain weird, that's pure Windows code there, I'm not doing anything so it should just work.

What video card are you using? Can you please run DXDiag and post your results?


Ahah, thanks :) But if I'm not clear, don't hesitate to ask me to explain myself better !

Turning them off isn't handy for me right now, since I'm discovering the game :P
I tried to put the tooltip in the corner of the screen [for people who would like to try it too, please see chapter "19.10. opart4.Ini file" of the manual][For top-left, the value is 0 ;)], but the issue is still there. But it's less intrusive because of it's new place.
For the menu, I don't know at all, maybe it's related to the fact it's windowed and not fullscreen ? Or some .net, visual C++ or directX or something like that ? (but I should be up to date though) Or because I'm on a french computer ? (just throwing some ideas, you may never know)
Thanks a lot for the support by the way

Sure !
So, my specs :
Win7 64bits
Intel Core i5 2300 @ 2.80GHz
6,00 Go Dual-Channel DDR3
NVIDIA GeForce GT 440 with 1535MB
And I attached a dxdiag file, hope this will helps !

Attachment (1)

< Message edited by Splatsch -- 11/25/2017 3:22:27 PM >

(in reply to ralphtricky)
Post #: 13
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> The Operational Art of War IV >> Tech Support >> Idle Mouse Cursor Creates Huge Black Box Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.275