Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Terrible Performance on Surface Pro 4 i7

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Terrible Performance on Surface Pro 4 i7 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Terrible Performance on Surface Pro 4 i7 - 5/29/2017 2:53:34 AM   
Fallschirmjager


Posts: 6778
Joined: 3/18/2002
From: Chattanooga, Tennessee
Status: offline
Admittedly this is much less powerful than my laptop but this tablet is more powerful than the first desktop I ran AE on back in 2009.
I am having a lot of issues with texture draw lag and input lag. When I move the map it takes several seconds to actually draw in the map and clicking on a button take a lot of lag for the screen to display.

I have the Surface Pro 4 i7 model with 16 GB of Ram. I am going to try command line switches to change the game to run on a single core.
However, the turns themselves run quickly. Only about 20% slower than my i7 4800MQ CPU on my laptop that is a 45W processor.
It seems like the integrated GPU us having trouble drawing the screen without lag. An odd issue since AE requires so little video ram and my GPU has access to up to 1GB worth.

_____________________________

Post #: 1
RE: Terrible Performance on Surface Pro 4 i7 - 5/29/2017 5:01:40 AM   
tbothy

 

Posts: 22
Joined: 4/8/2012
Status: offline
I ran it on a surface pro 3 with 4gb Ram i5, with the following switches with no problems
"War in the Pacific Admiral Edition.exe" -f -px1366 -py768 -altFont -cpu2 -skipVideo -deepColor

(in reply to Fallschirmjager)
Post #: 2
RE: Terrible Performance on Surface Pro 4 i7 - 5/29/2017 12:04:49 PM   
witpqs


Posts: 24990
Joined: 10/4/2004
From: Argleton
Status: offline
Look at the many threads about using the game's switches for Windows 10 performance. Likely you will find one(s) that work for you.

_____________________________


(in reply to tbothy)
Post #: 3
RE: Terrible Performance on Surface Pro 4 i7 - 5/30/2017 12:58:38 AM   
Fallschirmjager


Posts: 6778
Joined: 3/18/2002
From: Chattanooga, Tennessee
Status: offline
I got the game working very well using command line switches. I tried the core affinity switches and that did not help at all. In fact it made the Surface run 5-7 C hotter.
As I was reading the readme file I came across dd_sw which for me was the magic switch.
This forces the graphics back on the software which seems counter intuitive but does the trick.

I added in some more lines and even though due to the weird aspect ratio of the Surface I lose some screen to black bars the game runs fantastically and looks great.
I also found alt_font to be a must or else the in game text was fuzzy and harder to read.
I have the entire War in the Pacific on a device that weighs just 1.7 lbs.

In case anyone else is in a similar setup here is my entire command line.

"C:\Matrix Games\War in the Pacific Admiral's Edition\War in the Pacific Admiral Edition.exe" -dd_sw -deepColor -skipVideo -f -px1920 –py1200 -altFont



< Message edited by Fallschirmjager -- 5/30/2017 2:50:38 AM >


_____________________________


(in reply to witpqs)
Post #: 4
RE: Terrible Performance on Surface Pro 4 i7 - 5/30/2017 1:29:37 AM   
Lokasenna


Posts: 9131
Joined: 3/3/2012
From: Iowan in MD/DC
Status: offline
From looking it up before, in Windows 8 and Windows 10 it seems like you must run with -deepColor or else you will run into exactly the issues you describe.

(in reply to Fallschirmjager)
Post #: 5
RE: Terrible Performance on Surface Pro 4 i7 - 5/30/2017 2:52:40 AM   
Fallschirmjager


Posts: 6778
Joined: 3/18/2002
From: Chattanooga, Tennessee
Status: offline

quote:

ORIGINAL: Lokasenna

From looking it up before, in Windows 8 and Windows 10 it seems like you must run with -deepColor or else you will run into exactly the issues you describe.


I took it out as a test and while the game looks less sharp (due to loss of shades of color) the game still runs well.
I found -dd_sw to be the command line must. Taking that command line out causes the display lag.


_____________________________


(in reply to Lokasenna)
Post #: 6
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Terrible Performance on Surface Pro 4 i7 Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.211