Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: "Hyping" my forthcoming mod (pun intended)

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> RE: "Hyping" my forthcoming mod (pun intended) Page: <<   < prev  12 13 [14] 15 16   next >   >>
Login
Message << Older Topic   Newer Topic >>
RE: "Hyping" my forthcoming mod (pun intended) - 12/9/2017 9:12:17 PM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: fruitgnome

I use now version 1.6. The game freezes, then crashes. With the previous version 1.55, it said that there is not enough memory. The game uses only 1GB but there are 4GB more that it could use. Also with the new version 1.6 it only uses 1GB. I it also not possible to start then the Task Manager to close Distant Worlds, I only can hard reset my pc.

I also got this exception in 1.55 and 1.6:
Die Auflistung wurde geändert. Der Enumerationsvorgang kann möglicherweise nicht ausgeführt werden.


That translates to
"listing has been changed. The enumeration process may not be able to run."
I've never seen that one before. Was this with a game saved under a previous version? What size map were you using?

(in reply to fruitgnome)
Post #: 391
RE: "Hyping" my forthcoming mod (pun intended) - 12/9/2017 9:39:16 PM   
BlindOne

 

Posts: 45
Joined: 11/19/2017
Status: offline
That warning is the same as the IndexOutOfRangeException except in barbaric nothing new under the sun here.

And yes I speak two versions of barbaric. Dutch and German

< Message edited by BlindOne -- 12/9/2017 9:40:38 PM >

(in reply to RogerBacon)
Post #: 392
RE: "Hyping" my forthcoming mod (pun intended) - 12/9/2017 10:43:37 PM   
fruitgnome

 

Posts: 184
Joined: 6/4/2014
Status: offline
I test now the Version 1.6 in full auto mode.
Before I used Unleashed Extended with the 1.55 and 1.6.
The main problem is that the games uses only 1GB of RAM!
I search for the tool Large Adress Aware but it can only change the use of 2GB RAM to 4GB!

Sectors 15x15 with 250 Stars. But I build a lot of Fighter and Bomber Bays, because the better long range I find them great!!!

And thx 4 this fantastic mod!!!

Edit: I got a new Exception:
Der Index lag außerhalb des Bereichs. Er darf nicht negativ und kleiner als die Auflistung sein.
Parametername: index

< Message edited by fruitgnome -- 12/9/2017 11:50:33 PM >

(in reply to BlindOne)
Post #: 393
RE: "Hyping" my forthcoming mod (pun intended) - 12/10/2017 1:08:05 AM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline
quote:

ORIGINAL: fruitgnome

I test now the Version 1.6 in full auto mode.
Before I used Unleashed Extended with the 1.55 and 1.6.
The main problem is that the games uses only 1GB of RAM!
I search for the tool Large Adress Aware but it can only change the use of 2GB RAM to 4GB!

Sectors 15x15 with 250 Stars. But I build a lot of Fighter and Bomber Bays, because the better long range I find them great!!!

And thx 4 this fantastic mod!!!

Edit: I got a new Exception:
Der Index lag außerhalb des Bereichs. Er darf nicht negativ und kleiner als die Auflistung sein.
Parametername: index

quote:

Der Index lag außerhalb des Bereichs. Er darf nicht negativ und kleiner als die Auflistung sein.


I ran the exe through Large Address Aware before I released it. It should be able to handle much more than 1 GB ram.
Was this a new game or a load from a previous version?
Was there a stack trace when you got the error or just a message box? Did the game crash or allow you to continue playing?
How big was your last save game before the crash?

(in reply to fruitgnome)
Post #: 394
RE: "Hyping" my forthcoming mod (pun intended) - 12/10/2017 5:11:26 AM   
MaddMugsy

 

Posts: 4
Joined: 12/7/2017
Status: offline
Interestingly, the 1.6 exe won't start untless there's a customBackgroundImage file. Otherwise, no issues so far

I was going to post a custom image that i whipped up in mspaint, but the forum won't let me post links yet.


< Message edited by MaddMugsy -- 12/10/2017 7:39:39 AM >

(in reply to RogerBacon)
Post #: 395
RE: "Hyping" my forthcoming mod (pun intended) - 12/10/2017 11:16:49 AM   
fruitgnome

 

Posts: 184
Joined: 6/4/2014
Status: offline
The exe 1.6 will also not start if another theme is chosen ingame than Bacon World.

I run a fresh Distant Worlds Universe 1.9.5.12 installation over night. The game was using 3GB and the game was still running in full automode. I retest now the 1.6 with new game in full automode. I got often in this match the Exception:
Die Auflistung wurde geändert. Der Enumerationsvorgang kann möglicherweise nicht ausgeführt werden.
But the game is still running, no freeze, no crash. The game is still using 1GB NOT MORE!

< Message edited by fruitgnome -- 12/10/2017 1:13:33 PM >

(in reply to MaddMugsy)
Post #: 396
RE: "Hyping" my forthcoming mod (pun intended) - 12/10/2017 1:15:11 PM   
fruitgnome

 

Posts: 184
Joined: 6/4/2014
Status: offline
Is the game with this mod (V1.55 or V1.6) by you (community) more than 1GB RAM using? (Task Manager)

(in reply to fruitgnome)
Post #: 397
RE: "Hyping" my forthcoming mod (pun intended) - 12/10/2017 1:40:34 PM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: MaddMugsy

Interestingly, the 1.6 exe won't start untless there's a customBackgroundImage file. Otherwise, no issues so far

I was going to post a custom image that i whipped up in mspaint, but the forum won't let me post links yet.



Thanks for pointing that out. I've been running custom background for awhile so I'm not sure when that bug snuck in there. Another user posted the isse where the process gets to 22k and then shuts down and that's exactly what its doing now without a custom background image. I'll try to see why its doing that. In the meantime, here is the custom background image I've been using.



(in reply to MaddMugsy)
Post #: 398
RE: "Hyping" my forthcoming mod (pun intended) - 12/10/2017 2:41:19 PM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline
OK, I found the cause of the game not loading without a custom background image. I will upload a fix shortly.

New version uploaded.

If you have trouble switching themse and get an error like "Can't load image for \images\units\ships\family0\fighter" then you MAY have to rename your custombackgroundimage.jpg so the game doesn't see it. I think its counting images and that may through it off. You can re-enable after the switch. Or it might just work fine.

< Message edited by RogerBacon -- 12/10/2017 3:17:31 PM >

(in reply to RogerBacon)
Post #: 399
RE: "Hyping" my forthcoming mod (pun intended) - 12/11/2017 2:15:37 AM   
Beyondfubar

 

Posts: 26
Joined: 5/27/2017
Status: offline
When will this train of awesome end? Bacon your mod is awesome, it really adds to the game. Being that you can add this over the top of your own favorite mod and personal tweaks really makes it.

Speaking of never-ending awesome, I just completed my first playthrough with both starfall corrected and bacon mod with only minor errors (The crashing to desktop or worse variety being mostly due to leaving the game running, i.e. forgetting it was on for the magic 4 hour+ number and getting out of memory related things)

Couple of things:
After I killed the bugs, or rather they killed themselves by declaring war, and subsequently outting themselves.. (dumb dumb) I was able to give them a do over with !bringonthebugs. Ad Infinium bug events! yes!

Their ability to effectively use their planet destroyers was basically non-existent with the gravity wells. Is there a way to boost them to be the terror weapons they were? I like the wells far far to much to disable them.

Second, I get quite a few errors of the 'Can't find an image for race -1". This seems to be when I get a new race, or a independent race becomes a primary race, but not 100%. I'll try and get a SS of it up, but if you know what this could be I'd love to not have click storms when it occurs. To be clear this doesn't not crash the game, it just makes me hit a ton of windows with "OK" I was able to do a 100 year to victory completion, so thankfully I've worked out the bugs with my tweaks, and your great mod is stable as can be for me!

Edit: Grabbed 1.6, couldn't load a known good save. Patched with LAA and loaded good.

Edit 2: Hey Rogerbacon any chance of giving us the ability to loan out money? Would be interesting to fund other empires' wars on each other.


< Message edited by Beyondfubar -- 12/12/2017 2:38:18 AM >

(in reply to RogerBacon)
Post #: 400
RE: "Hyping" my forthcoming mod (pun intended) - 12/11/2017 3:27:39 PM   
MaddMugsy

 

Posts: 4
Joined: 12/7/2017
Status: offline
quote:

Edit: Grabbed 1.6, couldn't load a known good save. Patched with LAA and loaded good.


I diffed the new 1.6 with the one from 12/9 and it looks like the Large Address Aware flags aren't set on the new 12/10 exe.

(in reply to Beyondfubar)
Post #: 401
RE: "Hyping" my forthcoming mod (pun intended) - 12/12/2017 3:58:19 PM   
fruitgnome

 

Posts: 184
Joined: 6/4/2014
Status: offline
Is this:
Haree78's Extended Universe 1.03
www.larrymonte.com/downloads/DWExtendedUniverseBaconFiles.zip
still to use also with V1.6?

(in reply to MaddMugsy)
Post #: 402
RE: "Hyping" my forthcoming mod (pun intended) - 12/12/2017 8:09:24 PM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: fruitgnome

Is this:
Haree78's Extended Universe 1.03
www.larrymonte.com/downloads/DWExtendedUniverseBaconFiles.zip
still to use also with V1.6?



Yeah, that should still work.

(in reply to fruitgnome)
Post #: 403
RE: "Hyping" my forthcoming mod (pun intended) - 12/12/2017 8:20:01 PM   
fruitgnome

 

Posts: 184
Joined: 6/4/2014
Status: offline
THX, so I start a new game with your mod 1.6.
Are there any fiels which could help you, if we have, freeze or crash?

< Message edited by fruitgnome -- 12/12/2017 8:21:13 PM >

(in reply to RogerBacon)
Post #: 404
RE: "Hyping" my forthcoming mod (pun intended) - 12/12/2017 11:45:59 PM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: fruitgnome

THX, so I start a new game with your mod 1.6.
Are there any fiels which could help you, if we have, freeze or crash?


If you get a crash send me the stack dump, if acvailable, in a PM. Let's hope it works fine for you.

(in reply to fruitgnome)
Post #: 405
RE: "Hyping" my forthcoming mod (pun intended) - 12/13/2017 11:25:41 PM   
MaddMugsy

 

Posts: 4
Joined: 12/7/2017
Status: offline
Been playing for a little while with 1.6 and so far so good :)

I saw something yesterday about disabling the intro movies, so I tried doing that to speed up starting the game, but it ended up screwing up the whole in-game hud/display: no minimap, no top history bar or buttons, no time buttons, no info box, etc. Not even the Escape menu showed up. I re-enabled the movies and suddenly everything worked again. This is probably a vanilla issue though

Anyway, thanks to your mod, I'm finally able to rack up some hours in Distant Worlds! I've had the game for ages, but the eye strain from the poor font choices by the devs always made me give up and go play something else before getting very far.

(in reply to RogerBacon)
Post #: 406
RE: "Hyping" my forthcoming mod (pun intended) - 12/14/2017 12:56:28 AM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: MaddMugsy

Anyway, thanks to your mod, I'm finally able to rack up some hours in Distant Worlds! I've had the game for ages, but the eye strain from the poor font choices by the devs always made me give up and go play something else before getting very far.


Thanks. I'm glad you like it. Your post made my day.

(in reply to MaddMugsy)
Post #: 407
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 12:04:15 AM   
netie

 

Posts: 8
Joined: 12/17/2017
Status: offline
Hi,
It looks great and I want to try!
But with updated 12/10 exe, the game still doesn't start. (After clicking "Play Distant Worlds" button on the menu, nothing had happened.)

I saw silimar problems on Steam discusion. Graphics board can be an issue?
I run the Steam version on Surface pro 2(intel HD 4400).

(in reply to RogerBacon)
Post #: 408
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 12:50:09 AM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: netie

Hi,
It looks great and I want to try!
But with updated 12/10 exe, the game still doesn't start. (After clicking "Play Distant Worlds" button on the menu, nothing had happened.)

I saw silimar problems on Steam discusion. Graphics board can be an issue?
I run the Steam version on Surface pro 2(intel HD 4400).


OK, walk me through it exactly.

You double click on the exe. You get the pop up screen "Bacon Mod yada yada". You get to the start menu and select "Play distant Worlds" and nothing happens?
How big is the program in memory using task manager?

In C:\Users\[YourNameHere]\Documents\My Games\Distant Worlds Universe there is a file called DW-CrashDump.txt. What does it say?

(in reply to netie)
Post #: 409
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 1:14:02 AM   
netie

 

Posts: 8
Joined: 12/17/2017
Status: offline

quote:

ORIGINAL: RogerBacon


quote:

ORIGINAL: netie

Hi,
It looks great and I want to try!
But with updated 12/10 exe, the game still doesn't start. (After clicking "Play Distant Worlds" button on the menu, nothing had happened.)

I saw silimar problems on Steam discusion. Graphics board can be an issue?
I run the Steam version on Surface pro 2(intel HD 4400).


OK, walk me through it exactly.

You double click on the exe. You get the pop up screen "Bacon Mod yada yada". You get to the start menu and select "Play distant Worlds" and nothing happens?
How big is the program in memory using task manager?

In C:\Users\[YourNameHere]\Documents\My Games\Distant Worlds Universe there is a file called DW-CrashDump.txt. What does it say?



Thanks for quick response. :D
Executing the exe directly and nothing happens. No pop up screen.

Running through the start menu, task manager says..
"Distant Worlds (32 bit)" uses 21.4MB
"Game Menu (32 bit)" uses 21.8MB.

The game is not crashed and no crash dump appears.

It can be a help?

(in reply to RogerBacon)
Post #: 410
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 1:56:52 AM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: netie


Thanks for quick response. :D
Executing the exe directly and nothing happens. No pop up screen.

Running through the start menu, task manager says..
"Distant Worlds (32 bit)" uses 21.4MB
"Game Menu (32 bit)" uses 21.8MB.

The game is not crashed and no crash dump appears.

It can be a help?


It's really strange. I know a couple of people have this problem. Something is preventing the game from starting. I suspect it is something outside of the game such as an over aggressive anti virus program.
I'm not sure if I can help since there is no crash. The game just doesn't start. I would suggest posting your system specs and comparing with the other one or two people who have the same problem. Perhaps we can find a commonality.

(in reply to netie)
Post #: 411
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 2:40:04 AM   
netie

 

Posts: 8
Joined: 12/17/2017
Status: offline
quote:

ORIGINAL: RogerBacon

It's really strange. I know a couple of people have this problem. Something is preventing the game from starting. I suspect it is something outside of the game such as an over aggressive anti virus program.
I'm not sure if I can help since there is no crash. The game just doesn't start. I would suggest posting your system specs and comparing with the other one or two people who have the same problem. Perhaps we can find a commonality.



Okay, current PC specs here:
Surface pro 2
Steam, Win10pro(64bit), i5-4200U, 8GB, intel HD 4400
--

tried to stop (not uninstalled) anti-virus software and it has not changed the issue.
I will try an another PC other time.

Thx anyway!

[EDIT] "Win10pro" -> "Win10pro(64bit)"


< Message edited by netie -- 12/18/2017 8:32:59 PM >

(in reply to RogerBacon)
Post #: 412
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 7:53:26 PM   
Beyondfubar

 

Posts: 26
Joined: 5/27/2017
Status: offline
Hey Roger, just wanted to throw this out there for people that have very extremely late games: The ransoming has stopped working for me ~95 years in. Likely not related to you, since the save bloat for even a small-reg size star count and 5> empires tends to be high. This is on 15x15 map, but with exorbitant prices on ships (Wanted to keep it small to avoid massive crash potential on big maps with high star count and empires) Other than that and the Family-1 error for starfall all is good. Love the ability to kick start the bugs, I hadn't seen them after 102 years so I wanted to say thanks(!) for the ability to force the game to do that.

(in reply to fruitgnome)
Post #: 413
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 8:30:42 PM   
netie

 

Posts: 8
Joined: 12/17/2017
Status: offline

quote:

ORIGINAL: netie

Okay, current PC specs here:
Surface pro 2
Steam, Win10pro, i5-4200U, 8GB, intel HD 4400
--

tried to stop (not uninstalled) anti-virus software and it has not changed the issue.
I will try an another PC other time.

Thx anyway!


Hi,
I tested it on another PC.
And it was successfully launching! :D

Specs here:
Steam, Win8.1pro(64bit), i7-2600, 24GB, GTX560
(same anti-virus program is installed and is not disabled)
--

The specs here and recent my post are quite different and I cannot find the cause of this issue.
But I hope it can be a help!

(in reply to netie)
Post #: 414
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 9:49:49 PM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: netie


quote:

ORIGINAL: netie

Okay, current PC specs here:
Surface pro 2
Steam, Win10pro, i5-4200U, 8GB, intel HD 4400
--

tried to stop (not uninstalled) anti-virus software and it has not changed the issue.
I will try an another PC other time.

Thx anyway!


Hi,
I tested it on another PC.
And it was successfully launching! :D

Specs here:
Steam, Win8.1pro(64bit), i7-2600, 24GB, GTX560
(same anti-virus program is installed and is not disabled)
--

The specs here and recent my post are quite different and I cannot find the cause of this issue.
But I hope it can be a help!


That's great. At least you can play it now. The other computer you were trying to use was a tablet, right? Even though it has the same operating system maybe there's something different that caused it to not work. Strange that the unmodded DWU would work and the mod not.

(in reply to netie)
Post #: 415
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 9:55:56 PM   
RogerBacon

 

Posts: 563
Joined: 5/17/2000
From: Miami, Florida, U.S.A.
Status: offline

quote:

ORIGINAL: Beyondfubar

Hey Roger, just wanted to throw this out there for people that have very extremely late games: The ransoming has stopped working for me ~95 years in. Likely not related to you, since the save bloat for even a small-reg size star count and 5> empires tends to be high. This is on 15x15 map, but with exorbitant prices on ships (Wanted to keep it small to avoid massive crash potential on big maps with high star count and empires) Other than that and the Family-1 error for starfall all is good. Love the ability to kick start the bugs, I hadn't seen them after 102 years so I wanted to say thanks(!) for the ability to force the game to do that.


Hi Beyondfubar,

At 95 years in you are well beyond my experience (playing or testing). Not sure what happens that late in the game. You mentioned exorbitant ship prices. Are you using the values in BaconSettings to mod the ship prices globally? If so that's cool and the first I've heard of someone using it. Does the AI seem to handle it well?

As for ransoming, captured spies are kept on capitals for empires and on pirate bases for pirates. If a player changes his capital, voluntarily or otherwise, the prisoners should transfer as well. I tested that out so I'm not sure what could cause the ransoming to stop. Maybe the AI just stopped running spy missions?
During testing I wasn't able to test capturing and ransoming AI spies (they didn't run any unsuccessful missions against me). Can someone confirm that they can ransom AI spies? I was able to test ransoming back my own spies by sending them on suicidal missions.

(in reply to Beyondfubar)
Post #: 416
RE: "Hyping" my forthcoming mod (pun intended) - 12/18/2017 11:31:58 PM   
netie

 

Posts: 8
Joined: 12/17/2017
Status: offline
Of course, both machine can run vanilla DWU fine.
Surface pro 2 can run so many games. But, yes, some games cannot run properly on it.
I'll keep trying. :)

(in reply to RogerBacon)
Post #: 417
RE: "Hyping" my forthcoming mod (pun intended) - 12/20/2017 5:47:29 PM   
aldehyt

 

Posts: 14
Joined: 3/30/2014
Status: offline
At pirate gameplay, built freighters and other (SMUGGLERS), dont get neutral flag, is any solution for this ?

(in reply to netie)
Post #: 418
RE: "Hyping" my forthcoming mod (pun intended) - 12/20/2017 6:06:48 PM   
Dudok22

 

Posts: 6
Joined: 4/18/2015
Status: offline
This happens when I try to start a new game. few times it actually loaded but crashed few minutes into the new game.


************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at BaconDistantWorlds.BaconBuiltObject.HugeProcessingSpanActions(BuiltObject ship)
   at DistantWorlds.Types.BuiltObject.DoTasks(DateTime time, Int64 starDate, Boolean inView)
   at DistantWorlds.Start.method_76(Galaxy galaxy_0, Empire empire_0)
   at DistantWorlds.Start.method_77(Game game_1)
   at DistantWorlds.Start.btnStartNewGameStart_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at DistantWorlds.Controls.GlassButton.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at DistantWorlds.Controls.GlassButton.OnMouseUp(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)



(in reply to aldehyt)
Post #: 419
RE: "Hyping" my forthcoming mod (pun intended) - 12/20/2017 7:19:44 PM   
aldehyt

 

Posts: 14
Joined: 3/30/2014
Status: offline
Your mod barely working with others mods, so many Array OutOfBounds, i hope you know how to fix that, cause mod is great.

< Message edited by aldehyt -- 12/20/2017 7:20:08 PM >

(in reply to Dudok22)
Post #: 420
Page:   <<   < prev  12 13 [14] 15 16   next >   >>
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> RE: "Hyping" my forthcoming mod (pun intended) Page: <<   < prev  12 13 [14] 15 16   next >   >>
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.145