Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Wireless Router Causes Trouble

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> World in Flames >> Tech Support >> NetPlay Tech Support >> Wireless Router Causes Trouble Page: [1]
Login
Message << Older Topic   Newer Topic >>
Wireless Router Causes Trouble - 2/16/2017 8:52:39 PM   
paulderynck


Posts: 8171
Joined: 3/24/2007
From: Canada
Status: offline
Don and I began our NetPlay testing today. We decided to just do the Barbarossa scenario to start with. I have a wired connection but Don's is wireless. We appear to have proved what Centuur said in another thread - wireless connections are bad for NetPlay!

On two occasions Don received a flashing message (which BTW was hard to see because it was behind the map), but ultimately we learned via the appearance of a second message, that the connection to the NetPlay server had been lost.

IMO this is pretty bad for Matrix's NetPlay server since in this day and age it does not seem reasonable to expect all MWiF patrons to always have access to a wired internet connection. Either the communications protocols have to be made more durable or people need to be advised that they can't NetPlay using wireless.

The second time we were disconnected must have been just after the Russians finished setting up. Don did see me put the German Navy and Air Force on the map, but after that he saw nothing change so that would have been when the connection was lost, although the second flashing message was not seen until later on. We have a game save with matching entry numbers but when we restore from it, it wants us to end the German set-up and yet not a single German unit is on the map, not even the ones Don saw me place. I assume this is because that save was made when the Russians finished setting up, but clearly something in the save file is misleading MWiF.

Here's a screen shot from Don's end of the error message:




Attachment (1)

< Message edited by paulderynck -- 2/16/2017 8:53:16 PM >


_____________________________

Paul
Post #: 1
RE: Wireless Router Causes Trouble - 2/16/2017 8:58:09 PM   
paulderynck


Posts: 8171
Joined: 3/24/2007
From: Canada
Status: offline
Here is the save file from the Axis PC. Perhaps at least this will help solve why MWiF thinks the Germans have nothing to set up when in fact they have not set up anything.

Attachment (1)

_____________________________

Paul

(in reply to paulderynck)
Post #: 2
RE: Wireless Router Causes Trouble - 2/16/2017 11:14:32 PM   
Timian


Posts: 137
Joined: 9/14/2013
From: Tucson, AZ
Status: offline
And here is the save file from the Allied (Soviet) PC . . . Thanks, Don.

Will be getting a LAN Cable to connect my laptop to our wireless router tomorrow AM / Hopefully (for myself and Paul) this problem will be fixed.

Attachment (1)

(in reply to paulderynck)
Post #: 3
RE: Wireless Router Causes Trouble - 2/17/2017 4:38:58 AM   
Jagdtiger14


Posts: 1690
Joined: 1/22/2008
From: Miami Beach
Status: offline
This is exactly what happened with Bommerrang and myself. The only way you can play Netplay is with a cable hook up. At some point I'll find the time to get one...but players need to be aware of this.

_____________________________

Conflict with the unexpected: two qualities are indispensable; first, an intellect which, even in the midst of this obscurity, is not without some traces of inner light which lead to the truth; second, the courage to follow this faint light. KvC

(in reply to Timian)
Post #: 4
RE: Wireless Router Causes Trouble - 2/17/2017 12:14:43 PM   
Centuur


Posts: 8734
Joined: 6/3/2011
From: Hoorn (NED).
Status: offline
I've seen the same problem yesterday too. This needs to get fixed by Matrix IMHO. Yesterday this happened about 4 times when testing Netplay with Bommerrang.

< Message edited by Centuur -- 2/17/2017 12:16:01 PM >


_____________________________

Peter

(in reply to Jagdtiger14)
Post #: 5
RE: Wireless Router Causes Trouble - 2/17/2017 7:35:05 PM   
Shannon V. OKeets

 

Posts: 22063
Joined: 5/19/2005
From: Honolulu, Hawaii
Status: offline
The connection is dropped at the Slitherine end of the connection because the player's computer hasn't been "in touch" for a while.

The time delay in sending messages via wireless versus hardwired can be one or two orders of magnitude greater.

When my wife was printing from her computer to our printer, it was taking minutes to print a document. That connection is wireless from computer to router and either wireless or hardwired from the router to the printer. Making the connection from the router to the printer hardwired cut the time to 30 seconds. Note that the computer to the router was still wireless.

I have changed the error messages to provide me with more information about what the program was trying to do when it detected the dropped connection. Previously #141 would be reported from a couple dozen different places in the code. Now there are 10 different error codes to let me know exactly when in the program the problem happened.

Once we have gathered some more information using the new message numbers, I'll see if Slitherine can help fix this problem.

< Message edited by Shannon V. OKeets -- 2/17/2017 7:36:23 PM >


_____________________________

Steve

Perfection is an elusive goal.

(in reply to Centuur)
Post #: 6
RE: Wireless Router Causes Trouble - 2/17/2017 10:22:07 PM   
paulderynck


Posts: 8171
Joined: 3/24/2007
From: Canada
Status: offline
It is not necessarily all wireless is bad, it may be local conditions or certain hardware. FREX previously Bommerrang and I did a lot of NetPlay testing and he was on wireless and we never hit this issue.

Nonetheless today I tested again with Don after he converted his end to a wired connection and we did not have this problem.



_____________________________

Paul

(in reply to Shannon V. OKeets)
Post #: 7
RE: Wireless Router Causes Trouble - 2/18/2017 3:30:59 AM   
gw15


Posts: 900
Joined: 3/21/2010
Status: offline
The current Barb game I'm playing with another player - we have never had this problem and he's also on wireless.
Let me say though that I have huge data capacity and my router is a new 5g type. I can download a 80mg file in 5 seconds through my wireless.


quote:

ORIGINAL: paulderynck

It is not necessarily all wireless is bad, it may be local conditions or certain hardware. FREX previously Bommerrang and I did a lot of NetPlay testing and he was on wireless and we never hit this issue.

Nonetheless today I tested again with Don after he converted his end to a wired connection and we did not have this problem.




(in reply to paulderynck)
Post #: 8
RE: Wireless Router Causes Trouble - 2/19/2017 3:06:28 PM   
gw15


Posts: 900
Joined: 3/21/2010
Status: offline
Correction - my opponent is direct wired not wireless.

(in reply to gw15)
Post #: 9
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> World in Flames >> Tech Support >> NetPlay Tech Support >> Wireless Router Causes Trouble Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.176