Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

New UPDATED v1.21.04 Hotfix for Public Beta

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [Napoleonics] >> Empires in Arms the Napoleonic Wars of 1805 - 1815 >> New UPDATED v1.21.04 Hotfix for Public Beta Page: [1]
Login
Message << Older Topic   Newer Topic >>
New UPDATED v1.21.04 Hotfix for Public Beta - 2/7/2017 12:25:49 AM   
pzgndr

 

Posts: 2609
Joined: 3/18/2004
From: Maryland
Status: offline
I am posting an updated v1.21.04 as a pre-release candidate. Based on comments received from a pbem game, I think the path problem may be resolved now. At least, I was able to recreate the error before the fix and now it seems OK. This needs verification by the pbem game team.

Also included in the zip are two updated .ged files for the \Data\databases directory to correct map data bugs. Please copy the new EXE into the main game directory and the other two files into the sub-directory.

One minor graphics glitch I am working on is transfer of unit factors during reinforcement phase. Land unit images appear fine but naval fleet images and names are not appearing on the selection menu for some odd reason. You are still able to click where the icon should be to select a fleet and then transfer factors normally with images, so this is not a game stopper. I will continue to investigate this.

If the pbem game works ok and there are no other burning issues to resolve, this should be close to final for official release. I will wait to hear back from the pbem game, or from any others trying a smaller group pbem test game. Thank you.


Empires in Arms the Napoleonic Wars - 1.21.04
=============================================
- 0000541: [Rules Deviation] Incorrect interpretation of separate peace in the game - resolved.
- 0000576: [Game Bug] Enemy Depot in City blocks occupation - resolved.
- 0000646: [Game Enhancement] AAR battle marker - closed.
- 0000759: [Game Enhancement] Instead of an AAR battle marker, simply indicate number of factors involved in a battle in the log - resolved.
- 0000811: [Game Bug] Forces in city and out of city somehow switched - resolved.
- Game bug with port guns firing without enemy garrison present - resolved.
- Game bug with naval attack upon enemy fleets in a blockade box - resolved.
- Added political shading on/off toggle for main map based on mini-map selection.
- Added additional checks for besieged cities using sea supply to verify no blockades.
- AI Enhancement to restrict risky British and Russian amphib invasions into France and Holland prior to 1813 - resolved.
- Game bug with display of naval unit factors for heavy fleets with both heavy and light ships - resolved.
- Game bug with path and opening files related to loading PBEM gamestart file - resolved.

** NEW, added in update on 2/25/17
- Player view mode bug in PBEM - resolved.
- PBEM Admin Menu bug setting wars with minors - resolved.



Attachment (1)

< Message edited by pzgndr -- 2/25/2017 11:14:14 PM >


_____________________________

Bill
Empires in Arms Development Team
Post #: 1
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 2/7/2017 1:32:05 PM   
jnier


Posts: 402
Joined: 2/18/2002
Status: offline
Many thanks Bill. Keep up the good work!

(in reply to pzgndr)
Post #: 2
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 2/12/2017 6:19:07 PM   
76mm


Posts: 3736
Joined: 5/2/2004
From: Washington, DC
Status: offline
I wanted to mention one other minor glitch with this latest version: I'm playing as Prussia in this game and noticed that several times during the Russian land phase I'm getting messages to the effect of "AI cannot find path".

Also, this is my third game now and I've not yet seen the Russians leave Russia other than a couple of random corps wandering around and in my last game they made an impressive grab of Denmark and Holland. But I've never seen them send large armies through Prussia, Austria, or the other German states, even when they are allied to these states. Maybe they aren't granting Russia access?

(in reply to jnier)
Post #: 3
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 2/12/2017 7:41:15 PM   
pzgndr

 

Posts: 2609
Joined: 3/18/2004
From: Maryland
Status: offline
I'm not sure why players need to see this "AI cannot find path" message so I'll change this to be an AI Log message.

I have in fact seen AI Russians occasionally move into Prussia and Austria, but I agree it needs work. This is one of those operational/strategic AI things I'd like to improve on in the next version.

_____________________________

Bill
Empires in Arms Development Team

(in reply to 76mm)
Post #: 4
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 2/15/2017 3:22:12 PM   
Pans


Posts: 126
Joined: 11/22/2004
From: Germany
Status: offline
I Encounter with our PBEM game (v 1.21.03) that after the Russian Setup the placed Depots are gone. In the Counter pool are only one Depot left and no pieces on the map?
We will install v1.21.04 and hope this will fix this.

_____________________________


(in reply to pzgndr)
Post #: 5
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 2/15/2017 5:36:02 PM   
pzgndr

 

Posts: 2609
Joined: 3/18/2004
From: Maryland
Status: offline

quote:

ORIGINAL: Pans
I Encounter with our PBEM game (v 1.21.03) that after the Russian Setup the placed Depots are gone. In the Counter pool are only one Depot left and no pieces on the map?
We will install v1.21.04 and hope this will fix this.


I have a nagging feeling about problematic data exchanges like this. I've been doing some pbem testing and not able to get through Great Britain's February 1805 diplomacy phase; something is causing the phase to end and lock up upon starting it. I will continue to investigate this and the missing depots issue.

My concern is that the C++Builder 2007 compiler is pre-Vista, which was bad enough before with Win7 using WinXP compatibility mode but it seems to be worse now with Win10. I'm not optimistic that I can resolve these issues for v1.21? If we can't get pbem to work, we may have to wait for the next update. I'd like to get this official release out and then migrate the code to the latest Embarcadero C++Builder Berlin compiler which has Win10 compatibility. Hopefully that will work better and help resolve the various data issues.

_____________________________

Bill
Empires in Arms Development Team

(in reply to Pans)
Post #: 6
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 2/25/2017 11:26:12 PM   
pzgndr

 

Posts: 2609
Joined: 3/18/2004
From: Maryland
Status: offline
I posted an update to the v1.21.04 hotfix in the top post above.

Based on my PBEM playtesting, primarily using Great Britain as host and Prussia as client and the rest as AI, I was seeing a problem with Great Britain locking up in view mode and not normal mode during its Feb 1805 dip phase, preventing it from doing anything. I was also noting Prussia DOWs on adjacent minors during its dip phase were not being implemented, nor could the PBEM Admin menu fix that.

For now, the update appears to fix the view mode problem and in some cases the Admin could perform the DOWs but in some cases not. I will continue to investigate, but for now these fixes should help the PBEM game in progress to proceed. I was also still seeing some loan money transfers working, like from Great Britain to Prussia, but not others like from Austria to Prussia when I test Austria as PBEM host.

Like I said, I will continue to investigate. I could not recreate the missing depots issue. I'll see what I can get done in March and proceed toward an official release with or without PBEM working better.

_____________________________

Bill
Empires in Arms Development Team

(in reply to pzgndr)
Post #: 7
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 4/5/2017 1:30:46 PM   
DCWhitworth


Posts: 675
Joined: 12/15/2007
From: Norwich, England
Status: offline
We've hit a bug with v1.21.04 trying to start a PBEM game.

If you place the gamestart.pbm file in any directory other than the root empires in arms directory you get an error such as "Cannot open file "C:\matrix games\empires in arms\commin\graphics\ui\button\yes.bmp""

The commin part of the path gets changed for whichever directory the gamestart file is loaded from.

If the file is in the root EiA directory it all seems to work OK.

Interestingly I've only seen this issue on Windows 7 PCs, not been able to replicate it on Windows 10.

_____________________________

Regards
David

(in reply to pzgndr)
Post #: 8
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 4/13/2017 5:54:10 AM   
gazfun


Posts: 1047
Joined: 7/1/2004
From: Australia
Status: offline
ok we havent run a game yet waiting on 2 more players. Dont seem to have any problems so far running windows 10

< Message edited by gazfun -- 4/13/2017 6:47:53 AM >


_____________________________

Create your own history at www.thegeneralshq.org
[img]https://www.thegeneralshq.org/images/header-top_TGHQ_headerjpg.jpg[img]

(in reply to DCWhitworth)
Post #: 9
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 4/13/2017 12:33:05 PM   
pzgndr

 

Posts: 2609
Joined: 3/18/2004
From: Maryland
Status: offline

quote:

ORIGINAL: DCWhitworth

If you place the gamestart.pbm file in any directory other than the root empires in arms directory you get an error such as "Cannot open file "C:\matrix games\empires in arms\commin\graphics\ui\button\yes.bmp""

Interestingly I've only seen this issue on Windows 7 PCs, not been able to replicate it on Windows 10.


Interestingly, when I "fix" this problem in the code IDE and run it in debug mode it works but then doesn't work when I run the exe in the installed game. And vice versa. Not sure about the Win7 vs Win10 discrepancy? This stuff drives me nuts. So the latest hotfix had the "fix" that doesn't work, and I have corrected that for the official release installer which I tested the other day. Either I'll get another installer to test first or Matrix will shortly post the v1.21.04 official release. Finally. Please stand by.

I have still noticed issues with pbem in my playtesting that I could not resolve, so we are not out of the woods yet for pbem games. I am slowly wrestling with migrating the game source code to the latest compiler for Win10. Hopefully I will succeed with that (it is not trivial) and then move on to further development, with an initial emphasis on resolving the pbem problems with a hotfix so folks can play the game again.

_____________________________

Bill
Empires in Arms Development Team

(in reply to DCWhitworth)
Post #: 10
RE: New UPDATED v1.21.04 Hotfix for Public Beta - 6/3/2017 10:01:33 AM   
DCWhitworth


Posts: 675
Joined: 12/15/2007
From: Norwich, England
Status: offline

quote:

ORIGINAL: pzgndr


quote:

ORIGINAL: DCWhitworth

If you place the gamestart.pbm file in any directory other than the root empires in arms directory you get an error such as "Cannot open file "C:\matrix games\empires in arms\commin\graphics\ui\button\yes.bmp""

Interestingly I've only seen this issue on Windows 7 PCs, not been able to replicate it on Windows 10.


Interestingly, when I "fix" this problem in the code IDE and run it in debug mode it works but then doesn't work when I run the exe in the installed game. And vice versa. Not sure about the Win7 vs Win10 discrepancy? This stuff drives me nuts. So the latest hotfix had the "fix" that doesn't work, and I have corrected that for the official release installer which I tested the other day. Either I'll get another installer to test first or Matrix will shortly post the v1.21.04 official release. Finally. Please stand by.

I have still noticed issues with pbem in my playtesting that I could not resolve, so we are not out of the woods yet for pbem games. I am slowly wrestling with migrating the game source code to the latest compiler for Win10. Hopefully I will succeed with that (it is not trivial) and then move on to further development, with an initial emphasis on resolving the pbem problems with a hotfix so folks can play the game again.


Just to follow up on this, we've noticed no ill effects from using the work around to get our PBEM game started (place the gamestart file in the root Empires in Arms directory).

_____________________________

Regards
David

(in reply to pzgndr)
Post #: 11
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [Napoleonics] >> Empires in Arms the Napoleonic Wars of 1805 - 1815 >> New UPDATED v1.21.04 Hotfix for Public Beta Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.111