Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Unable To Connect To Firing Unit With Mandatory Datalink?

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> Unable To Connect To Firing Unit With Mandatory Datalink? Page: [1]
Login
Message << Older Topic   Newer Topic >>
Unable To Connect To Firing Unit With Mandatory Datalink? - 12/13/2016 12:27:27 AM   
reezing

 

Posts: 19
Joined: 9/6/2016
Status: offline
Playing the newest community mission pack right now. On mission "The Lost Province", the Type 54A++ Jiangkai 2 refuses to fire HQ-16As against cruise missiles. ctrl+f1 targeting gives the "unable to connect to firing unit with mandatory datalink" message. What is this?

edit: shift+f1 targeting, not ctrl+f1 BOL launch

< Message edited by reezing -- 12/13/2016 1:35:22 PM >
Post #: 1
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 12/13/2016 3:35:13 AM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline
You may need to update the game or database you are using.

Thanks

Mike

_____________________________


(in reply to reezing)
Post #: 2
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 12/13/2016 1:29:18 PM   
reezing

 

Posts: 19
Joined: 9/6/2016
Status: offline
I'm using the Steam version, scenario is using DB 3000 version 447. I'm assuming the database is updated along with the game, or is there a way to manually update the db that I haven't heard of?

(in reply to mikmykWS)
Post #: 3
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 12/13/2016 2:43:20 PM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline
Thanks. Sorry to say its a database error. This was fixed in a future version you should see soon.

Thanks!

Mike

_____________________________


(in reply to reezing)
Post #: 4
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 12/13/2016 6:51:05 PM   
reezing

 

Posts: 19
Joined: 9/6/2016
Status: offline
No worries, glad to hear.

(in reply to mikmykWS)
Post #: 5
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 12/14/2016 8:21:34 AM   
michaelm75au


Posts: 13089
Joined: 5/5/2001
From: Melbourne, Australia
Status: offline

quote:

ORIGINAL: reezing

I'm using the Steam version, scenario is using DB 3000 version 447. I'm assuming the database is updated along with the game, or is there a way to manually update the db that I haven't heard of?

The update will update the program(s), and add new official databases. It will also update the official scenarios as needed. Community scenarios need to be updated independently as they are not part of the official releases.

_____________________________

Michael

(in reply to reezing)
Post #: 6
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 12/14/2016 1:33:06 PM   
reezing

 

Posts: 19
Joined: 9/6/2016
Status: offline

quote:

ORIGINAL: michaelm


quote:

ORIGINAL: reezing

I'm using the Steam version, scenario is using DB 3000 version 447. I'm assuming the database is updated along with the game, or is there a way to manually update the db that I haven't heard of?

The update will update the program(s), and add new official databases. It will also update the official scenarios as needed. Community scenarios need to be updated independently as they are not part of the official releases.

Yes, but the Community Scenario pack was just updated less than a week ago.

(in reply to michaelm75au)
Post #: 7
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 1/1/2017 5:14:48 PM   
Denixen

 

Posts: 11
Joined: 11/19/2014
Status: offline
I can report that the same issue exist for SA-26 [42S6 Morfey] and SA-17 Grizzly [9K37M1-2 Buk-M1-2]. The database fix that was mentioned probably fixed all related datalink issues, but in case it doesn't I just wanted to let you now that there are more than one unit with this problem.

Have a good day!

(in reply to reezing)
Post #: 8
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 1/4/2017 5:08:12 AM   
mavfin

 

Posts: 274
Joined: 6/22/2010
Status: offline
quote:

ORIGINAL: reezing


quote:

ORIGINAL: michaelm


quote:

ORIGINAL: reezing

I'm using the Steam version, scenario is using DB 3000 version 447. I'm assuming the database is updated along with the game, or is there a way to manually update the db that I haven't heard of?

The update will update the program(s), and add new official databases. It will also update the official scenarios as needed. Community scenarios need to be updated independently as they are not part of the official releases.

Yes, but the Community Scenario pack was just updated less than a week ago.


Actually, I just downloaded the Steam version on Friday 12/30 and I'm finding the above to not necessarily be true...

The Steam Community Pack is indeed all updated to DB3000 v447 or CWDB v446, whichever is applicable.

However, the Standalone Scenarios and the Tutorials are not current (DB3000 v445 or CWDB v445). The LIVE DLC scenarios that I paid extra for, bought on Friday, are also DB3000 v445. The Northern Inferno scenarios are at least CWDB v445, and I think at least one was CWDB v444; i.e. not current.

Anyway, is this expected behavior, considering the first question asked here in this forum is if the scenarios are updated? I just downloaded the game on Friday, and it's not all updated. In fact, only the Steam Workshop files are updated so far, except for some scenarios I updated myself. Those had .ini files with them, so it was simple.

I have no issue with rebuilding the ones that need it, but, you probably should make it clear to new people that they need to check *every* new scenario, even the day you download the game, if this is how it is expected to be.

Andy

Note: I actually made a copy of the Scenarios folder before making any changes, just in case I blow one up while updating, so I have copies of the as-downloaded Scenario directories, not including the Steam Workshop Community Pack, if someone wants to see what I got new.

< Message edited by mavfin -- 1/4/2017 5:11:36 AM >

(in reply to reezing)
Post #: 9
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 1/4/2017 1:42:43 PM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline
Hi mavfin

The game is designed to match the database to the scenario when loaded. We generally update the scenarios to match for major updates but it isn't always done with every minor update or patch. Nobody has really ever complained but now that we see one perhaps we should change the process.

Thanks!

Mike

_____________________________


(in reply to mavfin)
Post #: 10
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 1/4/2017 7:35:22 PM   
mavfin

 

Posts: 274
Joined: 6/22/2010
Status: offline
My main intent is to make sure new people know, when you say, as you did in the 2nd post in this thread:
quote:


"You may need to update the game or database you are using.

Thanks

Mike "


That new people don't automatically reply "Of course it's current! I just downloaded the game new yesterday!"

If they know that isn't necessarily the case, they'll know to check the state of the scenario, update it if needed, then they can put in a tech support if they can still duplicate the problem.

As you say, it's not a problem most of the time. But, it does need to be known, particularly for new players. I also wasn't sure if it was supposed to be this way. From the previous post, this is normal. Question answered.

Andy


(in reply to mikmykWS)
Post #: 11
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 1/4/2017 11:40:03 PM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline

quote:

ORIGINAL: mavfin

My main intent is to make sure new people know, when you say, as you did in the 2nd post in this thread:
quote:


"You may need to update the game or database you are using.

Thanks

Mike "


That new people don't automatically reply "Of course it's current! I just downloaded the game new yesterday!"

If they know that isn't necessarily the case, they'll know to check the state of the scenario, update it if needed, then they can put in a tech support if they can still duplicate the problem.

As you say, it's not a problem most of the time. But, it does need to be known, particularly for new players. I also wasn't sure if it was supposed to be this way. From the previous post, this is normal. Question answered.

Andy




Yeah probably not a big deal.

Thanks!

Mike

_____________________________


(in reply to mavfin)
Post #: 12
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 1/13/2017 10:02:15 AM   
MrNerd

 

Posts: 3
Joined: 1/13/2017
Status: offline
Just to let you guys know, this problem is more likely related to the code, not the database. Before the R6 update my ownage cheaty custom ships worked just fine. But after that update, most of my sams stopped working because of that error. Note that this has happened to me in databases 447 and 446, while everything worked fine before the R6 update in 446. If 446 wasn't edited in the R6 update, then it must be the R6 code that has the bug.

My doomsday ships have sam missiles RIM-161E SM-3 NTW Blk IIA, RIM-174A ERAM SM-6MR Blk I, RIM-174A-2 ERAM SM-6MR Blk IA, RIM-116C RAM Blk II, SA-21b Growler [40N6] and RIM-162H ESSM Blk II. Of those RIM-162H is the only one that doesn't seem to have the error and is launchable, though i haven't tested the RIM-161E cause the possible targets are so different. I also remember that some other weapons were affected but can't remember which. The ships are based on zumwalt and i've added some needed datacomms for the weapons that worked before the R6 update.

(in reply to mikmykWS)
Post #: 13
RE: Unable To Connect To Firing Unit With Mandatory Dat... - 1/28/2017 5:40:47 PM   
glappkaeft

 

Posts: 3
Joined: 1/28/2017
Status: offline
FWIW I'm having the same issue with SSM Plt (Milan ER) units in the "Korean Campaign, 2018" community scenario even after I've done a deep rebuild with the 447 database.

(in reply to MrNerd)
Post #: 14
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> Unable To Connect To Firing Unit With Mandatory Datalink? Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.133