Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

WA AP Naval Patrol AD Bug

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Gary Grigsby's War in the West >> Tech Support >> WA AP Naval Patrol AD Bug Page: [1]
Login
Message << Older Topic   Newer Topic >>
WA AP Naval Patrol AD Bug - 10/7/2016 12:48:07 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
I set the Naval Patrol AP AD rather than using the automatic AI. As the WA in Turn 7, there was a bug in the Naval Patrol AD.



Attachment (1)

< Message edited by SLB -- 10/8/2016 11:16:50 PM >
Post #: 1
RE: WA AP Naval Patrol AD Bug - 10/7/2016 1:01:20 PM   
zakblood


Posts: 22300
Joined: 10/4/2012
Status: offline
not enough information given to form an opinion on what you mean, please add more if you wish and try and be clearer on what your trying to say thanks, as atm it just doesn't make any or much sense i'm sorry to say

(in reply to SLB)
Post #: 2
RE: WA AP Naval Patrol AD Bug - 10/7/2016 1:17:02 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
I know - I have spent the past 45 minutes (actual clock time) trying to upload the save and embed the jpeg. Now I am trying one sentence at a time. Tried to upload a save and got the message c:\fakepath\7-AP-Start.sav is not supported. Also, this You are not allowed to post links, emails or phone numbers for 7 days from the
date of your tenth post.

For some reason, I have had problems accessing your website and wrote about this on the Slitherine site and the only way that works at the moment is to use the link to the log in page provided by VPaulus.

< Message edited by SLB -- 10/7/2016 1:24:55 PM >

(in reply to zakblood)
Post #: 3
RE: WA AP Naval Patrol AD Bug - 10/7/2016 1:24:53 PM   
zakblood


Posts: 22300
Joined: 10/4/2012
Status: offline
yes site has rules about links and stuff so it's a 10 post and so many days etc etc

but you can post it at Slitherine and link me, and i'll post it here if you wish?

edited, found your post

http://www.slitherine.com/forum/viewtopic.php?f=31&t=73955

quote:

upload the save and embed the jpeg


do it there, and i'll grab and post it here if that helps?


< Message edited by zakblood -- 10/7/2016 1:27:16 PM >

(in reply to SLB)
Post #: 4
RE: WA AP Naval Patrol AD Bug - 10/7/2016 1:32:23 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
I suspect the problems are more generic - I had a long thread on the Slitherine site, see thread Slitherine and Matrix Websites will not open. Also, I have not had 10 posts, only 4. Couple of questions:
(1) Can I cut/paste a jpeg directly into the message between the image? If I can, the paste command does not work on your site for me.
(2) Can I upload a save directly from my computer, using the upload button?

Because we are slightly out-of-sync at the moment, I will try it. This may take awhile, my paste command will not work - somewhere buried in all the changes I have made to my privacy/security settings is the culprit.

A brief bug description, Turn 7 AP, playing as the WA, two of my five Naval Patrol ADs in the channel are blinking because the purple lines are drawn to the Engineering Rail Group MTO Service in Bizerte

Try one more time to upload save, it is a 2,000kb file. Did not work - do you know what causes/triggers the Matrix site message C:\fakepath\*** is not supported?

Thanks - almost two hours on this and time to walk the dog for a change in the perspective

< Message edited by SLB -- 10/7/2016 1:58:29 PM >

(in reply to zakblood)
Post #: 5
RE: WA AP Naval Patrol AD Bug - 10/7/2016 1:38:41 PM   
zakblood


Posts: 22300
Joined: 10/4/2012
Status: offline
1 no

2 yes

http://www.matrixgames.com/forums/faq.asp#4_7


< Message edited by zakblood -- 10/7/2016 1:39:54 PM >

(in reply to SLB)
Post #: 6
RE: WA AP Naval Patrol AD Bug - 10/7/2016 2:38:26 PM   
Helpless


Posts: 15548
Joined: 8/27/2004
Status: offline
Based on the picture I could say that staging base (formation point) is chosen too far. Was this AD setup by AI or by you?

As for the file upload, you can always send your save to 2by3@2by3games.com.

_____________________________

Pavel Zagzin
WITE/WITW/WITE-2 Development

(in reply to SLB)
Post #: 7
RE: WA AP Naval Patrol AD Bug - 10/7/2016 3:17:55 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
I setup the Naval Patrol AD in Turn 1 and this did not occur until Turn 7.

There is another problem, again maybe my PC settings: tried this: (1) used Mozilla with default settings, (2) renamed the save file to remove special characters, (3) got the save file directly from the game DAT folder, and (4) was going to use a new thread for the bug save. However, this did not work, got the message bug.sav is not supported.

Thanks - I will try your link after I check your suggestion.


< Message edited by SLB -- 10/7/2016 3:26:45 PM >

(in reply to Helpless)
Post #: 8
RE: WA AP Naval Patrol AD Bug - 10/7/2016 3:46:03 PM   
Helpless


Posts: 15548
Joined: 8/27/2004
Status: offline
quote:

I setup the Naval Patrol AD in Turn 1 and this did not occur until Turn 7.


If you setup the way it is drawn, it won't get executed as any plan can have a range to fly across the Europe and then back. This is is due to bad setup for the staging base (aka formation point).

You can reset it manually or delete AD and try to setup it again. I just tried to create Naval patrol AD in 1943 GC and automatic staging base selection worked just fine.

PS. Afaik, you need to to have some certain amount of post before it allows you to attach anything. You can attach either text, image or zip files (gif/txt/jpg/zip are supported). Zipping the save should work.

_____________________________

Pavel Zagzin
WITE/WITW/WITE-2 Development

(in reply to SLB)
Post #: 9
RE: WA AP Naval Patrol AD Bug - 10/7/2016 6:21:21 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
I setup the Naval Patrol around GB using their Coastal Command on Turn 1 and this worked fine until Turn 7. Being a newbie, I used this scenario and Husky as a learning exercise, so I plan to delete all saves except the bug save and start again. Thanks for your assistance.

(in reply to Helpless)
Post #: 10
RE: WA AP Naval Patrol AD Bug - 10/8/2016 11:16:12 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
Back again - same problem occurred and was tested twice, this time with a'bit more information:
(1) In Turn 1, I set the naval patrols for the Coastal HQ's and do not use AI automatic.
(2) Turns 2 and 3 Everything is fine in the AP and Move phases.
(3) Turn 4 Three of the coastal patrols (out of 5) south of Great Britain are showing the staging bases at hex 91,296

Retested by:
(1) Turn 3 Movement - did not move any units went straight to End Turn
(2) Turn 4 AP - three of the coastal patrols (out of 5) south of Great Britain are showing the staging bases at hex 91,296

I have jpeg and the save files. Because of the difficulty sending these to you, see above, what do you want me to do with them?

Thanks

PS: I plan to continue playing the scenario as this is a minor annoyance.

< Message edited by SLB -- 10/9/2016 1:51:42 AM >

(in reply to SLB)
Post #: 11
RE: WA AP Naval Patrol AD Bug - 10/9/2016 1:49:50 AM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
Turn 5 AP: four of the coastal patrols (out of 5) south of Great Britain are showing the staging bases at hex 91,296

I have jpeg and the save files.

Thanks


< Message edited by SLB -- 10/9/2016 1:51:05 AM >

(in reply to SLB)
Post #: 12
RE: WA AP Naval Patrol AD Bug - 10/9/2016 11:10:58 AM   
Helpless


Posts: 15548
Joined: 8/27/2004
Status: offline
Can you please send turn 3 save so I could try to replicate staging base reset. Thanks.

_____________________________

Pavel Zagzin
WITE/WITW/WITE-2 Development

(in reply to SLB)
Post #: 13
RE: WA AP Naval Patrol AD Bug - 10/9/2016 1:58:43 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
Be glad to - however, this may take some effort. On the positive side, this is my 10th post, so the site rules have been satisfied, I hope. Well that did not work again:
(1) tried to upload the game save file and got the "fakepath" message
(2) then took a screen shot of the message and got the 10 posts/7 days. Yes - I know, not 7 days, but I did not include email addresses, links or phone numbers either. Now I am confused - it did upload the screenshot even though I got a message on the 10 posts/7 days that implied my message was not accepted. Without drawing too fine a point, this site has been troublesome to use.

Edit 4 or 6/Last edit rejected (I really need to copy these before I click Ok, because the rejection deletes what I wrote): I will try to upload file on another post entitled Part 2.
Edit 5 or 7/Last edit rejected: there is a serious communication problem between my PC and your site, my last edit rejection (30 seconds ago) was due to the selection of a smiley. Question: Because of the problems I had yesterday, when I was writing one sentence per edit, is there a site limitation on the time span between edits, for example, wait 1 minute before you submit a new edit?

Attachment (1)

< Message edited by SLB -- 10/9/2016 2:31:52 PM >

(in reply to Helpless)
Post #: 14
RE: WA AP Naval Patrol AD Bug - 10/10/2016 4:33:35 PM   
Joel Billings


Posts: 27660
Joined: 9/20/2000
From: Santa Rosa, CA
Status: offline
I received the save you sent 2by3 and sent it on to Pavel (Helpless).

_____________________________

All understanding comes after the fact.
-- Soren Kierkegaard

(in reply to SLB)
Post #: 15
RE: WA AP Naval Patrol AD Bug - 10/10/2016 10:22:32 PM   
Helpless


Posts: 15548
Joined: 8/27/2004
Status: offline
Took a look at the save. Staging base is got reset for some naval ADs, because you have RAF Coastal Command air group stationed in N.Africa, so at some point it becomes last air groups which is still able to fly (although it is not getting the range even after staging base is reset to it's base).

This is pure display issue as it recalculates staging bases on the fly during air execution.

I made a code change, so it will try to recalculate staging bases for the air directives without valid targets (red squares) before air planning.

_____________________________

Pavel Zagzin
WITE/WITW/WITE-2 Development

(in reply to Joel Billings)
Post #: 16
RE: WA AP Naval Patrol AD Bug - 10/11/2016 11:10:01 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
I stopped setting the Naval Patrols manually and use automatic - so I will/can return to setting them manually with no game impact. Minor question, at the end of Turn 3 Movement Phase, the RAF Coastal HQ was hex 79,174. At the beginning of Turn 4 Air Planning, the purple lines are drawn to the Coastal Command for the Med at hex 91,296, if I move the Med Coastal HQ further east will that change the "display problem" or just wait for the next update?

Thanks

< Message edited by SLB -- 10/11/2016 11:16:38 PM >

(in reply to Helpless)
Post #: 17
RE: WA AP Naval Patrol AD Bug - 10/12/2016 8:52:08 AM   
Helpless


Posts: 15548
Joined: 8/27/2004
Status: offline
quote:

Minor question, at the end of Turn 3 Movement Phase, the RAF Coastal HQ was hex 79,174. At the beginning of Turn 4 Air Planning, the purple lines are drawn to the Coastal Command for the Med at hex 91,296, if I move the Med Coastal HQ further east will that change the "display problem" or just wait for the next update?


Location of air HQ is irrelevant. What matters is location of air groups attached to particular air hq. As noted above you have air group stationed in NA which is attached to RAF Coastal HQ. Move this group to UK or reassign it to Med Coastal HQ.

_____________________________

Pavel Zagzin
WITE/WITW/WITE-2 Development

(in reply to SLB)
Post #: 18
RE: WA AP Naval Patrol AD Bug - 10/12/2016 12:36:17 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
I think I understand now. First, I checked the attachments for Turns 1, 3/4 and 13, and the coastal air bases show the HHQ as the Coastal Air Force and the OHQ as the Mediterranean Allie. However, on Turn 4, several airbases in the message box at the bottom had a white/clickable statement: SET AIR GROUP HQ TO 'Coastal Air Force' (1). For Turns 13, seven of the fifteen bases show a "greyed out" statement: SET AIR GROUP HQ TO 'Coastal Air Force' (0). Is this what you are referring to?
Thanks



< Message edited by SLB -- 10/12/2016 2:22:42 PM >

(in reply to Helpless)
Post #: 19
RE: WA AP Naval Patrol AD Bug - 10/12/2016 1:10:52 PM   
Helpless


Posts: 15548
Joined: 8/27/2004
Status: offline
Your issue is not with Coastal Air Force (Med), but with RAF Coastal Air Force (UK).

In the save you sent, Tizi Ouzou air base has VP-63 USN Pa Sqn, which is attached to RAF CAF.

In F10 mode this air base appears with *, which means that it contains air groups from other air hqs.




Attachment (1)

< Message edited by Helpless -- 10/12/2016 1:16:39 PM >


_____________________________

Pavel Zagzin
WITE/WITW/WITE-2 Development

(in reply to SLB)
Post #: 20
RE: WA AP Naval Patrol AD Bug - 10/12/2016 1:12:54 PM   
Helpless


Posts: 15548
Joined: 8/27/2004
Status: offline
quote:

PS: suggest a sales message - WitW should only be played by those who love complexity, detail and micromanagement."


Just details.

_____________________________

Pavel Zagzin
WITE/WITW/WITE-2 Development

(in reply to SLB)
Post #: 21
RE: WA AP Naval Patrol AD Bug - 10/12/2016 1:16:58 PM   
zakblood


Posts: 22300
Joined: 10/4/2012
Status: offline
i play on easy with Air off, well on auto, plays very very well tbh

(in reply to Helpless)
Post #: 22
RE: WA AP Naval Patrol AD Bug - 10/12/2016 1:35:28 PM   
SLB

 

Posts: 22
Joined: 9/30/2016
Status: offline
Thanks for the help.

(in reply to zakblood)
Post #: 23
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Gary Grigsby's War in the West >> Tech Support >> WA AP Naval Patrol AD Bug Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.141