Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Installer doesn't work

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [Current Games From Matrix.] >> [Ancients] >> Hannibal: Rome and Carthage in the Second Punic War >> Tech Support >> Installer doesn't work Page: [1]
Login
Message << Older Topic   Newer Topic >>
Installer doesn't work - 8/1/2015 3:49:10 PM   
jlub

 

Posts: 13
Joined: 1/12/2012
Status: offline
The 1.05 beta installer (the only one available from the Matrix download page) does not work. It is missing files. After install, the game won't start because it says "FATAL ERROR: Unable to load C:\Hannibal\rt\bin\jetvm\jvm.dll". In fact the entire jetvm directory is missing.
Post #: 1
RE: Installer doesn't work - 8/4/2015 4:28:27 AM   
mercenarius


Posts: 637
Joined: 7/6/2010
Status: offline
Naturally I am very sorry for your trouble. I'm looking into this right now.

Did you install this on top of a brand new installation, or on top of an older version?

Of course it should work properly no matter what, but it might help to narrow things down.

_____________________________

James Warshawsky
Forced March Games, LLC

(in reply to jlub)
Post #: 2
RE: Installer doesn't work - 8/4/2015 5:50:19 AM   
jlub

 

Posts: 13
Joined: 1/12/2012
Status: offline
New install; I am trying to install on my new computer. It's Windows 8.1.

Thanks.

(in reply to mercenarius)
Post #: 3
RE: Installer doesn't work - 8/4/2015 5:54:46 AM   
mercenarius


Posts: 637
Joined: 7/6/2010
Status: offline
You should not need to use the 1.0.5 beta installer and you don't want
to use that in any case.

The final release update installer for 1.0.5 is available through the
downloads on the product page. At least, I was able to download it and
it worked fine for me (I did a clean install with version 1.0 and then
ran the 1.0.5 updater).

Please try to manually download the final release version of the 1.0.5
updater and then update the game using that. Since your installation got
mangled, you may need to install from scratch. I don't know. If you do,
you may want to preserve any saved games you have.

Here is the link. The 1.0.5 updater is at the top of the list:

Hannibal Downloads

If you cannot download the 1.0.5 updater from the product page, please
let me know and I'll find out what you need to do.

_____________________________

James Warshawsky
Forced March Games, LLC

(in reply to mercenarius)
Post #: 4
RE: Installer doesn't work - 8/4/2015 6:18:19 AM   
jlub

 

Posts: 13
Joined: 1/12/2012
Status: offline
Ok, it looks like I just downloaded from the wrong place. I went to "My products", then clicked on "Registered" under "Downloads" next to Hannibal. The only download available from there was "HannibalRC-UpdateRelease-105beta.exe", which is the one that didn't work. I'm downloading "HannibalRC-UpdateRelease-105.zip" from the main Hannibal download page now, which hopefully will be the right one. I'll post here tomorrow when I find out if it worked.

Thanks for your help!

(in reply to mercenarius)
Post #: 5
RE: Installer doesn't work - 8/5/2015 4:30:11 AM   
jlub

 

Posts: 13
Joined: 1/12/2012
Status: offline
Nope, this version doesn't work either. Same error, the "rt/bin/jetvm" directory does not exist.

If this is just an update to 1.05, then I need the 1.0 installer, which doesn't appear to be available to download anywhere that I can find.

(in reply to jlub)
Post #: 6
RE: Installer doesn't work - 8/5/2015 5:05:20 AM   
mercenarius


Posts: 637
Joined: 7/6/2010
Status: offline
Well, the base installer for the game you should have
either on the original CD-ROM or as a download if you
purchased the downloadable version. You can't obtain
that from the product page.

It appears that somehow your installation of the game has
gotten corrupted.

I think that you should try to uninstall your existing game. Then
reinstall using the original installer (when you first purchased
the game). Then use the 1.0.5 updater.

You should preserve any saved games before uninstalling the game. You
can do this by manually copying the files in the Saved Games folder to
a temp folder. The path to your "Saved Games" folder should be something
like C:\Matrix Games\Hannibal Rome and Carthage\User Data\Saved Games

The exact location might be different if you changed the default
installation directory for the game. If you haven't played and
saved any games yet, then this doesn't matter, of course.

Obviously you'll need your serial number and your original installer.

If you need more help please contact support at Matrix Games and
they should be able to assist you with installing/reinstalling.

_____________________________

James Warshawsky
Forced March Games, LLC

(in reply to jlub)
Post #: 7
RE: Installer doesn't work - 8/6/2015 2:39:34 AM   
jlub

 

Posts: 13
Joined: 1/12/2012
Status: offline
So, I apparently don't have my original installer download anymore. I was able to simply copy the entire installed game from my old computer to my new computer, then apply the 1.05 patch, which seems to have worked find.

But it does seem a bit nuts that I can't re-download the original installer (as a registered owner of the game, with a serial number, which I bought through the Matrix website originally). Thanks for reminding me why I usually buy games on Steam.

(in reply to mercenarius)
Post #: 8
RE: Installer doesn't work - 1/2/2016 6:09:00 PM   
rajmondas

 

Posts: 2
Joined: 1/2/2016
Status: offline
Hello,

I've purchased the game, downloaded, then downloaded the update installer from the website as suggested above. Several times. Also tried removing the game and clear installs. But the game won't run. When I 'Play a new game' the screen goes dark for a while, then there is some blinking and after a minute or so I am back at the game menu. At the same time I can read all the help files via the game menu.

My system is able to run Civilization V (I have direct 10) and my card is Intel HD Graphics 4000. Are you able to help me somehow?

Thank you!

r.

(in reply to jlub)
Post #: 9
RE: Installer doesn't work - 1/2/2016 8:17:38 PM   
zakblood


Posts: 22685
Joined: 10/4/2012
Status: online

quote:

ORIGINAL: jlub

So, I apparently don't have my original installer download anymore. I was able to simply copy the entire installed game from my old computer to my new computer, then apply the 1.05 patch, which seems to have worked find.

But it does seem a bit nuts that I can't re-download the original installer (as a registered owner of the game, with a serial number, which I bought through the Matrix website originally). Thanks for reminding me why I usually buy games on Steam.


There's no limit to the number of times you may request for new download links.

Just open a tech support ticket or contact support[at]slitherine.co.uk / http://www.matrixgames.com/support/ with your order details (order reference number or/and email address used when placed the order) and they will provide you with new download links.

(in reply to jlub)
Post #: 10
RE: Installer doesn't work - 1/2/2016 8:18:16 PM   
zakblood


Posts: 22685
Joined: 10/4/2012
Status: online

quote:

ORIGINAL: rajmondas

Hello,

I've purchased the game, downloaded, then downloaded the update installer from the website as suggested above. Several times. Also tried removing the game and clear installs. But the game won't run. When I 'Play a new game' the screen goes dark for a while, then there is some blinking and after a minute or so I am back at the game menu. At the same time I can read all the help files via the game menu.

My system is able to run Civilization V (I have direct 10) and my card is Intel HD Graphics 4000. Are you able to help me somehow?

Thank you!

r.


How to get a DxDiag report file:

1. Click on "START" (on Windows 8 press “Windows key” and the “R” key at the same time)
2. Click "run" (skip this step on Windows 8)
3. Type in "dxdiag" and click "OK"
4. Check through the tabs and perform all tests
5. Click "Save all Information..." and save the text file to a location of your choice

We prefer that DxDiag files be posted as message attachments rather than pasted into the body of the post.

add the exe of the game to your Anti Virus and firewall program, to make sure check the logs of these to see if it was one of them which was to blame.

That usually means a 3rd party program, like an Internet security programs, is interfering with the game or update installation.

run the game from a admin account and use full admin permissions.

please make sure all game pre requisite are installed with the game, even if you think or fully know there are already installed, it will only over write, and it may be that you have a older or newer version of these where as the game in question may need a certain version.

please make sure you are running the latest game version and have up to date drivers installed on you pc,

If you have the original version. So you'll need to update it from the Internet.
Please note that you'll only need the last update, as our updates are comprehensive.

(in reply to rajmondas)
Post #: 11
RE: Installer doesn't work - 1/3/2016 4:53:26 PM   
rajmondas

 

Posts: 2
Joined: 1/2/2016
Status: offline
Hello zakblood and thank you for you response.
I did everything as advised but the exe after being executed results in some blinking of the screen, then it goes black and then reverts to my game menu. Any suggestions?
I am not allowed to post any links to the forum, for unknown reasons, unfortunately.

r.

(in reply to zakblood)
Post #: 12
RE: Installer doesn't work - 1/3/2016 6:01:25 PM   
zakblood


Posts: 22685
Joined: 10/4/2012
Status: online
as per PM, change dpi down to default

(in reply to rajmondas)
Post #: 13
Page:   [1]
All Forums >> [Current Games From Matrix.] >> [Ancients] >> Hannibal: Rome and Carthage in the Second Punic War >> Tech Support >> Installer doesn't work Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.385