Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[1.9.5.10] custom game Pirate w/o other empires :(System.ArgumentOutOfRangeException)

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> [1.9.5.10] custom game Pirate w/o other empires :(System.ArgumentOutOfRangeException) Page: [1]
Login
Message << Older Topic   Newer Topic >>
[1.9.5.10] custom game Pirate w/o other empires :(Syste... - 2/10/2015 11:31:38 AM   
RoqueNE


Posts: 24
Joined: 11/3/2013
Status: offline
Hello

looks like a nasty bug made it through the quality assurance.

try to play a custom pirate game with this settings:
Galaxy: Ellipticial
Star Ammount: 1400
Physical Size: 15x15
Expansion: Prewarp
Aggression: Normal
Difficulty: Normal
Research: Normal
Creatures: Normal
Pirates: None

Colony Prevalence: Scarce
Independent Alien: Normal
Colony Influence: 104%
Colonization Range: 2,00

Race: Ketarov
TechLevel: Normal
Playstyle: Balanced
Starting Location: Random

Auto-Generate Empires: Off
Allow Independent: Off

Victory Condition: All off
Events: All on (except Shakturi)
Allow Tech Trading: On
Allow Kaltos: Off

and every time i click on start this happens:


Unfortunately, no crash log is created.


Please fix this



RoqueNE

< Message edited by RoqueNE -- 2/13/2015 4:34:19 PM >
Post #: 1
RE: [1.9.5.10] Game breaking Bug (System.ArgumentOutOfR... - 2/10/2015 1:58:22 PM   
ehsumrell1


Posts: 2519
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline
Hello RoqueNE;

I'm attempting to recreate your game situations to see if I can assist. But I have a quick
question.

According to your settings shown:

Auto-Generate Empires: Off

I'm assuming that either you have no other races in the game to compete against or either
you have manually selected a certain number of races in the bottom section of the "Other Races"
selection screen. If the latter is the case, can you post what those settings were please (i.e.
Race name, government, tech settings, etc.)




_____________________________

Shields are useless in "The Briar Patch"...

(in reply to RoqueNE)
Post #: 2
RE: [1.9.5.10] Game breaking Bug (System.ArgumentOutOfR... - 2/10/2015 7:39:33 PM   
RoqueNE


Posts: 24
Joined: 11/3/2013
Status: offline
in this case, I play actually completely alone. To try different things.

and.. i just realized, that's the error.
when the automatic generation is disabled and no empires set manually, the game crash.

with at least 1 other empire, it works.
lol -_-


< Message edited by RoqueNE -- 2/10/2015 8:40:17 PM >


_____________________________


(in reply to ehsumrell1)
Post #: 3
RE: [1.9.5.10] Game breaking Bug (System.ArgumentOutOfR... - 2/10/2015 8:21:47 PM   
Bingeling

 

Posts: 4704
Joined: 8/12/2010
Status: offline
I am quite sure I have started multiple games "all alone" to check various stuff. Obviously there is something off in this case.

(in reply to RoqueNE)
Post #: 4
RE: [1.9.5.10] Game breaking Bug (System.ArgumentOutOfR... - 2/10/2015 9:48:31 PM   
Osito


Posts: 851
Joined: 5/9/2013
Status: offline
quote:

ORIGINAL: Bingeling

I am quite sure I have started multiple games "all alone" to check various stuff. Obviously there is something off in this case.


Indeed, you can play the game with no other empires present. The real problem lies somewhere else. Anyway, I'm glad it seems to be working for you, RogueNE.

Osito

< Message edited by Osito -- 2/10/2015 10:48:53 PM >

(in reply to Bingeling)
Post #: 5
RE: [1.9.5.10] Game breaking Bug (System.ArgumentOutOfR... - 2/10/2015 10:25:55 PM   
ehsumrell1


Posts: 2519
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline

quote:

ORIGINAL: RoqueNE

in this case, I play actually completely alone. To try different things.

and.. i just realized, that's the error.
when the automatic generation is disabled and no empires set manually, the game crash.

with at least 1 other empire, it works.
lol -_-



So my first assumption was correct. As I recall, in my testing notes somewhere there was something that
mentioned this error. It seems that due to ruins that are explored having the ability to trigger an event,
such as 'awaking a sleeping race' or the like, then of course, an array error would naturally occur because
the game engine would not have an empire race to point to. So not such a 'nasty' bug after all.

@Bingeling:
Yes, I too have tested DW and some mods the same way. But the errors that do eventually pop up I often
anticipated and expected because I was privy to most of Elliot's game logic.

_____________________________

Shields are useless in "The Briar Patch"...

(in reply to RoqueNE)
Post #: 6
RE: [1.9.5.10] custom game Pirate w/o other empires :(S... - 3/18/2015 11:12:34 PM   
elliotg


Posts: 3234
Joined: 9/10/2007
Status: offline
Thanks for the report RoqueNE

This is fixed in the next update.

Elliot

(in reply to RoqueNE)
Post #: 7
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> [1.9.5.10] custom game Pirate w/o other empires :(System.ArgumentOutOfRangeException) Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.115