Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

[Bug][1.9.5.10] Pirate Private Ship Component Upgrades and Retrofit - Save file uploaded

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> [Bug][1.9.5.10] Pirate Private Ship Component Upgrades and Retrofit - Save file uploaded Page: [1]
Login
Message << Older Topic   Newer Topic >>
[Bug][1.9.5.10] Pirate Private Ship Component Upgrades ... - 2/5/2015 5:25:08 PM   
charnowc182

 

Posts: 4
Joined: 2/2/2015
Status: offline
I've found multiple issues when playing as pirate in version DWU 1.9.5.10. I've uploaded the save file which shows all relevant issues to the ftp site named as 'bug pirate component retrofit.dwg' Detailed descriptions are below.

1. Pirate private ship components are using only base values. This is shown in save file, as I enabled upgrades to existing ship components such as shields (100 -> 120), hyperdrive speed (12500 ->18750), fuel storage (65 ->80) etc. All state ships instantly will show upgraded values (120 str shields, faster hyperjump speed, even mid jump). Private (smuggler/mining) ships do not use the new researched values. Note that this does NOT involve any component changes, simply making existing ones better (from user perspective anyway).

Additionally, this is seen when constructing a private ship. While under construction, you can see the ship will have correct values (shield str 0 out 120). However, once completed, and given the smuggler/independent faction flag, the components instantly revert to base values (back to shield str 100, slow hyperdrive etc).

This issue is particularly crippling for smuggling based pirate playstyle, as most of your private smuggling ships will continue to move at such a slow hyper speed, that they can not even make it to smuggling targets before the mission ends, resulting in significant revenue loss. This, combined with the retrofit issue, described below as #3, results in private pirate smuggler ships that cant upgrade existing components, and cant even retrofit to newer components, staying at their pathetic values for an entire game.

2. Pirate Private Design - related to #1 above. Strangely, when starting the save game (uploaded, name above), I put the AI to auto upgrade designs. I then enabled research upgrades to existing components (shield str, hyper speed etc). After this, I then created my first medium freighter with the AIs base auto upgraded design. This medium freighter had correct component values (higher shield str 120, moved at 18500 hyper speed etc). HOWEVER, as soon as I turned this setting off, and manually upgraded the design (even with NO component changes at all, just name change to mk2), any further created medium freighters (mk2) would use base component values (slow hyperspeed, low shield str). This can be seen in the save file. a few medium freighters listed there will have updated speed/shield. Very strange...

3. Pirate Retrofit - Pirate private ships will never retrofit. I tried with a variety of retrofit settings including the following: (also note tried each of the scenarios while private ships had extra time (were often on 'No Mission') and also leaving game on 4x for a extended period.
-Empire policy settings - tried different settings here, private ships never upgrade.
-Design Screen settings - Tried putting to manual vs auto upgraded, also tried design setting to only retrofit when manually told or auto retrofit. Both ways wont have pirate private smugglers retrofit
-Ship list/grid command - I also tried telling private smuggler ships to Retrofit manually by clicking the ship in the grid, hitting Retrofit and selecting the design (with cost listed). This does nothing, ship continues to have No Mission.

Net result here is that I cannot find any way at all to get pirate private ships to upgrade. They never will. Also not related to materials, as I tried newer designs with less components (0 cost in money or materials).

Let me know if any other info is necessary.


Post #: 1
RE: [Bug][1.9.5.10] Pirate Private Ship Component Upgra... - 3/18/2015 11:14:39 PM   
elliotg


Posts: 3305
Joined: 9/10/2007
Status: offline
Thanks for the report charnowc182

These issues are fixed in the next update

Elliot

(in reply to charnowc182)
Post #: 2
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> [Bug][1.9.5.10] Pirate Private Ship Component Upgrades and Retrofit - Save file uploaded Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.135