Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Modding Resources

View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> Modding Resources Page: [1]
Message << Older Topic   Newer Topic >>
Modding Resources - 1/20/2015 10:27:44 PM   


Posts: 38
Joined: 1/20/2015
Status: offline
Hello everyone, though this is my first time posting I've been stalking this forum for ages,watching from the shadows while stroking a picture of a physical copy of DW:U and all that. . . I've recently just gone and lost what hopes I had for a realism themed overhaul of the resource system to come out, so I went ahead and tried my hand at it. Not as soul crushing as an overhaul of the tech-tree, but well, I can't even get the game to start. I know this is often related to something being written incorrectly or a comma missing somewhere (been tweaking stuff for DW:U ever since I got my hands on it). In all honesty I'm at my wit's end here, can't for the life of me find what may be wrong, tried just about anything and everything, gone over it hundreds of times, still can't get the darn thing to work. Maybe someone willing to look it over may find just what's wrong with it, always good to have another pair of fresh eyes look over it and all that. . . Anyone willing to lend some assistance? Attached is like my 100th revision of this darn thing.

[And yes, if I manage to get it working I plan on releasing it in here of course. Going to need victims *cough* testers, to get this monster balanced anyways. . .]

Attachment (1)
Post #: 1
RE: Modding Resources - 1/22/2015 1:30:48 AM   

Posts: 233
Joined: 5/23/2014
From: Pittsburgh
Status: offline
I didn't look at the file but I'm guessing you tried to remove gold as a resource, or maybe even changed its number or something. It likely crashes the game because of its connection with those solid gold asteroids. If this isn't the case then I'm not sure what it is.

(in reply to Overlord015)
Post #: 2
RE: Modding Resources - 1/22/2015 1:56:46 AM   

Posts: 2529
Joined: 8/17/2010
From: The Briar Patch Nebula
Status: offline
Hello Overload015, and welcome to the forums (officially)!

I've looked at your resources file and the first thing I noticed that would cause the
immediate crash you're having at load is that you've removed the 3 super luxury resources
that the game MUST HAVE to operate. Loros Fruit, Korrobian Spice, and Zentabia Fluid are
missing. Replace them back into your file with their original ID 19, 22, & 35 respectively.
That should solve your problem. The game MUST have these 3 resources to run. You can add
additional super luxury or regular luxury resources, but these three must be there. There
MIGHT be a strategic resource that is mandatory as well. Hope this helps!
Please post back if you still can't get things running.

< Message edited by ehsumrell1 -- 1/22/2015 3:08:58 AM >


Shields are useless in "The Briar Patch"...

(in reply to Overlord015)
Post #: 3
RE: Modding Resources - 1/22/2015 1:22:10 PM   


Posts: 38
Joined: 1/20/2015
Status: offline
Hello, thank you for your responses.

On the gold issue: Yeah I'm aware of it, I've actually played your mod (mensrea) and read about that from your attempts at taking gold out, so I really didn't touch it other than altering its percentages on its original spawns and making it spawn at other new ones. I'll try restoring it to vanilla values though, and see where that takes me. BTW, in your attempts at altering it, did you try simply renaming it? Did it still give you problems when you did so?

On the super luxuries: Hmmm, didn't expect that one, though all I really did was rename them and as with gold altered their distribution and percentages, though their positions (IDs) on the resource list seemed to have changed as I organized it so the the strategics were on top, luxuries on the middle, and synthetics on the bottom. I'll restore them to their original ID's and run the same test as with gold and see how it goes as well.

I thank you both for your assistance, I'll get the changes and tests done when I get the chance, I'll bring the results this Friday/Saturday.

(in reply to ehsumrell1)
Post #: 4
RE: Modding Resources - 1/22/2015 6:19:24 PM   


Posts: 110
Joined: 8/15/2014
Status: offline
About the gold issue: There was an earlier unfinished attempt to make a realistic ressource mod. Gold wasn't used and it didn't crashed when I tried it.

I think it was this mod:

(in reply to Overlord015)
Post #: 5
RE: Modding Resources - 1/22/2015 11:39:19 PM   


Posts: 38
Joined: 1/20/2015
Status: offline
Nailed it, it was not only the luxuries issue, but also a few elusive missing commas and typos. Also it seems that apparently you can't place luxuries on asteroids, bummer. Now gotta rework component resource reqs, add solid state fuel reactors (uranium and thorium), and do something about the whole planets starting with 25 resources, while there are entire 10-planet systems with only one. . . *sigh*

Thank you all for the help!

(in reply to Japhet)
Post #: 6
RE: Modding Resources - 1/23/2015 6:56:26 AM   

Posts: 174
Joined: 11/29/2012
Status: offline
Before attempting to try solid fuel sources like Uranium, there have been some attempts on that topic (one of them by me) that indicate that the game engine has difficulties handling non-gas fuels. I think it was mensrea in his Wh40k conversion mod who encountered similar problems. You might want to look for those threads to save yourself from experiencing the same frustration. I even have the suspicion that Caslon was introduced because the system didn't handle Uranium very well.

Not that I want to discourage you, I would love to see solid fuels working, maybe you're the guy who can make it happen.


(in reply to Overlord015)
Post #: 7
RE: Modding Resources - 1/23/2015 3:43:18 PM   
Fishers of Men

Posts: 329
Joined: 3/27/2010
From: Fishers, IN USA
Status: offline
For a few years I have been using Arcatus Actual Resources 1.3 mod. It is a good improvement. But Overlord015, your mod sounds very interesting and ambitious, to say the least. I hope you can work out the results you want. I will be waiting to see the outcome.


Old............but very fast

(in reply to Sirian)
Post #: 8
RE: Modding Resources - 3/23/2015 4:26:41 PM   


Posts: 38
Joined: 1/20/2015
Status: offline
Can't believe I find myself crawling back into this thread. . . Finally got some time off college duties and sat down to mod, been working on balancing the resource spawn rates. Then this error started popping up when trying to generate a test run:


There was an error while attempting to start a new game. If you are using a theme, please revert to the default Distant Worlds theme and try again

Error Details:

System.NullReferenceException: Object reference not set to an instance of an object.

at DistantWorlds.Types.Galaxy.SetupSolarSystem(GalaxyShape galaxyshape, Habitat sunHabitat, HabitatList&asteroidField)

at DistantWorlds.Types.Galaxy..ctor(Int32 galaxyRandomSeed, GalaxyShape galaxyShape, Int32 starCount, Double colony Prevalence, Int32 lifePrevalence, Double creaturePrevalence,DoublepiratePrevalence, Int32 pirateProximity, Int64 starDate, DoublebaseTechCost, Double hyperdriveSpeedMultiplier, Int32 age, Double aggressionLevel, Int32 maximumEmpireAmount, Boolean spawnNewEmpires, EmpireStartList empireStartrts, String applicationStartupPath, String customizationSetName, Bitmap galaxyBackground, Bitmap[] cloudImages, Double difficultyLevel, Int32 sector Width, Int32 sectorHeight, ResourceSystem resourceSystem, Boolean allowGiantKaltorGeneration)

at DistantWorlds.Start.wPyBURij0T(GalaxyShape , Int32 , Int32, Boolean , Double , Int32 Double , Double , Int32 , Double , Double , EmpireStart , EmpireStartList , VictoryConditions , EmpireVictoryConditions , EMpireVictoryConditions , Boolean , Boolean , GameStartResets )

(Yes, i just typed that in, too low level or something to post pictures apparently)

Interestingly when i revert to past revisions, it runs just fine, have compared the different revisions and I just can't find anything that may cause trouble. I don't think its something along the lines of a typo, misplaced ID/resource, etc. If this were the case the game wouldn't even start. Also this error doesn't CTD the game, it just keeps me from starting a game, regardless of settings or whether I chose to play as empire or pirate. Tested a few things to make sure this wasn't coming from somewhere else, but it only confirmed even further that something in the latest revision of the resource file must be bringing on this nonsense.

Been trying to crack this one for 3 days now (I wonder what did I break this time), any ideas?

(in reply to Fishers of Men)
Post #: 9
RE: Modding Resources - 3/31/2015 4:20:19 PM   

Posts: 207
Joined: 3/6/2015
Status: offline
Just taking a stab in the dark here (relatively new mod'r of DW myself)...

But have you tried using the unsurpassed Beyond Compare (free download) to look at the differences? You can look at all changes quickly, across all of your files, and double-check that they're saved as UTF-8 + BOM (PC). I have only seen one file absolutely require that it be saved as a UTF-8 file: GameText.txt - as it contained unicode characters and not just ASCII ones. Other files (so far) seem not to care, but maybe your issue is an ascii written file that is giving DW the bends?

(in reply to Overlord015)
Post #: 10
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> Modding Resources Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI