Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

If I did not have XNA framework installed

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds 1 Series >> If I did not have XNA framework installed Page: [1]
Login
Message << Older Topic   Newer Topic >>
If I did not have XNA framework installed - 1/3/2015 2:48:39 AM   
Justtheguybob

 

Posts: 27
Joined: 6/1/2014
Status: offline
I Noticed A huge bit of lag later on in the game after 4-5 hours.. So i began to search for why.. It turns out i did not have xna installed

Could this cause a significant performance drain?

Thanks for any answers.

(I Just now installed it and am going to test it will take me a while but an answer would still be nice just so I know for the future if having it vs not having it would cause a performance issue)




However after installing / testing it with xna (Previously had no issues) I am now getting this error with just the base vanilla game (My gpu and all drivers are up to date)

---------------------------
Error
---------------------------
An error has occurred. Distant Worlds will now exit.

Details of the error are below:

Error Code: ProcGx

System.OutOfMemoryException: Insufficient memory to continue the execution of the program.

at Microsoft.Xna.Framework.Helpers.GetExceptionFromResult(UInt32 result)

at Microsoft.Xna.Framework.Graphics.GraphicsHelpers.GetExceptionFromResult(UInt32 result)

at Microsoft.Xna.Framework.Graphics.Texture2D.CreateTexture(GraphicsDevice graphicsDevice, Int32 width, Int32 height, Boolean mipMap, UInt32 usage, _D3DPOOL pool, SurfaceFormat format)

at Microsoft.Xna.Framework.Graphics.Texture2D..ctor(GraphicsDevice graphicsDevice, Int32 width, Int32 height, Boolean mipMap, SurfaceFormat format)

at DistantWorlds.XnaDrawingHelper.FastBitmapToTexture(GraphicsDevice graphics, Bitmap bitmap, Boolean useAlternateBuffer)

at DistantWorlds.XnaDrawingHelper.FastBitmapToTexture(GraphicsDevice graphics, Bitmap bitmap)

at DistantWorlds.Controls.MainView.DrawMainViewXna()

at DistantWorlds.Main.ProgramLoop()
---------------------------
OK
---------------------------

Ive since then reinstalled the game from my SSD ( Which has 76 gb free) to on to my Hard drive which has 811 gb free

Got this crash

---------------------------
Error
---------------------------
An error has occurred. Distant Worlds will now exit.

Details of the error are below:

Error Code: GxEmP

System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown.

at System.Array.Resize[T](T[]& array, Int32 newSize)

at Microsoft.Xna.Framework.Graphics.SpriteBatch.InternalDraw(Texture2D texture, Vector4& destination, Boolean scaleDestination, Nullable`1& sourceRectangle, Color color, Single rotation, Vector2& origin, SpriteEffects effects, Single depth)

at DistantWorlds.XnaDrawingHelper.DrawLine(SpriteBatch spriteBatch, Vector2 vector1, Vector2 vector2, Color color, Int32 lineThickness, Boolean dashed, Texture2D arrowHeadTexture)

at DistantWorlds.XnaDrawingHelper.DrawLine(SpriteBatch spriteBatch, Single x1, Single y1, Single x2, Single y2, Color color, Int32 lineThickness, Boolean dashed, Texture2D arrowHeadTexture)

at DistantWorlds.Controls.MainView.QaGaRuAnapQ(SpriteBatch , Empire , Double , Int32 , Int32 , Int32 , Int32 )

at DistantWorlds.Controls.MainView.VayaRPv5lvB(SpriteBatch , SpriteBatch , Int32 , Int32 , Int32 , Int32 , Double , Int32 )

at DistantWorlds.Controls.MainView.DrawMainViewXna()

at DistantWorlds.Main.ProgramLoop()
---------------------------
OK
---------------------------




Heres a dxdiag


Attachment (1)

< Message edited by Justtheguybob -- 1/3/2015 5:00:25 AM >
Post #: 1
RE: If I did not have XNA framework installed - 1/3/2015 5:09:43 AM   
twinkypillow

 

Posts: 184
Joined: 9/11/2012
Status: offline
what the hell.. sounds like you uninstalled XNA framework. haha.


(in reply to Justtheguybob)
Post #: 2
RE: If I did not have XNA framework installed - 1/3/2015 8:11:08 AM   
Justtheguybob

 

Posts: 27
Joined: 6/1/2014
Status: offline
quote:

ORIGINAL: pumkinfacer22

what the hell.. sounds like you uninstalled XNA framework. haha.




Ya its really weird... I did a repair on it and now it seems to be working but its still very laggy / stuttery on the max galaxy late game (maxed stars/size).. Talking to a guy on steam he said he has no lag at all with a 3.3 ghz cpu.. idk maybe im on drugs ive tried my computer in a non overclocked state and it overclocked at 4.5 Ghz and it still is super has problems.

Ive tried changing my ram settings also..

At any rate heres a full spec of my computer
Windows 7
Intel Core i7 3970X @4.5 (I tried at its base clock speed,it made it even slower)
16Gb (4x4) Gskill Ripjaws X 1600Mhz F3-12800CL9Q-16GBXL
16.0GB DDR3 @ 800MHz (Its really 1600 MhZ just the way the program puts it)
Gigabyte Technology Co., Ltd. X79-UP4
22EA53 (1920x1080@60Hz)
3071MB NVIDIA GeForce GTX 780 (EVGA) 31 °C
3071MB NVIDIA GeForce GTX 780 (EVGA) 26 °C
ForceWare version: 347.09
SLI Disabled
238GB ATA Samsung SSD 840 SCSI Disk Device (SSD) 29 °C
112GB ATA Corsair Force GT SCSI Disk Device (SSD) 29 °C
2795GB ATA ST3000NC002-1DY1 SCSI Disk Device (SATA) 33 °C
Realtek High Definition Audio

(Just to simplify the dxdiag)

Gonna leave it running over night at 4x speed and see if I get a crash when I wake up.. (On a smaller galaxy size just to see what happens)

< Message edited by Justtheguybob -- 1/3/2015 9:20:53 AM >

(in reply to twinkypillow)
Post #: 3
RE: If I did not have XNA framework installed - 1/3/2015 8:26:40 AM   
twinkypillow

 

Posts: 184
Joined: 9/11/2012
Status: offline
Ok, GET BACK over to steam and ask that guy to post and give you his exact system with all info!! i need that.

I can't post on steam cause I don't have the steam version.. can you believe that ****? i can't post on a forum cause i don't have the "steam" version of the game.. anyway whatever..

but i don't really believe that guy either. I have a very similar system like yours.. 840 Evo, 16 gigs ram.. i7 4700mq... 2 gig nvidia 755m

anyway get his specs.. even maybe ask him to use speccy and send you the snapshot.. anything..

but then come back here and post his system
.. maybe even ask him what he has tweaked..

pretty please?

(in reply to Justtheguybob)
Post #: 4
RE: If I did not have XNA framework installed - 1/3/2015 8:28:14 AM   
twinkypillow

 

Posts: 184
Joined: 9/11/2012
Status: offline
also after you get all that info from him, send me your save game.. i can try it..

although you have it modded yes? believe it or not, i have been playing vanilla universe. updated to latest of course..


(in reply to twinkypillow)
Post #: 5
RE: If I did not have XNA framework installed - 1/3/2015 5:14:38 PM   
Justtheguybob

 

Posts: 27
Joined: 6/1/2014
Status: offline

quote:

ORIGINAL: pumkinfacer22

also after you get all that info from him, send me your save game.. i can try it..

although you have it modded yes? believe it or not, i have been playing vanilla universe. updated to latest of course..





I asked him he has a 3.3 Ghz cpu non oced. Mine is 3.5 non oced and still lags like crazy my specs were far better in every way than his. I am baffled. I think he is just trolling tbh.

(in reply to twinkypillow)
Post #: 6
RE: If I did not have XNA framework installed - 1/3/2015 6:50:21 PM   
twinkypillow

 

Posts: 184
Joined: 9/11/2012
Status: offline
Look, every system has bottlenecks,

you need to know his motherboard exact model and exact model ram etc.. just out of curiosity..

maybe he has the latest greatest MSI motherboard with some features that make it superspeed hyper technology or whatever..

***Edit** see next post below for latest *****

quote:

here is the latest i could find right now. check these out
MSI z97 gaming 5, ASRock z97 fatal1ty stuff, ASUS Maximus (i bet these are already old now)


http://rog.asus.com/316922014/asus-gaming-motherboards/asus-first-in-world-to-unleash-full-sata-express-performance/

(i'm sure these aren't the latest out right now..)

but i also think he is kinda lying. everybody gets lag late game with this coding/programming..


my problems are as such in my posted below pic.. "unknown" ram?? come on.. you know those timings are crappy on that bad puppy..-and a lenovo motherboard. yikes. i dont even want to know my Front-side-bus and settings on this thing.

*older links but give you the idea*
http://www.computershopper.com/feature/the-complete-guide-to-buying-a-motherboard4
http://computer.howstuffworks.com/motherboard4.htm


thats all i got for now..







Attachment (1)

< Message edited by pumkinfacer22 -- 1/3/2015 8:29:06 PM >

(in reply to Justtheguybob)
Post #: 7
RE: If I did not have XNA framework installed - 1/3/2015 7:26:08 PM   
twinkypillow

 

Posts: 184
Joined: 9/11/2012
Status: offline
ok just found the most crazy speed and most costing motherboard and cpu for no lag gaming.. here you go.

Rampage V extreme
http://www.asus.com/us/Motherboards/RAMPAGE_V_EXTREME/


Cpu

http://ark.intel.com/products/82930/Intel-Core-i7-5960X-Processor-Extreme-Edition-20M-Cache-up-to-3_50-GHz

Ram
http://www.gskill.com/en/products (whichever but most expensive buy..)

SSD Harddrive
http://www.gskill.com/en/finder?cat=265&series=2307


now you go play largest map 47 empires and tell me if you get lag?


(in reply to twinkypillow)
Post #: 8
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds 1 Series >> If I did not have XNA framework installed Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.151