Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Trouble with lag late game with 6x6 x 700 stars

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds 1 Series >> Tech Support >> Trouble with lag late game with 6x6 x 700 stars Page: [1]
Login
Message << Older Topic   Newer Topic >>
Trouble with lag late game with 6x6 x 700 stars - 1/3/2015 1:43:24 AM   
Justtheguybob

 

Posts: 27
Joined: 6/1/2014
Status: offline
This game is so laggy late game.. even with 6x6 x 700
Here are my specs..

(This is with 45 empires if that is good information to have in here)


Windows 7
Intel Core i7 3970X @ 4.3 GhZ
16.0GB DDR3 @ 799MHz (11-11-11-28)
22EA53 (1920x1080@60Hz)
3071MB NVIDIA GeForce GTX 780 (EVGA) 32 °C
3071MB NVIDIA GeForce GTX 780 (EVGA) 28 °C
ForceWare version: 347.09
SLI Disabled

238GB ATA Samsung SSD 840 SCSI Disk Device (SSD) 29 °C
112GB ATA Corsair Force GT SCSI Disk Device (SSD) 30 °C
2795GB ATA ST3000NC002-1DY1 SCSI Disk Device (SATA)



If I am playing a game at 6x6 x 700 stars the game becomes UNPLAYABLE Later on in the game (By later on I mean 5-6 hours down the road) It is so laggy and stuttery its crazy.

Everything I have is up to date driver wise.







Am I doing something wrong? Does everyone lag or what?

It crashes very rarely with this







10:37:40 AM Finalizer: System.NullReferenceException: Object reference not set to an instance of an object.
at DistantWorlds.Types.SteamAPI.Shutdown()11:21:43 AM Finalizer: System.NullReferenceException: Object reference not set to an instance of an object.
at DistantWorlds.Types.SteamAPI.Shutdown()8:49:57 PM Finalizer: System.NullReferenceException: Object reference not set to an instance of an object.
at DistantWorlds.Types.SteamAPI.Shutdown()1:27:59 AM Finalizer: System.NullReferenceException: Object reference not set to an instance of an object.
at DistantWorlds.Types.SteamAPI.Shutdown()

< Message edited by Justtheguybob -- 1/3/2015 2:45:32 AM >
Post #: 1
RE: Trouble with lag late game with 6x6 x 700 stars - 1/3/2015 4:59:31 AM   
twinkypillow

 

Posts: 184
Joined: 9/11/2012
Status: offline
honey.. welcome to whatever framework coding bullcrap Distant Worlds Creator decided to use..

i love the game.. but obviously he chose the absolute worst engine/framework whatever you call it for this game..

its ok.. as long as this CRAP doesn't happen for distant worlds 2..


i dont think you should be getting lag on that small of a map.. but come on man.. 45 empires?? really?? what do you think is the problem?

i play with 11-19 empires and i can't stand lag just with my 30 ships on the screen with 4 fighter bays on each of them..

but again, the amazing engine/framework this guy chose to use for this game is again the culprit..

it literally is pointless to play late-game games.. i just lost one cause i couldn't even save it got so crappy.. ****ty code.. ****ty framework etc..





Attachment (1)

(in reply to Justtheguybob)
Post #: 2
RE: Trouble with lag late game with 6x6 x 700 stars - 1/3/2015 5:12:06 PM   
Justtheguybob

 

Posts: 27
Joined: 6/1/2014
Status: offline
ok well im glad its not just me :) Geuss there are some huge trolls on steam

(in reply to twinkypillow)
Post #: 3
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds 1 Series >> Tech Support >> Trouble with lag late game with 6x6 x 700 stars Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.391