Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

New UI problem in Steam version

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> New UI problem in Steam version Page: [1]
Login
Message << Older Topic   Newer Topic >>
New UI problem in Steam version - 9/28/2014 8:33:23 AM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
Hi,
I have a problem in 1.05 Steam that I never had pre-Steam.
Sorry, I uninstalled the non Steam version, so I don't know if its 1.05 or 1.05 Steam.
On the unit details panel on right side of screen, the interactive elements are getting corrupted when I mouse over them.
In the 3rd example in my attached screenshots, it looks like it has zoomed in loads for this element, and that is the cause of the problem.

The problem goes if i deselect and re-select a unit, but returns as soon as I mouse over one of the relevant buttons.
Everything else seems fine.
Thanks
AL




Attachment (1)
Post #: 1
RE: New UI problem in Steam version - 9/30/2014 5:27:10 PM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
anything?
I re-installed game through steam, the problem remains

(in reply to alcamatraz)
Post #: 2
RE: New UI problem in Steam version - 9/30/2014 7:14:38 PM   
Dimitris


Posts: 12372
Joined: 7/31/2005
Status: offline
Hi, thanks for reporting this. Please allow us some time to investigate it.

_____________________________


(in reply to alcamatraz)
Post #: 3
RE: New UI problem in Steam version - 9/30/2014 7:26:51 PM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
sure thing, thanks

(in reply to Dimitris)
Post #: 4
RE: New UI problem in Steam version - 10/22/2014 8:25:41 PM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
bumping again.
how much time do you think?

(in reply to alcamatraz)
Post #: 5
RE: New UI problem in Steam version - 10/22/2014 9:01:40 PM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline
Sorry alcamatraz.

We're contacting steam on this one.

Thanks!

Mike

_____________________________


(in reply to alcamatraz)
Post #: 6
RE: New UI problem in Steam version - 10/22/2014 9:03:30 PM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
thanks for the update.

(in reply to mikmykWS)
Post #: 7
RE: New UI problem in Steam version - 10/23/2014 2:42:15 PM   
Erik Rutins

 

Posts: 34394
Joined: 3/28/2000
From: Vermont, USA
Status: offline
This does not seem like it could possibly be a Steam issue. Have you tried verifying your local files? To verify the data right click on the game in the steam library and select Properties>Local Files>Verify Integrity of Game Cache.

If that doesn't fix it, it seems like some kind of hardware/software issue between your system and the game. First step there would be to check and update video and audio drivers and turn off any third party software that could be interfering, such as anti-virus/security or desktop/windows modification software to see if it helps. You could also try resetting your Windows desktop/video settings to their defaults.

Regards,

- Erik


_____________________________


Erik Rutins
Director of Product Development




For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to alcamatraz)
Post #: 8
RE: New UI problem in Steam version - 10/23/2014 10:53:17 PM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline
Hi alcamatraz

Can you try opening your steam client, going to settings from the Steam drop down. From there select interface and then uncheck the enable DirectWrite.

The other thing you can try is disabling the steam overlay in play. While in settings select InGame on the left and then uncheck the enable the steam overlay.

Please let us know if disabling any of these solves your issue.

Thanks!

Mike

_____________________________


(in reply to Erik Rutins)
Post #: 9
RE: New UI problem in Steam version - 10/24/2014 1:30:43 AM   
Asterix909

 

Posts: 9
Joined: 10/8/2014
Status: offline
Hi, I have the same issue, as reported here: http ://www .matrixgames.com/forums/tm.asp?m=3712662
and re-mentioned here: http ://www .matrixgames.com/forums/tm.asp?m=3717600

quote:

ORIGINAL: Erik Rutins
Have you tried verifying your local files? To verify the data right click on the game in the steam library and select Properties>Local Files>Verify Integrity of Game Cache.

I just tried this, no dice.


quote:

ORIGINAL: Erik Rutins
If that doesn't fix it, it seems like some kind of hardware/software issue between your system and the game. First step there would be to check and update video and audio drivers and turn off any third party software that could be interfering, such as anti-virus/security or desktop/windows modification software to see if it helps. You could also try resetting your Windows desktop/video settings to their defaults.


My video drivers are up to date and I am running no anti-virus or other modification software. As indicated in my thread regarding the issue, I did try playing with my display setting including changing resolution and changing (including disabling) aero mode.


quote:

ORIGINAL: mikmyk

Can you try opening your steam client, going to settings from the Steam drop down. From there select interface and then uncheck the enable DirectWrite.

Just tried this, unfortunately no dice.
quote:

ORIGINAL: mikmyk
The other thing you can try is disabling the steam overlay in play. While in settings select InGame on the left and then uncheck the enable the steam overlay.


As indicated in my original thread, I tried that to no avail.


This is a very odd issue for sure! My Surface Pro (1) doesn't experience any problem, but my desktop does (my desktop dxdiag is attached to my original post, for the record).

(in reply to mikmykWS)
Post #: 10
RE: New UI problem in Steam version - 10/24/2014 3:47:46 PM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
Hi, Thanks for the suggestions.

I confirm I have validated the install, files were already correct. I also did a total reinstall.
Disabling the steam overlay has no effect. However, the steam overlay does not work even when enabled. In particular, the steam launcher only brings up the CMANO launcher, not the game itself.
So finally, directwrite had no effect, apart from making steam uglier.

It could be my video drivers, they are totally up to date, but as I said, before the steam version i didn't have this problem. Maybe its not steam, maybe a drivers update borked it, and was coincidentally at same time.
I'll try rolling back this weekend, and i'll try re-installing the non steam version as well.

Glad to hear I am not the only person with this issue, since it means its not totally me, but sorry that you have same problem Asterix.

(in reply to Asterix909)
Post #: 11
RE: New UI problem in Steam version - 10/25/2014 2:11:54 AM   
caffienatedjedi

 

Posts: 2
Joined: 10/25/2014
Status: offline
Registered to stop and say I had the same issue with the Steam version. Worked fine a version or two ago, but not anymore. Validation and disabling the steam overlay didn't fix it, sadly.

Also been having some driver issues, so there may be a relation. Just hope this gets fixed, it makes it hard to focus with the ui glitching out.

(in reply to alcamatraz)
Post #: 12
RE: New UI problem in Steam version - 10/25/2014 1:12:12 PM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline
Are any of you also running the matrix version? If so are you seeing the behavior there?

Trying to see if this is really Steam specific or something general.

Mike

_____________________________


(in reply to caffienatedjedi)
Post #: 13
RE: New UI problem in Steam version - 10/25/2014 6:12:36 PM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline

quote:

ORIGINAL: mikmyk

Are any of you also running the matrix version? If so are you seeing the behavior there?

Trying to see if this is really Steam specific or something general.

Mike


Yes, I just installed the matrix version. The problem is not present in the matrix version. So it is somehow specific to the steam version.

Thanks again
AL

(in reply to mikmykWS)
Post #: 14
RE: New UI problem in Steam version - 10/25/2014 7:53:42 PM   
Dimitris


Posts: 12372
Joined: 7/31/2005
Status: offline
IIRC the steam client adds some "social" overlays tot he game. Can you please try disabling these overlays and check if the problem persists?

_____________________________


(in reply to alcamatraz)
Post #: 15
RE: New UI problem in Steam version - 10/25/2014 8:08:10 PM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
Hi, Thanks for helping to look into this.
As far as i know, the only thing meeting that description is the thing called the "steam overlay".
This was suggested in the posts above, and disabling this did not help.
Please let me know if there is anything else you are thinking of.

(in reply to Dimitris)
Post #: 16
RE: New UI problem in Steam version - 10/25/2014 9:53:14 PM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline
Hi guys,

Trying to get in contact with a higher level support person at Steam to see if we can partner to solve this. Will let you know.

Thanks!

Mike

< Message edited by mikmyk -- 10/25/2014 10:53:29 PM >


_____________________________


(in reply to alcamatraz)
Post #: 17
RE: New UI problem in Steam version - 10/25/2014 10:42:13 PM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
Thanks guys, appreciate that you are being very good at providing status updates, hope steam can help!

(in reply to mikmykWS)
Post #: 18
RE: New UI problem in Steam version - 10/27/2014 1:10:57 PM   
Asterix909

 

Posts: 9
Joined: 10/8/2014
Status: offline
Let me know if I (we) can help.

And remember, the fact that we have a problem and desire it addressed is ultimately a compliment of the game; I do not bother tech supporting with issues in crappy games, only the good ones:-)
(I write that because my only posts have been about this flaw and I do not want it to come across as entirely negative!)

(in reply to alcamatraz)
Post #: 19
RE: New UI problem in Steam version - 10/27/2014 2:31:36 PM   
Erik Rutins

 

Posts: 34394
Joined: 3/28/2000
From: Vermont, USA
Status: offline
Hi guys,

Unfortunately we don't have any timeframe on when/if Steam will be able to help on this. We're speaking with them, but any solution could take a while.

Do you both have the non-Steam versions that you can play in the meantime?

Regards,

- Erik


_____________________________


Erik Rutins
Director of Product Development




For official support, please use our Help Desk: http://www.matrixgames.com/helpdesk/

Freedom is not Free.

(in reply to Asterix909)
Post #: 20
RE: New UI problem in Steam version - 10/27/2014 5:27:44 PM   
caffienatedjedi

 

Posts: 2
Joined: 10/25/2014
Status: offline
I purchased my version through Steam, is there a means of registering it and getting a Matrix version?

(in reply to Erik Rutins)
Post #: 21
RE: New UI problem in Steam version - 10/28/2014 8:09:32 AM   
alcamatraz

 

Posts: 31
Joined: 4/2/2011
Status: offline
I already have matrix version, so no problem for me. I think it would be good to provide the steam only users a matrix key though.

(in reply to caffienatedjedi)
Post #: 22
RE: New UI problem in Steam version - 11/11/2014 5:45:24 PM   
CVNTiger

 

Posts: 1
Joined: 11/11/2014
Status: offline
I would like to add that I've got the same issue occurring, and if it is an issue with steam itself it would be greatly appreciated if steam buyers could get a copy of the standalone game.

(in reply to alcamatraz)
Post #: 23
RE: New UI problem in Steam version - 11/12/2014 4:09:51 PM   
mikmykWS

 

Posts: 11524
Joined: 3/22/2005
Status: offline
Sorry guys still no word from a steam on this.

Mike

_____________________________


(in reply to CVNTiger)
Post #: 24
RE: New UI problem in Steam version - 11/27/2014 10:11:45 PM   
Doofage

 

Posts: 1
Joined: 11/27/2014
Status: offline
Hi guys, I'm new here, having just bought the Steam version of the game Today I also encountered this issue.

After checking the steam forums for an solution, I was lead to the matrix support forum where I came across this topic. after reading through and seeing a suggestion of disabling the steam overlay, I thought I would give it a shot. Then I remembered I have another program that puts an overlay on games like steam does, called raptr, it's a similar thing to steam. So I tried disabling that first before disabling the Steam overlay, and bingo! the issue has gone for me. I hope this can help others. Now I'm going to try learn how to play this thing, I thought Fleet Command was complicated!


Doofage


tl:dr
raptr overlay was causing this issue for me, disabled it and yey!

(in reply to mikmykWS)
Post #: 25
RE: New UI problem in Steam version - 11/27/2014 11:05:39 PM   
Dimitris


Posts: 12372
Joined: 7/31/2005
Status: offline
Thanks for sharing this information, very useful for future reference.

_____________________________


(in reply to Doofage)
Post #: 26
RE: New UI problem in Steam version - 12/1/2014 1:32:44 PM   
Asterix909

 

Posts: 9
Joined: 10/8/2014
Status: offline
I have raptr!!! I will try this asap and report back here. Unfortunately asap may not be until this evening but... this sounds promising.

EDIT: Ok so I got too excited and quickly launched the game before going to work (I am home later than normal today, how fortuitous); long story short: it works.

I tried disabling the raptr overlay but still had the issue. So then I closed the raptr client completely and the issue was gone.

Fantastic sleuthing Doofage!

I don't really use raptr at all, except to automatically optimize some games' graphical settings (you just kinda get it with the new AMD drivers) and have never had issue enough to disable it or delete it. While I will still probably keep it around (again, just to change graphic settings) I'll be sure to shut 'er down before launching Command.

Thanks again Doofage! And thanks Command Devs for investigating!

< Message edited by Asterix909 -- 12/1/2014 2:53:42 PM >

(in reply to Dimitris)
Post #: 27
RE: New UI problem in Steam version - 10/23/2015 10:46:28 PM   
MrFreeze

 

Posts: 47
Joined: 6/10/2014
From: Vancouver BC
Status: offline
Bump!
got exactly the same problem, but i do not have raptr installed, neither the steam overlay. Will check which overlay may cause this on my laptop if i can find it but just for futur ref seems that a bug that can happen with more than one software

EDIT: found it: on my latop it's Nahimic (a software that run in the background to improve sound on my MSI, latest version available )

< Message edited by MrFreeze -- 10/24/2015 12:43:43 AM >

(in reply to Asterix909)
Post #: 28
RE: New UI problem in Steam version - 4/3/2017 10:47:12 PM   
bgreman

 

Posts: 2
Joined: 4/3/2017
Status: offline
I'm aware that this thread is ancient at this point, and I'm not sure there's a better place for this, but I had the same issue, and had neither Raptr nor Nahimic.

For me, it was similar to Nahimic though. I found, through trial and error, A program installed with my ASUS Motherboard, Sonic Suite 2, was causing the issue. Like Nahimic, it claims to improve sound, but I find no use for it. I found that launching it launched two other executables: SS2Svc64 and SS2Svc32 when I checked Task Manager. Killing SS2Svc32 and restarting CMANO fixed the issue for me. To avoid having to do this every time, I went to the Startup tab of Task Manager (in Win 10; in prior versions of Windows I believe this would need to be done in msconfig) and disabled SS2UILauncher. I hope this helps someone else.

(in reply to MrFreeze)
Post #: 29
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> Tech Support >> New UI problem in Steam version Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.174