Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: [WIP] DW - Starfall - version 1.01

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> RE: [WIP] DW - Starfall - version 1.01 Page: <<   < prev  7 8 [9] 10 11   next >   >>
Login
Message << Older Topic   Newer Topic >>
RE: [WIP] DW - Starfall - version 1.01 - 6/19/2015 6:24:02 AM   
RiftHick

 

Posts: 54
Joined: 2/23/2015
Status: offline
It's unlikely that Fierce is going to be able to do anything regarding that bug/ issue. It's a problem tied to some conflict on components (or a specific component) above #256, it is something that Elliot or some other Distant Worlds dev would need to look into but I imagine their busy with other things right now.

Fierce, I possess copies of versions 0.6, 0.7 and 0.8 (exactly as you released them) of your work. You are welcome to any of them if you need them, just let me know and I'll do what I can to send the data to you.

(in reply to danymatrix)
Post #: 241
RE: [WIP] DW - Starfall - version 1.01 - 6/19/2015 3:19:11 PM   
Rikoom

 

Posts: 1
Joined: 6/10/2015
Status: offline
I'm so sad about this amazing mod !

I played some hours without problems until i found some crusaders and destroyers. Then they become huge (XL size) and their maintenances increase x10 or more in one shot.

I'm so sad because I see all the work done on this mod

(in reply to RiftHick)
Post #: 242
RE: [WIP] DW - Starfall - version 1.01 - 6/19/2015 4:56:22 PM   
Francoy


Posts: 107
Joined: 3/10/2005
Status: offline
You could reduce the number of components to 255 by extending each technology with more upgrade instead of new components...

And maybe reduce the number of technology lines(for example 2 lines for constructions should be enough).

< Message edited by Francoy -- 6/19/2015 6:00:49 PM >

(in reply to Rikoom)
Post #: 243
RE: [WIP] DW - Starfall - version 1.01 - 6/19/2015 5:09:30 PM   
IDoY

 

Posts: 2
Joined: 5/6/2015
Status: offline
Still looking for v0.09.

(in reply to Francoy)
Post #: 244
RE: [WIP] DW - Starfall - version 1.01 - 6/19/2015 6:54:35 PM   
RiftHick

 

Posts: 54
Joined: 2/23/2015
Status: offline
Fierce knows all that Francoy, I've even offered to do it for him. However Fierce as opted to wait it out.

That said I will disagree with you on reducing tech projects, if you reduce them you then have 70~ or so race files who's project orders you have to completely re-write some partially others almost entirely something you don't need to do when just increasing expansion of <#255 components is more than adequate as a temporary fix and certainly much quicker. Alternatively it might just wind up being most time-effective thing to do nothing but wait on the devs for their thoughts or actions.

(in reply to IDoY)
Post #: 245
RE: [WIP] DW - Starfall - version 1.01 - 6/22/2015 8:49:27 AM   
Phuket

 

Posts: 56
Joined: 6/20/2015
Status: offline
You can bet I'll be giving this mod a run through! Its coming out fantastic!

(in reply to RiftHick)
Post #: 246
RE: [WIP] DW - Starfall - version 1.01 - 7/4/2015 6:10:51 PM   
danymatrix

 

Posts: 61
Joined: 6/26/2014
Status: offline
any news?

(in reply to Phuket)
Post #: 247
RE: [WIP] DW - Starfall - version 1.01 - 8/1/2015 1:06:11 AM   
patekm

 

Posts: 4
Joined: 8/14/2014
Status: offline
I love this mod, I personally can't even bring myself to play the base game anymore since having run this. That said, version 1.01 isn't playable, due to the component bug. I respect that the modder wants to wait it out and have the game fixed, especially given that this was an actual feature in a recent patch (upping the 255 components). BUT, in the meantime, here we wait. Does anyone feel like sharing a link to version 0.9? Please? I deleted my copy not even a few days after getting 1.01, and wow I regret it. I even used the internet archive to find the old link to version 0.9 on this forum but it had already been taken down.

Version 0.9 is playable given the current state of affairs. Can someone please upload it somewhere?

(in reply to danymatrix)
Post #: 248
RE: [WIP] DW - Starfall - version 1.01 - 8/4/2015 7:06:59 PM   
LordArkham

 

Posts: 28
Joined: 7/20/2015
Status: offline
I've read a lot of this thread - I assume that the thing to do is not install the mod at all and wait?

(in reply to patekm)
Post #: 249
RE: [WIP] DW - Starfall - version 1.01 - 8/5/2015 3:25:35 AM   
patekm

 

Posts: 4
Joined: 8/14/2014
Status: offline
I would suggest trying it. It appears that the modder himself was not experiencing the bug, which should be apparent very quickly in your playthrough, namely that gigantic pirate ships will be littered throughout your space because they will have become stuck wherever they were at when the bug hit.

(in reply to LordArkham)
Post #: 250
RE: [WIP] DW - Starfall - version 1.01 - 8/21/2015 8:32:21 PM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline
Well it looks like no fix will happen anytime soon. And since I have some time, I will try fixing this mod.

The only solution, that will work will be what RiftHick suggested in a previous post.

And that is to remove all the components above 255 and re-use older components with the new component stats. That should work but would take some time.

I will update when there is progress.

(in reply to patekm)
Post #: 251
RE: [WIP] DW - Starfall - version 1.01 - 8/22/2015 5:36:59 PM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline
Updated to version 1.05

Goto first page for info and download link

(in reply to fierceking)
Post #: 252
RE: [WIP] DW - Starfall - version 1.01 - 8/22/2015 9:54:13 PM   
Uncle Lumpy


Posts: 155
Joined: 7/1/2005
Status: offline
Yeah!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Thank You!!!

(in reply to fierceking)
Post #: 253
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 3:15:54 PM   
Hanekem

 

Posts: 48
Joined: 5/22/2010
Status: offline
I am getting an error about component 256 when I try to run the mod :/

(in reply to Uncle Lumpy)
Post #: 254
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 4:38:11 PM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline

quote:

ORIGINAL: Hanekem

I am getting an error about component 256 when I try to run the mod :/


What error are you getting?

And what version of DW are you using?

(in reply to Hanekem)
Post #: 255
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 5:15:55 PM   
Hanekem

 

Posts: 48
Joined: 5/22/2010
Status: offline
I am running the latest version of DW.
As for the Error, I need to check, but something about not finding the component.
EDIT: more precisely, can't load the .BMP of the component, maybe a link got left in the mod?

I am sure i downloaded the latest version of the mod too, v1.05.

< Message edited by Hanekem -- 8/23/2015 6:20:02 PM >

(in reply to fierceking)
Post #: 256
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 7:40:14 PM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline
It looks like I deleted some of the bmp images.

Download this file and replace the old one. This is only if you already downloaded 1.05.

http://www.mediafire.com/download/m05khw7ki88yb49/components.rar



Attachment (1)

< Message edited by fierceking -- 8/24/2015 12:18:24 AM >

(in reply to Hanekem)
Post #: 257
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 8:43:25 PM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline
Updated to version 1.06

Goto first page for info and download link

(in reply to fierceking)
Post #: 258
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 11:10:13 PM   
Aerial

 

Posts: 6
Joined: 8/23/2015
Status: offline

quote:

ORIGINAL: fierceking

It looks like I deleted some of the bmp images.

Download this file and replace the old one. This is only if you already downloaded 1.05.


Download how? It just opens to code.

(in reply to fierceking)
Post #: 259
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 11:19:01 PM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline
Use this link instead if your having problems with other link

http://www.mediafire.com/download/m05khw7ki88yb49/components.rar

(in reply to Aerial)
Post #: 260
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 11:31:22 PM   
Aerial

 

Posts: 6
Joined: 8/23/2015
Status: offline
Thanks for the new link.

I didn't want to say anything in case I was just failing to install that properly, but I can't seem to switch my game over to Starfall.

I keep getting this:
Could not load required image: Distant worlds universe/images/ui/components/Component_256.bmp

And I am using 1.05, with the components file overwritten with the new one.

< Message edited by Aerial -- 8/24/2015 12:33:53 AM >

(in reply to fierceking)
Post #: 261
RE: [WIP] DW - Starfall - version 1.01 - 8/23/2015 11:55:28 PM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline
Not sure why it's giving errors since the mod doesn't use the images anymore.

Here are the files...

You will need to delete the components folder inside my mod. And replace with this folder which contains all the bmp images. It basically has all component images from 0 to 287. That should fix it

http://www.mediafire.com/download/2o85mihy12gm0zq/components_bmp.rar

< Message edited by fierceking -- 8/24/2015 12:56:06 AM >

(in reply to Aerial)
Post #: 262
RE: [WIP] DW - Starfall - version 1.01 - 8/24/2015 12:08:14 AM   
Hanekem

 

Posts: 48
Joined: 5/22/2010
Status: offline
I tried 1.06 and got another error, this time with the galaxy_backdrop.jpg, can't find it or open it. the error message is not very clear.

(in reply to fierceking)
Post #: 263
RE: [WIP] DW - Starfall - version 1.01 - 8/24/2015 12:12:45 AM   
Aerial

 

Posts: 6
Joined: 8/23/2015
Status: offline

quote:

ORIGINAL: fierceking

Not sure why it's giving errors since the mod doesn't use the images anymore.

Here are the files...

You will need to delete the components folder inside my mod. And replace with this folder which contains all the bmp images. It basically has all component images from 0 to 287. That should fix it


It sat there loading the new theme for a full minute again and I thought it was going to give me the same error message, but it successfully switched to Starfall.
Thanks for the help, fierce.

(in reply to Hanekem)
Post #: 264
RE: [WIP] DW - Starfall - version 1.01 - 8/24/2015 12:14:41 AM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline

quote:

ORIGINAL: Aerial


quote:

ORIGINAL: fierceking

Not sure why it's giving errors since the mod doesn't use the images anymore.

Here are the files...

You will need to delete the components folder inside my mod. And replace with this folder which contains all the bmp images. It basically has all component images from 0 to 287. That should fix it


It sat there loading the new theme for a full minute again and I thought it was going to give me the same error message, but it successfully switched to Starfall.
Thanks for the help, fierce.

Good to hear that it finally works I think

(in reply to Aerial)
Post #: 265
RE: [WIP] DW - Starfall - version 1.01 - 8/24/2015 12:18:59 AM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline

quote:

ORIGINAL: Hanekem

I tried 1.06 and got another error, this time with the galaxy_backdrop.jpg, can't find it or open it. the error message is not very clear.

Can you check the galaxy backdrop folder and see if there are 3 images in there?

C:\Matrix Games\Distant Worlds Universe\Customization\DW - Starfall\images\environment\galaxybackdrops

You should see these 3 files



(in reply to Hanekem)
Post #: 266
RE: [WIP] DW - Starfall - version 1.01 - 8/24/2015 12:36:37 AM   
Hanekem

 

Posts: 48
Joined: 5/22/2010
Status: offline
I have them, not sure what is the problem

(in reply to fierceking)
Post #: 267
RE: [WIP] DW - Starfall - version 1.01 - 8/24/2015 12:49:03 AM   
fierceking

 

Posts: 235
Joined: 7/24/2010
Status: offline

quote:

ORIGINAL: Hanekem

I have them, not sure what is the problem

Not sure what the problem is. I never touched those images.

Try switching back to default mod and then back to my mod and see if that does anything.

then try...
Delete my mod, start the game and test if it runs the default game. Then if that is ok, reinstall my mod and check if you still get the error

(in reply to Hanekem)
Post #: 268
RE: [WIP] DW - Starfall - version 1.01 - 8/24/2015 12:54:29 AM   
Hanekem

 

Posts: 48
Joined: 5/22/2010
Status: offline

quote:

ORIGINAL: fierceking


quote:

ORIGINAL: Hanekem

I have them, not sure what is the problem

Not sure what the problem is. I never touched those images.

Try switching back to default mod and then back to my mod and see if that does anything.

then try...
Delete my mod, start the game and test if it runs the default game. Then if that is ok, reinstall my mod and check if you still get the error




Yeah, going back to default and then selecting the mod did it, it probably was the strain of going from a mod to another. Thanks!

(in reply to fierceking)
Post #: 269
RE: [WIP] DW - Starfall - version 1.01 - 8/24/2015 4:20:58 PM   
Unreal2004

 

Posts: 27
Joined: 8/20/2014
Status: offline
Thanks for the 256 bug update and keeping this alive!!

(in reply to Hanekem)
Post #: 270
Page:   <<   < prev  7 8 [9] 10 11   next >   >>
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Design and Modding >> RE: [WIP] DW - Starfall - version 1.01 Page: <<   < prev  7 8 [9] 10 11   next >   >>
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.156