Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Energy Balancing not working [1.9.5.3]

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Energy Balancing not working [1.9.5.3] Page: [1]
Login
Message << Older Topic   Newer Topic >>
Energy Balancing not working [1.9.5.3] - 6/9/2014 3:40:31 PM   
Locarnus


Posts: 275
Joined: 5/30/2010
From: Earth, Sol
Status: offline
edit: still there in 1.9.5.3


Hello,

I made a mod which changes the energy production of reactor components.
While testing it, Francoy found out that the energy balancing does not work as stated in the design templates. It just is not apparant without modding.

Basically it just seems to add only 1 reactor if the number stated in the design template is not sufficient.

This makes modding any energy using component next to impossible (weapons, superweapons, reactors, hyperdrives, and so on).

For demonstration purposes I just modded the components.txt, so that the "Basic Space Reactor" and the "Fission Reactor" are about 1/3 in size, output and resource costs. The modded components.txt is attached to this post.

Then I just started a new game on tech level 1.

The result is, that nearly all autodesigned vessels are severely underpowered in terms of energy production.

edit:
Savegame and components.txt in a zip: energy-balance-test.zip




Attachment (1)

< Message edited by Locarnus -- 6/14/2014 4:07:12 PM >


_____________________________

DW:U BalanceMod v0.9 (extended TechTree)
compatible with DW:U Extended, StarTrek and XPanded

http://www.matrixgames.com/forums/tm.asp?m=3624576
Post #: 1
RE: Energy Balancing not working [1.9.5.2 and before] - 6/12/2014 7:25:50 AM   
elliotg


Posts: 3289
Joined: 9/10/2007
Status: offline
Hi Locarnus

The AI ship design will add as many reactors as required to meet your energy output needs, not just a single reactor.

However the current logic to drive hyperdrives at full speed does add only a single reactor.

We'll add a fix for this in the next update (1.9.5.3)

Thanks
Elliot

(in reply to Locarnus)
Post #: 2
RE: Energy Balancing not working [1.9.5.2 and before] - 6/14/2014 3:07:59 PM   
Locarnus


Posts: 275
Joined: 5/30/2010
From: Earth, Sol
Status: offline
Hello,

the problem is still there in 1.9.5.3, just tested.

best regards,
Locarnus

_____________________________

DW:U BalanceMod v0.9 (extended TechTree)
compatible with DW:U Extended, StarTrek and XPanded

http://www.matrixgames.com/forums/tm.asp?m=3624576

(in reply to elliotg)
Post #: 3
RE: Energy Balancing not working [1.9.5.2 and before] - 6/15/2014 12:12:31 PM   
Icemania


Posts: 1843
Joined: 6/5/2013
From: Australia
Status: offline
Please Matrix help Locarnus because this mod looks fantastic ...

(in reply to Locarnus)
Post #: 4
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Energy Balancing not working [1.9.5.3] Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.137