Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: my auto updater doesn't work after 1.09

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> World in Flames >> Tech Support >> RE: my auto updater doesn't work after 1.09 Page: <<   < prev  1 [2]
Login
Message << Older Topic   Newer Topic >>
RE: my auto updater doesn't work after 1.09 - 1/29/2014 10:04:52 PM   
paulderynck


Posts: 8156
Joined: 3/24/2007
From: Canada
Status: offline

quote:

ORIGINAL: shaddock

Can someone please explain what the C++ runtime library is supposed to be.

Is it a library of functions the program calls and compiles with the game rather than having to have all of them included in the game?

Or is Microsoft constantly updating their version of C++?

Or is it something completely different?

It should not matter. It's a Matrix problem that's been introduced into the update executable and it's their duty to fix it.

< Message edited by paulderynck -- 1/29/2014 11:05:28 PM >


_____________________________

Paul

(in reply to shaddock)
Post #: 31
RE: my auto updater doesn't work after 1.09 - 1/30/2014 11:42:17 AM   
rogerdubbs


Posts: 28
Joined: 1/30/2014
Status: offline
I have never been able to autoupdate, with any version. I'm running on Windows 8.1 in a parallels virtual machine on my mac, which could make a difference I suppose. Here is the latest attempt's log entry:

[01/30/2014 06:27:16] Success Update started: C:\Matrix Games\World in Flames\update.exe
[01/30/2014 06:27:16] Notice Update engine version: 3.0.0.0
[01/30/2014 06:27:16] Notice Product: World in Flames, version %ProductVer%
[01/30/2014 06:27:16] Success Language set: Primary = 9, Secondary = 1
[01/30/2014 06:27:16] Success Include script: _TU20_Global_Functions.lua
[01/30/2014 06:27:16] Success Display screen: Welcome
[01/30/2014 06:27:19] Success Display screen: Download Server Script
[01/30/2014 06:27:23] Error An error occurred when trying to download the server file. Server ID: TrueUpdate Server 1 : An error occurred when trying to open the FTP file. (3618)
[01/30/2014 06:27:23] Error The server returned extended information
(3618)
[01/30/2014 06:27:23] Error Server Returned Extended Information: 200 Type set to I
500 Illegal PORT command
500 LPRT not understood
(0)
[01/30/2014 06:27:23] Error Script: Download Server Script > On Start, Line 114 (3618)
[01/30/2014 06:27:23] Success Display screen: Download Server Script Failed
[01/30/2014 06:27:29] Success Run client data event: Client Script
[01/30/2014 06:27:30] Notice Exit update process (Return code: 5)

_____________________________

Roger

(in reply to shaddock)
Post #: 32
RE: my auto updater doesn't work after 1.09 - 2/3/2014 8:17:24 PM   
Andrew Loveridge


Posts: 606
Joined: 7/20/2009
Status: offline
I have not been able to duplicate this. Could you please tell me what systems you are on, and if you have recently updated them?

If you have never been able to use the updater, it is most likely an issue with you firewall or Anti-virus keeping the Updater from accessing our FTP.

_____________________________


(in reply to rogerdubbs)
Post #: 33
RE: my auto updater doesn't work after 1.09 - 2/3/2014 8:40:43 PM   
Dabrion


Posts: 733
Joined: 11/5/2013
From: Northpole
Status: offline

quote:

ORIGINAL: rogerdubbs

I have never been able to autoupdate, with any version. I'm running on Windows 8.1 in a parallels virtual machine on my mac, which could make a difference I suppose. Here is the latest attempt's log entry:

[01/30/2014 06:27:16] Success Update started: C:\Matrix Games\World in Flames\update.exe
[01/30/2014 06:27:16] Notice Update engine version: 3.0.0.0
[01/30/2014 06:27:16] Notice Product: World in Flames, version %ProductVer%
[01/30/2014 06:27:16] Success Language set: Primary = 9, Secondary = 1
[01/30/2014 06:27:16] Success Include script: _TU20_Global_Functions.lua
[01/30/2014 06:27:16] Success Display screen: Welcome
[01/30/2014 06:27:19] Success Display screen: Download Server Script
[01/30/2014 06:27:23] Error An error occurred when trying to download the server file. Server ID: TrueUpdate Server 1 : An error occurred when trying to open the FTP file. (3618)
[01/30/2014 06:27:23] Error The server returned extended information
(3618)
[01/30/2014 06:27:23] Error Server Returned Extended Information: 200 Type set to I
500 Illegal PORT command
500 LPRT not understood
(0)
[01/30/2014 06:27:23] Error Script: Download Server Script > On Start, Line 114 (3618)
[01/30/2014 06:27:23] Success Display screen: Download Server Script Failed
[01/30/2014 06:27:29] Success Run client data event: Client Script
[01/30/2014 06:27:30] Notice Exit update process (Return code: 5)


This sound like the NAT from the VM client network is messing with the ports for the FTP connection. FTP passive mode could help, or explicit port forwarding.


_____________________________

“WiF is like sex: sure, it may give some practical results, but that's not why we do it.”
- Richard P. Feynman, 'WiF, Sex, and the Dual Slit Experiment'.

(in reply to rogerdubbs)
Post #: 34
RE: my auto updater doesn't work after 1.09 - 2/3/2014 11:38:39 PM   
ksandgren

 

Posts: 6
Joined: 7/31/2005
Status: offline
Autoupdater still fails after 1.1.2. After uninstall and reinstall it will work exactly one time and then the same error comes up and aborts. I don't care if this is a "MWIF problem" or a "Matrix problem" it is a broken MWIF result that needs to be addressed after five weeks or repeated reports and comments.

(in reply to Dabrion)
Post #: 35
RE: my auto updater doesn't work after 1.09 - 2/4/2014 1:21:29 PM   
Kwll

 

Posts: 34
Joined: 6/6/2000
From: Hurricane, WV
Status: offline
I just installed the 1.1.2 patch and I still have the issue, with regard to updating.

FYI since the comment was made over antivirus software before, I am using Norton 2014 360 for my antivirus etc. It does ask me when I install the game/patch and advises the WIF is unknown, however, I always have provided authorization for it to run. Could it be something else in that program?

(in reply to ksandgren)
Post #: 36
RE: my auto updater doesn't work after 1.09 - 2/4/2014 5:48:30 PM   
AxelNL


Posts: 2383
Joined: 9/24/2011
From: The Netherlands
Status: offline
I have a different anti-virus, so I don't think so

(in reply to Kwll)
Post #: 37
RE: my auto updater doesn't work after 1.09 - 2/4/2014 6:08:33 PM   
warspite1


Posts: 44997
Joined: 2/2/2008
From: England
Status: offline

quote:

ORIGINAL: Andrew Loveridge

I have not been able to duplicate this. Could you please tell me what systems you are on, and if you have recently updated them?

If you have never been able to use the updater, it is most likely an issue with you firewall or Anti-virus keeping the Updater from accessing our FTP.
warspite1

I am on Windows 7 Home Premium. Never had an issue with the auto updater on any matrix game - WITE, WITP-AE, CTGW, PoN. Didn't have a problem with MWIF either until the last couple of updates.... No I have not changed the system in any way.


_____________________________

England expects that every man will do his duty. Horatio Nelson October 1805



(in reply to Andrew Loveridge)
Post #: 38
RE: my auto updater doesn't work after 1.09 - 2/4/2014 6:10:16 PM   
paulderynck


Posts: 8156
Joined: 3/24/2007
From: Canada
Status: offline
Assuming it's been awhile, can you try running it with those other games and tell us if it functions, so we can narrow the problem?


_____________________________

Paul

(in reply to warspite1)
Post #: 39
RE: my auto updater doesn't work after 1.09 - 2/4/2014 6:19:51 PM   
warspite1


Posts: 44997
Joined: 2/2/2008
From: England
Status: offline
Yep - just tried PoN - updated fine.

_____________________________

England expects that every man will do his duty. Horatio Nelson October 1805



(in reply to paulderynck)
Post #: 40
RE: my auto updater doesn't work after 1.09 - 2/4/2014 6:52:29 PM   
paulderynck


Posts: 8156
Joined: 3/24/2007
From: Canada
Status: offline
I just had the same issue. Used my update.exe from last August and updated successfully, then I clicked "Check for Update" and got the Runtime error. I thought my update.exe must have been replaced with a newer bugged one, but it hadn't. But I did notice that update.dat now has today's time stamp. So I replaced it with an earlier one and then ran the update which did work but told me I was already at the most recent version. Again the update.dat had been replaced, but from then on it worked, each time saying the update is not needed.

So maybe the problem lies in update.dat, but only if the version is detected as needing to be updated.

_____________________________

Paul

(in reply to warspite1)
Post #: 41
RE: my auto updater doesn't work after 1.09 - 2/4/2014 9:40:03 PM   
Maucat


Posts: 18
Joined: 3/13/2007
From: Rome, Italy
Status: offline

quote:

ORIGINAL: ksandgren

Autoupdater still fails after 1.1.2. After uninstall and reinstall it will work exactly one time and then the same error comes up and aborts. I don't care if this is a "MWIF problem" or a "Matrix problem" it is a broken MWIF result that needs to be addressed after five weeks or repeated reports and comments.


I too have still the same problem...

_____________________________

I played WIF since the first edition and now finally play the computer game !!!

(in reply to ksandgren)
Post #: 42
RE: my auto updater doesn't work after 1.09 - 2/5/2014 12:59:01 PM   
Moltke71


Posts: 1253
Joined: 9/23/2000
Status: offline
I've had the problem since 1.09. I can update manually just fine but I like the updater. The updater in all other Matrix games work. As I have the download version, I hesitate to uninstall/reinstall.

_____________________________

Jim Cobb

(in reply to Maucat)
Post #: 43
RE: my auto updater doesn't work after 1.09 - 2/5/2014 1:09:46 PM   
Dabrion


Posts: 733
Joined: 11/5/2013
From: Northpole
Status: offline
They are aware of the problem, just too incompetent to solve it.

_____________________________

“WiF is like sex: sure, it may give some practical results, but that's not why we do it.”
- Richard P. Feynman, 'WiF, Sex, and the Dual Slit Experiment'.

(in reply to Moltke71)
Post #: 44
RE: my auto updater doesn't work after 1.09 - 2/5/2014 2:18:31 PM   
Centuur


Posts: 8722
Joined: 6/3/2011
From: Hoorn (NED).
Status: offline

quote:

ORIGINAL: Dabrion

They are aware of the problem, just too incompetent to solve it.


Stop insulting people you don't know. It's against the forum rules...

_____________________________

Peter

(in reply to Dabrion)
Post #: 45
RE: my auto updater doesn't work after 1.09 - 2/5/2014 2:31:43 PM   
Dabrion


Posts: 733
Joined: 11/5/2013
From: Northpole
Status: offline
They don't stop to insult me with this garbage software and service.. It has been almost three weeks since 1.0.9. Call me judgemental but incompetence was the first that came to mind. What do you suggest instead?

_____________________________

“WiF is like sex: sure, it may give some practical results, but that's not why we do it.”
- Richard P. Feynman, 'WiF, Sex, and the Dual Slit Experiment'.

(in reply to Centuur)
Post #: 46
RE: my auto updater doesn't work after 1.09 - 2/5/2014 2:46:31 PM   
Centuur


Posts: 8722
Joined: 6/3/2011
From: Hoorn (NED).
Status: offline

quote:

ORIGINAL: Dabrion

They don't stop to insult me with this garbage software and service.. It has been almost three weeks since 1.0.9. Call me judgemental but incompetence was the first that came to mind. What do you suggest instead?


To take a deep breath, throw the game in a corner for the next 6 months and come back at that time.

Or,

Quit making life for the people here more miserable than it already is and refrain from making remarks which aren't contributing to the game at all. Or are you really one of those people who can't do anything else anymore when they don't get what they want (because they didn't read the product page carefully) and than continue to keep wailing about it?
If so, you are a troll. I hope you aren't in that league, but frankly, I'm getting fed up with your comments.

Start mailing Matrix with all your complaints directly. Get a lawyer, go to court. I don't care. But stop messing around with people who can't make any decision about what Matrix need to do or not.
To me, this kind of behaviour is childish and annoying.

_____________________________

Peter

(in reply to Dabrion)
Post #: 47
RE: my auto updater doesn't work after 1.09 - 2/7/2014 1:08:19 AM   
rogerdubbs


Posts: 28
Joined: 1/30/2014
Status: offline
I'm not quite sure if this is something I need to do or if this is a suggestion for the developers?

quote:

ORIGINAL: Dabrion

This sound like the NAT from the VM client network is messing with the ports for the FTP connection. FTP passive mode could help, or explicit port forwarding.



For grins, I ran through all the network options parallels gives me, and none of them made it better - many made it worse. I don't think I'm doing anything fancy with respect to firewalls and such.

If nothing else, I'd like a better error message than the one I get - even the logs aren't very informative.

Is there an ftp address and port I should try from my machine to see if I can connect manually?

(in reply to Dabrion)
Post #: 48
RE: my auto updater doesn't work after 1.09 - 2/7/2014 1:24:30 AM   
Dabrion


Posts: 733
Joined: 11/5/2013
From: Northpole
Status: offline

quote:

ORIGINAL: rogerdubbs

I'm not quite sure if this is something I need to do or if this is a suggestion for the developers?

quote:

ORIGINAL: Dabrion

This sound like the NAT from the VM client network is messing with the ports for the FTP connection. FTP passive mode could help, or explicit port forwarding.



For grins, I ran through all the network options parallels gives me, and none of them made it better - many made it worse. I don't think I'm doing anything fancy with respect to firewalls and such.

If nothing else, I'd like a better error message than the one I get - even the logs aren't very informative.

Is there an ftp address and port I should try from my machine to see if I can connect manually?


You want a bridged adapter or bridged network mode to avoid the NAT **** up. Quick search finds this: http://download.parallels.com/desktop/v4/docs/en/Parallels_Desktop_Users_Guide/22251.htm. I dont have a mac, so cannot help with the details.

Or wait until the updater is configured to use a passive ftp connection. Which is probably never..

_____________________________

“WiF is like sex: sure, it may give some practical results, but that's not why we do it.”
- Richard P. Feynman, 'WiF, Sex, and the Dual Slit Experiment'.

(in reply to rogerdubbs)
Post #: 49
RE: my auto updater doesn't work after 1.09 - 2/7/2014 8:02:35 PM   
paulderynck


Posts: 8156
Joined: 3/24/2007
From: Canada
Status: offline

quote:

ORIGINAL: rogerdubbs
Is there an ftp address and port I should try from my machine to see if I can connect manually?


If you mean to go to Matrix and download the patch manually, then the link is at the top right of the post from Andrew/Matrix when a new version is announced.

_____________________________

Paul

(in reply to rogerdubbs)
Post #: 50
RE: my auto updater doesn't work after 1.09 - 3/26/2014 11:47:30 AM   
pzgndr

 

Posts: 3027
Joined: 3/18/2004
From: Maryland
Status: offline
Still not working with latest v1.1.7.2. I can manually download and install the patches fine, but there should be a resolution path for this. Could you provide us new files to overwrite possibly corrupted files or tell us how to clear something? This can't be too difficult to track down and fix, can it?

(in reply to paulderynck)
Post #: 51
RE: my auto updater doesn't work after 1.09 - 4/1/2014 9:11:42 PM   
Ullern


Posts: 1837
Joined: 5/28/2006
Status: offline
I had a problem using the auto-updater to update to the 1.1.6 version all last month and only today
did I resolve the issue.

The updater started downloading update, but stopped at a random time before completion.
Typically when the update was 20% to 50% completed. (I never got past 50%).

I did reinstall, but that didn't help at all.

Turning off the firewall helped though.
The Firewall was an unlikely candidate for the error since I did give MWIF all access, the previous
versions updated quite nicely, and because the error only happened quite a while into the download process.

I won't speculate into why the firewall can cause this behavior, but the size of the update and or update speed
(I got download speeds of around 2.5 MB/sec) could in theory be part of the trouble. (But what is different with
the 1.1.6 and previous versions is a more interesting question - although I'm not sure I ever installed 1.1.5
I did install most of previous versions.)

Anyhow it's possible to download the update from the World In Flames page
http://www.matrixgames.com/products/296/downloads/

(1.1.6 is the currently last "official" update accessible with the auto-updater, even though more updates
are available as Beta versions if you search for it.)

(in reply to paulderynck)
Post #: 52
RE: my auto updater doesn't work after 1.09 - 4/4/2014 5:31:22 PM   
Gerry Edwards


Posts: 163
Joined: 2/22/2013
Status: offline
Hello Everyone,

We have not forgotten about this issue and are striving to find the cause. One of the problems we are having is we have been unable to replicate the problem on any of our test machines here. Any details you can give us about your system, how many times you updated before this began, what os and bit you are on, and what AV software you have installed will be greatly helpful. Any of you who are willing to help please send me a PM as another option would be for me to remote view the problem as it happens. Any help is greatly appreciated.

Thank you for your time and patience.

Gerry

_____________________________

Those who came before pave the path of tomorrow.

(in reply to Ullern)
Post #: 53
RE: my auto updater doesn't work after 1.09 - 10/16/2014 10:47:46 PM   
analog_relic


Posts: 6
Joined: 11/23/2012
Status: offline

quote:

ORIGINAL: Gerry Edwards

Hello Everyone,

We have not forgotten about this issue and are striving to find the cause. One of the problems we are having is we have been unable to replicate the problem on any of our test machines here. Any details you can give us about your system, how many times you updated before this began, what os and bit you are on, and what AV software you have installed will be greatly helpful. Any of you who are willing to help please send me a PM as another option would be for me to remote view the problem as it happens. Any help is greatly appreciated.

Thank you for your time and patience.

Gerry



Still not working. I am DLing the latest update now. I am running Win 7 (Home) 64-bit and have changed nothing since installing MWiF. After install, the updater worked once and never again. If you want to remote watch the error, I am OK with that. AR

(in reply to Gerry Edwards)
Post #: 54
RE: my auto updater doesn't work after 1.09 - 10/17/2014 5:46:52 AM   
AxelNL


Posts: 2383
Joined: 9/24/2011
From: The Netherlands
Status: offline
Matrix fixed this (in the summer, as I recall). You needed to download a version which included the fix, and it worked seamlessly at my side. Did the latest commercial release with it recently. If you search the forum for it you will probably find it.

(in reply to analog_relic)
Post #: 55
RE: my auto updater doesn't work after 1.09 - 10/17/2014 12:58:59 PM   
pzgndr

 

Posts: 3027
Joined: 3/18/2004
From: Maryland
Status: offline
See the Updater Fix thread above?

(in reply to AxelNL)
Post #: 56
RE: my auto updater doesn't work after 1.09 - 10/17/2014 4:51:11 PM   
AxelNL


Posts: 2383
Joined: 9/24/2011
From: The Netherlands
Status: offline

quote:

ORIGINAL: pzgndr

See the Updater Fix thread above?


That's it!

(in reply to pzgndr)
Post #: 57
Page:   <<   < prev  1 [2]
All Forums >> [New Releases from Matrix Games] >> World in Flames >> Tech Support >> RE: my auto updater doesn't work after 1.09 Page: <<   < prev  1 [2]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.383