Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Free Oil Reorganization Bug

View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> World in Flames >> Tech Support >> Free Oil Reorganization Bug Page: [1]
Message << Older Topic   Newer Topic >>
Free Oil Reorganization Bug - 1/6/2014 3:48:34 PM   

Posts: 829
Joined: 6/22/2012
From: Salinas, CA
Status: offline
I was doing my CW oil reorganization after sorting out the massive problem the program caused when the Faeroes Gap lost all convoy points only to find a new problem in oil reorganization. I discovered that I could get free oil reorganization from previously saved oil points that were being sent to production.

After getting resources being illegally convoyed to Britain stopped I decided to use the previously saved oil points in Britain to fuel the idled factories in Britain. I had 15 idle British factories in the home isles and by coincidence had 15 previously saved oil points. After sending all 15 previously saved oil points in Britain to the 15 idled British home island factories I thought I had everything fixed.

Then I got to the Oil Use Phase and I had to reorganize 3 oil points worth of ships that I had to return to port in Britain. With no convoy points in the Faeroes Gap the program correctly disallowed me from using any oil points for reorganization that weren't located in Britain. So I decided to reorganize all ships except Battleships, 2.1 oil points worth.

As I selected ships to be reorganized with previously saved oil points located in Britain but being shipped to a factory for production I noticed that the cost was not being immediately deducted as I clicked on each ship. The other ships being reorganized outside of Britain using oil from outside Britain worked just fine.

So when I got to the Final Production Planning Phase I was disconcerted to see that I still had 15 previously saved oil points in Britain going to the 15 factories in Britain that needed a resource to produce. I should have had 13 left and should have lost two build points but didn't. I went back to look at the screen from the autosave from the beginning of the CW Preliminary Planning Phase of that turn and saw that it said I had 22 previously saved oil points to begin. When I was at the Final Production Planning Phase it said I now had 15. I tried to use 6 oil points to reorganize the 7 points of ships and units that needed oil for reorganization. I should have seen 16 saved oil points to begin with, not 15. It looks like it incorrectly counted all of my oil reorganization cost rather than the amount I actually used. I still had the 15 previously saved oil points in Britain instead of the 13 that should have been there. Plus I had several other previously saved oil points not in Britain that weren't used for oil reorganization that should have been in that tally but weren't.

I'm not sure if I had not sent those saved oil points to production if they would have been properly used. I saw as Japan that when I used previously saved oil points that weren't being sent to production that same turn that they were properly used. So it looks like the program gets confused during oil reorganization when previously saved oil points being sent to production also get picked to be used for oil reorganization aren't being properly retasked from production to oil reorganization.

The other thing I didn't like when getting to the CW Final Production Planning Phase was that I now saw 10 of the 15 oil points were now showing as not being used for production, just being idle. I then saved and went to reopen the Preliminary Production Phase to check that screen for the beginning saved oil points number as I thought it was in error and I confirmed that indeed it was. When I retored my Final Productio Planning Phase I found that another previously saved oil point from Britain dropped out of production. So I had to waste more time sending them back into production.

I tried to attach a saved game file of the Oil Reorganization Phase but that function isn't working. It's giving me some kind of fakepath error. I hope that gets fixed soon so if someone wants to see the file they can.

Post #: 1
RE: Free Oil Reorganization Bug - 1/6/2014 11:53:46 PM   

Posts: 8051
Joined: 3/24/2007
From: Canada
Status: offline
Did you zip the game file? AFAIK you can only attach files of type zip or jpg.



(in reply to Omnius)
Post #: 2
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> World in Flames >> Tech Support >> Free Oil Reorganization Bug Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI