Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Several bugs

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> World in Flames >> Tech Support >> Several bugs Page: [1]
Login
Message << Older Topic   Newer Topic >>
Several bugs - 11/10/2013 10:11:01 AM   
SPerdomo

 

Posts: 11
Joined: 8/24/2007
Status: offline
Hello,

I have encountered a couple of bugs, and when I tried to report them through the in-game report functionality, I couldn't.

Game crashes when trying to use an AA unit to defend against Ground Strike: I have found this one in the Barbarossa scenario and the Global War one; the game allows me to select the unit correctly, takes me to the form, but when it is going to roll the dice then it crashes and I get a message saying that there is no email address for that action. This happens playing solitaire and hotseat. I tried to not use the unit to defend, still the game crashed with the same message, only workaround I have found so far is to not have an AA unit adjacent to any hex I am going to use Ground Strike or Ground Support against (sort of defeats the point of the unit, but at least I can go on playing).

Game crashes on overrunning air units previously disorganized: I have encountered this in the Barbarossa scenario; I attack a stack, destroy the defend land units, get the movement after combat option, and when moving over the disorganized fighter on the hex, the video of the tanks overrunning gets stuck and crashes the game.

Land unit disappearing on Land Attack: I have encountered this only once, during the Global War scenario; as Germany, attacking a stack of Polish units, select several stacks of units to attack, all went well until for some reason, on the fourth stack I chose, only one of the units was picked, the other two remained in the hex, untouched. When moving this unit over the stack to be attacked, I only got a big "X" (unit was adjacent, obviously, and not disorganized). I tried to put the unit back on its stack, but couldn't, pressed "Esc" to try and go back, the unit disappeared and the turn went on as if nothing had happened, except that this unit was now totally gone, vanished.

Several crashes on Ground Strikes: for some reason I encounter regular crashes with the Ground Strike videos, they seem to start running, get stuck and crash the game, this has happened both in the global war and barbarossa scenario, for no apparent reason. Closing the game and reloading from a previous save usually fixes it (but sometimes forces to replay parts of the turn, even previous ground strikes).


Just in case it is relevant, my PC is an Alienware X51, i5-2320 @ 3.00GHz, 8 Gigas of Ram and a GTX555. I run the game on Windows 7, Two screens, one for the main map, another one for the world map and other forms (main screen is on 1920*1020 resolution, secondary one is on 1280*1024)

Question: a couple of these errors seem to happen only with those videos, which, to be honest, I do not need or particularly like, is it possible to disable them completely?

Thanks for any support you can provide.

Edit: forgot another crash: when selecting a stack of units with the flyover, if I then move them over the flyover itself, the game crashes. I have to select the units, be very careful not to move the mouse, and wait until the flyover disappears, then move the units to the hex I want to move them to. I tend to have the main map on zoom 5, so the flyover is quite big as are the units themselves, and this means I tend to have problems whenever I want to move or attack with units directly under or right and under of the stack I am selecting.

< Message edited by SPerdomo -- 11/10/2013 11:22:58 AM >
Post #: 1
RE: Several bugs - 11/10/2013 10:20:19 AM   
AxelNL


Posts: 2373
Joined: 9/24/2011
From: The Netherlands
Status: offline

quote:

ORIGINAL: SPerdomo

Hello,

I have encountered a couple of bugs, and when I tried to report them through the in-game report functionality, I couldn't.

Game crashes when trying to use an AA unit to defend against Ground Strike: I have found this one in the Barbarossa scenario and the Global War one; the game allows me to select the unit correctly, takes me to the form, but when it is going to roll the dice then it crashes and I get a message saying that there is no email address for that action. This happens playing solitaire and hotseat. I tried to not use the unit to defend, still the game crashed with the same message, only workaround I have found so far is to not have an AA unit adjacent to any hex I am going to use Ground Strike or Ground Support against (sort of defeats the point of the unit, but at least I can go on playing).

Game crashes on overrunning air units previously disorganized: I have encountered this in the Barbarossa scenario; I attack a stack, destroy the defend land units, get the movement after combat option, and when moving over the disorganized fighter on the hex, the video of the tanks overrunning gets stuck and crashes the game.

Land unit disappearing on Land Attack: I have encountered this only once, during the Global War scenario; as Germany, attacking a stack of Polish units, select several stacks of units to attack, all went well until for some reason, on the fourth stack I chose, only one of the units was picked, the other two remained in the hex, untouched. When moving this unit over the stack to be attacked, I only got a big "X" (unit was adjacent, obviously, and not disorganized). I tried to put the unit back on its stack, but couldn't, pressed "Esc" to try and go back, the unit disappeared and the turn went on as if nothing had happened, except that this unit was now totally gone, vanished.

Several crashes on Ground Strikes: for some reason I encounter regular crashes with the Ground Strike videos, they seem to start running, get stuck and crash the game, this has happened both in the global war and barbarossa scenario, for no apparent reason. Closing the game and reloading from a previous save usually fixes it (but sometimes forces to replay parts of the turn, even previous ground strikes).


Just in case it is relevant, my PC is an Alienware X51, i5-2320 @ 3.00GHz, 8 Gigas of Ram and a GTX555. I run the game on Windows 7, Two screens, one for the main map, another one for the world map and other forms (main screen is on 1920*1020 resolution, secondary one is on 1280*1024)

Question: a couple of these errors seem to happen only with those videos, which, to be honest, I do not need or particularly like, is it possible to disable them completely?

Thanks for any support you can provide.


on the last question: you can disable the historical video's in the Player Interface Settings. Click on the Interface pull-down menu in the main form to acces that.

Your hardware should not be a factor I would say. There must be something else which interferes with the video's. I have disabled them as well. Game has chrome enough on it's own.

(in reply to SPerdomo)
Post #: 2
RE: Several bugs - 11/10/2013 10:26:05 AM   
SPerdomo

 

Posts: 11
Joined: 8/24/2007
Status: offline
Ah, there it is, thanks, I missed that Interface option. I will see if that fixes those crashes, thank you very much for your help, AxelNL.


Edit: just loaded a couple of the save games I had previous to some of those crashes (i.e.: the fighter unit being overrun after land attack in Barbarossa), not playing the video meant that I got instantly a message saying that the fighter was destroyed, game went on perfectly; so yeah, disabling the videos certainly helped on that one, I am guessing that will also help on the Ground Strike ones.

I think these are still relevant for someone who might want to play having the videos active, and also regarding the other bugs not related to videos, but thanks indeed AxelNL for helping me fix that :)

< Message edited by SPerdomo -- 11/10/2013 11:32:28 AM >

(in reply to AxelNL)
Post #: 3
RE: Several bugs - 11/10/2013 3:37:43 PM   
Shannon V. OKeets

 

Posts: 21911
Joined: 5/19/2005
From: Honolulu, Hawaii
Status: offline

quote:

ORIGINAL: SPerdomo

Ah, there it is, thanks, I missed that Interface option. I will see if that fixes those crashes, thank you very much for your help, AxelNL.


Edit: just loaded a couple of the save games I had previous to some of those crashes (i.e.: the fighter unit being overrun after land attack in Barbarossa), not playing the video meant that I got instantly a message saying that the fighter was destroyed, game went on perfectly; so yeah, disabling the videos certainly helped on that one, I am guessing that will also help on the Ground Strike ones.

I think these are still relevant for someone who might want to play having the videos active, and also regarding the other bugs not related to videos, but thanks indeed AxelNL for helping me fix that :)

Thank you for reporting this. I'll try to figure out what the conflict is with the historical videos playing.

_____________________________

Steve

Perfection is an elusive goal.

(in reply to SPerdomo)
Post #: 4
RE: Several bugs - 11/11/2013 3:37:58 PM   
SPerdomo

 

Posts: 11
Joined: 8/24/2007
Status: offline
Hi Steve,

By disabling the videos most of the bugs I was encountering have disappeared, however the one with the AA unit defending vs Ground Strike remains (actually, adjacent to the target hex is enough, whether I choose to skip the phase or use it to defend, the game crashes).

The message I was getting was:
"There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel."

I installed Windows live mail, and now the game doesn't display that message, but it still crashes every time; the form for submitting bugs popped up fine however, so I submitted two reports, one for when I chose to use the AA to defend, and the other one when I skipped using the AA unit.

Is there anything I am missing with the email address that the game might be wanting to use?

Thanks in advance for any help you can provide.

By the way, if you need the save file, I have it saved just before (crash happens when trying to ground strike units in china)

(in reply to Shannon V. OKeets)
Post #: 5
RE: Several bugs - 11/11/2013 3:56:31 PM   
SPerdomo

 

Posts: 11
Joined: 8/24/2007
Status: offline
I tried to configure Netplay, to see if it had something to do with my email address not being registered by the game, and now I am also getting this message:
"Error=21. Game url non-existent (wrong game url)."

The registration and email are valid though, can log in to slitherin's page no problem, and the serial seems to be correctly registered as well. I guess it is not related, but still, just in case.

(in reply to SPerdomo)
Post #: 6
RE: Several bugs - 11/11/2013 5:22:47 PM   
Shannon V. OKeets

 

Posts: 21911
Joined: 5/19/2005
From: Honolulu, Hawaii
Status: offline
Let me see if I have the remaining error count correct from you original post:

1 - AA bug

2 - Land combat declaration



_____________________________

Steve

Perfection is an elusive goal.

(in reply to SPerdomo)
Post #: 7
RE: Several bugs - 11/11/2013 5:24:32 PM   
Shannon V. OKeets

 

Posts: 21911
Joined: 5/19/2005
From: Honolulu, Hawaii
Status: offline

quote:

ORIGINAL: SPerdomo

I tried to configure Netplay, to see if it had something to do with my email address not being registered by the game, and now I am also getting this message:
"Error=21. Game url non-existent (wrong game url)."

The registration and email are valid though, can log in to slitherin's page no problem, and the serial seems to be correctly registered as well. I guess it is not related, but still, just in case.

I am not sure what you mean by "configure NetPlay". Do you mean clicking on the NetPlay forum button on the opening MWIF splash screen? Or when entering information to register for the forum? Or something else?

_____________________________

Steve

Perfection is an elusive goal.

(in reply to SPerdomo)
Post #: 8
RE: Several bugs - 11/11/2013 8:21:25 PM   
SPerdomo

 

Posts: 11
Joined: 8/24/2007
Status: offline
Hi Steve,

Regarding the bugs, yes, indeed, the AA one and land combat declaration (this last one only happened once, if it happens again I will take more details, however the AA one happens 100% of the times).

Regarding Netplay, I press "Private WIF NetPlay Forum", then "Log In to Forum" , the serial number verification goes well, had already previously entered my details (user name, email, password...) then, after the verification, I get a pop up saying "Error=21. Game url non-existent (wrong game url)."

This pop up has an "ok" button, pressing it makes another pop up appear, stating "Unable to access Seeking Opponent database." ; pressing "Ok" on this pop up takes me to a form that reads "Seeking opponent" and has a column for "Players On-line" that appears blank.

On the lower part of that form there is an area with the title "Replies to Seeking Opponent Post" were two phrases appear in blue: "World in Flames Netplay Private Forum active. Game url non-existent (wrong game url)".


(in reply to Shannon V. OKeets)
Post #: 9
RE: Several bugs - 11/24/2013 8:01:56 PM   
Karlima

 

Posts: 6
Joined: 11/24/2013
Status: offline
Hi SPerdomo

I have just tried to play Barbarossa with a mate. Vi too experienced the crash after applying AA fire in Barbarossa.

- Ground strike hex was on Lvov, where i had 2 USSR INF Units. I had a 3-2 AA unit in the forest SE of Lvov.

- I couldnt select the target hex for the AA-fire, but Lvov was the only one possible to receive def AA-fire, so i just spend all 4 on it. After allocating the game said waiting on my screen with nothing happening at on my mates..

- We both had the historical videos turned of.

(in reply to SPerdomo)
Post #: 10
RE: Several bugs - 11/24/2013 8:17:44 PM   
Shannon V. OKeets

 

Posts: 21911
Joined: 5/19/2005
From: Honolulu, Hawaii
Status: offline

quote:

ORIGINAL: Karlima

Hi SPerdomo

I have just tried to play Barbarossa with a mate. Vi too experienced the crash after applying AA fire in Barbarossa.

- Ground strike hex was on Lvov, where i had 2 USSR INF Units. I had a 3-2 AA unit in the forest SE of Lvov.

- I couldnt select the target hex for the AA-fire, but Lvov was the only one possible to receive def AA-fire, so i just spend all 4 on it. After allocating the game said waiting on my screen with nothing happening at on my mates..

- We both had the historical videos turned of.

NetPlay I assume?

Were both of you using version 1.0.4?

_____________________________

Steve

Perfection is an elusive goal.

(in reply to Karlima)
Post #: 11
RE: Several bugs - 11/24/2013 9:17:50 PM   
Zorachus99


Posts: 1054
Joined: 9/15/2000
From: Palo Alto, CA
Status: offline
Make sure you are not using solitaire, not hotseat. That AA Bug is a crash bug there too.

EDIT:>

I take it all back. AA is fixed in HOTSEAT!!!!

Wooohooo!!!

I will always do a regression test for a bug before posting.

Thanks Steve!



< Message edited by Zorachus99 -- 11/24/2013 10:24:03 PM >


_____________________________

Most men can survive adversity, the true test of a man's character is power. -Abraham Lincoln

(in reply to Shannon V. OKeets)
Post #: 12
RE: Several bugs - 11/25/2013 9:45:04 PM   
LeeChard

 

Posts: 1059
Joined: 9/12/2007
From: Michigan
Status: offline
Same crash, AA defending ground strike. Barbarossa scenario and could not report.

By the way...great game!

(in reply to SPerdomo)
Post #: 13
RE: Several bugs - 11/25/2013 11:05:31 PM   
Shannon V. OKeets

 

Posts: 21911
Joined: 5/19/2005
From: Honolulu, Hawaii
Status: offline

quote:

ORIGINAL: Ranger5355

Same crash, AA defending ground strike. Barbarossa scenario and could not report.

By the way...great game!

Is your version up-to-date? The Update today was for 1.0.4.1.

_____________________________

Steve

Perfection is an elusive goal.

(in reply to LeeChard)
Post #: 14
RE: Several bugs - 11/26/2013 11:56:19 AM   
LeeChard

 

Posts: 1059
Joined: 9/12/2007
From: Michigan
Status: offline
Nope. 1.0.4
I'll fix that, thanks

(in reply to Shannon V. OKeets)
Post #: 15
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> World in Flames >> Tech Support >> Several bugs Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.152