Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

RE: [RELEASED] Speech and Ambient Sound Module - files attached

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> RE: [RELEASED] Speech and Ambient Sound Module - files attached Page: <<   < prev  5 6 [7] 8 9   next >   >>
Login
Message << Older Topic   Newer Topic >>
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/20/2015 4:32:46 PM   
Rangoon

 

Posts: 83
Joined: 9/25/2013
Status: offline

quote:

ORIGINAL: jptheronmd

Hi everyone, I am new to the forums and need some help with Seahag. I am running version 1.0g together with CMANO v1.07 B678. I ran Seahag as the instructions explained and used the Default Speech Grid and Sound Grid buttons first. I also manually entered the Steam version of CMANOs dir D:\Steam Games\steamapps\common\Command Modern Air Naval Operations\Logs. AutoDetect Player side is on. I then exit and restart Seahag. Start it and can hear the initialization and start up speech. I then load CMANO and start a scenario. Seahag detects a new log file and I can hear the speech confirming this. From then on all I hear is the ambient sound and no speech.

I have also tried disabling side detection and manually entering the side. Any ideas?

Regards
JP

PS I am using Windows 8.1 64 bit.


So just to clarify, you are using all of the default entries from 1.0g? I mean did you change anything? Can you upload a log file which you feel should have triggered TTS but didn't? Or paste in the entries which should have triggered TTS?

(in reply to jptheronmd)
Post #: 181
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/20/2015 6:29:54 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
Thanks for the reply Rangoon. Here is a log file attached. Yes - everything on default.

Attachment (1)

(in reply to Rangoon)
Post #: 182
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/20/2015 7:20:29 PM   
Rangoon

 

Posts: 83
Joined: 9/25/2013
Status: offline

quote:

ORIGINAL: jptheronmd

Thanks for the reply Rangoon. Here is a log file attached. Yes - everything on default.


Sorry, I actually meant a CMANO log file. Although I did notice in the SeaHag log in kept mentioning "skipping until player side found".

After you set the default sound grid etc., and your other options like auto detect player side, did you save the SeaHag settings?

Here are my program settings for SeaHag, everything above the Log Window:
Allow auto selector, checked
Start at end of file, checked
More Diagnostics, unchecked
Use Microsoft Speech API
Voice On, checked
Sound On, checked
CMANO log files location (set location) - D:\Program Files\Matrix Games\Command Modern Air Naval Operations\Logs
Speech Level: 1
AutoDetect Playerside, checked
Savegame Force Wait for PlayerSide, checked
Reset PlayerSide on New File, checked

Save Settings
Start SeaHag

You should at least be getting things like contact reports and weapon engagement announcements once you get into that phase of the mission. That should be pretty standard for whatever mission you're playing.

Did you let the mission advance that far?

Also, you could copy/paste the following line below the SeaHag log window, turn AutoDetect Playerside off and manually input CVW-15 as playerside, then hit Parse Line. Do you get a TTS event?

2/21/1983 5:03:46 PM - CVW-15: New contact! Designated BOGEY #58 - Detected by VF-51 Screaming Eagles, NE-100 [Sensors: AN/AWG-9] at 118deg - 104.8nm

(in reply to jptheronmd)
Post #: 183
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/21/2015 3:15:33 AM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline
Hi JP,

To confirm -

1/ You have clicked Default speech grid then Default Sound grid.
2/ You entered into Hag your CMANO logfile directory
2/ You clicked save settings and then clicked start SeaHag and Hag Spoke.
4/ Hag found your new logfile and spoke, but then said nothing more?

Can you post a screenshot of your hag window please, if you heard hag speak when you clicked start SeaHag then it would be down to the speech grid processing which works for pretty much all situations.

The only other thing I can think of is that you have not got the log settings turned on in CMANO, which activated in the menu Game->Game Options->Message Log tab.

Mine are as per the attached picture.


Regards

Sluggy








Attachment (1)

< Message edited by sluggy -- 4/21/2015 4:16:34 AM >

(in reply to jptheronmd)
Post #: 184
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/21/2015 9:46:20 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
Hi sluggy, thanks for the reply. I have done exactly as you said. Does SeaHag only read pop up messaged? I do not have popup messages enabled as I don't like how they pause the sim. I will test and reply with screen shot as soon as possible.

(in reply to sluggy2010)
Post #: 185
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/21/2015 9:52:03 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
Here is my message log settings.

Attachment (1)

(in reply to jptheronmd)
Post #: 186
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/21/2015 9:54:35 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
My Seahag window.

Attachment (1)

(in reply to jptheronmd)
Post #: 187
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/21/2015 10:44:36 PM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline
Nope the opposite - it only can receive the entries tagged for the logs - popups does not affect it.

Can you post the actual CMANO log file from the game session ( rather than the debug output above) and I'll try this end.

Cheers

Sluggy

< Message edited by sluggy -- 4/21/2015 11:47:17 PM >

(in reply to jptheronmd)
Post #: 188
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/22/2015 6:33:18 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
Here it is

Attachment (1)

(in reply to sluggy2010)
Post #: 189
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/22/2015 6:46:34 PM   
Rangoon

 

Posts: 83
Joined: 9/25/2013
Status: offline
quote:

ORIGINAL: jptheronmd

Here it is



I see that the player side is not being recognized when I try an entry from this log file. It appears to be the date format in the time stamp that it's getting confused by. From the debugger:

RAW Line:1983-02-21 5:04:36 PM - CVW-15: New contact! Designated BOGEY #58 - Detected by VAW-114 Hormel Hogs, NE-600 [Sensors: AN/ALR-59 PDS] at 117deg - Estimated 169nm
Processing Line <Timestamp Removed>2-21 5:04:36 PM - CVW-15: New contact! Designated BOGEY #58 - Detected by VAW-114 Hormel Hogs, NE-600 [Sensors: AN/ALR-59 PDS] at 117deg - Estimated 169nm
Checking Player Side is 2-21 5 Filtering for CVW-15
Failed Side Check - Skipping Line


the side in ths log file is CVW-15, but Sea Hag is recognizing as "2-21 5" which is the date and first digit of time from the time stamp. In my logs, the format of the time stamp is different: "2/21/1983 5:03:46 PM"

Does it work if you change the date format in CMANO?

EDIT: In fact, I don't see a way to change the format in CMANO. Is this just being pulled from Windows? I'm sure Sluggy will know what to do.

< Message edited by Rangoon -- 4/22/2015 7:51:40 PM >

(in reply to jptheronmd)
Post #: 190
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/23/2015 12:36:26 AM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline
Is that the original text file? - it looks wrong - why is HTML embedded in there?

Is all that in your original file JP? Or something that the upload process has added?

If that is in the original file then that is why its not working.


Sluggy



1983-02-21 5:00:01 PM - CVW-15: <BODY scroll=auto><DIV id=yui_3_7_2_1_1377346728025_12158><B><SPAN lang=EN-GB>Phase I: Ready aircraft</SPAN></B></DIV>
<DIV><B><SPAN lang=EN-GB></SPAN></B><SPAN lang=EN-GB></SPAN> </DIV>
<DIV></DIV>
<DIV id=yui_3_7_2_1_1377346728025_12160><SPAN lang=EN-GB id=yui_3_7_2_1_1377346728025_12159>Select NAS Fallon air base on the map. In the <EM>Unit Status </EM>pane press the <EM>Aircraft: 40/72 </EM>button to bring up the Air Ops (Air Operations) window. Press the + (plus) to the left of the aircraft types to list each individual aircraft on the base. Review the list of aircraft and their loadouts. The aircraft that will participate in the strike have been readied with combat or support loadouts, the rest are set to unavailable.</SPAN></DIV>
<DIV><SPAN lang=EN-GB></SPAN> </DIV>
<DIV></DIV>
<DIV><SPAN lang=EN-GB>There are F-14A Tomcat fighters armed with long-range air-to-air missiles (AAMs), A-6E Intruder bomb trucks in the strike role armed with various types of bombs, A-7E Corsairs in the suppression of enemy air defenses (SEAD) role armed with anti-radiation (anti-radar) missiles (ARMs), and more A-7E Corsairs in the stand-off role and ground attack role armed with TV-guided glide bombs and iron bombs.</SPAN></DIV>

< Message edited by sluggy -- 4/23/2015 1:55:08 AM >

(in reply to Rangoon)
Post #: 191
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/23/2015 7:52:50 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
Hi Sluggy,

That is the correct log file. It is for a tutorial mission. I notice the 'normal' missions do not have all the HTML stuff. Let me try with a normal mission like Frisian Flag and re-post a log file.

JP

(in reply to sluggy2010)
Post #: 192
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/23/2015 8:27:55 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
Tested with Frisian flag. Same thing. Uploaded log file and it looks 'normal'. Still not sure why this is happening. Got Steam to check install integrity too. Files all OK.

Attachment (1)

(in reply to jptheronmd)
Post #: 193
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 4/24/2015 3:25:06 AM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline
OK - I can see the problem now - will fix it up tonight / tomorrow.

For the intro mission with the tags in it - they will definitely not work.

The "normal" missions will after I've made the change - it is the date format causing the problem.

Which country / language combination are you using out of interest?



Regards

Sluggy

(in reply to jptheronmd)
Post #: 194
Version 1.0i - 4/24/2015 3:15:22 PM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline

OK, for those users with different date formats like JP above then version 1.0i should fix the date recognition issues.

Please find attached version 1.0i if Rangoon and JP could confirm it works for both of you then I'll update the front page version.


Cheers

Sluggy



Attachment (1)

(in reply to sluggy2010)
Post #: 195
RE: Version 1.0i - 4/24/2015 8:59:52 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
Hi Scully thanks so much. I realize now what you mean about the dates. I am using a date format as yyyy/mm/dd.

Sorry to be a bother.

Thank you!

(in reply to sluggy2010)
Post #: 196
RE: Version 1.0i - 4/25/2015 1:39:08 AM   
Rangoon

 

Posts: 83
Joined: 9/25/2013
Status: offline
quote:

ORIGINAL: sluggy


OK, for those users with different date formats like JP above then version 1.0i should fix the date recognition issues.

Please find attached version 1.0i if Rangoon and JP could confirm it works for both of you then I'll update the front page version.


Cheers

Sluggy




I pasted another contact event from JP's log into 1.0i and it worked fine.

< Message edited by Rangoon -- 4/25/2015 2:40:03 AM >

(in reply to sluggy2010)
Post #: 197
RE: Version 1.0i - 4/25/2015 12:19:44 PM   
jptheronmd

 

Posts: 15
Joined: 4/19/2015
Status: offline
Hi Rangoon and Sluggy,

Just tested last night works perfectly (if I can remember to turn off and on when I play the next scenario)

(in reply to Rangoon)
Post #: 198
RE: Version 1.0i - 4/25/2015 3:04:01 PM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline
Thanks chaps - credited and front page version updated.


Regards

Sluggy

(in reply to Rangoon)
Post #: 199
RE: Version 1.0i - 4/25/2015 3:08:00 PM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline

As Saturday was ANZAC day here in Australia - I cannot let that go past without a note of remembrance and thanks.

http://www.smh.com.au/national/ww1/anzac-day-thousands-brave-cold-for-canberra-dawn-service-on-gallipoli-centenary-20150424-1msq79.html

We Will Remember Them.






(in reply to sluggy2010)
Post #: 200
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 4/26/2015 1:17:30 PM   
pandoraefretum

 

Posts: 115
Joined: 9/27/2013
Status: offline
Don't mean to cause trouble... but I used SeaHag a b c d e now i and suddenly it's not auto-detecting my side hence I have no messages read out. I'm on CMANO 678 or v1.07

in Seahag e I get "Player side is now United Kingdom"
in Seahag i I get no such speech nor any subsequent speech


< Message edited by pandoraefretum -- 4/26/2015 3:31:55 PM >

(in reply to sluggy2010)
Post #: 201
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 4/26/2015 11:44:40 PM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline

Thanks for the heads up - can you upload the logfile which does not work please.

Cheers

Sluggy

(in reply to pandoraefretum)
Post #: 202
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 4/27/2015 2:33:01 AM   
Mgellis


Posts: 2029
Joined: 8/18/2007
Status: offline
Just curious...will it ever be possible to customize the image?

(in reply to sluggy2010)
Post #: 203
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 4/27/2015 2:49:34 PM   
sluggy2010

 

Posts: 121
Joined: 10/2/2013
Status: offline
No sorry - other than updates for fixes as people find issues SeaHag won't change.



< Message edited by sluggy -- 4/27/2015 3:52:41 PM >

(in reply to Mgellis)
Post #: 204
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 4/29/2015 6:52:47 PM   
pandoraefretum

 

Posts: 115
Joined: 9/27/2013
Status: offline
thanks, I will - I just rechecked e working i not setting the player side
what's the exact location and name of this logfile ??
ciao, Roland

(in reply to sluggy2010)
Post #: 205
RE: [RELEASED] Speech and Ambient Sound Module - files ... - 5/4/2015 7:54:15 PM   
ETF


Posts: 1713
Joined: 9/16/2004
From: Hamilton Area, Canada
Status: offline
Delete.....

< Message edited by ETF -- 5/4/2015 8:56:47 PM >


_____________________________

My Top Matrix Games 1) CMO MP?? 2) WITP/AE 3) SOW 4) Armor Brigade 5) Pride of Nations

Twitter
https://twitter.com/TacticWargamer

(in reply to sluggy2010)
Post #: 206
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 5/8/2015 5:35:18 PM   
pandoraefretum

 

Posts: 115
Joined: 9/27/2013
Status: offline
Sluggy, hi

I've got 1.0i working ; the solution was to change the regional settings, and set date regional format to United States MM/dd/yyyy (United Kingdom is what was previously set as I am in UK). I read this had been solved on the forum... but maybe I'm on the wrong track. Thanks a bunch for Seahag.

(in reply to sluggy2010)
Post #: 207
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 5/24/2015 8:19:28 AM   
nudn1k

 

Posts: 50
Joined: 7/18/2013
Status: offline
Hi sluggy,

thanks for the awesome software. javascript:void(AddText('[\&o]')) Command is not the same without it.

However, v10i seems to cut only the first four characters of the text and because of that finds part of the timestamp as player side. See attached screenshot.
German region settings here, on Vista 64.

v10g is running fine. Here are some settings that might be useful:

- in the line: "reports BDA status change" set prevent repeat to 1s, so speech is not getting behind if many status changes are reported at once.

- replace "is waiting for orders." with "is waiting."




Attachment (1)

(in reply to pandoraefretum)
Post #: 208
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 5/25/2015 5:56:13 PM   
pandoraefretum

 

Posts: 115
Joined: 9/27/2013
Status: offline
I noticed my PC cooling fans are whizzing away so
I checked my v1.0i : the process is taking up a very fixed 30% of my CPU time (in Win Task Manager)
Instead v1.0e is taking up 0% CPU time....(the difference seems to be between version e (0% CPU) and f (13%CPU))
I wonder if the 1.0i download is corrupt or something?
Could you please put back the link to SeaHag 1.0h, Sluggy ?

Oh and I also wanted to say that I have installed Cmano and Seahag on my new Surface Pro 3 (what a machine!)
Since it has Windows 8.1 I am enjoying default voice HAZEL (UK English) which is not unlike AUDREY except it's free!!

< Message edited by pandoraefretum -- 5/25/2015 9:07:51 PM >

(in reply to nudn1k)
Post #: 209
RE: [RELEASED] Speech and Ambient Sound Module - Update... - 6/20/2015 6:12:05 PM   
bertibott

 

Posts: 29
Joined: 6/19/2015
From: Germany
Status: offline
hi...

i wanted to try out SeaHag... the idea sounds like it could really improve the game experience... sadly i am afraid, that I also am having a date format problem. I live in Germany so my standard date foramt is DD.MM.YYYY


Apparently it is not possible for a "german" windows to adopt the american date format (obviously Microsoft knows whats best for me...) so unless i change my system language I am pretty much stuck.

Not knowing how difficult this would be to implement... wouldn't it be easiest and best to just specify the date format in the SeaHag-Settings?

I would really love to have this feature working with my game!

I wanted to post parts of the logfiles... but I am guessing that the forum interprets long collums of numbers as phonenumbers... and I am not allowed to post these yet... :(

(in reply to pandoraefretum)
Post #: 210
Page:   <<   < prev  5 6 [7] 8 9   next >   >>
All Forums >> [New Releases from Matrix Games] >> Command: Modern Operations series >> RE: [RELEASED] Speech and Ambient Sound Module - files attached Page: <<   < prev  5 6 [7] 8 9   next >   >>
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.223