Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Can't attack pirate facilities

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Can't attack pirate facilities Page: [1]
Login
Message << Older Topic   Newer Topic >>
Can't attack pirate facilities - 8/24/2013 9:49:34 PM   
CMS1302

 

Posts: 15
Joined: 8/24/2013
Status: offline
Hi folks,
I have got some problems getting rid of pirate facilities at one of my colonies. The background: I conquered an alien system containing two inhabited planets - one controlled by a common empire I was at war with, one by a pirate fraction. I invaded and conquered both.
But now I've still got the pirate facilities (base, fortress and network) on the formerly pirate controlled planet.
I wanted to attack those facilities using my invading forces, but when I select the colony in the colony list, the Attack-Facility-Button is grey and won't work. So I got the troops on the planet, a target to attack but can't assign the mission for some reason.

Is anyone familiar with this problem or have I just missed some conditions necessary for attacking a pirate base like a certain time frame after conquering a planet?

Ingo

< Message edited by CMS1302 -- 8/24/2013 9:52:16 PM >
Post #: 1
RE: Can't attack pirate facilities - 8/25/2013 3:52:23 AM   
mSterian

 

Posts: 155
Joined: 7/25/2013
Status: offline
I don't think you can destroy a Criminal network.

(in reply to CMS1302)
Post #: 2
RE: Can't attack pirate facilities - 8/25/2013 7:28:06 AM   
Kayoz


Posts: 1516
Joined: 12/20/2010
From: Timbuktu
Status: offline
Are you playing a normal empire or a pirate?

_____________________________

“That which can be asserted without evidence, can be dismissed without evidence.” ― Christopher Hitchens

(in reply to CMS1302)
Post #: 3
RE: Can't attack pirate facilities - 8/25/2013 7:58:10 AM   
mSterian

 

Posts: 155
Joined: 7/25/2013
Status: offline
This is mostly probably a design overlook.
They didn't think what should happen when you take over a planet owned by pirates.

Yet, maybe it's intended. Once a pirate planet, always a pirate planet :) Only developers can answer you.

(in reply to Kayoz)
Post #: 4
RE: Can't attack pirate facilities - 8/25/2013 11:32:50 AM   
kheben

 

Posts: 14
Joined: 6/21/2013
Status: offline
Have you tried selecting the first facility in the colony overview and then giving the attack order? Usually, this will begin the fight with all facilities. In 1.9.0.10, this worked with a network as well.

(in reply to mSterian)
Post #: 5
RE: Can't attack pirate facilities - 8/25/2013 11:45:23 AM   
mSterian

 

Posts: 155
Joined: 7/25/2013
Status: offline
Oh, I remembert now. You can destroy Pirate BASE and FORTRESS but not the Crime Network.\
That is there forever and ever.

Makes sense though, do you know how hard it is to get 300k credits to build that when playing as pirate?

(in reply to kheben)
Post #: 6
RE: Can't attack pirate facilities - 8/25/2013 12:26:47 PM   
CMS1302

 

Posts: 15
Joined: 8/24/2013
Status: offline
Thanks for replying so fast!

First of all I'm playing a normal empire. And it is definitely possible to destroy a network - I just tried it with a different one (planet controlled by pirates, just like the first one). And if I remember right from a former battle, you can attack each fascility separately. No matter which you choose first. That's why I'm not sure whether it's a bug.

I've been noticing some bugs recently like mining stations that exist on the map at galaxy level but can't be seen at planet or system level - even in the editor. At galaxy Level you can even select them, but will get nothing but a blank status window and you can't give them any orders. But nonetheless it blocks me from building a miming station at its planet.
So I thought maybe those pirate facilities on my planet are some sort of bug-base that effects the gameplay but is not really existent.I just don't know for sure whether it's a bug or if there's a rule that determines when you can attack those fascilites and when you can't.

Still the question remains how do I get rid of those fascilities without deleting an reestablishing the colony by editor?

Ingo

(in reply to CMS1302)
Post #: 7
RE: Can't attack pirate facilities - 8/25/2013 2:50:44 PM   
mSterian

 

Posts: 155
Joined: 7/25/2013
Status: offline
Those mining stations that you see are "unbuilt". Meaning a constructor started to construct it, but as soon as it started, it got attacked and ran.
It does not come to finish the job though.

(in reply to CMS1302)
Post #: 8
RE: Can't attack pirate facilities - 8/26/2013 12:56:56 AM   
CyclopsSlayer


Posts: 582
Joined: 2/11/2012
Status: offline
As well, when I see Pirates building a base on one of my planets, WHY do I have to wait until it is completed before attacking it? As any orbital Base or Ship caught in construction shouldn't it be an eligible target?

(in reply to mSterian)
Post #: 9
RE: Can't attack pirate facilities - 8/26/2013 6:16:46 AM   
Starke

 

Posts: 147
Joined: 6/7/2013
Status: offline

quote:

ORIGINAL: CyclopsSlayer

As well, when I see Pirates building a base on one of my planets, WHY do I have to wait until it is completed before attacking it? As any orbital Base or Ship caught in construction shouldn't it be an eligible target?

Unless something changed since 1.9.0.8, they are eligible. (I think I just discussed this with you in another thread too =) ) Also, I've been able to invade planets with the Criminal Network, wiping it out in the process, many times in my past games. 0.o (also pre-1.9.0.8)

(in reply to CyclopsSlayer)
Post #: 10
RE: Can't attack pirate facilities - 8/26/2013 4:31:09 PM   
CMS1302

 

Posts: 15
Joined: 8/24/2013
Status: offline

quote:

ORIGINAL: Starke


I've been able to invade planets with the Criminal Network, wiping it out in the process, many times in my past games.

I'm able to do so as well. It just doesn't work with that damn colony. I think I'll just use the editor to destroy it. As no one seems to know any reason why it shouldn't be attackable I conclude it's just a bug.

And concerning mining stations which aren't there: even if a construction ship starts a station and stops building it I usually still have the hexagonical base marker and I'm able to repair/ finish the station or to scrap it at least. And I have/ can't do any of that.

(in reply to Starke)
Post #: 11
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds Series >> Tech Support >> Can't attack pirate facilities Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.137