Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Strange game crashes

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Strange game crashes Page: [1]
Login
Message << Older Topic   Newer Topic >>
Strange game crashes - 7/23/2013 8:54:45 AM   
Banzan

 

Posts: 288
Joined: 3/13/2010
From: Bremen, Germany
Status: offline
Hi all,

i never had any problem with WitPAE in the past, but since i re-installed Windows 7, suddenly the game keeps crashing when setting a destination for a fleet or LCU.
Only hardwarechanges were 2x data-disks (D:) on raid 1 now and the SSD (C:) Disk changed to one with more size.
Every other program is running fine, just WitPAE keeps crashing with a VB error (no special error, just "stopped running").
It actually didn't crash directly, but stops you from clicking any base or unit and and if you try to save you get that error and the game is terminated.

Anyone else ever had that problem? Re-installed the game serveral times already and even copied a running version from my notebook into the folder, but no joy.

Anyone else is using Bitdefender as an Anti-Virus program? Its the only other change on ther system besides the disk changes, and my last idea to try out this evening. Would be anyoning if i never had problems with a free anti-virus program and get trouble with a payed one.

Post #: 1
RE: Strange game crashes - 7/23/2013 4:24:05 PM   
Lokasenna


Posts: 9233
Joined: 3/3/2012
From: Iowan in MD/DC
Status: offline
It sounds like a software library or driver issue. I would make sure you have up to date drivers (graphics first, then sound) as well as libraries, which can be included in Windows updates or maybe you need to download the package. VB stands for Visual Basic, but I couldn't tell you exactly which one you need (if any)...

(in reply to Banzan)
Post #: 2
RE: Strange game crashes - 7/23/2013 6:24:36 PM   
Banzan

 

Posts: 288
Joined: 3/13/2010
From: Bremen, Germany
Status: offline
All drivers were updated (all MS patches installed, too) after the installation and VB is intigrated into windows 7, no need to install it anymore. I am uninstalling Bitdefender now and try my old AV-program again, maybe that will help. *sigh*

< Message edited by Banzan -- 7/23/2013 6:25:06 PM >

(in reply to Lokasenna)
Post #: 3
RE: Strange game crashes - 7/23/2013 7:34:11 PM   
Sardaukar


Posts: 9521
Joined: 11/28/2001
From: Finland/Israel
Status: offline
One trick to narrow the problem is to temporarily rename you SOUND and VIDEO directories to NO_SOUND and NO_VIDEO and play the game (don't worry, it wont affect the game, you just lose sound and start video). If crashes stop, it tells you that e.g. former case (very common cause for crashes in AE) is that sound drivers are conflicting with game.

_____________________________

"To meaningless French Idealism, Liberty, Fraternity and Equality...we answer with German Realism, Infantry, Cavalry and Artillery" -Prince von Bülov, 1870-


(in reply to Banzan)
Post #: 4
RE: Strange game crashes - 7/23/2013 7:37:48 PM   
Sardaukar


Posts: 9521
Joined: 11/28/2001
From: Finland/Israel
Status: offline
*double tap*

< Message edited by Sardaukar -- 7/23/2013 7:38:10 PM >


_____________________________

"To meaningless French Idealism, Liberty, Fraternity and Equality...we answer with German Realism, Infantry, Cavalry and Artillery" -Prince von Bülov, 1870-


(in reply to Banzan)
Post #: 5
RE: Strange game crashes - 7/23/2013 7:47:51 PM   
Lokasenna


Posts: 9233
Joined: 3/3/2012
From: Iowan in MD/DC
Status: offline
That's a nice trick.

My guess is that it's video-related, from the description of the problem.

(in reply to Sardaukar)
Post #: 6
RE: Strange game crashes - 7/24/2013 2:47:29 AM   
michaelm75au


Posts: 13354
Joined: 5/5/2001
From: Melbourne, Australia
Status: offline
VB not used, rather it uses the VC libraries.
Does it behave same way when a new game is started?
What version are you running?

_____________________________

Michael

(in reply to Lokasenna)
Post #: 7
RE: Strange game crashes - 7/24/2013 8:25:32 AM   
Banzan

 

Posts: 288
Joined: 3/13/2010
From: Bremen, Germany
Status: offline
It happends with any scenario, using latest beta and the updated scenarios from AndyMac. Sometimes it runs some turns fine, next time it doesnt run one turn. I changed the antivirus program, but didn't have enough time to play yesterday evening. I hope i can try this evening.

The errormessage indicates MS VB, but that could be a translation problem. Will check if the errormessages for VB and VC are similar in german.

< Message edited by Banzan -- 7/24/2013 8:26:20 AM >

(in reply to michaelm75au)
Post #: 8
RE: Strange game crashes - 7/26/2013 9:39:53 AM   
Banzan

 

Posts: 288
Joined: 3/13/2010
From: Bremen, Germany
Status: offline
Yesterday evening, i was able to play the first 3 turns of the GC (Scen 2) without any trouble. I haven't been able to finish the first turn of a GC since the re-installaion, only of smaller scenarios. I'll try some more turns this weekend, but it really looks like as the problem was caused by the AV-Program (BitDefender).


Edit:
Problem has not shown again and i could play the first 3 weeks of the GC without any problems. I guess its solved now.

< Message edited by Banzan -- 7/29/2013 10:36:33 AM >

(in reply to Banzan)
Post #: 9
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> War in the Pacific: Admiral's Edition >> Tech Support >> Strange game crashes Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.432