Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Possible naval movement bug

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Decisive Campaigns Series >> Decisive Campaigns: Case Blue >> Tech Support >> Possible naval movement bug Page: [1]
Login
Message << Older Topic   Newer Topic >>
Possible naval movement bug - 8/10/2012 5:14:35 AM   
krupp_88mm


Posts: 406
Joined: 10/13/2008
Status: offline
I have noticed something strange that happens when units are loaded onto naval transports. If I were to say load a division onto a transport on turn one in a port.. or load it onto the transport form a shore. the next turn when I move the transport the units onboard loose their AP's for one turn (reduced to 0. HOWEVER.. if I move the transport one hex at a time... the units will not loose their AP's.

I am not sure if its intended the units loose their ap's, or if they are intended not too. Either way, it seems strange that moving a ship hex by hex preserves the units ap's.
Post #: 1
RE: Possible naval movement bug - 8/10/2012 10:55:48 AM   
Vic


Posts: 6043
Joined: 5/17/2004
Status: offline
Hi Krupp,

Actually i think its working as it should. Are you sure?

If you load a unit from a shore hex it loses all AP. If you move out of a port the passengers lose all AP. This is done to make moving out of a port and invading an enemy hex in the same turn impossible. So to always give the enemy navy and airforce a chance to spot and move in for the kill.

But it might be i did not replicate your moves properly. If you could be so kind could you recheck and note down exact moves from say 1st Soviet Turn Case Blue?

best,
Vic




_____________________________

Visit www.vrdesigns.net for the latest news, polls, screenshots and blogs on Decisive Campaigns and Advanced Tactics


(in reply to krupp_88mm)
Post #: 2
RE: Possible naval movement bug - 8/10/2012 8:39:52 PM   
krupp_88mm


Posts: 406
Joined: 10/13/2008
Status: offline
Vic I did some testing to reproduce the problem and I figured out what caused it. The ai pathing was moving the transports THROUGH a port, removing the Ap's of the units on board.. when i manually moved them around the port they do not loose the ap.

(in reply to Vic)
Post #: 3
RE: Possible naval movement bug - 8/11/2012 4:16:33 AM   
krupp_88mm


Posts: 406
Joined: 10/13/2008
Status: offline
I also managed to move a naval transport about 100km into land... I dont know how this happened and I forgot to save it. i cant do it again

(in reply to krupp_88mm)
Post #: 4
RE: Possible naval movement bug - 8/11/2012 5:21:41 PM   
Vic


Posts: 6043
Joined: 5/17/2004
Status: offline

quote:

ORIGINAL: krupp_88mm

Vic I did some testing to reproduce the problem and I figured out what caused it. The ai pathing was moving the transports THROUGH a port, removing the Ap's of the units on board.. when i manually moved them around the port they do not loose the ap.


interesting catch! this is not ideal behaviour. i am putting this on the list for v1.03.

i would be really interested in the info how you managed to move a ship in land too. hope you can reproduce. let me know when you'll do.

best,
Vic

_____________________________

Visit www.vrdesigns.net for the latest news, polls, screenshots and blogs on Decisive Campaigns and Advanced Tactics


(in reply to krupp_88mm)
Post #: 5
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Decisive Campaigns Series >> Decisive Campaigns: Case Blue >> Tech Support >> Possible naval movement bug Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.117