Matrix Games Forums

Forums  Register  Login  Photo Gallery  Member List  Search  Calendars  FAQ 

My Profile  Inbox  Address Book  My Subscription  My Forums  Log Out

Five Second Cycle of Poor Performance

 
View related threads: (in this forum | in all forums)

Logged in as: Guest
Users viewing this topic: none
  Printable Version
All Forums >> [New Releases from Matrix Games] >> Distant Worlds 1 Series >> Tech Support >> Five Second Cycle of Poor Performance Page: [1]
Login
Message << Older Topic   Newer Topic >>
Five Second Cycle of Poor Performance - 8/3/2012 11:23:18 AM   
stryc

 

Posts: 155
Joined: 7/30/2012
Status: offline
I suppose only someone technically connected with the game's mechanics will be able to answer this but does the game run some sort of routine that cycles every five second? Every five seconds the frame rate falls away dramatically, then for the next five seconds it's smooth, then for the next five seconds it falls away again... repeat ad nauseum. At first I thought this was caused by pop-up dialogues but that’s not the case, the laggy five second cycles are just much more noticeable when a pop-up chunks in rather than sliding in smoothly.

Once I'd noticed this cycle I tested it in the following manner: start a completely new game (v1.7.0.16), zoom in on a planet and gently circle the view around by holding RMB. For five seconds it will be smooth (~50fps), for five seconds it will be very laggy (~5fps), then for five seconds it will be smooth again, etc. The mouse pointer remains smooth at all times as does any other process running concurrently with the game. As a further test I ran another game (Binding of Isaac) concurrently with DW and watched how that was performing on the second monitor as DW was going through its five second performance drop cycle and that other game was unaffected; I also streamed a vod via my browser and that too remained unaffected; CPU load reports similarly were not spiking in five second intervals (no core ever gets above 30% whilst running DW).

I’ve tried the following tweaks to no avail:-
Affinity tweaks (1, 2, all processors);
Resolution drop (down from 1920x1200);
Colour depth drop (down from 32bit to 16bit);
Run the game in compatibility mode (XP SP3);
Disable extended desktop (from 2 down to 1 monitor);
Minimal in-game settings (minimal stars, no nebulae, no LR Scanner overlay, no other overlays);
Mobo and GFX driver updates (already where up to date);
Stripped away all unnecessary processes including virus scanners and so forth;
Run the game from a SSD.

No other game or application follows the same five second cycle of good performance then very poor performance, it's just DW.

AMD Phenom II 965 3.4GHz; 4GB RAM; HD6870; W7-64
Post #: 1
Page:   [1]
All Forums >> [New Releases from Matrix Games] >> Distant Worlds 1 Series >> Tech Support >> Five Second Cycle of Poor Performance Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.148